source: projects/specs/trunk/b/bind/bind-vl.spec @ 7883

Revision 7883, 21.1 KB checked in by daisuke, 11 years ago (diff)

bind: update to 9.9.4

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind
5%define pversion 9.9.4
6%define sversion 9.9.4
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.9.2p2-1vl7
10
11%define bind_uid  25
12%define bind_gid  25
13
14Summary: A DNS (Domain Name System) server.
15Summary(ja): DNS (Domain Name System) サーバ
16Name: %{pname}
17Version: %{pversion}
18Release: 1%{?_dist_release}
19Epoch: %{bind_epoch}
20License: distributable
21Group: System Environment/Daemons
22Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
23Source1: bind-manpages.tar.bz2
24Source2: named.sysconfig
25Source3: named.init
26Source4: named.logrotate
27Source5: keygen.c
28URL: http://www.isc.org/bind.html
29Patch1: bind-9.3.3rc2-rndckey.patch
30
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: openssl-devel glibc-devel libtool
33BuildRequires: libxml2-devel
34BuildRequires: libcap-devel
35Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
36Requires(pre): shadow-utils
37Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
38Requires(post): coreutils, chkconfig
39Requires(preun): initscripts, chkconfig
40#Requires(triggerpostun): chkconfig
41Conflicts: bind9 <= 9.2.1-0vl5, bind-current
42Obsoletes: bind9 <= 9.2.1-0vl5
43Obsoletes: bind-current < 1:9.9.4-1
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: daisuke
48
49%description
50BIND (Berkeley Internet Name Domain) is an implementation of the DNS
51(Domain Name System) protocols. BIND includes a DNS server (named),
52which resolves host names to IP addresses, and a resolver library
53(routines for applications to use when interfacing with DNS).  A DNS
54server allows clients to name resources or objects and share the
55information with other network machines.  The named DNS server can be
56used on workstations as a caching name server, but is generally only
57needed on one machine for an entire network.  Note that the
58configuration files for making BIND act as a simple caching nameserver
59are included in the caching-nameserver package. 
60
61Install the bind package if you need a DNS server for your network.  If
62you want bind to act a caching name server, you will also need to install
63the caching-nameserver package.
64
65
66%package libs
67Summary: Libraries used by various DNS packages
68Group: System Environment/Libraries
69Obsoletes: bind-current-libs <= %{old_bind_version}
70
71%description libs
72Contains libraries used by both the bind server package as well as the utils packages.
73
74
75%package utils
76Summary: Utilities for querying DNS name servers.
77Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
78Group: Applications/System
79Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
80Conflicts: bind9-utils <= 9.2.1-0vl5
81Conflicts: bind-current-utils
82Obsoletes: bind9-utils <= 9.2.1-0vl5
83Obsoletes: bind-current-utils <= %{old_bind_version}
84
85%description utils
86Bind-utils contains a collection of utilities for querying DNS (Domain
87Name Service) name servers to find out information about Internet hosts.
88These tools will provide you with the IP addresses for given host names,
89as well as other information about registered domains and network
90addresses.
91
92You should install bind-utils if you need to get information from DNS name
93servers.
94
95
96%package devel
97Summary: Include files and libraries needed for bind DNS development.
98Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
99Group: Development/Libraries
100Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
101Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
102Conflicts: bind9-devel <= 9.2.1-0vl5
103Conflicts: bind-current-devel
104Obsoletes: bind9-devel <= 9.2.1-0vl5
105Obsoletes: bind-current-devel <= %{old_bind_version}
106
107%description devel
108The bind-devel package contains all the include files and the
109library required for DNS (Domain Name Service) development for
110BIND versions 9.x.x.
111
112You should install bind-devel if you want to develop bind DNS
113applications. If you install bind-devel, you'll also need to install
114bind.
115#'
116
117%prep
118%setup -n bind-%{sversion} -q
119%patch1 -p1 -b .key
120perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
121
122%build
123libtoolize --copy --force
124aclocal
125autoconf
126%configure \
127  --with-libtool \
128  --with-openssl=/usr \
129  --disable-openssl-version-ceck \
130  --enable-threads \
131  --enable-ipv6 \
132  --with-pic \
133  --with-dlz-dlopen \
134  --enable-filter-aaaa \
135  --enable-fixed-rrset
136make %{?_smp_mflags}
137
138%install
139rm -rf $RPM_BUILD_ROOT
140mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
141mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
142mkdir -p ${RPM_BUILD_ROOT}/var/named
143mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
144mkdir -p ${RPM_BUILD_ROOT}/var/run/named
145
146make DESTDIR=$RPM_BUILD_ROOT install
147install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
148install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
149install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
150install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
151touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
152gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
153cd $RPM_BUILD_ROOT%{_mandir}
154tar xjf %{SOURCE1}
155# newer version is contained in source
156rm -f man5/named.conf.5.gz
157mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
158cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
159
160chmod +x %{buildroot}%{_libdir}/*.so.*
161
162%pre
163if [ "$1" -eq 1 ]; then
164  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
165  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
166fi;
167:;
168
169%post
170/sbin/ldconfig
171/sbin/chkconfig --add named
172if [ "$1" -eq 1 ]; then
173  if [ ! -e /etc/rndc.key ]; then
174    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
175  fi
176  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
177  # rndc.key has to have correct perms and ownership, CVE-2007-6283
178  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
179  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
180
181  # Check DNSSEC settings if this is a fresh install
182  if [ -r /etc/sysconfig/dnssec ]; then
183    . /etc/sysconfig/dnssec
184    [ -x /usr/sbin/dnssec-configure ] && \
185      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
186        /dev/null 2>&1
187  fi;
188fi
189:;
190
191%preun
192if [ "$1" -eq 0 ]; then
193   /sbin/service named stop >/dev/null 2>&1 || :
194   /sbin/chkconfig --del named ||:
195fi
196exit 0
197
198
199%postun
200if [ "$1" -ge 1 ]; then
201        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
202fi
203/sbin/ldconfig
204
205%triggerpostun -- bind < 8.2.2_P5-15
206/sbin/chkconfig --add named
207/sbin/ldconfig
208
209%triggerpostun -- bind-current < 1:9.9.4-1
210/sbin/chkconfig --add named
211/sbin/ldconfig
212
213%clean
214rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
215
216
217%post libs
218/sbin/ldconfig
219
220%postun libs
221/sbin/ldconfig
222
223
224%files
225%defattr(-,root,root)
226%doc CHANGES README
227%doc doc/arm doc/draft doc/rfc doc/misc
228%config(noreplace) %{_sysconfdir}/logrotate.d/named
229%config %{_sysconfdir}/rc.d/init.d/named
230%config(noreplace) %{_sysconfdir}/sysconfig/named
231%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
232%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
233%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
234
235%{_sbindir}/dnssec*
236%{_sbindir}/lwresd
237%{_sbindir}/named
238%{_sbindir}/named-bootconf
239%{_sbindir}/named-check*
240%{_sbindir}/named-compilezone
241%{_sbindir}/rndc*
242%{_sbindir}/dns-keygen
243%{_sbindir}/arpaname
244%{_sbindir}/ddns-confgen
245%{_sbindir}/genrandom
246%{_sbindir}/isc-hmac-fixup
247%{_sbindir}/named-journalprint
248%{_sbindir}/nsec3hash
249
250%{_mandir}/man1/arpaname.1*
251%{_mandir}/man5/resolv.conf.5*
252%{_mandir}/man5/named.conf.5*
253%{_mandir}/man5/rndc.conf.5*
254%{_mandir}/man8/rndc.8*
255%{_mandir}/man8/named.8*
256%{_mandir}/man8/lwresd.8*
257%{_mandir}/man8/dnssec*.8*
258%{_mandir}/man8/named-checkconf.8*
259%{_mandir}/man8/named-checkzone.8*
260%{_mandir}/man8/named-compilezone.8*
261%{_mandir}/man8/rndc-confgen.8*
262%{_mandir}/man8/ddns-confgen.8*
263%{_mandir}/man8/genrandom.8*
264%{_mandir}/man8/isc-hmac-fixup.8*
265%{_mandir}/man8/named-journalprint.8*
266%{_mandir}/man8/nsec3hash.8*
267
268%attr(-,named,named) %dir %{_var}/named
269%attr(-,named,named) %dir %{_var}/run/named
270     
271
272%files libs
273%defattr(-,root,root)
274%{_libdir}/*.so.*
275
276%files utils
277%defattr(-,root,root)
278%{_bindir}/dig
279%{_bindir}/host
280%{_bindir}/nslookup
281%{_bindir}/nsupdate
282%{_mandir}/man1/host.1*
283%{_mandir}/man1/nsupdate.1*
284%{_mandir}/man1/dig.1*
285%{_mandir}/man5/resolver.5*
286%{_mandir}/man1/nslookup.1*
287%{_mandir}/man8/nslookup.8*
288
289
290%files devel
291%defattr(-,root,root)
292%{_libdir}/*.so
293%{_libdir}/*.a
294%{_includedir}/*
295%{_mandir}/man3/*
296%{_mandir}/man1/isc-config.sh.1*
297%{_bindir}/isc-config.sh
298
299%changelog
300* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
301- update to 9.9.4(ESV)
302
303* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
304- update to 9.9.2-P2
305- remove .la
306- remove Conflicts/Obsoletes from libs subpackage.
307- add configure options
308  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
309
310* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
311- new upstream release.
312- added an option "--with-dlz-dlopen".
313
314* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
315- Obosoletes: bind.* < 1:9.6.ESV.R1
316 - fixed <BTS:VineLinux:1139>
317
318* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
319- new upstream release with security fix (CVE-2011-1910)
320
321* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
322- add BuildRequires: libxml2-devel, libcap-devel
323
324* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
325- new upstream release with security fix (CVE-2011-1907)
326- fix changelog typo
327
328* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
329- Obosoletes: bind.* < 1:9.6.ESV.R1
330
331* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
332- update to 9.8.0
333- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
334
335* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
336- rebuild with openssl-1.0.0c
337
338* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
339- fix Req: in bind package
340
341* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
342- change package name bind -> bind-current
343- add epoch 1
344- new upstream release
345
346* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
347- new upstream release
348
349* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
350- rebuilt with gcc-4.4.3-3 on ppc
351
352* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
353- rebuilt with new toolchains (for VineSeed)
354- s/BuildPrereq/BuildRequires/
355
356* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
357- add man1/isc-config.sh.1 into devel file list
358
359* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
360- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
361
362* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
363- new upstream release with security fix (CVE-2009-4022)
364
365* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
366- new upstream release with security fix
367
368* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
369- new upstream release
370- clean up %%post/%%pre scriptlet
371  - create named user and group in %%pre
372  - don't remove named user/group in %%preun
373  - use rndc-confgen to create rndc.key
374
375* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
376- new upstream release
377- drop patch0 and patch14, merged in upstream
378
379* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
380- new upstream release with security fix
381
382* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
383- new upstream release with security fix
384- new versioning policy
385
386* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
387- new upstream release with security fix
388
389* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
390- new upstream release
391- build with new openssl/toolchain
392
393* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
394- new upstream release with security fix
395
396* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
397- new upstream release
398
399* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
400- add Prereq sed
401
402* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
403- new upstream release for security fix (CVE-2006-4095,4096)
404
405* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
406- separate -libs package
407- remove old named.conf.5.gz
408  - newer version is contained in source
409
410* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
411- add bsdcompat patch (Patch4)
412- add fix_h_errno patch from FC
413  - h_errno not being accessed / set correctly in libbind
414
415* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
416- new upstream release
417
418* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
419- added PreReq to bind-utils (see: [VineSeed:09555])
420
421* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
422- new upstream release
423
424* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
425- fix /etc/init.d/named to use rndc
426
427* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
428- rebuild to remove unneeded dependancy
429
430* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
431- new upstream release
432
433* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
434- new upstream release
435
436* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
437- fix dependancies.
438
439* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
440- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
441- change package name to bind for VineSeed.
442- use more macros.
443
444* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
445- fixed some macros
446- add conflicts: to bind-* in bind9-devel and bind9-utils
447- add provides: bind = %%{version}
448
449* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
450- use %%configure macros
451
452* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
453- fixed inconsistent dependency
454
455* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
456- updated to 9.2.2rc1
457
458* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
459- updated to bind9(9.2.1), test packages ;)
460        -- based on Rawhide's bind-9.2.0-8
461        -- changed name bind9
462        -- added Conflicts: bind
463
464* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
465- release 8.3.1 includes security fixes
466
467* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
468- Upgraded to current stable release 8.3.0
469
470* Mon Oct  8 2001 <zn@mbf.nifty.com>
471- 8.2.5-0vl0: Upgraded to new upstream version.
472
473* Thu May 24 2001 <sagami@vinelinux.org>
474- 8.2.4-0vl1: eliminate CVS related files from %%doc
475
476* Thu May 17 2001 <sagami@vinelinux.org>
477- 8.2.4-0vl0
478
479* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
480- 8.2.3-1vl2
481- built on VineSeed
482
483* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
484- add doc/old
485- build for Vine 2.1
486
487* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
488- 8.2.3, fixes several security problems
489
490* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
491- static libraries may be used in shared objects. Build with -fPIC on ia64
492
493* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
494- 8.2.2-P7 (fixes Bug #20546)
495
496* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
497- condrestart fixes
498
499* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
500- change the init script to take condrestart, not cond-restart
501- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
502  the %pre and %post scripts
503
504* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
505- Don't prereq /etc/init.d
506
507* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
508- move initscript back
509
510* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
511- automatic rebuild
512
513* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
514- add "exit 0" for uninstall case
515
516* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
517- add prereq init.d and cleanup install section
518
519* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
520- fix the init script
521
522* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
523- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
524
525* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
526- Fix up the initscript (Bug #13033)
527- Fix build with current glibc (Bug #12755)
528- /etc/rc.d/init.d -> /etc/init.d
529- use %%{_mandir} rather than /usr/share/man
530
531* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
532- fix conflict with man-pages
533- remove compatibilty chkconfig links
534- initscript munging
535
536* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
537- modify logrotate setup to use PID file
538- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
539- actually bump the release this time
540
541* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- FHS compliance
543
544* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
545- clean up restart patch
546
547* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
548- provide /var/named (fix for bugs #9847, #10205)
549- preserve args when restarted via ndc(8) (bug #10227)
550- make resolv.conf(5) a link to resolver(5) (bug #10245)
551- fix SYSTYPE bug in all makefiles
552- move creation of named user from %%post into %%pre
553
554* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
555- Fix TTL (patch from ISC, Bug #9820)
556
557* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
558- fix typo in spec (it's %post, without a leading blank) introduced in -6
559- change SYSTYPE to linux
560
561* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
562- pick a standard < 100 uid/gid for named
563
564* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
565- Pass named a '-u named' parameter by default, and add/remove user.
566
567* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
568- fix host mx bug (Bug #9021)
569
570* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
571- rebuild to fix dependencies
572- man pages are compressed
573
574* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
576
577* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
578- Fix up location of named-bootconf.pl and make it executable
579  (Bug #8028)
580- bind-devel requires bind
581
582* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
583- update to 8.2.2-P5
584
585* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
586- update to 8.2.2-P3
587
588* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
589- add patch to stop a cache only server from complaining about lame servers
590  on every request.
591
592* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
593- use real stop and start in named.init for restart, not ndc restart, it has
594  problems when named has changed during a package update... (# 4890)
595
596* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
597- chkconfig --del in %preun, not %postun
598
599* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
600- initscript munging
601
602* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
603- fix installed chkconfig links to match init file
604
605* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
606- conflict with new (in man-1.24) man pages (#3876,#3877).
607
608* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
609- fix named.logrotate (wrong %SOURCE)
610
611* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
612- update to 8.2.1.
613- add named.logrotate (#3571).
614- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
615- vet file list.
616
617* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
618- don't run by default
619
620* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
621- nslookup fixes (#2463).
622- missing files (#3152).
623
624* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
625- nslookup patched:
626  to count numRecords properly
627  to fix subsequent calls to ls -d
628  to parse "view" and "finger" commands properly
629  the view hack updated for bind-8 (using sed)
630
631* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
632- add ISC patch
633- add quick hack to make host not crash
634- add more docs
635
636* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
637- add probing information in the init file to keep linuxconf happy
638- dont strip libbind
639
640* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
641- auto rebuild in the new build environment (release 3)
642
643* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
644- removed 'done' output at named shutdown.
645
646* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
647- version 8.2
648
649* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
650- patch to use the __FDS_BITS macro
651- build for glibc 2.1
652
653* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
654- change named.restart to /usr/sbin/ndc restart
655
656* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
657- install man pages correctly.
658- change K10named to K45named.
659
660* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
661- don't start if /etc/named.conf doesn't exist.
662
663* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
664- autmagically create /etc/named.conf from /etc/named.boot in %post
665- remove echo in %post
666
667* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
668- merge in 5.1 mods
669
670* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
671- Several essential modifications to build and install correctly.
672- Modified 'ndc' to avoid deprecated use of '-'
673
674* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
675- Used buildroot
676- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
677  on Redhat 5.0 instead of <nlist.h>
678
Note: See TracBrowser for help on using the repository browser.