source: projects/specs/trunk/b/bind/bind-vl.spec @ 521

Revision 521, 18.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.1P3
4%define sversion 9.6.1-P3
5
6%define bind_uid  25
7%define bind_gid  25
8
9Summary: A DNS (Domain Name System) server.
10Summary(ja): DNS (Domain Name System) サーバ
11Name: bind
12Version: %{pversion}
13Release: 4%{?_dist_release}
14License: distributable
15Group: System Environment/Daemons
16Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
17Source1: bind-manpages.tar.bz2
18Source2: named.sysconfig
19Source3: named.init
20Source4: named.logrotate
21Source5: keygen.c
22URL: http://www.isc.org/bind.html
23Patch1: bind-9.3.3rc2-rndckey.patch
24
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27Requires: bind-libs = %{version}-%{release}
28Requires(pre): shadow-utils
29Requires(post): bind-utils = %{version}-%{release}
30Requires(post): coreutils, chkconfig
31Requires(preun): initscripts, chkconfig
32Requires(triggerpostun): chkconfig
33Conflicts: bind9 <= 9.2.1-0vl5
34Obsoletes: bind9 <= 9.2.1-0vl5
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%description
40BIND (Berkeley Internet Name Domain) is an implementation of the DNS
41(Domain Name System) protocols. BIND includes a DNS server (named),
42which resolves host names to IP addresses, and a resolver library
43(routines for applications to use when interfacing with DNS).  A DNS
44server allows clients to name resources or objects and share the
45information with other network machines.  The named DNS server can be
46used on workstations as a caching name server, but is generally only
47needed on one machine for an entire network.  Note that the
48configuration files for making BIND act as a simple caching nameserver
49are included in the caching-nameserver package. 
50
51Install the bind package if you need a DNS server for your network.  If
52you want bind to act a caching name server, you will also need to install
53the caching-nameserver package.
54
55
56%package libs
57Summary: Libraries used by various DNS packages
58Group: System Environment/Libraries
59
60%description libs
61Contains libraries used by both the bind server package as well as the utils packages.
62
63
64%package utils
65Summary: Utilities for querying DNS name servers.
66Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
67Group: Applications/System
68Requires: bind-libs = %{version}-%{release}
69Conflicts: bind9-utils <= 9.2.1-0vl5
70Obsoletes: bind9-utils <= 9.2.1-0vl5
71
72
73%description utils
74Bind-utils contains a collection of utilities for querying DNS (Domain
75Name Service) name servers to find out information about Internet hosts.
76These tools will provide you with the IP addresses for given host names,
77as well as other information about registered domains and network
78addresses.
79
80You should install bind-utils if you need to get information from DNS name
81servers.
82
83
84%package devel
85Summary: Include files and libraries needed for bind DNS development.
86Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
87Group: Development/Libraries
88Requires: bind >= 9.2.1-0vl7
89Requires: bind-libs = %{version}-%{release}
90Conflicts: bind9-devel <= 9.2.1-0vl5
91Obsoletes: bind9-devel <= 9.2.1-0vl5
92
93
94%description devel
95The bind-devel package contains all the include files and the
96library required for DNS (Domain Name Service) development for
97BIND versions 9.x.x.
98
99You should install bind-devel if you want to develop bind DNS
100applications. If you install bind-devel, you'll also need to install
101bind.
102#'
103
104%prep
105%setup -n bind-%{sversion} -q
106%patch1 -p1 -b .key
107
108%build
109libtoolize --copy --force
110aclocal
111autoconf
112%configure --with-libtool --with-openssl=/usr --enable-threads
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
118mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
119mkdir -p ${RPM_BUILD_ROOT}/var/named
120mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
121mkdir -p ${RPM_BUILD_ROOT}/var/run/named
122
123make DESTDIR=$RPM_BUILD_ROOT install
124install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
125install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
126install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
127install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
128touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
129gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
130cd $RPM_BUILD_ROOT%{_mandir}
131tar xjf %{SOURCE1}
132# newer version is contained in source
133rm -f man5/named.conf.5.gz
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
135cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
136
137
138%pre
139if [ "$1" -eq 1 ]; then
140  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
141  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
142fi;
143:;
144
145%post
146/sbin/ldconfig
147/sbin/chkconfig --add named
148if [ "$1" -eq 1 ]; then
149  if [ ! -e /etc/rndc.key ]; then
150    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
151  fi
152  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
153  # rndc.key has to have correct perms and ownership, CVE-2007-6283
154  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
155  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
156
157  # Check DNSSEC settings if this is a fresh install
158  if [ -r /etc/sysconfig/dnssec ]; then
159    . /etc/sysconfig/dnssec
160    [ -x /usr/sbin/dnssec-configure ] && \
161      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
162        /dev/null 2>&1
163  fi;
164fi
165:;
166
167%preun
168if [ "$1" -eq 0 ]; then
169   /sbin/service named stop >/dev/null 2>&1 || :
170   /sbin/chkconfig --del named ||:
171fi
172exit 0
173
174
175%postun
176if [ "$1" -ge 1 ]; then
177        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
178fi
179/sbin/ldconfig
180
181%triggerpostun -- bind < 8.2.2_P5-15
182/sbin/chkconfig --add named
183/sbin/ldconfig
184
185%clean
186rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
187
188
189%post libs -p /sbin/ldconfig
190
191%postun libs -p /sbin/ldconfig
192
193
194%files
195%defattr(-,root,root)
196%doc CHANGES README
197%doc doc/arm doc/draft doc/rfc doc/misc
198%config(noreplace) %{_sysconfdir}/logrotate.d/named
199%config %{_sysconfdir}/rc.d/init.d/named
200%config(noreplace) %{_sysconfdir}/sysconfig/named
201%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
203
204%{_sbindir}/dnssec*
205%{_sbindir}/lwresd
206%{_sbindir}/named
207%{_sbindir}/named-bootconf
208%{_sbindir}/named-check*
209%{_sbindir}/named-compilezone
210%{_sbindir}/rndc*
211%{_sbindir}/dns-keygen
212
213#%{_libdir}/libbind9.so.*
214#%{_libdir}/libisccc.so.*
215#%{_libdir}/libisccfg.so.*
216
217%{_mandir}/man5/resolv.conf.5*
218%{_mandir}/man5/named.conf.5*
219%{_mandir}/man5/rndc.conf.5*
220%{_mandir}/man8/rndc.8*
221%{_mandir}/man8/named.8*
222%{_mandir}/man8/lwresd.8*
223%{_mandir}/man8/dnssec*.8*
224%{_mandir}/man8/named-checkconf.8*
225%{_mandir}/man8/named-checkzone.8*
226%{_mandir}/man8/named-compilezone.8*
227%{_mandir}/man8/rndc-confgen.8*
228
229%attr(-,named,named) %dir %{_var}/named
230%attr(-,named,named) %dir %{_var}/run/named
231     
232
233%files libs
234%defattr(-,root,root)
235%{_libdir}/*.so.*
236
237%files utils
238%defattr(-,root,root)
239%{_bindir}/dig
240%{_bindir}/host
241%{_bindir}/nslookup
242%{_bindir}/nsupdate
243#%{_libdir}/libdns.so.*
244#%{_libdir}/libisc.so.*
245#%{_libdir}/liblwres.so.*
246%{_mandir}/man1/host.1*
247%{_mandir}/man1/nsupdate.1*
248%{_mandir}/man1/dig.1*
249%{_mandir}/man5/resolver.5*
250%{_mandir}/man1/nslookup.1*
251%{_mandir}/man8/nslookup.8*
252
253
254%files devel
255%defattr(-,root,root)
256%{_libdir}/*.so
257%{_libdir}/*.la
258%{_libdir}/*.a
259%{_includedir}/*
260%{_mandir}/man3/*
261%{_mandir}/man1/isc-config.sh.1*
262%{_bindir}/isc-config.sh
263
264%changelog
265* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
266- rebuilt with gcc-4.4.3-3 on ppc
267
268* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
269- rebuilt with new toolchains (for VineSeed)
270- s/BuildPrereq/BuildRequires/
271
272* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
273- add man1/isc-config.sh.1 into devel file list
274
275* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
276- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
277
278* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
279- new upstream release with security fix (CVE-2009-4022)
280
281* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
282- new upstream release with security fix
283
284* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
285- new upstream release
286- clean up %%post/%%pre scriptlet
287  - create named user and group in %%pre
288  - don't remove named user/group in %%preun
289  - use rndc-confgen to create rndc.key
290
291* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
292- new upstream release
293- drop patch0 and patch14, merged in upstream
294
295* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
296- new upstream release with security fix
297
298* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
299- new upstream release with security fix
300- new versioning policy
301
302* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
303- new upstream release with security fix
304
305* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
306- new upstream release
307- build with new openssl/toolchain
308
309* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
310- new upstream release with security fix
311
312* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
313- new upstream release
314
315* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
316- add Prereq sed
317
318* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
319- new upstream release for security fix (CVE-2006-4095,4096)
320
321* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
322- separate -libs package
323- remove old named.conf.5.gz
324  - newer version is contained in source
325
326* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
327- add bsdcompat patch (Patch4)
328- add fix_h_errno patch from FC
329  - h_errno not being accessed / set correctly in libbind
330
331* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
332- new upstream release
333
334* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
335- added PreReq to bind-utils (see: [VineSeed:09555])
336
337* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
338- new upstream release
339
340* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
341- fix /etc/init.d/named to use rndc
342
343* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
344- rebuild to remove unneeded dependancy
345
346* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
347- new upstream release
348
349* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
350- new upstream release
351
352* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
353- fix dependancies.
354
355* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
356- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
357- change package name to bind for VineSeed.
358- use more macros.
359
360* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
361- fixed some macros
362- add conflicts: to bind-* in bind9-devel and bind9-utils
363- add provides: bind = %%{version}
364
365* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
366- use %%configure macros
367
368* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
369- fixed inconsistent dependency
370
371* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
372- updated to 9.2.2rc1
373
374* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
375- updated to bind9(9.2.1), test packages ;)
376        -- based on Rawhide's bind-9.2.0-8
377        -- changed name bind9
378        -- added Conflicts: bind
379
380* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
381- release 8.3.1 includes security fixes
382
383* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
384- Upgraded to current stable release 8.3.0
385
386* Mon Oct  8 2001 <zn@mbf.nifty.com>
387- 8.2.5-0vl0: Upgraded to new upstream version.
388
389* Thu May 24 2001 <sagami@vinelinux.org>
390- 8.2.4-0vl1: eliminate CVS related files from %%doc
391
392* Thu May 17 2001 <sagami@vinelinux.org>
393- 8.2.4-0vl0
394
395* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
396- 8.2.3-1vl2
397- built on VineSeed
398
399* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
400- add doc/old
401- build for Vine 2.1
402
403* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
404- 8.2.3, fixes several security problems
405
406* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
407- static libraries may be used in shared objects. Build with -fPIC on ia64
408
409* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
410- 8.2.2-P7 (fixes Bug #20546)
411
412* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
413- condrestart fixes
414
415* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
416- change the init script to take condrestart, not cond-restart
417- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
418  the %pre and %post scripts
419
420* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
421- Don't prereq /etc/init.d
422
423* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
424- move initscript back
425
426* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
427- automatic rebuild
428
429* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
430- add "exit 0" for uninstall case
431
432* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
433- add prereq init.d and cleanup install section
434
435* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
436- fix the init script
437
438* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
439- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
440
441* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
442- Fix up the initscript (Bug #13033)
443- Fix build with current glibc (Bug #12755)
444- /etc/rc.d/init.d -> /etc/init.d
445- use %%{_mandir} rather than /usr/share/man
446
447* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
448- fix conflict with man-pages
449- remove compatibilty chkconfig links
450- initscript munging
451
452* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
453- modify logrotate setup to use PID file
454- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
455- actually bump the release this time
456
457* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- FHS compliance
459
460* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
461- clean up restart patch
462
463* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
464- provide /var/named (fix for bugs #9847, #10205)
465- preserve args when restarted via ndc(8) (bug #10227)
466- make resolv.conf(5) a link to resolver(5) (bug #10245)
467- fix SYSTYPE bug in all makefiles
468- move creation of named user from %%post into %%pre
469
470* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
471- Fix TTL (patch from ISC, Bug #9820)
472
473* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
474- fix typo in spec (it's %post, without a leading blank) introduced in -6
475- change SYSTYPE to linux
476
477* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
478- pick a standard < 100 uid/gid for named
479
480* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
481- Pass named a '-u named' parameter by default, and add/remove user.
482
483* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
484- fix host mx bug (Bug #9021)
485
486* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
487- rebuild to fix dependencies
488- man pages are compressed
489
490* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
491- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
492
493* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
494- Fix up location of named-bootconf.pl and make it executable
495  (Bug #8028)
496- bind-devel requires bind
497
498* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
499- update to 8.2.2-P5
500
501* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
502- update to 8.2.2-P3
503
504* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
505- add patch to stop a cache only server from complaining about lame servers
506  on every request.
507
508* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
509- use real stop and start in named.init for restart, not ndc restart, it has
510  problems when named has changed during a package update... (# 4890)
511
512* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
513- chkconfig --del in %preun, not %postun
514
515* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
516- initscript munging
517
518* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
519- fix installed chkconfig links to match init file
520
521* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
522- conflict with new (in man-1.24) man pages (#3876,#3877).
523
524* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
525- fix named.logrotate (wrong %SOURCE)
526
527* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
528- update to 8.2.1.
529- add named.logrotate (#3571).
530- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
531- vet file list.
532
533* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
534- don't run by default
535
536* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
537- nslookup fixes (#2463).
538- missing files (#3152).
539
540* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
541- nslookup patched:
542  to count numRecords properly
543  to fix subsequent calls to ls -d
544  to parse "view" and "finger" commands properly
545  the view hack updated for bind-8 (using sed)
546
547* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
548- add ISC patch
549- add quick hack to make host not crash
550- add more docs
551
552* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
553- add probing information in the init file to keep linuxconf happy
554- dont strip libbind
555
556* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
557- auto rebuild in the new build environment (release 3)
558
559* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
560- removed 'done' output at named shutdown.
561
562* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
563- version 8.2
564
565* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
566- patch to use the __FDS_BITS macro
567- build for glibc 2.1
568
569* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
570- change named.restart to /usr/sbin/ndc restart
571
572* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
573- install man pages correctly.
574- change K10named to K45named.
575
576* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
577- don't start if /etc/named.conf doesn't exist.
578
579* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
580- autmagically create /etc/named.conf from /etc/named.boot in %post
581- remove echo in %post
582
583* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
584- merge in 5.1 mods
585
586* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
587- Several essential modifications to build and install correctly.
588- Modified 'ndc' to avoid deprecated use of '-'
589
590* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
591- Used buildroot
592- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
593  on Redhat 5.0 instead of <nlist.h>
594
Note: See TracBrowser for help on using the repository browser.