source: projects/specs/trunk/b/bind/bind-vl.spec @ 7606

Revision 7606, 20.0 KB checked in by daisuke, 11 years ago (diff)

merged with Vine 6 updates

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R8
4%define sversion 9.6-ESV-R8
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 2%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27BuildRequires: libxml2-devel libcap-devel
28Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
31Conflicts: bind9 <= 9.2.1-0vl5, bind-current
32Obsoletes: bind9 <= 9.2.1-0vl5
33epoch: %{bind_epoch}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39BIND (Berkeley Internet Name Domain) is an implementation of the DNS
40(Domain Name System) protocols. BIND includes a DNS server (named),
41which resolves host names to IP addresses, and a resolver library
42(routines for applications to use when interfacing with DNS).  A DNS
43server allows clients to name resources or objects and share the
44information with other network machines.  The named DNS server can be
45used on workstations as a caching name server, but is generally only
46needed on one machine for an entire network.  Note that the
47configuration files for making BIND act as a simple caching nameserver
48are included in the caching-nameserver package. 
49
50Install the bind package if you need a DNS server for your network.  If
51you want bind to act a caching name server, you will also need to install
52the caching-nameserver package.
53
54
55%package libs
56Summary: Libraries used by various DNS packages
57Group: System Environment/Libraries
58
59%description libs
60Contains libraries used by both the bind server package as well as the utils packages.
61
62
63%package utils
64Summary: Utilities for querying DNS name servers.
65Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
66Group: Applications/System
67Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
68Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
69Obsoletes: bind9-utils <= 9.2.1-0vl5
70
71
72%description utils
73Bind-utils contains a collection of utilities for querying DNS (Domain
74Name Service) name servers to find out information about Internet hosts.
75These tools will provide you with the IP addresses for given host names,
76as well as other information about registered domains and network
77addresses.
78
79You should install bind-utils if you need to get information from DNS name
80servers.
81
82
83%package devel
84Summary: Include files and libraries needed for bind DNS development.
85Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
86Group: Development/Libraries
87Requires: bind = %{bind_epoch}:%{version}-%{release}
88Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
89Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
90Obsoletes: bind9-devel <= 9.2.1-0vl5
91
92
93%description devel
94The bind-devel package contains all the include files and the
95library required for DNS (Domain Name Service) development for
96BIND versions 9.x.x.
97
98You should install bind-devel if you want to develop bind DNS
99applications. If you install bind-devel, you'll also need to install
100bind.
101#'
102
103%prep
104%setup -n bind-%{sversion} -q
105%patch1 -p1 -b .key
106
107%build
108libtoolize --copy --force
109aclocal
110autoconf
111%configure --with-libtool --with-openssl=/usr --enable-threads
112make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
117mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
118mkdir -p ${RPM_BUILD_ROOT}/var/named
119mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
120mkdir -p ${RPM_BUILD_ROOT}/var/run/named
121
122make DESTDIR=$RPM_BUILD_ROOT install
123install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
124install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
125install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
126install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
127touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
128gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
129cd $RPM_BUILD_ROOT%{_mandir}
130tar xjf %{SOURCE1}
131# newer version is contained in source
132rm -f man5/named.conf.5.gz
133mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
134cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
135
136# fix permissions
137chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
138
139%pre
140if [ "$1" -eq 1 ]; then
141  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
142  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
143fi;
144:;
145
146%post
147/sbin/ldconfig
148/sbin/chkconfig --add named
149if [ "$1" -eq 1 ]; then
150  if [ ! -e /etc/rndc.key ]; then
151    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
152  fi
153  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
154  # rndc.key has to have correct perms and ownership, CVE-2007-6283
155  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
156  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
157
158  # Check DNSSEC settings if this is a fresh install
159  if [ -r /etc/sysconfig/dnssec ]; then
160    . /etc/sysconfig/dnssec
161    [ -x /usr/sbin/dnssec-configure ] && \
162      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
163        /dev/null 2>&1
164  fi;
165fi
166:;
167
168%preun
169if [ "$1" -eq 0 ]; then
170   /sbin/service named stop >/dev/null 2>&1 || :
171   /sbin/chkconfig --del named ||:
172fi
173exit 0
174
175
176%postun
177if [ "$1" -ge 1 ]; then
178        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
179fi
180/sbin/ldconfig
181
182%triggerpostun -- bind < 8.2.2_P5-15
183/sbin/chkconfig --add named
184/sbin/ldconfig
185
186%clean
187rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
188
189
190%post libs -p /sbin/ldconfig
191
192%postun libs -p /sbin/ldconfig
193
194
195%files
196%defattr(-,root,root)
197%doc CHANGES README
198%doc doc/arm doc/draft doc/rfc doc/misc
199%config(noreplace) %{_sysconfdir}/logrotate.d/named
200%config %{_sysconfdir}/rc.d/init.d/named
201%config(noreplace) %{_sysconfdir}/sysconfig/named
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
203%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
204
205%{_sbindir}/dnssec*
206%{_sbindir}/lwresd
207%{_sbindir}/named
208%{_sbindir}/named-bootconf
209%{_sbindir}/named-check*
210%{_sbindir}/named-compilezone
211%{_sbindir}/rndc*
212%{_sbindir}/dns-keygen
213
214%{_mandir}/man5/resolv.conf.5*
215%{_mandir}/man5/named.conf.5*
216%{_mandir}/man5/rndc.conf.5*
217%{_mandir}/man8/rndc.8*
218%{_mandir}/man8/named.8*
219%{_mandir}/man8/lwresd.8*
220%{_mandir}/man8/dnssec*.8*
221%{_mandir}/man8/named-checkconf.8*
222%{_mandir}/man8/named-checkzone.8*
223%{_mandir}/man8/named-compilezone.8*
224%{_mandir}/man8/rndc-confgen.8*
225
226%attr(-,named,named) %dir %{_var}/named
227%attr(-,named,named) %dir %{_var}/run/named
228     
229
230%files libs
231%defattr(-,root,root)
232%{_libdir}/*.so.*
233
234%files utils
235%defattr(-,root,root)
236%{_bindir}/dig
237%{_bindir}/host
238%{_bindir}/nslookup
239%{_bindir}/nsupdate
240%{_mandir}/man1/host.1*
241%{_mandir}/man1/nsupdate.1*
242%{_mandir}/man1/dig.1*
243%{_mandir}/man5/resolver.5*
244%{_mandir}/man1/nslookup.1*
245%{_mandir}/man8/nslookup.8*
246
247
248%files devel
249%defattr(-,root,root)
250%{_libdir}/*.so
251%{_libdir}/*.a
252%{_includedir}/*
253%{_mandir}/man3/*
254%{_mandir}/man1/isc-config.sh.1*
255%{_bindir}/isc-config.sh
256
257%changelog
258* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R8-2
259- remove Conflicts from libs
260
261* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
262- new upstream release with secrity fix (CVE-2012-5166)
263
264* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
265- new upstream release with secrity fix (CVE-2012-4244)
266
267
268* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
269- new upstream release with secrity fix (CVE-2012-3817)
270- fix permission of shared libs
271- remove .la
272
273* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
274- new upstream release with security fix (CVE-2012-1667)
275
276* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
277- new upstream release with security fix (CVE-2011-4313)
278
279* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
280- new upstream release with security fix (CVE-2011-2464)
281- use hoge(pre) tags instead of old hogepre tags
282
283* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
284- new upstream release with security fix (CVE-2011-1910)
285
286* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
287- new upstream release
288
289* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
290- rebuild with openssl-1.0.0c
291
292* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
293- rebuild package
294
295* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
296- change spec filename bind9-vl -> bind-vl
297
298* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
299- new upstream ESV release
300- add BR: libxml2-devel libcap-devel
301
302* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
303- add Conflicts bind-current
304
305* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
306- new upstream ESV release
307- add epoch 1 to upgrade from exist bind package
308
309* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
310- add man1/isc-config.sh.1 into devel file list
311
312* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
313- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
314
315* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
316- new upstream release with security fix (CVE-2009-4022)
317
318* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
319- new upstream release with security fix
320
321* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
322- new upstream release
323- clean up %%post/%%pre scriptlet
324  - create named user and group in %%pre
325  - don't remove named user/group in %%preun
326  - use rndc-confgen to create rndc.key
327
328* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
329- new upstream release
330- drop patch0 and patch14, merged in upstream
331
332* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
333- new upstream release with security fix
334
335* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
336- new upstream release with security fix
337- new versioning policy
338
339* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
340- new upstream release with security fix
341
342* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
343- new upstream release
344- build with new openssl/toolchain
345
346* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
347- new upstream release with security fix
348
349* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
350- new upstream release
351
352* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
353- add Prereq sed
354
355* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
356- new upstream release for security fix (CVE-2006-4095,4096)
357
358* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
359- separate -libs package
360- remove old named.conf.5.gz
361  - newer version is contained in source
362
363* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
364- add bsdcompat patch (Patch4)
365- add fix_h_errno patch from FC
366  - h_errno not being accessed / set correctly in libbind
367
368* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
369- new upstream release
370
371* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
372- added PreReq to bind-utils (see: [VineSeed:09555])
373
374* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
375- new upstream release
376
377* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
378- fix /etc/init.d/named to use rndc
379
380* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
381- rebuild to remove unneeded dependancy
382
383* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
384- new upstream release
385
386* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
387- new upstream release
388
389* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
390- fix dependancies.
391
392* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
393- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
394- change package name to bind for VineSeed.
395- use more macros.
396
397* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
398- fixed some macros
399- add conflicts: to bind-* in bind9-devel and bind9-utils
400- add provides: bind = %%{version}
401
402* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
403- use %%configure macros
404
405* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
406- fixed inconsistent dependency
407
408* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
409- updated to 9.2.2rc1
410
411* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
412- updated to bind9(9.2.1), test packages ;)
413        -- based on Rawhide's bind-9.2.0-8
414        -- changed name bind9
415        -- added Conflicts: bind
416
417* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
418- release 8.3.1 includes security fixes
419
420* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
421- Upgraded to current stable release 8.3.0
422
423* Mon Oct  8 2001 <zn@mbf.nifty.com>
424- 8.2.5-0vl0: Upgraded to new upstream version.
425
426* Thu May 24 2001 <sagami@vinelinux.org>
427- 8.2.4-0vl1: eliminate CVS related files from %%doc
428
429* Thu May 17 2001 <sagami@vinelinux.org>
430- 8.2.4-0vl0
431
432* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
433- 8.2.3-1vl2
434- built on VineSeed
435
436* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
437- add doc/old
438- build for Vine 2.1
439
440* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
441- 8.2.3, fixes several security problems
442
443* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
444- static libraries may be used in shared objects. Build with -fPIC on ia64
445
446* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
447- 8.2.2-P7 (fixes Bug #20546)
448
449* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
450- condrestart fixes
451
452* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
453- change the init script to take condrestart, not cond-restart
454- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
455  the %pre and %post scripts
456
457* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- Don't prereq /etc/init.d
459
460* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
461- move initscript back
462
463* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
464- automatic rebuild
465
466* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
467- add "exit 0" for uninstall case
468
469* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
470- add prereq init.d and cleanup install section
471
472* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
473- fix the init script
474
475* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
476- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
477
478* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
479- Fix up the initscript (Bug #13033)
480- Fix build with current glibc (Bug #12755)
481- /etc/rc.d/init.d -> /etc/init.d
482- use %%{_mandir} rather than /usr/share/man
483
484* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
485- fix conflict with man-pages
486- remove compatibilty chkconfig links
487- initscript munging
488
489* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
490- modify logrotate setup to use PID file
491- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
492- actually bump the release this time
493
494* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
495- FHS compliance
496
497* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
498- clean up restart patch
499
500* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
501- provide /var/named (fix for bugs #9847, #10205)
502- preserve args when restarted via ndc(8) (bug #10227)
503- make resolv.conf(5) a link to resolver(5) (bug #10245)
504- fix SYSTYPE bug in all makefiles
505- move creation of named user from %%post into %%pre
506
507* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
508- Fix TTL (patch from ISC, Bug #9820)
509
510* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
511- fix typo in spec (it's %post, without a leading blank) introduced in -6
512- change SYSTYPE to linux
513
514* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
515- pick a standard < 100 uid/gid for named
516
517* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
518- Pass named a '-u named' parameter by default, and add/remove user.
519
520* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- fix host mx bug (Bug #9021)
522
523* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
524- rebuild to fix dependencies
525- man pages are compressed
526
527* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
528- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
529
530* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
531- Fix up location of named-bootconf.pl and make it executable
532  (Bug #8028)
533- bind-devel requires bind
534
535* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
536- update to 8.2.2-P5
537
538* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
539- update to 8.2.2-P3
540
541* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
542- add patch to stop a cache only server from complaining about lame servers
543  on every request.
544
545* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
546- use real stop and start in named.init for restart, not ndc restart, it has
547  problems when named has changed during a package update... (# 4890)
548
549* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
550- chkconfig --del in %preun, not %postun
551
552* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
553- initscript munging
554
555* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
556- fix installed chkconfig links to match init file
557
558* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
559- conflict with new (in man-1.24) man pages (#3876,#3877).
560
561* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
562- fix named.logrotate (wrong %SOURCE)
563
564* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
565- update to 8.2.1.
566- add named.logrotate (#3571).
567- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
568- vet file list.
569
570* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
571- don't run by default
572
573* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
574- nslookup fixes (#2463).
575- missing files (#3152).
576
577* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
578- nslookup patched:
579  to count numRecords properly
580  to fix subsequent calls to ls -d
581  to parse "view" and "finger" commands properly
582  the view hack updated for bind-8 (using sed)
583
584* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
585- add ISC patch
586- add quick hack to make host not crash
587- add more docs
588
589* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
590- add probing information in the init file to keep linuxconf happy
591- dont strip libbind
592
593* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
594- auto rebuild in the new build environment (release 3)
595
596* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
597- removed 'done' output at named shutdown.
598
599* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
600- version 8.2
601
602* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
603- patch to use the __FDS_BITS macro
604- build for glibc 2.1
605
606* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
607- change named.restart to /usr/sbin/ndc restart
608
609* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
610- install man pages correctly.
611- change K10named to K45named.
612
613* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
614- don't start if /etc/named.conf doesn't exist.
615
616* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
617- autmagically create /etc/named.conf from /etc/named.boot in %post
618- remove echo in %post
619
620* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
621- merge in 5.1 mods
622
623* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
624- Several essential modifications to build and install correctly.
625- Modified 'ndc' to avoid deprecated use of '-'
626
627* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
628- Used buildroot
629- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
630  on Redhat 5.0 instead of <nlist.h>
631
Note: See TracBrowser for help on using the repository browser.