source: projects/specs/trunk/b/bind/bind-vl.spec @ 2124

Revision 2124, 18.7 KB checked in by iwamoto, 14 years ago (diff)

add bind-vl.spec (9.6.ESV)

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R2
4%define sversion 9.6-ESV-R2
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 2%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildPreReq: openssl-devel glibc-devel libtool
27BuildRequires: libxml2-devel libcap-devel
28PreReq: chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29PreReq: bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
31Conflicts: bind9 <= 9.2.1-0vl5, bind-current
32Obsoletes: bind9 <= 9.2.1-0vl5
33epoch: %{bind_epoch}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39BIND (Berkeley Internet Name Domain) is an implementation of the DNS
40(Domain Name System) protocols. BIND includes a DNS server (named),
41which resolves host names to IP addresses, and a resolver library
42(routines for applications to use when interfacing with DNS).  A DNS
43server allows clients to name resources or objects and share the
44information with other network machines.  The named DNS server can be
45used on workstations as a caching name server, but is generally only
46needed on one machine for an entire network.  Note that the
47configuration files for making BIND act as a simple caching nameserver
48are included in the caching-nameserver package. 
49
50Install the bind package if you need a DNS server for your network.  If
51you want bind to act a caching name server, you will also need to install
52the caching-nameserver package.
53
54
55%package libs
56Summary: Libraries used by various DNS packages
57Group: System Environment/Libraries
58Conflicts: bind-current-libs
59
60%description libs
61Contains libraries used by both the bind server package as well as the utils packages.
62
63
64%package utils
65Summary: Utilities for querying DNS name servers.
66Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
67Group: Applications/System
68Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
69Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
70Obsoletes: bind9-utils <= 9.2.1-0vl5
71
72
73%description utils
74Bind-utils contains a collection of utilities for querying DNS (Domain
75Name Service) name servers to find out information about Internet hosts.
76These tools will provide you with the IP addresses for given host names,
77as well as other information about registered domains and network
78addresses.
79
80You should install bind-utils if you need to get information from DNS name
81servers.
82
83
84%package devel
85Summary: Include files and libraries needed for bind DNS development.
86Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
87Group: Development/Libraries
88Requires: bind = %{bind_epoch}:%{version}-%{release}
89Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
90Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
91Obsoletes: bind9-devel <= 9.2.1-0vl5
92
93
94%description devel
95The bind-devel package contains all the include files and the
96library required for DNS (Domain Name Service) development for
97BIND versions 9.x.x.
98
99You should install bind-devel if you want to develop bind DNS
100applications. If you install bind-devel, you'll also need to install
101bind.
102#'
103
104%prep
105%setup -n bind-%{sversion} -q
106%patch1 -p1 -b .key
107
108%build
109libtoolize --copy --force
110aclocal
111autoconf
112%configure --with-libtool --with-openssl=/usr --enable-threads
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
118mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
119mkdir -p ${RPM_BUILD_ROOT}/var/named
120mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
121mkdir -p ${RPM_BUILD_ROOT}/var/run/named
122
123make DESTDIR=$RPM_BUILD_ROOT install
124install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
125install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
126install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
127install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
128touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
129gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
130cd $RPM_BUILD_ROOT%{_mandir}
131tar xjf %{SOURCE1}
132# newer version is contained in source
133rm -f man5/named.conf.5.gz
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
135cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
136
137
138%pre
139if [ "$1" -eq 1 ]; then
140  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
141  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
142fi;
143:;
144
145%post
146/sbin/ldconfig
147/sbin/chkconfig --add named
148if [ "$1" -eq 1 ]; then
149  if [ ! -e /etc/rndc.key ]; then
150    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
151  fi
152  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
153  # rndc.key has to have correct perms and ownership, CVE-2007-6283
154  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
155  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
156
157  # Check DNSSEC settings if this is a fresh install
158  if [ -r /etc/sysconfig/dnssec ]; then
159    . /etc/sysconfig/dnssec
160    [ -x /usr/sbin/dnssec-configure ] && \
161      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
162        /dev/null 2>&1
163  fi;
164fi
165:;
166
167%preun
168if [ "$1" -eq 0 ]; then
169   /sbin/service named stop >/dev/null 2>&1 || :
170   /sbin/chkconfig --del named ||:
171fi
172exit 0
173
174
175%postun
176if [ "$1" -ge 1 ]; then
177        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
178fi
179/sbin/ldconfig
180
181%triggerpostun -- bind < 8.2.2_P5-15
182/sbin/chkconfig --add named
183/sbin/ldconfig
184
185%clean
186rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
187
188
189%post libs -p /sbin/ldconfig
190
191%postun libs -p /sbin/ldconfig
192
193
194%files
195%defattr(-,root,root)
196%doc CHANGES README
197%doc doc/arm doc/draft doc/rfc doc/misc
198%config(noreplace) %{_sysconfdir}/logrotate.d/named
199%config %{_sysconfdir}/rc.d/init.d/named
200%config(noreplace) %{_sysconfdir}/sysconfig/named
201%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
203
204%{_sbindir}/dnssec*
205%{_sbindir}/lwresd
206%{_sbindir}/named
207%{_sbindir}/named-bootconf
208%{_sbindir}/named-check*
209%{_sbindir}/named-compilezone
210%{_sbindir}/rndc*
211%{_sbindir}/dns-keygen
212
213#%{_libdir}/libbind9.so.*
214#%{_libdir}/libisccc.so.*
215#%{_libdir}/libisccfg.so.*
216
217%{_mandir}/man5/resolv.conf.5*
218%{_mandir}/man5/named.conf.5*
219%{_mandir}/man5/rndc.conf.5*
220%{_mandir}/man8/rndc.8*
221%{_mandir}/man8/named.8*
222%{_mandir}/man8/lwresd.8*
223%{_mandir}/man8/dnssec*.8*
224%{_mandir}/man8/named-checkconf.8*
225%{_mandir}/man8/named-checkzone.8*
226%{_mandir}/man8/named-compilezone.8*
227%{_mandir}/man8/rndc-confgen.8*
228
229%attr(-,named,named) %dir %{_var}/named
230%attr(-,named,named) %dir %{_var}/run/named
231     
232
233%files libs
234%defattr(-,root,root)
235%{_libdir}/*.so.*
236
237%files utils
238%defattr(-,root,root)
239%{_bindir}/dig
240%{_bindir}/host
241%{_bindir}/nslookup
242%{_bindir}/nsupdate
243#%{_libdir}/libdns.so.*
244#%{_libdir}/libisc.so.*
245#%{_libdir}/liblwres.so.*
246%{_mandir}/man1/host.1*
247%{_mandir}/man1/nsupdate.1*
248%{_mandir}/man1/dig.1*
249%{_mandir}/man5/resolver.5*
250%{_mandir}/man1/nslookup.1*
251%{_mandir}/man8/nslookup.8*
252
253
254%files devel
255%defattr(-,root,root)
256%{_libdir}/*.so
257%{_libdir}/*.la
258%{_libdir}/*.a
259%{_includedir}/*
260%{_mandir}/man3/*
261%{_mandir}/man1/isc-config.sh.1*
262%{_bindir}/isc-config.sh
263
264%changelog
265* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
266- change spec filename bind9-vl -> bind-vl
267
268* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
269- new upstream ESV release
270- add BR: libxml2-devel libcap-devel
271
272* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
273- add Conflicts bind-current
274
275* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
276- new upstream ESV release
277- add epoch 1 to upgrade from exist bind package
278
279* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
280- add man1/isc-config.sh.1 into devel file list
281
282* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
283- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
284
285* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
286- new upstream release with security fix (CVE-2009-4022)
287
288* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
289- new upstream release with security fix
290
291* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
292- new upstream release
293- clean up %%post/%%pre scriptlet
294  - create named user and group in %%pre
295  - don't remove named user/group in %%preun
296  - use rndc-confgen to create rndc.key
297
298* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
299- new upstream release
300- drop patch0 and patch14, merged in upstream
301
302* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
303- new upstream release with security fix
304
305* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
306- new upstream release with security fix
307- new versioning policy
308
309* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
310- new upstream release with security fix
311
312* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
313- new upstream release
314- build with new openssl/toolchain
315
316* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
317- new upstream release with security fix
318
319* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
320- new upstream release
321
322* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
323- add Prereq sed
324
325* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
326- new upstream release for security fix (CVE-2006-4095,4096)
327
328* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
329- separate -libs package
330- remove old named.conf.5.gz
331  - newer version is contained in source
332
333* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
334- add bsdcompat patch (Patch4)
335- add fix_h_errno patch from FC
336  - h_errno not being accessed / set correctly in libbind
337
338* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
339- new upstream release
340
341* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
342- added PreReq to bind-utils (see: [VineSeed:09555])
343
344* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
345- new upstream release
346
347* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
348- fix /etc/init.d/named to use rndc
349
350* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
351- rebuild to remove unneeded dependancy
352
353* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
354- new upstream release
355
356* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
357- new upstream release
358
359* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
360- fix dependancies.
361
362* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
363- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
364- change package name to bind for VineSeed.
365- use more macros.
366
367* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
368- fixed some macros
369- add conflicts: to bind-* in bind9-devel and bind9-utils
370- add provides: bind = %%{version}
371
372* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
373- use %%configure macros
374
375* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
376- fixed inconsistent dependency
377
378* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
379- updated to 9.2.2rc1
380
381* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
382- updated to bind9(9.2.1), test packages ;)
383        -- based on Rawhide's bind-9.2.0-8
384        -- changed name bind9
385        -- added Conflicts: bind
386
387* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
388- release 8.3.1 includes security fixes
389
390* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
391- Upgraded to current stable release 8.3.0
392
393* Mon Oct  8 2001 <zn@mbf.nifty.com>
394- 8.2.5-0vl0: Upgraded to new upstream version.
395
396* Thu May 24 2001 <sagami@vinelinux.org>
397- 8.2.4-0vl1: eliminate CVS related files from %%doc
398
399* Thu May 17 2001 <sagami@vinelinux.org>
400- 8.2.4-0vl0
401
402* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
403- 8.2.3-1vl2
404- built on VineSeed
405
406* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
407- add doc/old
408- build for Vine 2.1
409
410* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
411- 8.2.3, fixes several security problems
412
413* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
414- static libraries may be used in shared objects. Build with -fPIC on ia64
415
416* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
417- 8.2.2-P7 (fixes Bug #20546)
418
419* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
420- condrestart fixes
421
422* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
423- change the init script to take condrestart, not cond-restart
424- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
425  the %pre and %post scripts
426
427* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
428- Don't prereq /etc/init.d
429
430* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
431- move initscript back
432
433* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
434- automatic rebuild
435
436* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
437- add "exit 0" for uninstall case
438
439* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
440- add prereq init.d and cleanup install section
441
442* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
443- fix the init script
444
445* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
446- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
447
448* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
449- Fix up the initscript (Bug #13033)
450- Fix build with current glibc (Bug #12755)
451- /etc/rc.d/init.d -> /etc/init.d
452- use %%{_mandir} rather than /usr/share/man
453
454* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
455- fix conflict with man-pages
456- remove compatibilty chkconfig links
457- initscript munging
458
459* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
460- modify logrotate setup to use PID file
461- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
462- actually bump the release this time
463
464* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
465- FHS compliance
466
467* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
468- clean up restart patch
469
470* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
471- provide /var/named (fix for bugs #9847, #10205)
472- preserve args when restarted via ndc(8) (bug #10227)
473- make resolv.conf(5) a link to resolver(5) (bug #10245)
474- fix SYSTYPE bug in all makefiles
475- move creation of named user from %%post into %%pre
476
477* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
478- Fix TTL (patch from ISC, Bug #9820)
479
480* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
481- fix typo in spec (it's %post, without a leading blank) introduced in -6
482- change SYSTYPE to linux
483
484* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
485- pick a standard < 100 uid/gid for named
486
487* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
488- Pass named a '-u named' parameter by default, and add/remove user.
489
490* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
491- fix host mx bug (Bug #9021)
492
493* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
494- rebuild to fix dependencies
495- man pages are compressed
496
497* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
498- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
499
500* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
501- Fix up location of named-bootconf.pl and make it executable
502  (Bug #8028)
503- bind-devel requires bind
504
505* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
506- update to 8.2.2-P5
507
508* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
509- update to 8.2.2-P3
510
511* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
512- add patch to stop a cache only server from complaining about lame servers
513  on every request.
514
515* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
516- use real stop and start in named.init for restart, not ndc restart, it has
517  problems when named has changed during a package update... (# 4890)
518
519* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
520- chkconfig --del in %preun, not %postun
521
522* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
523- initscript munging
524
525* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
526- fix installed chkconfig links to match init file
527
528* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
529- conflict with new (in man-1.24) man pages (#3876,#3877).
530
531* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
532- fix named.logrotate (wrong %SOURCE)
533
534* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
535- update to 8.2.1.
536- add named.logrotate (#3571).
537- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
538- vet file list.
539
540* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
541- don't run by default
542
543* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
544- nslookup fixes (#2463).
545- missing files (#3152).
546
547* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
548- nslookup patched:
549  to count numRecords properly
550  to fix subsequent calls to ls -d
551  to parse "view" and "finger" commands properly
552  the view hack updated for bind-8 (using sed)
553
554* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
555- add ISC patch
556- add quick hack to make host not crash
557- add more docs
558
559* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
560- add probing information in the init file to keep linuxconf happy
561- dont strip libbind
562
563* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
564- auto rebuild in the new build environment (release 3)
565
566* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
567- removed 'done' output at named shutdown.
568
569* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
570- version 8.2
571
572* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
573- patch to use the __FDS_BITS macro
574- build for glibc 2.1
575
576* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
577- change named.restart to /usr/sbin/ndc restart
578
579* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
580- install man pages correctly.
581- change K10named to K45named.
582
583* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
584- don't start if /etc/named.conf doesn't exist.
585
586* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
587- autmagically create /etc/named.conf from /etc/named.boot in %post
588- remove echo in %post
589
590* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
591- merge in 5.1 mods
592
593* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
594- Several essential modifications to build and install correctly.
595- Modified 'ndc' to avoid deprecated use of '-'
596
597* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
598- Used buildroot
599- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
600  on Redhat 5.0 instead of <nlist.h>
601
Note: See TracBrowser for help on using the repository browser.