source: projects/specs/trunk/b/bind/bind-vl.spec @ 1382

Revision 1382, 18.4 KB checked in by daisuke, 14 years ago (diff)

update to 9.7.1-P2

Line 
1%define _localstatedir /var
2
3%define pversion 9.7.1P2
4%define sversion 9.7.1-P2
5
6%define bind_uid  25
7%define bind_gid  25
8
9Summary: A DNS (Domain Name System) server.
10Summary(ja): DNS (Domain Name System) サーバ
11Name: bind
12Version: %{pversion}
13Release: 1%{?_dist_release}
14License: distributable
15Group: System Environment/Daemons
16Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
17Source1: bind-manpages.tar.bz2
18Source2: named.sysconfig
19Source3: named.init
20Source4: named.logrotate
21Source5: keygen.c
22URL: http://www.isc.org/bind.html
23Patch1: bind-9.3.3rc2-rndckey.patch
24
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27Requires: bind-libs = %{version}-%{release}
28Requires(pre): shadow-utils
29Requires(post): bind-utils = %{version}-%{release}
30Requires(post): coreutils, chkconfig
31Requires(preun): initscripts, chkconfig
32Requires(triggerpostun): chkconfig
33Conflicts: bind9 <= 9.2.1-0vl5
34Obsoletes: bind9 <= 9.2.1-0vl5
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: daisuke
39
40%description
41BIND (Berkeley Internet Name Domain) is an implementation of the DNS
42(Domain Name System) protocols. BIND includes a DNS server (named),
43which resolves host names to IP addresses, and a resolver library
44(routines for applications to use when interfacing with DNS).  A DNS
45server allows clients to name resources or objects and share the
46information with other network machines.  The named DNS server can be
47used on workstations as a caching name server, but is generally only
48needed on one machine for an entire network.  Note that the
49configuration files for making BIND act as a simple caching nameserver
50are included in the caching-nameserver package. 
51
52Install the bind package if you need a DNS server for your network.  If
53you want bind to act a caching name server, you will also need to install
54the caching-nameserver package.
55
56
57%package libs
58Summary: Libraries used by various DNS packages
59Group: System Environment/Libraries
60
61%description libs
62Contains libraries used by both the bind server package as well as the utils packages.
63
64
65%package utils
66Summary: Utilities for querying DNS name servers.
67Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
68Group: Applications/System
69Requires: bind-libs = %{version}-%{release}
70Conflicts: bind9-utils <= 9.2.1-0vl5
71Obsoletes: bind9-utils <= 9.2.1-0vl5
72
73
74%description utils
75Bind-utils contains a collection of utilities for querying DNS (Domain
76Name Service) name servers to find out information about Internet hosts.
77These tools will provide you with the IP addresses for given host names,
78as well as other information about registered domains and network
79addresses.
80
81You should install bind-utils if you need to get information from DNS name
82servers.
83
84
85%package devel
86Summary: Include files and libraries needed for bind DNS development.
87Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
88Group: Development/Libraries
89Requires: bind >= 9.2.1-0vl7
90Requires: bind-libs = %{version}-%{release}
91Conflicts: bind9-devel <= 9.2.1-0vl5
92Obsoletes: bind9-devel <= 9.2.1-0vl5
93
94
95%description devel
96The bind-devel package contains all the include files and the
97library required for DNS (Domain Name Service) development for
98BIND versions 9.x.x.
99
100You should install bind-devel if you want to develop bind DNS
101applications. If you install bind-devel, you'll also need to install
102bind.
103#'
104
105%prep
106%setup -n bind-%{sversion} -q
107%patch1 -p1 -b .key
108
109%build
110libtoolize --copy --force
111aclocal
112autoconf
113%configure --with-libtool --with-openssl=/usr --enable-threads
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
119mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
120mkdir -p ${RPM_BUILD_ROOT}/var/named
121mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
122mkdir -p ${RPM_BUILD_ROOT}/var/run/named
123
124make DESTDIR=$RPM_BUILD_ROOT install
125install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
126install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
127install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
128install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
129touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
130gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
131cd $RPM_BUILD_ROOT%{_mandir}
132tar xjf %{SOURCE1}
133# newer version is contained in source
134rm -f man5/named.conf.5.gz
135mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
136cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
137
138
139%pre
140if [ "$1" -eq 1 ]; then
141  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
142  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
143fi;
144:;
145
146%post
147/sbin/ldconfig
148/sbin/chkconfig --add named
149if [ "$1" -eq 1 ]; then
150  if [ ! -e /etc/rndc.key ]; then
151    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
152  fi
153  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
154  # rndc.key has to have correct perms and ownership, CVE-2007-6283
155  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
156  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
157
158  # Check DNSSEC settings if this is a fresh install
159  if [ -r /etc/sysconfig/dnssec ]; then
160    . /etc/sysconfig/dnssec
161    [ -x /usr/sbin/dnssec-configure ] && \
162      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
163        /dev/null 2>&1
164  fi;
165fi
166:;
167
168%preun
169if [ "$1" -eq 0 ]; then
170   /sbin/service named stop >/dev/null 2>&1 || :
171   /sbin/chkconfig --del named ||:
172fi
173exit 0
174
175
176%postun
177if [ "$1" -ge 1 ]; then
178        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
179fi
180/sbin/ldconfig
181
182%triggerpostun -- bind < 8.2.2_P5-15
183/sbin/chkconfig --add named
184/sbin/ldconfig
185
186%clean
187rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
188
189
190%post libs -p /sbin/ldconfig
191
192%postun libs -p /sbin/ldconfig
193
194
195%files
196%defattr(-,root,root)
197%doc CHANGES README
198%doc doc/arm doc/draft doc/rfc doc/misc
199%config(noreplace) %{_sysconfdir}/logrotate.d/named
200%config %{_sysconfdir}/rc.d/init.d/named
201%config(noreplace) %{_sysconfdir}/sysconfig/named
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
203%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
204
205%{_sbindir}/dnssec*
206%{_sbindir}/lwresd
207%{_sbindir}/named
208%{_sbindir}/named-bootconf
209%{_sbindir}/named-check*
210%{_sbindir}/named-compilezone
211%{_sbindir}/rndc*
212%{_sbindir}/dns-keygen
213
214#%{_libdir}/libbind9.so.*
215#%{_libdir}/libisccc.so.*
216#%{_libdir}/libisccfg.so.*
217
218%{_mandir}/man5/resolv.conf.5*
219%{_mandir}/man5/named.conf.5*
220%{_mandir}/man5/rndc.conf.5*
221%{_mandir}/man8/rndc.8*
222%{_mandir}/man8/named.8*
223%{_mandir}/man8/lwresd.8*
224%{_mandir}/man8/dnssec*.8*
225%{_mandir}/man8/named-checkconf.8*
226%{_mandir}/man8/named-checkzone.8*
227%{_mandir}/man8/named-compilezone.8*
228%{_mandir}/man8/rndc-confgen.8*
229
230%attr(-,named,named) %dir %{_var}/named
231%attr(-,named,named) %dir %{_var}/run/named
232     
233
234%files libs
235%defattr(-,root,root)
236%{_libdir}/*.so.*
237
238%files utils
239%defattr(-,root,root)
240%{_bindir}/dig
241%{_bindir}/host
242%{_bindir}/nslookup
243%{_bindir}/nsupdate
244#%{_libdir}/libdns.so.*
245#%{_libdir}/libisc.so.*
246#%{_libdir}/liblwres.so.*
247%{_mandir}/man1/host.1*
248%{_mandir}/man1/nsupdate.1*
249%{_mandir}/man1/dig.1*
250%{_mandir}/man5/resolver.5*
251%{_mandir}/man1/nslookup.1*
252%{_mandir}/man8/nslookup.8*
253
254
255%files devel
256%defattr(-,root,root)
257%{_libdir}/*.so
258%{_libdir}/*.la
259%{_libdir}/*.a
260%{_includedir}/*
261%{_mandir}/man3/*
262%{_mandir}/man1/isc-config.sh.1*
263%{_bindir}/isc-config.sh
264
265%changelog
266* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
267- new upstream release
268
269* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
270- rebuilt with gcc-4.4.3-3 on ppc
271
272* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
273- rebuilt with new toolchains (for VineSeed)
274- s/BuildPrereq/BuildRequires/
275
276* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
277- add man1/isc-config.sh.1 into devel file list
278
279* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
280- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
281
282* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
283- new upstream release with security fix (CVE-2009-4022)
284
285* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
286- new upstream release with security fix
287
288* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
289- new upstream release
290- clean up %%post/%%pre scriptlet
291  - create named user and group in %%pre
292  - don't remove named user/group in %%preun
293  - use rndc-confgen to create rndc.key
294
295* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
296- new upstream release
297- drop patch0 and patch14, merged in upstream
298
299* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
300- new upstream release with security fix
301
302* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
303- new upstream release with security fix
304- new versioning policy
305
306* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
307- new upstream release with security fix
308
309* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
310- new upstream release
311- build with new openssl/toolchain
312
313* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
314- new upstream release with security fix
315
316* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
317- new upstream release
318
319* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
320- add Prereq sed
321
322* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
323- new upstream release for security fix (CVE-2006-4095,4096)
324
325* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
326- separate -libs package
327- remove old named.conf.5.gz
328  - newer version is contained in source
329
330* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
331- add bsdcompat patch (Patch4)
332- add fix_h_errno patch from FC
333  - h_errno not being accessed / set correctly in libbind
334
335* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
336- new upstream release
337
338* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
339- added PreReq to bind-utils (see: [VineSeed:09555])
340
341* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
342- new upstream release
343
344* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
345- fix /etc/init.d/named to use rndc
346
347* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
348- rebuild to remove unneeded dependancy
349
350* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
351- new upstream release
352
353* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
354- new upstream release
355
356* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
357- fix dependancies.
358
359* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
360- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
361- change package name to bind for VineSeed.
362- use more macros.
363
364* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
365- fixed some macros
366- add conflicts: to bind-* in bind9-devel and bind9-utils
367- add provides: bind = %%{version}
368
369* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
370- use %%configure macros
371
372* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
373- fixed inconsistent dependency
374
375* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
376- updated to 9.2.2rc1
377
378* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
379- updated to bind9(9.2.1), test packages ;)
380        -- based on Rawhide's bind-9.2.0-8
381        -- changed name bind9
382        -- added Conflicts: bind
383
384* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
385- release 8.3.1 includes security fixes
386
387* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
388- Upgraded to current stable release 8.3.0
389
390* Mon Oct  8 2001 <zn@mbf.nifty.com>
391- 8.2.5-0vl0: Upgraded to new upstream version.
392
393* Thu May 24 2001 <sagami@vinelinux.org>
394- 8.2.4-0vl1: eliminate CVS related files from %%doc
395
396* Thu May 17 2001 <sagami@vinelinux.org>
397- 8.2.4-0vl0
398
399* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
400- 8.2.3-1vl2
401- built on VineSeed
402
403* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
404- add doc/old
405- build for Vine 2.1
406
407* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
408- 8.2.3, fixes several security problems
409
410* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
411- static libraries may be used in shared objects. Build with -fPIC on ia64
412
413* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
414- 8.2.2-P7 (fixes Bug #20546)
415
416* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
417- condrestart fixes
418
419* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
420- change the init script to take condrestart, not cond-restart
421- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
422  the %pre and %post scripts
423
424* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
425- Don't prereq /etc/init.d
426
427* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
428- move initscript back
429
430* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
431- automatic rebuild
432
433* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
434- add "exit 0" for uninstall case
435
436* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
437- add prereq init.d and cleanup install section
438
439* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
440- fix the init script
441
442* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
443- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
444
445* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
446- Fix up the initscript (Bug #13033)
447- Fix build with current glibc (Bug #12755)
448- /etc/rc.d/init.d -> /etc/init.d
449- use %%{_mandir} rather than /usr/share/man
450
451* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
452- fix conflict with man-pages
453- remove compatibilty chkconfig links
454- initscript munging
455
456* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
457- modify logrotate setup to use PID file
458- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
459- actually bump the release this time
460
461* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
462- FHS compliance
463
464* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
465- clean up restart patch
466
467* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
468- provide /var/named (fix for bugs #9847, #10205)
469- preserve args when restarted via ndc(8) (bug #10227)
470- make resolv.conf(5) a link to resolver(5) (bug #10245)
471- fix SYSTYPE bug in all makefiles
472- move creation of named user from %%post into %%pre
473
474* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
475- Fix TTL (patch from ISC, Bug #9820)
476
477* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
478- fix typo in spec (it's %post, without a leading blank) introduced in -6
479- change SYSTYPE to linux
480
481* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
482- pick a standard < 100 uid/gid for named
483
484* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
485- Pass named a '-u named' parameter by default, and add/remove user.
486
487* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
488- fix host mx bug (Bug #9021)
489
490* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
491- rebuild to fix dependencies
492- man pages are compressed
493
494* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
495- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
496
497* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
498- Fix up location of named-bootconf.pl and make it executable
499  (Bug #8028)
500- bind-devel requires bind
501
502* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
503- update to 8.2.2-P5
504
505* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
506- update to 8.2.2-P3
507
508* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
509- add patch to stop a cache only server from complaining about lame servers
510  on every request.
511
512* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
513- use real stop and start in named.init for restart, not ndc restart, it has
514  problems when named has changed during a package update... (# 4890)
515
516* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
517- chkconfig --del in %preun, not %postun
518
519* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
520- initscript munging
521
522* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
523- fix installed chkconfig links to match init file
524
525* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
526- conflict with new (in man-1.24) man pages (#3876,#3877).
527
528* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
529- fix named.logrotate (wrong %SOURCE)
530
531* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
532- update to 8.2.1.
533- add named.logrotate (#3571).
534- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
535- vet file list.
536
537* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
538- don't run by default
539
540* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
541- nslookup fixes (#2463).
542- missing files (#3152).
543
544* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
545- nslookup patched:
546  to count numRecords properly
547  to fix subsequent calls to ls -d
548  to parse "view" and "finger" commands properly
549  the view hack updated for bind-8 (using sed)
550
551* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
552- add ISC patch
553- add quick hack to make host not crash
554- add more docs
555
556* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
557- add probing information in the init file to keep linuxconf happy
558- dont strip libbind
559
560* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
561- auto rebuild in the new build environment (release 3)
562
563* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
564- removed 'done' output at named shutdown.
565
566* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
567- version 8.2
568
569* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
570- patch to use the __FDS_BITS macro
571- build for glibc 2.1
572
573* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
574- change named.restart to /usr/sbin/ndc restart
575
576* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
577- install man pages correctly.
578- change K10named to K45named.
579
580* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
581- don't start if /etc/named.conf doesn't exist.
582
583* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
584- autmagically create /etc/named.conf from /etc/named.boot in %post
585- remove echo in %post
586
587* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
588- merge in 5.1 mods
589
590* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
591- Several essential modifications to build and install correctly.
592- Modified 'ndc' to avoid deprecated use of '-'
593
594* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
595- Used buildroot
596- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
597  on Redhat 5.0 instead of <nlist.h>
598
Note: See TracBrowser for help on using the repository browser.