source: projects/specs/trunk/b/bind/bind-vl.spec @ 12425

Revision 12425, 24.9 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

bind-9.11.20-2

fail2ban-0.11.1-1

Line 
1%bcond_with systemd
2
3%bcond_with python
4%define python_executable %{__python}
5
6%define _localstatedir /var
7%define _unpackaged_files_terminate_build 1
8
9%define sname bind
10%define pname bind
11# example: 9.9.13.P1
12%define pversion 9.11.20
13# example: 9.9.13-P1
14%define sversion 9.11.20
15%define bind_epoch 1
16# fixed <BTS:VineLinux:1139>
17%define old_bind_version 1:9.9.2p2-1vl7
18
19%define bind_uid  25
20%define bind_gid  25
21
22%bcond_with readline
23
24Summary: A DNS (Domain Name System) server.
25Summary(ja): DNS (Domain Name System) サーバ
26Name: %{pname}
27Epoch: %{bind_epoch}
28Version: %{pversion}
29Release: 2%{?_dist_release}%{?with_systemd:.systemd}
30Group: System Environment/Daemons
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke
34
35License: ISC and BSD and Public Domain
36URL: http://www.isc.org/bind.html
37Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
38Source1: bind-manpages.tar.bz2
39Source2: named.sysconfig
40Source3: named.init
41Source4: named.logrotate
42Source5: keygen.c
43Source100: named.service
44Source101: named-setup-rndc.service
45Source102: named.sysconfig.systemd
46Source103: bind.tmpfiles.d
47Source104: named.conf
48
49Patch1: bind-9.11.5-rndckey.patch
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52%if %{with python}
53BuildRequires: python
54BuildRequires: python-rpm-macros
55BuildRequires: python-ply
56%endif
57BuildRequires: openssl-devel glibc-devel libtool
58BuildRequires: libxml2-devel
59BuildRequires: libcap-devel
60%if %{with readline}
61BuildRequires: readline-devel
62%endif
63Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
64Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
65Requires(pre): shadow-utils
66Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
67Requires(post): coreutils
68%if %{with systemd}
69%{?systemd_requires}
70%else
71Requires(post): chkconfig
72Requires(preun): chkconfig
73%endif
74Conflicts: bind9 <= 9.2.1-0vl5, bind-current
75Obsoletes: bind9 <= 9.2.1-0vl5
76Obsoletes: bind-current < 1:9.9.4-1
77
78%description
79BIND (Berkeley Internet Name Domain) is an implementation of the DNS
80(Domain Name System) protocols. BIND includes a DNS server (named),
81which resolves host names to IP addresses, and a resolver library
82(routines for applications to use when interfacing with DNS).  A DNS
83server allows clients to name resources or objects and share the
84information with other network machines.  The named DNS server can be
85used on workstations as a caching name server, but is generally only
86needed on one machine for an entire network.  Note that the
87configuration files for making BIND act as a simple caching nameserver
88are included in the caching-nameserver package. 
89
90Install the bind package if you need a DNS server for your network.  If
91you want bind to act a caching name server, you will also need to install
92the caching-nameserver package.
93
94
95%package libs
96Summary: Libraries used by various DNS packages
97Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
98Group: System Environment/Libraries
99Obsoletes: bind-current-libs <= %{old_bind_version}
100
101%description libs
102Contains libraries used by both the bind server package as well as the utils packages.
103
104
105%package utils
106Summary: Utilities for querying DNS name servers.
107Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
108Group: Applications/System
109Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
110Conflicts: bind9-utils <= 9.2.1-0vl5
111Conflicts: bind-current-utils
112Obsoletes: bind9-utils <= 9.2.1-0vl5
113Obsoletes: bind-current-utils <= %{old_bind_version}
114
115%description utils
116Bind-utils contains a collection of utilities for querying DNS (Domain
117Name Service) name servers to find out information about Internet hosts.
118These tools will provide you with the IP addresses for given host names,
119as well as other information about registered domains and network
120addresses.
121
122You should install bind-utils if you need to get information from DNS name
123servers.
124
125
126%package devel
127Summary: Include files and libraries needed for bind DNS development.
128Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
129Group: Development/Libraries
130Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
131Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
132Conflicts: bind9-devel <= 9.2.1-0vl5
133Conflicts: bind-current-devel
134Obsoletes: bind9-devel <= 9.2.1-0vl5
135Obsoletes: bind-current-devel <= %{old_bind_version}
136
137%description devel
138The bind-devel package contains all the include files and the
139library required for DNS (Domain Name Service) development for
140BIND versions 9.x.x.
141
142You should install bind-devel if you want to develop bind DNS
143applications. If you install bind-devel, you'll also need to install
144bind.
145#'
146
147%prep
148%setup -n bind-%{sversion} -q
149%patch1 -p1 -b .key
150perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
151
152%build
153libtoolize --copy --force
154aclocal
155autoconf
156%configure \
157  --with-libtool \
158  --with-openssl=/usr \
159%if %{without readline}
160    --without-readline \
161%endif
162  --disable-openssl-version-ceck \
163  --enable-threads \
164  --enable-ipv6 \
165  --with-pic \
166  --with-dlz-dlopen \
167%if %{with python}
168  --with-python=%{python_executable} \
169%else
170  --with-python=no \
171%endif
172  --enable-filter-aaaa \
173  --enable-fixed-rrset
174make %{?_smp_mflags}
175
176%install
177rm -rf %{buildroot}
178mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
179mkdir -p %{buildroot}/usr/{bin,lib,sbin,include}
180mkdir -p %{buildroot}/var/named/data
181mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
182mkdir -p %{buildroot}/var/run/named
183
184make DESTDIR=%{buildroot} install
185install -c -m 640 bin/rndc/rndc.conf %{buildroot}/etc
186install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
187touch %{buildroot}%{_sysconfdir}/rndc.key
188gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
189cd %{buildroot}%{_mandir}
190tar xjf %{SOURCE1}
191# newer version is contained in source
192rm -f man5/named.conf.5.gz
193
194install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
195
196%if %{with systemd}
197# Systemd unit files
198mkdir -p %{buildroot}%{_unitdir}
199install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
200install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
201install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
202mkdir -p %{buildroot}%{_tmpfilesdir}
203install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
204%else
205mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
206install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
207cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
208%endif
209
210chmod +x %{buildroot}%{_libdir}/*.so.*
211
212rm -f %{buildroot}%{_libdir}/*.la
213
214%clean
215rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
216
217
218%pre
219if [ "$1" -eq 1 ]; then
220  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
221  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
222fi;
223:;
224
225%post
226/sbin/ldconfig
227if [ "$1" -eq 1 ]; then
228  if [ ! -e /etc/rndc.key ]; then
229    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
230  fi
231  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
232  # rndc.key has to have correct perms and ownership, CVE-2007-6283
233  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
234  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
235
236  # Check DNSSEC settings if this is a fresh install
237  if [ -r /etc/sysconfig/dnssec ]; then
238    . /etc/sysconfig/dnssec
239    [ -x /usr/sbin/dnssec-configure ] && \
240      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
241        /dev/null 2>&1
242  fi;
243fi
244%if %{with systemd}
245%systemd_post named.service
246%else
247if [ "$1" -eq 1 ]; then
248  /sbin/chkconfig --add named
249fi
250%endif
251:;
252
253%preun
254%if %{with systemd}
255# Package removal, not upgrade
256%systemd_preun named.service
257%else
258if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
259   /sbin/service named stop >/dev/null 2>&1 || :
260   /sbin/chkconfig --del named ||:
261fi
262%endif
263exit 0
264
265%postun
266/sbin/ldconfig
267%if %{with systemd}
268# Package upgrade, not uninstall
269%systemd_postun_with_restart named.service
270%else
271if [ "$1" -ge 1 ]; then
272        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
273fi
274%endif
275exit 0
276
277%triggerpostun -- bind < 8.2.2_P5-15
278/sbin/chkconfig --add named
279/sbin/ldconfig
280
281%triggerpostun -- bind-current < 1:9.9.4-1
282/sbin/chkconfig --add named
283/sbin/ldconfig
284
285%post libs -p /sbin/ldconfig
286
287%postun libs -p /sbin/ldconfig
288
289
290%files
291%defattr(-,root,root)
292%license COPYRIGHT
293%doc CHANGES README*
294%doc doc/arm doc/misc
295%config(noreplace) %{_sysconfdir}/named.conf
296%config(noreplace) %{_sysconfdir}/logrotate.d/named
297%if %{with systemd}
298%{_unitdir}/named.service
299%{_unitdir}/named-setup-rndc.service
300%{_tmpfilesdir}/named.conf
301%else
302%config %{_sysconfdir}/rc.d/init.d/named
303%attr(-,named,named) %dir %{_var}/run/named
304%endif
305%config(noreplace) %{_sysconfdir}/sysconfig/named
306%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
307%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
308%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
309
310%attr(-,named,named) %dir %{_var}/named
311%attr(-,named,named) %dir %{_var}/named/data
312
313%{_sbindir}/dnssec*
314%{_sbindir}/lwresd
315%{_sbindir}/named
316%{_sbindir}/named-check*
317%{_sbindir}/named-compilezone
318%{_sbindir}/rndc*
319%{_sbindir}/dns-keygen
320%{_bindir}/arpaname
321%{_sbindir}/ddns-confgen
322%{_sbindir}/genrandom
323%{_sbindir}/isc-hmac-fixup
324%{_sbindir}/named-journalprint
325%{_sbindir}/nsec3hash
326%{_sbindir}/tsig-keygen
327
328%if %{with python}
329%{python_sitelib}/*
330%endif
331
332%{_mandir}/man1/arpaname.1*
333%{_mandir}/man5/resolv.conf.5*
334%{_mandir}/man5/named.conf.5*
335%{_mandir}/man5/rndc.conf.5*
336%{_mandir}/man8/rndc.8*
337%{_mandir}/man8/named.8*
338%{_mandir}/man8/lwresd.8*
339%{_mandir}/man8/dnssec*.8*
340%{_mandir}/man8/named-checkconf.8*
341%{_mandir}/man8/named-checkzone.8*
342%{_mandir}/man8/named-compilezone.8*
343%{_mandir}/man8/rndc-confgen.8*
344%{_mandir}/man8/ddns-confgen.8*
345%{_mandir}/man8/genrandom.8*
346%{_mandir}/man8/isc-hmac-fixup.8*
347%{_mandir}/man8/named-journalprint.8*
348%{_mandir}/man8/nsec3hash.8*
349%{_mandir}/man8/tsig-keygen.8*
350
351%files libs
352%defattr(-,root,root)
353%{_libdir}/*.so.*
354
355%files utils
356%defattr(-,root,root)
357%{_bindir}/delv
358%{_bindir}/dig
359%{_bindir}/host
360%{_bindir}/mdig
361%{_bindir}/named-rrchecker
362%{_bindir}/nslookup
363%{_bindir}/nsupdate
364%{_mandir}/man1/delv.1*
365%{_mandir}/man1/dig.1*
366%{_mandir}/man1/host.1*
367%{_mandir}/man1/mdig.1*
368%{_mandir}/man1/named-rrchecker.1*
369%{_mandir}/man1/nslookup.1*
370%{_mandir}/man1/nsupdate.1*
371%{_mandir}/man5/resolver.5*
372%{_mandir}/man8/nslookup.8*
373
374%files devel
375%defattr(-,root,root)
376%{_libdir}/*.so
377%{_libdir}/*.a
378%{_includedir}/*
379%{_mandir}/man3/*
380%{_mandir}/man1/bind9-config.1*
381%{_mandir}/man1/isc-config.sh.1*
382%{_bindir}/bind9-config
383%{_bindir}/isc-config.sh
384
385%changelog
386* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
387- added systemd support (disabled as default).
388
389* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
390- updated to 9.11.20.
391
392* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
393- updated to 9.11.12.
394
395* Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
396- updated to 9.11.11.
397
398* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
399- updated to 9.11.5 (new ESV).
400- updated Patch1.
401
402* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
403- updated to 9.9.13.P1.
404- updated Patch1.
405
406* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
407- update to 9.9.9.P8
408
409* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
410- new upstream release.
411
412* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
413- new upstream release.
414
415* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
416- new upstream release.
417
418* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
419- new upstream release with secrity fix (CVE-2016-1285,1286)
420- built with openssl 1.0.2g
421
422* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
423- new upstream release with secrity fix (CVE-2015-4620) 
424
425* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
426- new upstream release with secrity fix (CVE-2015-4620)
427
428* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
429- rebuilt without readline to avoid GPL infection
430
431* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
432- new upstream release with secrity fix (CVE-2015-1349)
433- added BR: readline-devel
434
435* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
436- new upstream release with secrity fix (CVE-2014-8500) 
437- used "3" as release number because of being newer than Vine Linux/6 updates
438
439* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
440- update to 9.9.4(ESV)
441
442* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
443- update to 9.9.2-P2
444- remove .la
445- remove Conflicts/Obsoletes from libs subpackage.
446- add configure options
447  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
448
449* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
450- new upstream release.
451- added an option "--with-dlz-dlopen".
452
453* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
454- Obosoletes: bind.* < 1:9.6.ESV.R1
455 - fixed <BTS:VineLinux:1139>
456
457* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
458- new upstream release with security fix (CVE-2011-1910)
459
460* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
461- add BuildRequires: libxml2-devel, libcap-devel
462
463* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
464- new upstream release with security fix (CVE-2011-1907)
465- fix changelog typo
466
467* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
468- Obosoletes: bind.* < 1:9.6.ESV.R1
469
470* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
471- update to 9.8.0
472- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
473
474* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
475- rebuild with openssl-1.0.0c
476
477* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
478- fix Req: in bind package
479
480* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
481- change package name bind -> bind-current
482- add epoch 1
483- new upstream release
484
485* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
486- new upstream release
487
488* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
489- rebuilt with gcc-4.4.3-3 on ppc
490
491* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
492- rebuilt with new toolchains (for VineSeed)
493- s/BuildPrereq/BuildRequires/
494
495* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
496- add man1/isc-config.sh.1 into devel file list
497
498* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
499- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
500
501* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
502- new upstream release with security fix (CVE-2009-4022)
503
504* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
505- new upstream release with security fix
506
507* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
508- new upstream release
509- clean up %%post/%%pre scriptlet
510  - create named user and group in %%pre
511  - don't remove named user/group in %%preun
512  - use rndc-confgen to create rndc.key
513
514* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
515- new upstream release
516- drop patch0 and patch14, merged in upstream
517
518* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
519- new upstream release with security fix
520
521* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
522- new upstream release with security fix
523- new versioning policy
524
525* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
526- new upstream release with security fix
527
528* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
529- new upstream release
530- build with new openssl/toolchain
531
532* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
533- new upstream release with security fix
534
535* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
536- new upstream release
537
538* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
539- add Prereq sed
540
541* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
542- new upstream release for security fix (CVE-2006-4095,4096)
543
544* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
545- separate -libs package
546- remove old named.conf.5.gz
547  - newer version is contained in source
548
549* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
550- add bsdcompat patch (Patch4)
551- add fix_h_errno patch from FC
552  - h_errno not being accessed / set correctly in libbind
553
554* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
555- new upstream release
556
557* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
558- added PreReq to bind-utils (see: [VineSeed:09555])
559
560* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
561- new upstream release
562
563* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
564- fix /etc/init.d/named to use rndc
565
566* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
567- rebuild to remove unneeded dependancy
568
569* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
570- new upstream release
571
572* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
573- new upstream release
574
575* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
576- fix dependancies.
577
578* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
579- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
580- change package name to bind for VineSeed.
581- use more macros.
582
583* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
584- fixed some macros
585- add conflicts: to bind-* in bind9-devel and bind9-utils
586- add provides: bind = %%{version}
587
588* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
589- use %%configure macros
590
591* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
592- fixed inconsistent dependency
593
594* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
595- updated to 9.2.2rc1
596
597* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
598- updated to bind9(9.2.1), test packages ;)
599        -- based on Rawhide's bind-9.2.0-8
600        -- changed name bind9
601        -- added Conflicts: bind
602
603* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
604- release 8.3.1 includes security fixes
605
606* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
607- Upgraded to current stable release 8.3.0
608
609* Mon Oct  8 2001 <zn@mbf.nifty.com>
610- 8.2.5-0vl0: Upgraded to new upstream version.
611
612* Thu May 24 2001 <sagami@vinelinux.org>
613- 8.2.4-0vl1: eliminate CVS related files from %%doc
614
615* Thu May 17 2001 <sagami@vinelinux.org>
616- 8.2.4-0vl0
617
618* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
619- 8.2.3-1vl2
620- built on VineSeed
621
622* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
623- add doc/old
624- build for Vine 2.1
625
626* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
627- 8.2.3, fixes several security problems
628
629* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
630- static libraries may be used in shared objects. Build with -fPIC on ia64
631
632* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
633- 8.2.2-P7 (fixes Bug #20546)
634
635* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
636- condrestart fixes
637
638* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
639- change the init script to take condrestart, not cond-restart
640- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
641  the %pre and %post scripts
642
643* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
644- Don't prereq /etc/init.d
645
646* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
647- move initscript back
648
649* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
650- automatic rebuild
651
652* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
653- add "exit 0" for uninstall case
654
655* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
656- add prereq init.d and cleanup install section
657
658* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
659- fix the init script
660
661* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
662- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
663
664* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
665- Fix up the initscript (Bug #13033)
666- Fix build with current glibc (Bug #12755)
667- /etc/rc.d/init.d -> /etc/init.d
668- use %%{_mandir} rather than /usr/share/man
669
670* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
671- fix conflict with man-pages
672- remove compatibilty chkconfig links
673- initscript munging
674
675* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
676- modify logrotate setup to use PID file
677- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
678- actually bump the release this time
679
680* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
681- FHS compliance
682
683* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
684- clean up restart patch
685
686* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
687- provide /var/named (fix for bugs #9847, #10205)
688- preserve args when restarted via ndc(8) (bug #10227)
689- make resolv.conf(5) a link to resolver(5) (bug #10245)
690- fix SYSTYPE bug in all makefiles
691- move creation of named user from %%post into %%pre
692
693* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
694- Fix TTL (patch from ISC, Bug #9820)
695
696* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
697- fix typo in spec (it's %post, without a leading blank) introduced in -6
698- change SYSTYPE to linux
699
700* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
701- pick a standard < 100 uid/gid for named
702
703* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
704- Pass named a '-u named' parameter by default, and add/remove user.
705
706* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
707- fix host mx bug (Bug #9021)
708
709* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
710- rebuild to fix dependencies
711- man pages are compressed
712
713* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
714- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
715
716* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
717- Fix up location of named-bootconf.pl and make it executable
718  (Bug #8028)
719- bind-devel requires bind
720
721* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
722- update to 8.2.2-P5
723
724* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
725- update to 8.2.2-P3
726
727* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
728- add patch to stop a cache only server from complaining about lame servers
729  on every request.
730
731* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
732- use real stop and start in named.init for restart, not ndc restart, it has
733  problems when named has changed during a package update... (# 4890)
734
735* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
736- chkconfig --del in %preun, not %postun
737
738* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
739- initscript munging
740
741* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
742- fix installed chkconfig links to match init file
743
744* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
745- conflict with new (in man-1.24) man pages (#3876,#3877).
746
747* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
748- fix named.logrotate (wrong %SOURCE)
749
750* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
751- update to 8.2.1.
752- add named.logrotate (#3571).
753- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
754- vet file list.
755
756* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
757- don't run by default
758
759* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
760- nslookup fixes (#2463).
761- missing files (#3152).
762
763* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
764- nslookup patched:
765  to count numRecords properly
766  to fix subsequent calls to ls -d
767  to parse "view" and "finger" commands properly
768  the view hack updated for bind-8 (using sed)
769
770* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
771- add ISC patch
772- add quick hack to make host not crash
773- add more docs
774
775* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
776- add probing information in the init file to keep linuxconf happy
777- dont strip libbind
778
779* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
780- auto rebuild in the new build environment (release 3)
781
782* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
783- removed 'done' output at named shutdown.
784
785* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
786- version 8.2
787
788* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
789- patch to use the __FDS_BITS macro
790- build for glibc 2.1
791
792* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
793- change named.restart to /usr/sbin/ndc restart
794
795* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
796- install man pages correctly.
797- change K10named to K45named.
798
799* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
800- don't start if /etc/named.conf doesn't exist.
801
802* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
803- autmagically create /etc/named.conf from /etc/named.boot in %post
804- remove echo in %post
805
806* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
807- merge in 5.1 mods
808
809* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
810- Several essential modifications to build and install correctly.
811- Modified 'ndc' to avoid deprecated use of '-'
812
813* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
814- Used buildroot
815- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
816  on Redhat 5.0 instead of <nlist.h>
817
Note: See TracBrowser for help on using the repository browser.