source: projects/specs/trunk/b/bind/bind-vl.spec @ 12310

Revision 12310, 23.6 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1%bcond_with python
2%define python_executable %{__python}
3
4%define _localstatedir /var
5%define _unpackaged_files_terminate_build 1
6
7%define sname bind
8%define pname bind
9# example: 9.9.13.P1
10%define pversion 9.11.12
11# example: 9.9.13-P1
12%define sversion 9.11.12
13%define bind_epoch 1
14# fixed <BTS:VineLinux:1139>
15%define old_bind_version 1:9.9.2p2-1vl7
16
17%define bind_uid  25
18%define bind_gid  25
19
20%bcond_with readline
21
22Summary: A DNS (Domain Name System) server.
23Summary(ja): DNS (Domain Name System) サーバ
24Name: %{pname}
25Version: %{pversion}
26Release: 1%{?_dist_release}
27Epoch: %{bind_epoch}
28License: ISC and BSD and Public Domain
29Group: System Environment/Daemons
30URL: http://www.isc.org/bind.html
31
32Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
33Source1: bind-manpages.tar.bz2
34Source2: named.sysconfig
35Source3: named.init
36Source4: named.logrotate
37Source5: keygen.c
38Patch1: bind-9.11.5-rndckey.patch
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41%if %{with python}
42BuildRequires: python
43BuildRequires: python-rpm-macros
44BuildRequires: python-ply
45%endif
46BuildRequires: openssl-devel glibc-devel libtool
47BuildRequires: libxml2-devel
48BuildRequires: libcap-devel
49%if %{with readline}
50BuildRequires: readline-devel
51%endif
52Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
53Requires(pre): shadow-utils
54Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
55Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
56Requires(post): coreutils, chkconfig
57Requires(preun): initscripts, chkconfig
58Conflicts: bind9 <= 9.2.1-0vl5, bind-current
59Obsoletes: bind9 <= 9.2.1-0vl5
60Obsoletes: bind-current < 1:9.9.4-1
61
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: daisuke
65
66%description
67BIND (Berkeley Internet Name Domain) is an implementation of the DNS
68(Domain Name System) protocols. BIND includes a DNS server (named),
69which resolves host names to IP addresses, and a resolver library
70(routines for applications to use when interfacing with DNS).  A DNS
71server allows clients to name resources or objects and share the
72information with other network machines.  The named DNS server can be
73used on workstations as a caching name server, but is generally only
74needed on one machine for an entire network.  Note that the
75configuration files for making BIND act as a simple caching nameserver
76are included in the caching-nameserver package. 
77
78Install the bind package if you need a DNS server for your network.  If
79you want bind to act a caching name server, you will also need to install
80the caching-nameserver package.
81
82
83%package libs
84Summary: Libraries used by various DNS packages
85Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
86Group: System Environment/Libraries
87Obsoletes: bind-current-libs <= %{old_bind_version}
88
89%description libs
90Contains libraries used by both the bind server package as well as the utils packages.
91
92
93%package utils
94Summary: Utilities for querying DNS name servers.
95Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
96Group: Applications/System
97Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
98Conflicts: bind9-utils <= 9.2.1-0vl5
99Conflicts: bind-current-utils
100Obsoletes: bind9-utils <= 9.2.1-0vl5
101Obsoletes: bind-current-utils <= %{old_bind_version}
102
103%description utils
104Bind-utils contains a collection of utilities for querying DNS (Domain
105Name Service) name servers to find out information about Internet hosts.
106These tools will provide you with the IP addresses for given host names,
107as well as other information about registered domains and network
108addresses.
109
110You should install bind-utils if you need to get information from DNS name
111servers.
112
113
114%package devel
115Summary: Include files and libraries needed for bind DNS development.
116Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
117Group: Development/Libraries
118Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
119Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
120Conflicts: bind9-devel <= 9.2.1-0vl5
121Conflicts: bind-current-devel
122Obsoletes: bind9-devel <= 9.2.1-0vl5
123Obsoletes: bind-current-devel <= %{old_bind_version}
124
125%description devel
126The bind-devel package contains all the include files and the
127library required for DNS (Domain Name Service) development for
128BIND versions 9.x.x.
129
130You should install bind-devel if you want to develop bind DNS
131applications. If you install bind-devel, you'll also need to install
132bind.
133#'
134
135%prep
136%setup -n bind-%{sversion} -q
137%patch1 -p1 -b .key
138perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
139
140%build
141libtoolize --copy --force
142aclocal
143autoconf
144%configure \
145  --with-libtool \
146  --with-openssl=/usr \
147%if %{without readline}
148    --without-readline \
149%endif
150  --disable-openssl-version-ceck \
151  --enable-threads \
152  --enable-ipv6 \
153  --with-pic \
154  --with-dlz-dlopen \
155%if %{with python}
156  --with-python=%{python_executable} \
157%else
158  --with-python=no \
159%endif
160  --enable-filter-aaaa \
161  --enable-fixed-rrset
162make %{?_smp_mflags}
163
164%install
165rm -rf $RPM_BUILD_ROOT
166mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
167mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
168mkdir -p ${RPM_BUILD_ROOT}/var/named
169mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
170mkdir -p ${RPM_BUILD_ROOT}/var/run/named
171
172make DESTDIR=$RPM_BUILD_ROOT install
173install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
174install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
175install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
176touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
177gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
178cd $RPM_BUILD_ROOT%{_mandir}
179tar xjf %{SOURCE1}
180# newer version is contained in source
181rm -f man5/named.conf.5.gz
182mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
183cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
184
185chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
186
187rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
188
189%clean
190rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
191
192
193%pre
194if [ "$1" -eq 1 ]; then
195  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
196  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
197fi;
198:;
199
200%post
201/sbin/ldconfig
202/sbin/chkconfig --add named
203if [ "$1" -eq 1 ]; then
204  if [ ! -e /etc/rndc.key ]; then
205    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
206  fi
207  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
208  # rndc.key has to have correct perms and ownership, CVE-2007-6283
209  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
210  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
211
212  # Check DNSSEC settings if this is a fresh install
213  if [ -r /etc/sysconfig/dnssec ]; then
214    . /etc/sysconfig/dnssec
215    [ -x /usr/sbin/dnssec-configure ] && \
216      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
217        /dev/null 2>&1
218  fi;
219fi
220:;
221
222%preun
223if [ "$1" -eq 0 ]; then
224   /sbin/service named stop >/dev/null 2>&1 || :
225   /sbin/chkconfig --del named ||:
226fi
227exit 0
228
229%postun
230if [ "$1" -ge 1 ]; then
231        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
232fi
233/sbin/ldconfig
234
235%triggerpostun -- bind < 8.2.2_P5-15
236/sbin/chkconfig --add named
237/sbin/ldconfig
238
239%triggerpostun -- bind-current < 1:9.9.4-1
240/sbin/chkconfig --add named
241/sbin/ldconfig
242
243%post libs -p /sbin/ldconfig
244
245%postun libs -p /sbin/ldconfig
246
247
248%files
249%defattr(-,root,root)
250%license COPYRIGHT
251%doc CHANGES README*
252%doc doc/arm doc/misc
253%config(noreplace) %{_sysconfdir}/logrotate.d/named
254%config %{_sysconfdir}/rc.d/init.d/named
255%config(noreplace) %{_sysconfdir}/sysconfig/named
256%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
257%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
258%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
259
260%{_sbindir}/dnssec*
261%{_sbindir}/lwresd
262%{_sbindir}/named
263%{_sbindir}/named-check*
264%{_sbindir}/named-compilezone
265%{_sbindir}/rndc*
266%{_sbindir}/dns-keygen
267%{_bindir}/arpaname
268%{_sbindir}/ddns-confgen
269%{_sbindir}/genrandom
270%{_sbindir}/isc-hmac-fixup
271%{_sbindir}/named-journalprint
272%{_sbindir}/nsec3hash
273%{_sbindir}/tsig-keygen
274
275%if %{with python}
276%{python_sitelib}/*
277%endif
278
279%{_mandir}/man1/arpaname.1*
280%{_mandir}/man5/resolv.conf.5*
281%{_mandir}/man5/named.conf.5*
282%{_mandir}/man5/rndc.conf.5*
283%{_mandir}/man8/rndc.8*
284%{_mandir}/man8/named.8*
285%{_mandir}/man8/lwresd.8*
286%{_mandir}/man8/dnssec*.8*
287%{_mandir}/man8/named-checkconf.8*
288%{_mandir}/man8/named-checkzone.8*
289%{_mandir}/man8/named-compilezone.8*
290%{_mandir}/man8/rndc-confgen.8*
291%{_mandir}/man8/ddns-confgen.8*
292%{_mandir}/man8/genrandom.8*
293%{_mandir}/man8/isc-hmac-fixup.8*
294%{_mandir}/man8/named-journalprint.8*
295%{_mandir}/man8/nsec3hash.8*
296%{_mandir}/man8/tsig-keygen.8*
297
298%attr(-,named,named) %dir %{_var}/named
299%attr(-,named,named) %dir %{_var}/run/named
300
301
302%files libs
303%defattr(-,root,root)
304%{_libdir}/*.so.*
305
306%files utils
307%defattr(-,root,root)
308%{_bindir}/delv
309%{_bindir}/dig
310%{_bindir}/host
311%{_bindir}/mdig
312%{_bindir}/named-rrchecker
313%{_bindir}/nslookup
314%{_bindir}/nsupdate
315%{_mandir}/man1/delv.1*
316%{_mandir}/man1/dig.1*
317%{_mandir}/man1/host.1*
318%{_mandir}/man1/mdig.1*
319%{_mandir}/man1/named-rrchecker.1*
320%{_mandir}/man1/nslookup.1*
321%{_mandir}/man1/nsupdate.1*
322%{_mandir}/man5/resolver.5*
323%{_mandir}/man8/nslookup.8*
324
325%files devel
326%defattr(-,root,root)
327%{_libdir}/*.so
328%{_libdir}/*.a
329%{_includedir}/*
330%{_mandir}/man3/*
331%{_mandir}/man1/bind9-config.1*
332%{_mandir}/man1/isc-config.sh.1*
333%{_bindir}/bind9-config
334%{_bindir}/isc-config.sh
335
336%changelog
337* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
338- updated to 9.11.12.
339
340* Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
341- updated to 9.11.11.
342
343* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
344- updated to 9.11.5 (new ESV).
345- updated Patch1.
346
347* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
348- updated to 9.9.13.P1.
349- updated Patch1.
350
351* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
352- update to 9.9.9.P8
353
354* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
355- new upstream release.
356
357* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
358- new upstream release.
359
360* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
361- new upstream release.
362
363* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
364- new upstream release with secrity fix (CVE-2016-1285,1286)
365- built with openssl 1.0.2g
366
367* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
368- new upstream release with secrity fix (CVE-2015-4620) 
369
370* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
371- new upstream release with secrity fix (CVE-2015-4620)
372
373* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
374- rebuilt without readline to avoid GPL infection
375
376* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
377- new upstream release with secrity fix (CVE-2015-1349)
378- added BR: readline-devel
379
380* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
381- new upstream release with secrity fix (CVE-2014-8500) 
382- used "3" as release number because of being newer than Vine Linux/6 updates
383
384* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
385- update to 9.9.4(ESV)
386
387* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
388- update to 9.9.2-P2
389- remove .la
390- remove Conflicts/Obsoletes from libs subpackage.
391- add configure options
392  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
393
394* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
395- new upstream release.
396- added an option "--with-dlz-dlopen".
397
398* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
399- Obosoletes: bind.* < 1:9.6.ESV.R1
400 - fixed <BTS:VineLinux:1139>
401
402* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
403- new upstream release with security fix (CVE-2011-1910)
404
405* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
406- add BuildRequires: libxml2-devel, libcap-devel
407
408* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
409- new upstream release with security fix (CVE-2011-1907)
410- fix changelog typo
411
412* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
413- Obosoletes: bind.* < 1:9.6.ESV.R1
414
415* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
416- update to 9.8.0
417- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
418
419* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
420- rebuild with openssl-1.0.0c
421
422* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
423- fix Req: in bind package
424
425* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
426- change package name bind -> bind-current
427- add epoch 1
428- new upstream release
429
430* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
431- new upstream release
432
433* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
434- rebuilt with gcc-4.4.3-3 on ppc
435
436* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
437- rebuilt with new toolchains (for VineSeed)
438- s/BuildPrereq/BuildRequires/
439
440* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
441- add man1/isc-config.sh.1 into devel file list
442
443* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
444- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
445
446* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
447- new upstream release with security fix (CVE-2009-4022)
448
449* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
450- new upstream release with security fix
451
452* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
453- new upstream release
454- clean up %%post/%%pre scriptlet
455  - create named user and group in %%pre
456  - don't remove named user/group in %%preun
457  - use rndc-confgen to create rndc.key
458
459* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
460- new upstream release
461- drop patch0 and patch14, merged in upstream
462
463* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
464- new upstream release with security fix
465
466* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
467- new upstream release with security fix
468- new versioning policy
469
470* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
471- new upstream release with security fix
472
473* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
474- new upstream release
475- build with new openssl/toolchain
476
477* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
478- new upstream release with security fix
479
480* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
481- new upstream release
482
483* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
484- add Prereq sed
485
486* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
487- new upstream release for security fix (CVE-2006-4095,4096)
488
489* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
490- separate -libs package
491- remove old named.conf.5.gz
492  - newer version is contained in source
493
494* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
495- add bsdcompat patch (Patch4)
496- add fix_h_errno patch from FC
497  - h_errno not being accessed / set correctly in libbind
498
499* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
500- new upstream release
501
502* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
503- added PreReq to bind-utils (see: [VineSeed:09555])
504
505* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
506- new upstream release
507
508* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
509- fix /etc/init.d/named to use rndc
510
511* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
512- rebuild to remove unneeded dependancy
513
514* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
515- new upstream release
516
517* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
518- new upstream release
519
520* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
521- fix dependancies.
522
523* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
524- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
525- change package name to bind for VineSeed.
526- use more macros.
527
528* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
529- fixed some macros
530- add conflicts: to bind-* in bind9-devel and bind9-utils
531- add provides: bind = %%{version}
532
533* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
534- use %%configure macros
535
536* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
537- fixed inconsistent dependency
538
539* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
540- updated to 9.2.2rc1
541
542* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
543- updated to bind9(9.2.1), test packages ;)
544        -- based on Rawhide's bind-9.2.0-8
545        -- changed name bind9
546        -- added Conflicts: bind
547
548* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
549- release 8.3.1 includes security fixes
550
551* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
552- Upgraded to current stable release 8.3.0
553
554* Mon Oct  8 2001 <zn@mbf.nifty.com>
555- 8.2.5-0vl0: Upgraded to new upstream version.
556
557* Thu May 24 2001 <sagami@vinelinux.org>
558- 8.2.4-0vl1: eliminate CVS related files from %%doc
559
560* Thu May 17 2001 <sagami@vinelinux.org>
561- 8.2.4-0vl0
562
563* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
564- 8.2.3-1vl2
565- built on VineSeed
566
567* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
568- add doc/old
569- build for Vine 2.1
570
571* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
572- 8.2.3, fixes several security problems
573
574* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
575- static libraries may be used in shared objects. Build with -fPIC on ia64
576
577* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
578- 8.2.2-P7 (fixes Bug #20546)
579
580* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
581- condrestart fixes
582
583* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
584- change the init script to take condrestart, not cond-restart
585- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
586  the %pre and %post scripts
587
588* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
589- Don't prereq /etc/init.d
590
591* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
592- move initscript back
593
594* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
595- automatic rebuild
596
597* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
598- add "exit 0" for uninstall case
599
600* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
601- add prereq init.d and cleanup install section
602
603* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
604- fix the init script
605
606* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
607- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
608
609* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
610- Fix up the initscript (Bug #13033)
611- Fix build with current glibc (Bug #12755)
612- /etc/rc.d/init.d -> /etc/init.d
613- use %%{_mandir} rather than /usr/share/man
614
615* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
616- fix conflict with man-pages
617- remove compatibilty chkconfig links
618- initscript munging
619
620* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
621- modify logrotate setup to use PID file
622- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
623- actually bump the release this time
624
625* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
626- FHS compliance
627
628* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
629- clean up restart patch
630
631* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
632- provide /var/named (fix for bugs #9847, #10205)
633- preserve args when restarted via ndc(8) (bug #10227)
634- make resolv.conf(5) a link to resolver(5) (bug #10245)
635- fix SYSTYPE bug in all makefiles
636- move creation of named user from %%post into %%pre
637
638* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
639- Fix TTL (patch from ISC, Bug #9820)
640
641* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
642- fix typo in spec (it's %post, without a leading blank) introduced in -6
643- change SYSTYPE to linux
644
645* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
646- pick a standard < 100 uid/gid for named
647
648* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
649- Pass named a '-u named' parameter by default, and add/remove user.
650
651* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
652- fix host mx bug (Bug #9021)
653
654* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
655- rebuild to fix dependencies
656- man pages are compressed
657
658* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
659- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
660
661* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
662- Fix up location of named-bootconf.pl and make it executable
663  (Bug #8028)
664- bind-devel requires bind
665
666* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
667- update to 8.2.2-P5
668
669* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
670- update to 8.2.2-P3
671
672* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
673- add patch to stop a cache only server from complaining about lame servers
674  on every request.
675
676* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
677- use real stop and start in named.init for restart, not ndc restart, it has
678  problems when named has changed during a package update... (# 4890)
679
680* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
681- chkconfig --del in %preun, not %postun
682
683* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
684- initscript munging
685
686* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
687- fix installed chkconfig links to match init file
688
689* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
690- conflict with new (in man-1.24) man pages (#3876,#3877).
691
692* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
693- fix named.logrotate (wrong %SOURCE)
694
695* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
696- update to 8.2.1.
697- add named.logrotate (#3571).
698- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
699- vet file list.
700
701* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
702- don't run by default
703
704* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
705- nslookup fixes (#2463).
706- missing files (#3152).
707
708* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
709- nslookup patched:
710  to count numRecords properly
711  to fix subsequent calls to ls -d
712  to parse "view" and "finger" commands properly
713  the view hack updated for bind-8 (using sed)
714
715* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
716- add ISC patch
717- add quick hack to make host not crash
718- add more docs
719
720* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
721- add probing information in the init file to keep linuxconf happy
722- dont strip libbind
723
724* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
725- auto rebuild in the new build environment (release 3)
726
727* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
728- removed 'done' output at named shutdown.
729
730* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
731- version 8.2
732
733* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
734- patch to use the __FDS_BITS macro
735- build for glibc 2.1
736
737* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
738- change named.restart to /usr/sbin/ndc restart
739
740* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
741- install man pages correctly.
742- change K10named to K45named.
743
744* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
745- don't start if /etc/named.conf doesn't exist.
746
747* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
748- autmagically create /etc/named.conf from /etc/named.boot in %post
749- remove echo in %post
750
751* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
752- merge in 5.1 mods
753
754* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
755- Several essential modifications to build and install correctly.
756- Modified 'ndc' to avoid deprecated use of '-'
757
758* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
759- Used buildroot
760- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
761  on Redhat 5.0 instead of <nlist.h>
762
Note: See TracBrowser for help on using the repository browser.