source: projects/specs/trunk/b/bind/bind-vl.spec @ 11029

Revision 11029, 22.7 KB checked in by iwaim, 7 years ago (diff)

bind 9.9.9.P8-1

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind
5%define pversion 9.9.9.P8
6%define sversion 9.9.9-P8
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.9.2p2-1vl7
10
11%define bind_uid  25
12%define bind_gid  25
13
14%bcond_with readline
15
16Summary: A DNS (Domain Name System) server.
17Summary(ja): DNS (Domain Name System) サーバ
18Name: %{pname}
19Version: %{pversion}
20Release: 1%{?_dist_release}
21Epoch: %{bind_epoch}
22License: ISC and BSD and Public Domain
23Group: System Environment/Daemons
24URL: http://www.isc.org/bind.html
25
26Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
27Source1: bind-manpages.tar.bz2
28Source2: named.sysconfig
29Source3: named.init
30Source4: named.logrotate
31Source5: keygen.c
32Patch1: bind-9.3.3rc2-rndckey.patch
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: openssl-devel glibc-devel libtool
36BuildRequires: libxml2-devel
37BuildRequires: libcap-devel
38%if %{with readline}
39BuildRequires: readline-devel
40%endif
41Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
42Requires(pre): shadow-utils
43Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
44Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
45Requires(post): coreutils, chkconfig
46Requires(preun): initscripts, chkconfig
47Conflicts: bind9 <= 9.2.1-0vl5, bind-current
48Obsoletes: bind9 <= 9.2.1-0vl5
49Obsoletes: bind-current < 1:9.9.4-1
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: daisuke
54
55%description
56BIND (Berkeley Internet Name Domain) is an implementation of the DNS
57(Domain Name System) protocols. BIND includes a DNS server (named),
58which resolves host names to IP addresses, and a resolver library
59(routines for applications to use when interfacing with DNS).  A DNS
60server allows clients to name resources or objects and share the
61information with other network machines.  The named DNS server can be
62used on workstations as a caching name server, but is generally only
63needed on one machine for an entire network.  Note that the
64configuration files for making BIND act as a simple caching nameserver
65are included in the caching-nameserver package. 
66
67Install the bind package if you need a DNS server for your network.  If
68you want bind to act a caching name server, you will also need to install
69the caching-nameserver package.
70
71
72%package libs
73Summary: Libraries used by various DNS packages
74Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
75Group: System Environment/Libraries
76Obsoletes: bind-current-libs <= %{old_bind_version}
77
78%description libs
79Contains libraries used by both the bind server package as well as the utils packages.
80
81
82%package utils
83Summary: Utilities for querying DNS name servers.
84Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
85Group: Applications/System
86Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
87Conflicts: bind9-utils <= 9.2.1-0vl5
88Conflicts: bind-current-utils
89Obsoletes: bind9-utils <= 9.2.1-0vl5
90Obsoletes: bind-current-utils <= %{old_bind_version}
91
92%description utils
93Bind-utils contains a collection of utilities for querying DNS (Domain
94Name Service) name servers to find out information about Internet hosts.
95These tools will provide you with the IP addresses for given host names,
96as well as other information about registered domains and network
97addresses.
98
99You should install bind-utils if you need to get information from DNS name
100servers.
101
102
103%package devel
104Summary: Include files and libraries needed for bind DNS development.
105Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
106Group: Development/Libraries
107Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
108Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
109Conflicts: bind9-devel <= 9.2.1-0vl5
110Conflicts: bind-current-devel
111Obsoletes: bind9-devel <= 9.2.1-0vl5
112Obsoletes: bind-current-devel <= %{old_bind_version}
113
114%description devel
115The bind-devel package contains all the include files and the
116library required for DNS (Domain Name Service) development for
117BIND versions 9.x.x.
118
119You should install bind-devel if you want to develop bind DNS
120applications. If you install bind-devel, you'll also need to install
121bind.
122#'
123
124%prep
125%setup -n bind-%{sversion} -q
126%patch1 -p1 -b .key
127perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
128
129%build
130libtoolize --copy --force
131aclocal
132autoconf
133%configure \
134  --with-libtool \
135  --with-openssl=/usr \
136%if %{without readline}
137    --without-readline \
138%endif
139  --disable-openssl-version-ceck \
140  --enable-threads \
141  --enable-ipv6 \
142  --with-pic \
143  --with-dlz-dlopen \
144  --enable-filter-aaaa \
145  --enable-fixed-rrset
146make %{?_smp_mflags}
147
148%install
149rm -rf $RPM_BUILD_ROOT
150mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
151mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
152mkdir -p ${RPM_BUILD_ROOT}/var/named
153mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
154mkdir -p ${RPM_BUILD_ROOT}/var/run/named
155
156make DESTDIR=$RPM_BUILD_ROOT install
157install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
158install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
159install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
160install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
161touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
162gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
163cd $RPM_BUILD_ROOT%{_mandir}
164tar xjf %{SOURCE1}
165# newer version is contained in source
166rm -f man5/named.conf.5.gz
167mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
168cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
169
170chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
171
172rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
173
174%clean
175rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
176
177
178%pre
179if [ "$1" -eq 1 ]; then
180  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
181  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
182fi;
183:;
184
185%post
186/sbin/ldconfig
187/sbin/chkconfig --add named
188if [ "$1" -eq 1 ]; then
189  if [ ! -e /etc/rndc.key ]; then
190    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
191  fi
192  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
193  # rndc.key has to have correct perms and ownership, CVE-2007-6283
194  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
195  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
196
197  # Check DNSSEC settings if this is a fresh install
198  if [ -r /etc/sysconfig/dnssec ]; then
199    . /etc/sysconfig/dnssec
200    [ -x /usr/sbin/dnssec-configure ] && \
201      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
202        /dev/null 2>&1
203  fi;
204fi
205:;
206
207%preun
208if [ "$1" -eq 0 ]; then
209   /sbin/service named stop >/dev/null 2>&1 || :
210   /sbin/chkconfig --del named ||:
211fi
212exit 0
213
214%postun
215if [ "$1" -ge 1 ]; then
216        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
217fi
218/sbin/ldconfig
219
220%triggerpostun -- bind < 8.2.2_P5-15
221/sbin/chkconfig --add named
222/sbin/ldconfig
223
224%triggerpostun -- bind-current < 1:9.9.4-1
225/sbin/chkconfig --add named
226/sbin/ldconfig
227
228%post libs -p /sbin/ldconfig
229
230%postun libs -p /sbin/ldconfig
231
232
233%files
234%defattr(-,root,root)
235%doc CHANGES README
236%doc doc/arm doc/misc
237%config(noreplace) %{_sysconfdir}/logrotate.d/named
238%config %{_sysconfdir}/rc.d/init.d/named
239%config(noreplace) %{_sysconfdir}/sysconfig/named
240%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
241%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
242%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
243
244%{_sbindir}/dnssec*
245%{_sbindir}/lwresd
246%{_sbindir}/named
247%{_sbindir}/named-bootconf
248%{_sbindir}/named-check*
249%{_sbindir}/named-compilezone
250%{_sbindir}/rndc*
251%{_sbindir}/dns-keygen
252%{_sbindir}/arpaname
253%{_sbindir}/ddns-confgen
254%{_sbindir}/genrandom
255%{_sbindir}/isc-hmac-fixup
256%{_sbindir}/named-journalprint
257%{_sbindir}/nsec3hash
258
259%{_mandir}/man1/arpaname.1*
260%{_mandir}/man5/resolv.conf.5*
261%{_mandir}/man5/named.conf.5*
262%{_mandir}/man5/rndc.conf.5*
263%{_mandir}/man8/rndc.8*
264%{_mandir}/man8/named.8*
265%{_mandir}/man8/lwresd.8*
266%{_mandir}/man8/dnssec*.8*
267%{_mandir}/man8/named-checkconf.8*
268%{_mandir}/man8/named-checkzone.8*
269%{_mandir}/man8/named-compilezone.8*
270%{_mandir}/man8/rndc-confgen.8*
271%{_mandir}/man8/ddns-confgen.8*
272%{_mandir}/man8/genrandom.8*
273%{_mandir}/man8/isc-hmac-fixup.8*
274%{_mandir}/man8/named-journalprint.8*
275%{_mandir}/man8/nsec3hash.8*
276
277%attr(-,named,named) %dir %{_var}/named
278%attr(-,named,named) %dir %{_var}/run/named
279     
280
281%files libs
282%defattr(-,root,root)
283%{_libdir}/*.so.*
284
285%files utils
286%defattr(-,root,root)
287%{_bindir}/dig
288%{_bindir}/host
289%{_bindir}/nslookup
290%{_bindir}/nsupdate
291%{_mandir}/man1/host.1*
292%{_mandir}/man1/nsupdate.1*
293%{_mandir}/man1/dig.1*
294%{_mandir}/man5/resolver.5*
295%{_mandir}/man1/nslookup.1*
296%{_mandir}/man8/nslookup.8*
297
298%files devel
299%defattr(-,root,root)
300%{_libdir}/*.so
301%{_libdir}/*.a
302%{_includedir}/*
303%{_mandir}/man3/*
304%{_mandir}/man1/bind9-config.1*
305%{_mandir}/man1/isc-config.sh.1*
306%{_bindir}/bind9-config
307%{_bindir}/isc-config.sh
308
309%changelog
310* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
311- update to 9.9.9.P8
312
313* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
314- new upstream release.
315
316* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
317- new upstream release.
318
319* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
320- new upstream release.
321
322* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
323- new upstream release with secrity fix (CVE-2016-1285,1286)
324- built with openssl 1.0.2g
325
326* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
327- new upstream release with secrity fix (CVE-2015-4620) 
328
329* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
330- new upstream release with secrity fix (CVE-2015-4620)
331
332* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
333- rebuilt without readline to avoid GPL infection
334
335* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
336- new upstream release with secrity fix (CVE-2015-1349)
337- added BR: readline-devel
338
339* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
340- new upstream release with secrity fix (CVE-2014-8500) 
341- used "3" as release number because of being newer than Vine Linux/6 updates
342
343* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
344- update to 9.9.4(ESV)
345
346* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
347- update to 9.9.2-P2
348- remove .la
349- remove Conflicts/Obsoletes from libs subpackage.
350- add configure options
351  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
352
353* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
354- new upstream release.
355- added an option "--with-dlz-dlopen".
356
357* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
358- Obosoletes: bind.* < 1:9.6.ESV.R1
359 - fixed <BTS:VineLinux:1139>
360
361* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
362- new upstream release with security fix (CVE-2011-1910)
363
364* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
365- add BuildRequires: libxml2-devel, libcap-devel
366
367* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
368- new upstream release with security fix (CVE-2011-1907)
369- fix changelog typo
370
371* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
372- Obosoletes: bind.* < 1:9.6.ESV.R1
373
374* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
375- update to 9.8.0
376- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
377
378* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
379- rebuild with openssl-1.0.0c
380
381* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
382- fix Req: in bind package
383
384* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
385- change package name bind -> bind-current
386- add epoch 1
387- new upstream release
388
389* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
390- new upstream release
391
392* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
393- rebuilt with gcc-4.4.3-3 on ppc
394
395* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
396- rebuilt with new toolchains (for VineSeed)
397- s/BuildPrereq/BuildRequires/
398
399* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
400- add man1/isc-config.sh.1 into devel file list
401
402* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
403- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
404
405* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
406- new upstream release with security fix (CVE-2009-4022)
407
408* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
409- new upstream release with security fix
410
411* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
412- new upstream release
413- clean up %%post/%%pre scriptlet
414  - create named user and group in %%pre
415  - don't remove named user/group in %%preun
416  - use rndc-confgen to create rndc.key
417
418* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
419- new upstream release
420- drop patch0 and patch14, merged in upstream
421
422* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
423- new upstream release with security fix
424
425* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
426- new upstream release with security fix
427- new versioning policy
428
429* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
430- new upstream release with security fix
431
432* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
433- new upstream release
434- build with new openssl/toolchain
435
436* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
437- new upstream release with security fix
438
439* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
440- new upstream release
441
442* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
443- add Prereq sed
444
445* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
446- new upstream release for security fix (CVE-2006-4095,4096)
447
448* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
449- separate -libs package
450- remove old named.conf.5.gz
451  - newer version is contained in source
452
453* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
454- add bsdcompat patch (Patch4)
455- add fix_h_errno patch from FC
456  - h_errno not being accessed / set correctly in libbind
457
458* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
459- new upstream release
460
461* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
462- added PreReq to bind-utils (see: [VineSeed:09555])
463
464* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
465- new upstream release
466
467* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
468- fix /etc/init.d/named to use rndc
469
470* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
471- rebuild to remove unneeded dependancy
472
473* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
474- new upstream release
475
476* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
477- new upstream release
478
479* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
480- fix dependancies.
481
482* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
483- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
484- change package name to bind for VineSeed.
485- use more macros.
486
487* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
488- fixed some macros
489- add conflicts: to bind-* in bind9-devel and bind9-utils
490- add provides: bind = %%{version}
491
492* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
493- use %%configure macros
494
495* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
496- fixed inconsistent dependency
497
498* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
499- updated to 9.2.2rc1
500
501* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
502- updated to bind9(9.2.1), test packages ;)
503        -- based on Rawhide's bind-9.2.0-8
504        -- changed name bind9
505        -- added Conflicts: bind
506
507* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
508- release 8.3.1 includes security fixes
509
510* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
511- Upgraded to current stable release 8.3.0
512
513* Mon Oct  8 2001 <zn@mbf.nifty.com>
514- 8.2.5-0vl0: Upgraded to new upstream version.
515
516* Thu May 24 2001 <sagami@vinelinux.org>
517- 8.2.4-0vl1: eliminate CVS related files from %%doc
518
519* Thu May 17 2001 <sagami@vinelinux.org>
520- 8.2.4-0vl0
521
522* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
523- 8.2.3-1vl2
524- built on VineSeed
525
526* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
527- add doc/old
528- build for Vine 2.1
529
530* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
531- 8.2.3, fixes several security problems
532
533* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
534- static libraries may be used in shared objects. Build with -fPIC on ia64
535
536* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
537- 8.2.2-P7 (fixes Bug #20546)
538
539* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
540- condrestart fixes
541
542* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
543- change the init script to take condrestart, not cond-restart
544- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
545  the %pre and %post scripts
546
547* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- Don't prereq /etc/init.d
549
550* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
551- move initscript back
552
553* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
554- automatic rebuild
555
556* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
557- add "exit 0" for uninstall case
558
559* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
560- add prereq init.d and cleanup install section
561
562* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
563- fix the init script
564
565* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
566- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
567
568* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
569- Fix up the initscript (Bug #13033)
570- Fix build with current glibc (Bug #12755)
571- /etc/rc.d/init.d -> /etc/init.d
572- use %%{_mandir} rather than /usr/share/man
573
574* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
575- fix conflict with man-pages
576- remove compatibilty chkconfig links
577- initscript munging
578
579* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
580- modify logrotate setup to use PID file
581- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
582- actually bump the release this time
583
584* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
585- FHS compliance
586
587* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
588- clean up restart patch
589
590* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
591- provide /var/named (fix for bugs #9847, #10205)
592- preserve args when restarted via ndc(8) (bug #10227)
593- make resolv.conf(5) a link to resolver(5) (bug #10245)
594- fix SYSTYPE bug in all makefiles
595- move creation of named user from %%post into %%pre
596
597* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
598- Fix TTL (patch from ISC, Bug #9820)
599
600* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
601- fix typo in spec (it's %post, without a leading blank) introduced in -6
602- change SYSTYPE to linux
603
604* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
605- pick a standard < 100 uid/gid for named
606
607* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
608- Pass named a '-u named' parameter by default, and add/remove user.
609
610* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
611- fix host mx bug (Bug #9021)
612
613* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
614- rebuild to fix dependencies
615- man pages are compressed
616
617* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
618- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
619
620* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
621- Fix up location of named-bootconf.pl and make it executable
622  (Bug #8028)
623- bind-devel requires bind
624
625* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
626- update to 8.2.2-P5
627
628* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
629- update to 8.2.2-P3
630
631* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
632- add patch to stop a cache only server from complaining about lame servers
633  on every request.
634
635* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
636- use real stop and start in named.init for restart, not ndc restart, it has
637  problems when named has changed during a package update... (# 4890)
638
639* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
640- chkconfig --del in %preun, not %postun
641
642* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
643- initscript munging
644
645* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
646- fix installed chkconfig links to match init file
647
648* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
649- conflict with new (in man-1.24) man pages (#3876,#3877).
650
651* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
652- fix named.logrotate (wrong %SOURCE)
653
654* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
655- update to 8.2.1.
656- add named.logrotate (#3571).
657- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
658- vet file list.
659
660* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
661- don't run by default
662
663* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
664- nslookup fixes (#2463).
665- missing files (#3152).
666
667* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
668- nslookup patched:
669  to count numRecords properly
670  to fix subsequent calls to ls -d
671  to parse "view" and "finger" commands properly
672  the view hack updated for bind-8 (using sed)
673
674* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
675- add ISC patch
676- add quick hack to make host not crash
677- add more docs
678
679* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
680- add probing information in the init file to keep linuxconf happy
681- dont strip libbind
682
683* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
684- auto rebuild in the new build environment (release 3)
685
686* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
687- removed 'done' output at named shutdown.
688
689* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
690- version 8.2
691
692* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
693- patch to use the __FDS_BITS macro
694- build for glibc 2.1
695
696* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
697- change named.restart to /usr/sbin/ndc restart
698
699* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
700- install man pages correctly.
701- change K10named to K45named.
702
703* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
704- don't start if /etc/named.conf doesn't exist.
705
706* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
707- autmagically create /etc/named.conf from /etc/named.boot in %post
708- remove echo in %post
709
710* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
711- merge in 5.1 mods
712
713* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
714- Several essential modifications to build and install correctly.
715- Modified 'ndc' to avoid deprecated use of '-'
716
717* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
718- Used buildroot
719- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
720  on Redhat 5.0 instead of <nlist.h>
721
Note: See TracBrowser for help on using the repository browser.