source: projects/specs/trunk/b/bind/bind-vl.spec @ 12422

Revision 12422, 23.7 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

bind-9.11.20-1

samba-4.12.5-1

webkitgtk4-2.28.2-1

Line 
1%bcond_with python
2%define python_executable %{__python}
3
4%define _localstatedir /var
5%define _unpackaged_files_terminate_build 1
6
7%define sname bind
8%define pname bind
9# example: 9.9.13.P1
10%define pversion 9.11.20
11# example: 9.9.13-P1
12%define sversion 9.11.20
13%define bind_epoch 1
14# fixed <BTS:VineLinux:1139>
15%define old_bind_version 1:9.9.2p2-1vl7
16
17%define bind_uid  25
18%define bind_gid  25
19
20%bcond_with readline
21
22Summary: A DNS (Domain Name System) server.
23Summary(ja): DNS (Domain Name System) サーバ
24Name: %{pname}
25Epoch: %{bind_epoch}
26Version: %{pversion}
27Release: 1%{?_dist_release}
28Group: System Environment/Daemons
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: daisuke
32
33License: ISC and BSD and Public Domain
34URL: http://www.isc.org/bind.html
35Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
36Source1: bind-manpages.tar.bz2
37Source2: named.sysconfig
38Source3: named.init
39Source4: named.logrotate
40Source5: keygen.c
41Patch1: bind-9.11.5-rndckey.patch
42
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44%if %{with python}
45BuildRequires: python
46BuildRequires: python-rpm-macros
47BuildRequires: python-ply
48%endif
49BuildRequires: openssl-devel glibc-devel libtool
50BuildRequires: libxml2-devel
51BuildRequires: libcap-devel
52%if %{with readline}
53BuildRequires: readline-devel
54%endif
55Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
56Requires(pre): shadow-utils
57Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
58Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
59Requires(post): coreutils, chkconfig
60Requires(preun): initscripts, chkconfig
61Conflicts: bind9 <= 9.2.1-0vl5, bind-current
62Obsoletes: bind9 <= 9.2.1-0vl5
63Obsoletes: bind-current < 1:9.9.4-1
64
65%description
66BIND (Berkeley Internet Name Domain) is an implementation of the DNS
67(Domain Name System) protocols. BIND includes a DNS server (named),
68which resolves host names to IP addresses, and a resolver library
69(routines for applications to use when interfacing with DNS).  A DNS
70server allows clients to name resources or objects and share the
71information with other network machines.  The named DNS server can be
72used on workstations as a caching name server, but is generally only
73needed on one machine for an entire network.  Note that the
74configuration files for making BIND act as a simple caching nameserver
75are included in the caching-nameserver package. 
76
77Install the bind package if you need a DNS server for your network.  If
78you want bind to act a caching name server, you will also need to install
79the caching-nameserver package.
80
81
82%package libs
83Summary: Libraries used by various DNS packages
84Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
85Group: System Environment/Libraries
86Obsoletes: bind-current-libs <= %{old_bind_version}
87
88%description libs
89Contains libraries used by both the bind server package as well as the utils packages.
90
91
92%package utils
93Summary: Utilities for querying DNS name servers.
94Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
95Group: Applications/System
96Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
97Conflicts: bind9-utils <= 9.2.1-0vl5
98Conflicts: bind-current-utils
99Obsoletes: bind9-utils <= 9.2.1-0vl5
100Obsoletes: bind-current-utils <= %{old_bind_version}
101
102%description utils
103Bind-utils contains a collection of utilities for querying DNS (Domain
104Name Service) name servers to find out information about Internet hosts.
105These tools will provide you with the IP addresses for given host names,
106as well as other information about registered domains and network
107addresses.
108
109You should install bind-utils if you need to get information from DNS name
110servers.
111
112
113%package devel
114Summary: Include files and libraries needed for bind DNS development.
115Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
116Group: Development/Libraries
117Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
118Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
119Conflicts: bind9-devel <= 9.2.1-0vl5
120Conflicts: bind-current-devel
121Obsoletes: bind9-devel <= 9.2.1-0vl5
122Obsoletes: bind-current-devel <= %{old_bind_version}
123
124%description devel
125The bind-devel package contains all the include files and the
126library required for DNS (Domain Name Service) development for
127BIND versions 9.x.x.
128
129You should install bind-devel if you want to develop bind DNS
130applications. If you install bind-devel, you'll also need to install
131bind.
132#'
133
134%prep
135%setup -n bind-%{sversion} -q
136%patch1 -p1 -b .key
137perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
138
139%build
140libtoolize --copy --force
141aclocal
142autoconf
143%configure \
144  --with-libtool \
145  --with-openssl=/usr \
146%if %{without readline}
147    --without-readline \
148%endif
149  --disable-openssl-version-ceck \
150  --enable-threads \
151  --enable-ipv6 \
152  --with-pic \
153  --with-dlz-dlopen \
154%if %{with python}
155  --with-python=%{python_executable} \
156%else
157  --with-python=no \
158%endif
159  --enable-filter-aaaa \
160  --enable-fixed-rrset
161make %{?_smp_mflags}
162
163%install
164rm -rf $RPM_BUILD_ROOT
165mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
166mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
167mkdir -p ${RPM_BUILD_ROOT}/var/named
168mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
169mkdir -p ${RPM_BUILD_ROOT}/var/run/named
170
171make DESTDIR=$RPM_BUILD_ROOT install
172install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
173install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
174install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
175touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
176gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
177cd $RPM_BUILD_ROOT%{_mandir}
178tar xjf %{SOURCE1}
179# newer version is contained in source
180rm -f man5/named.conf.5.gz
181mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
182cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
183
184chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
185
186rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
187
188%clean
189rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
190
191
192%pre
193if [ "$1" -eq 1 ]; then
194  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
195  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
196fi;
197:;
198
199%post
200/sbin/ldconfig
201/sbin/chkconfig --add named
202if [ "$1" -eq 1 ]; then
203  if [ ! -e /etc/rndc.key ]; then
204    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
205  fi
206  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
207  # rndc.key has to have correct perms and ownership, CVE-2007-6283
208  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
209  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
210
211  # Check DNSSEC settings if this is a fresh install
212  if [ -r /etc/sysconfig/dnssec ]; then
213    . /etc/sysconfig/dnssec
214    [ -x /usr/sbin/dnssec-configure ] && \
215      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
216        /dev/null 2>&1
217  fi;
218fi
219:;
220
221%preun
222if [ "$1" -eq 0 ]; then
223   /sbin/service named stop >/dev/null 2>&1 || :
224   /sbin/chkconfig --del named ||:
225fi
226exit 0
227
228%postun
229if [ "$1" -ge 1 ]; then
230        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
231fi
232/sbin/ldconfig
233
234%triggerpostun -- bind < 8.2.2_P5-15
235/sbin/chkconfig --add named
236/sbin/ldconfig
237
238%triggerpostun -- bind-current < 1:9.9.4-1
239/sbin/chkconfig --add named
240/sbin/ldconfig
241
242%post libs -p /sbin/ldconfig
243
244%postun libs -p /sbin/ldconfig
245
246
247%files
248%defattr(-,root,root)
249%license COPYRIGHT
250%doc CHANGES README*
251%doc doc/arm doc/misc
252%config(noreplace) %{_sysconfdir}/logrotate.d/named
253%config %{_sysconfdir}/rc.d/init.d/named
254%config(noreplace) %{_sysconfdir}/sysconfig/named
255%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
256%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
257%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
258
259%{_sbindir}/dnssec*
260%{_sbindir}/lwresd
261%{_sbindir}/named
262%{_sbindir}/named-check*
263%{_sbindir}/named-compilezone
264%{_sbindir}/rndc*
265%{_sbindir}/dns-keygen
266%{_bindir}/arpaname
267%{_sbindir}/ddns-confgen
268%{_sbindir}/genrandom
269%{_sbindir}/isc-hmac-fixup
270%{_sbindir}/named-journalprint
271%{_sbindir}/nsec3hash
272%{_sbindir}/tsig-keygen
273
274%if %{with python}
275%{python_sitelib}/*
276%endif
277
278%{_mandir}/man1/arpaname.1*
279%{_mandir}/man5/resolv.conf.5*
280%{_mandir}/man5/named.conf.5*
281%{_mandir}/man5/rndc.conf.5*
282%{_mandir}/man8/rndc.8*
283%{_mandir}/man8/named.8*
284%{_mandir}/man8/lwresd.8*
285%{_mandir}/man8/dnssec*.8*
286%{_mandir}/man8/named-checkconf.8*
287%{_mandir}/man8/named-checkzone.8*
288%{_mandir}/man8/named-compilezone.8*
289%{_mandir}/man8/rndc-confgen.8*
290%{_mandir}/man8/ddns-confgen.8*
291%{_mandir}/man8/genrandom.8*
292%{_mandir}/man8/isc-hmac-fixup.8*
293%{_mandir}/man8/named-journalprint.8*
294%{_mandir}/man8/nsec3hash.8*
295%{_mandir}/man8/tsig-keygen.8*
296
297%attr(-,named,named) %dir %{_var}/named
298%attr(-,named,named) %dir %{_var}/run/named
299
300
301%files libs
302%defattr(-,root,root)
303%{_libdir}/*.so.*
304
305%files utils
306%defattr(-,root,root)
307%{_bindir}/delv
308%{_bindir}/dig
309%{_bindir}/host
310%{_bindir}/mdig
311%{_bindir}/named-rrchecker
312%{_bindir}/nslookup
313%{_bindir}/nsupdate
314%{_mandir}/man1/delv.1*
315%{_mandir}/man1/dig.1*
316%{_mandir}/man1/host.1*
317%{_mandir}/man1/mdig.1*
318%{_mandir}/man1/named-rrchecker.1*
319%{_mandir}/man1/nslookup.1*
320%{_mandir}/man1/nsupdate.1*
321%{_mandir}/man5/resolver.5*
322%{_mandir}/man8/nslookup.8*
323
324%files devel
325%defattr(-,root,root)
326%{_libdir}/*.so
327%{_libdir}/*.a
328%{_includedir}/*
329%{_mandir}/man3/*
330%{_mandir}/man1/bind9-config.1*
331%{_mandir}/man1/isc-config.sh.1*
332%{_bindir}/bind9-config
333%{_bindir}/isc-config.sh
334
335%changelog
336* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
337- updated to 9.11.20.
338
339* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
340- updated to 9.11.12.
341
342* Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
343- updated to 9.11.11.
344
345* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
346- updated to 9.11.5 (new ESV).
347- updated Patch1.
348
349* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
350- updated to 9.9.13.P1.
351- updated Patch1.
352
353* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
354- update to 9.9.9.P8
355
356* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
357- new upstream release.
358
359* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
360- new upstream release.
361
362* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
363- new upstream release.
364
365* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
366- new upstream release with secrity fix (CVE-2016-1285,1286)
367- built with openssl 1.0.2g
368
369* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
370- new upstream release with secrity fix (CVE-2015-4620) 
371
372* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
373- new upstream release with secrity fix (CVE-2015-4620)
374
375* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
376- rebuilt without readline to avoid GPL infection
377
378* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
379- new upstream release with secrity fix (CVE-2015-1349)
380- added BR: readline-devel
381
382* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
383- new upstream release with secrity fix (CVE-2014-8500) 
384- used "3" as release number because of being newer than Vine Linux/6 updates
385
386* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
387- update to 9.9.4(ESV)
388
389* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
390- update to 9.9.2-P2
391- remove .la
392- remove Conflicts/Obsoletes from libs subpackage.
393- add configure options
394  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
395
396* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
397- new upstream release.
398- added an option "--with-dlz-dlopen".
399
400* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
401- Obosoletes: bind.* < 1:9.6.ESV.R1
402 - fixed <BTS:VineLinux:1139>
403
404* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
405- new upstream release with security fix (CVE-2011-1910)
406
407* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
408- add BuildRequires: libxml2-devel, libcap-devel
409
410* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
411- new upstream release with security fix (CVE-2011-1907)
412- fix changelog typo
413
414* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
415- Obosoletes: bind.* < 1:9.6.ESV.R1
416
417* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
418- update to 9.8.0
419- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
420
421* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
422- rebuild with openssl-1.0.0c
423
424* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
425- fix Req: in bind package
426
427* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
428- change package name bind -> bind-current
429- add epoch 1
430- new upstream release
431
432* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
433- new upstream release
434
435* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
436- rebuilt with gcc-4.4.3-3 on ppc
437
438* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
439- rebuilt with new toolchains (for VineSeed)
440- s/BuildPrereq/BuildRequires/
441
442* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
443- add man1/isc-config.sh.1 into devel file list
444
445* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
446- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
447
448* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
449- new upstream release with security fix (CVE-2009-4022)
450
451* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
452- new upstream release with security fix
453
454* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
455- new upstream release
456- clean up %%post/%%pre scriptlet
457  - create named user and group in %%pre
458  - don't remove named user/group in %%preun
459  - use rndc-confgen to create rndc.key
460
461* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
462- new upstream release
463- drop patch0 and patch14, merged in upstream
464
465* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
466- new upstream release with security fix
467
468* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
469- new upstream release with security fix
470- new versioning policy
471
472* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
473- new upstream release with security fix
474
475* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
476- new upstream release
477- build with new openssl/toolchain
478
479* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
480- new upstream release with security fix
481
482* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
483- new upstream release
484
485* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
486- add Prereq sed
487
488* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
489- new upstream release for security fix (CVE-2006-4095,4096)
490
491* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
492- separate -libs package
493- remove old named.conf.5.gz
494  - newer version is contained in source
495
496* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
497- add bsdcompat patch (Patch4)
498- add fix_h_errno patch from FC
499  - h_errno not being accessed / set correctly in libbind
500
501* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
502- new upstream release
503
504* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
505- added PreReq to bind-utils (see: [VineSeed:09555])
506
507* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
508- new upstream release
509
510* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
511- fix /etc/init.d/named to use rndc
512
513* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
514- rebuild to remove unneeded dependancy
515
516* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
517- new upstream release
518
519* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
520- new upstream release
521
522* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
523- fix dependancies.
524
525* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
526- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
527- change package name to bind for VineSeed.
528- use more macros.
529
530* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
531- fixed some macros
532- add conflicts: to bind-* in bind9-devel and bind9-utils
533- add provides: bind = %%{version}
534
535* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
536- use %%configure macros
537
538* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
539- fixed inconsistent dependency
540
541* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
542- updated to 9.2.2rc1
543
544* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
545- updated to bind9(9.2.1), test packages ;)
546        -- based on Rawhide's bind-9.2.0-8
547        -- changed name bind9
548        -- added Conflicts: bind
549
550* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
551- release 8.3.1 includes security fixes
552
553* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
554- Upgraded to current stable release 8.3.0
555
556* Mon Oct  8 2001 <zn@mbf.nifty.com>
557- 8.2.5-0vl0: Upgraded to new upstream version.
558
559* Thu May 24 2001 <sagami@vinelinux.org>
560- 8.2.4-0vl1: eliminate CVS related files from %%doc
561
562* Thu May 17 2001 <sagami@vinelinux.org>
563- 8.2.4-0vl0
564
565* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
566- 8.2.3-1vl2
567- built on VineSeed
568
569* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
570- add doc/old
571- build for Vine 2.1
572
573* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
574- 8.2.3, fixes several security problems
575
576* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
577- static libraries may be used in shared objects. Build with -fPIC on ia64
578
579* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
580- 8.2.2-P7 (fixes Bug #20546)
581
582* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
583- condrestart fixes
584
585* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
586- change the init script to take condrestart, not cond-restart
587- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
588  the %pre and %post scripts
589
590* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
591- Don't prereq /etc/init.d
592
593* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
594- move initscript back
595
596* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
597- automatic rebuild
598
599* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
600- add "exit 0" for uninstall case
601
602* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
603- add prereq init.d and cleanup install section
604
605* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
606- fix the init script
607
608* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
609- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
610
611* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
612- Fix up the initscript (Bug #13033)
613- Fix build with current glibc (Bug #12755)
614- /etc/rc.d/init.d -> /etc/init.d
615- use %%{_mandir} rather than /usr/share/man
616
617* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
618- fix conflict with man-pages
619- remove compatibilty chkconfig links
620- initscript munging
621
622* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
623- modify logrotate setup to use PID file
624- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
625- actually bump the release this time
626
627* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
628- FHS compliance
629
630* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
631- clean up restart patch
632
633* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
634- provide /var/named (fix for bugs #9847, #10205)
635- preserve args when restarted via ndc(8) (bug #10227)
636- make resolv.conf(5) a link to resolver(5) (bug #10245)
637- fix SYSTYPE bug in all makefiles
638- move creation of named user from %%post into %%pre
639
640* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
641- Fix TTL (patch from ISC, Bug #9820)
642
643* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
644- fix typo in spec (it's %post, without a leading blank) introduced in -6
645- change SYSTYPE to linux
646
647* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
648- pick a standard < 100 uid/gid for named
649
650* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
651- Pass named a '-u named' parameter by default, and add/remove user.
652
653* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
654- fix host mx bug (Bug #9021)
655
656* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
657- rebuild to fix dependencies
658- man pages are compressed
659
660* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
661- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
662
663* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
664- Fix up location of named-bootconf.pl and make it executable
665  (Bug #8028)
666- bind-devel requires bind
667
668* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
669- update to 8.2.2-P5
670
671* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
672- update to 8.2.2-P3
673
674* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
675- add patch to stop a cache only server from complaining about lame servers
676  on every request.
677
678* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
679- use real stop and start in named.init for restart, not ndc restart, it has
680  problems when named has changed during a package update... (# 4890)
681
682* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
683- chkconfig --del in %preun, not %postun
684
685* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
686- initscript munging
687
688* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
689- fix installed chkconfig links to match init file
690
691* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
692- conflict with new (in man-1.24) man pages (#3876,#3877).
693
694* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
695- fix named.logrotate (wrong %SOURCE)
696
697* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
698- update to 8.2.1.
699- add named.logrotate (#3571).
700- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
701- vet file list.
702
703* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
704- don't run by default
705
706* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
707- nslookup fixes (#2463).
708- missing files (#3152).
709
710* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
711- nslookup patched:
712  to count numRecords properly
713  to fix subsequent calls to ls -d
714  to parse "view" and "finger" commands properly
715  the view hack updated for bind-8 (using sed)
716
717* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
718- add ISC patch
719- add quick hack to make host not crash
720- add more docs
721
722* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
723- add probing information in the init file to keep linuxconf happy
724- dont strip libbind
725
726* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
727- auto rebuild in the new build environment (release 3)
728
729* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
730- removed 'done' output at named shutdown.
731
732* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
733- version 8.2
734
735* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
736- patch to use the __FDS_BITS macro
737- build for glibc 2.1
738
739* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
740- change named.restart to /usr/sbin/ndc restart
741
742* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
743- install man pages correctly.
744- change K10named to K45named.
745
746* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
747- don't start if /etc/named.conf doesn't exist.
748
749* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
750- autmagically create /etc/named.conf from /etc/named.boot in %post
751- remove echo in %post
752
753* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
754- merge in 5.1 mods
755
756* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
757- Several essential modifications to build and install correctly.
758- Modified 'ndc' to avoid deprecated use of '-'
759
760* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
761- Used buildroot
762- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
763  on Redhat 5.0 instead of <nlist.h>
764
Note: See TracBrowser for help on using the repository browser.