source: projects/specs/trunk/b/bind/bind-vl.spec @ 9467

Revision 9467, 21.9 KB checked in by inagaki, 9 years ago (diff)

2015-03-24 Ryoichi INAGAKI <ryo1@…>

  • bind, guild, js, unixODBC: rebuilt
  • ed: updated


RevLine 
[2124]1%define _localstatedir /var
2
[7883]3%define sname bind
4%define pname bind
[9391]5%define pversion 9.9.6.P2
6%define sversion 9.9.6-P2
[2124]7%define bind_epoch 1
[7883]8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.9.2p2-1vl7
[2124]10
11%define bind_uid  25
12%define bind_gid  25
13
[9467]14%bcond_with readline
15
[2124]16Summary: A DNS (Domain Name System) server.
17Summary(ja): DNS (Domain Name System) サーバ
[7883]18Name: %{pname}
[2124]19Version: %{pversion}
[9467]20Release: 2%{?_dist_release}
[7883]21Epoch: %{bind_epoch}
[9467]22License: ISC and BSD and Public Domain
[2124]23Group: System Environment/Daemons
[9333]24URL: http://www.isc.org/bind.html
25
[7883]26Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
[2124]27Source1: bind-manpages.tar.bz2
28Source2: named.sysconfig
29Source3: named.init
30Source4: named.logrotate
31Source5: keygen.c
32Patch1: bind-9.3.3rc2-rndckey.patch
[7883]33
[9333]34BuildRoot: %{_tmppath}/%{name}-%{version}-root
[9467]35BuildRequires: openssl-devel glibc-devel libtool
[7883]36BuildRequires: libxml2-devel
37BuildRequires: libcap-devel
[9467]38%if %{with readline}
39BuildRequires: readline-devel
40%endif
[9333]41Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
42Requires(pre): shadow-utils
[7883]43Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
44Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
45Requires(post): coreutils, chkconfig
46Requires(preun): initscripts, chkconfig
[2124]47Conflicts: bind9 <= 9.2.1-0vl5, bind-current
48Obsoletes: bind9 <= 9.2.1-0vl5
[7883]49Obsoletes: bind-current < 1:9.9.4-1
[2124]50
51Vendor: Project Vine
52Distribution: Vine Linux
[7883]53Packager: daisuke
[2124]54
55%description
56BIND (Berkeley Internet Name Domain) is an implementation of the DNS
57(Domain Name System) protocols. BIND includes a DNS server (named),
58which resolves host names to IP addresses, and a resolver library
59(routines for applications to use when interfacing with DNS).  A DNS
60server allows clients to name resources or objects and share the
61information with other network machines.  The named DNS server can be
62used on workstations as a caching name server, but is generally only
63needed on one machine for an entire network.  Note that the
64configuration files for making BIND act as a simple caching nameserver
65are included in the caching-nameserver package. 
66
67Install the bind package if you need a DNS server for your network.  If
68you want bind to act a caching name server, you will also need to install
69the caching-nameserver package.
70
71
72%package libs
73Summary: Libraries used by various DNS packages
[9333]74Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
[2124]75Group: System Environment/Libraries
[7883]76Obsoletes: bind-current-libs <= %{old_bind_version}
[2124]77
78%description libs
79Contains libraries used by both the bind server package as well as the utils packages.
80
81
82%package utils
83Summary: Utilities for querying DNS name servers.
84Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
85Group: Applications/System
[7883]86Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
87Conflicts: bind9-utils <= 9.2.1-0vl5
88Conflicts: bind-current-utils
[2124]89Obsoletes: bind9-utils <= 9.2.1-0vl5
[7883]90Obsoletes: bind-current-utils <= %{old_bind_version}
[2124]91
92%description utils
93Bind-utils contains a collection of utilities for querying DNS (Domain
94Name Service) name servers to find out information about Internet hosts.
95These tools will provide you with the IP addresses for given host names,
96as well as other information about registered domains and network
97addresses.
98
99You should install bind-utils if you need to get information from DNS name
100servers.
101
102
103%package devel
104Summary: Include files and libraries needed for bind DNS development.
105Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
106Group: Development/Libraries
[7883]107Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
108Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
109Conflicts: bind9-devel <= 9.2.1-0vl5
110Conflicts: bind-current-devel
[2124]111Obsoletes: bind9-devel <= 9.2.1-0vl5
[7883]112Obsoletes: bind-current-devel <= %{old_bind_version}
[2124]113
114%description devel
115The bind-devel package contains all the include files and the
116library required for DNS (Domain Name Service) development for
117BIND versions 9.x.x.
118
119You should install bind-devel if you want to develop bind DNS
120applications. If you install bind-devel, you'll also need to install
121bind.
122#'
123
124%prep
125%setup -n bind-%{sversion} -q
126%patch1 -p1 -b .key
[7883]127perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
[2124]128
129%build
130libtoolize --copy --force
131aclocal
132autoconf
[7883]133%configure \
134  --with-libtool \
135  --with-openssl=/usr \
[9467]136%if %{without readline}
137    --without-readline \
138%endif
[7883]139  --disable-openssl-version-ceck \
140  --enable-threads \
141  --enable-ipv6 \
142  --with-pic \
143  --with-dlz-dlopen \
144  --enable-filter-aaaa \
145  --enable-fixed-rrset
[2124]146make %{?_smp_mflags}
147
148%install
149rm -rf $RPM_BUILD_ROOT
150mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
151mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
152mkdir -p ${RPM_BUILD_ROOT}/var/named
153mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
154mkdir -p ${RPM_BUILD_ROOT}/var/run/named
155
156make DESTDIR=$RPM_BUILD_ROOT install
157install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
158install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
159install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
160install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
161touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
162gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
163cd $RPM_BUILD_ROOT%{_mandir}
164tar xjf %{SOURCE1}
165# newer version is contained in source
166rm -f man5/named.conf.5.gz
167mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
168cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
169
[9333]170chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
[2124]171
[9333]172rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
173
174%clean
175rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
176
177
[2124]178%pre
179if [ "$1" -eq 1 ]; then
180  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
181  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
182fi;
183:;
184
185%post
186/sbin/ldconfig
187/sbin/chkconfig --add named
188if [ "$1" -eq 1 ]; then
189  if [ ! -e /etc/rndc.key ]; then
190    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
191  fi
192  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
193  # rndc.key has to have correct perms and ownership, CVE-2007-6283
194  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
195  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
196
197  # Check DNSSEC settings if this is a fresh install
198  if [ -r /etc/sysconfig/dnssec ]; then
199    . /etc/sysconfig/dnssec
200    [ -x /usr/sbin/dnssec-configure ] && \
201      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
202        /dev/null 2>&1
203  fi;
204fi
205:;
206
207%preun
208if [ "$1" -eq 0 ]; then
209   /sbin/service named stop >/dev/null 2>&1 || :
210   /sbin/chkconfig --del named ||:
211fi
212exit 0
213
214%postun
215if [ "$1" -ge 1 ]; then
216        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
217fi
218/sbin/ldconfig
219
220%triggerpostun -- bind < 8.2.2_P5-15
221/sbin/chkconfig --add named
222/sbin/ldconfig
223
[7883]224%triggerpostun -- bind-current < 1:9.9.4-1
225/sbin/chkconfig --add named
226/sbin/ldconfig
227
[9333]228%post libs -p /sbin/ldconfig
[2124]229
[9333]230%postun libs -p /sbin/ldconfig
[2124]231
232
233%files
234%defattr(-,root,root)
235%doc CHANGES README
[9333]236%doc doc/arm doc/misc
[2124]237%config(noreplace) %{_sysconfdir}/logrotate.d/named
238%config %{_sysconfdir}/rc.d/init.d/named
239%config(noreplace) %{_sysconfdir}/sysconfig/named
240%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
241%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
[7883]242%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
[2124]243
244%{_sbindir}/dnssec*
245%{_sbindir}/lwresd
246%{_sbindir}/named
247%{_sbindir}/named-bootconf
248%{_sbindir}/named-check*
249%{_sbindir}/named-compilezone
250%{_sbindir}/rndc*
251%{_sbindir}/dns-keygen
[7883]252%{_sbindir}/arpaname
253%{_sbindir}/ddns-confgen
254%{_sbindir}/genrandom
255%{_sbindir}/isc-hmac-fixup
256%{_sbindir}/named-journalprint
257%{_sbindir}/nsec3hash
[2124]258
[7883]259%{_mandir}/man1/arpaname.1*
[2124]260%{_mandir}/man5/resolv.conf.5*
261%{_mandir}/man5/named.conf.5*
262%{_mandir}/man5/rndc.conf.5*
263%{_mandir}/man8/rndc.8*
264%{_mandir}/man8/named.8*
265%{_mandir}/man8/lwresd.8*
266%{_mandir}/man8/dnssec*.8*
267%{_mandir}/man8/named-checkconf.8*
268%{_mandir}/man8/named-checkzone.8*
269%{_mandir}/man8/named-compilezone.8*
270%{_mandir}/man8/rndc-confgen.8*
[7883]271%{_mandir}/man8/ddns-confgen.8*
272%{_mandir}/man8/genrandom.8*
273%{_mandir}/man8/isc-hmac-fixup.8*
274%{_mandir}/man8/named-journalprint.8*
275%{_mandir}/man8/nsec3hash.8*
[2124]276
277%attr(-,named,named) %dir %{_var}/named
278%attr(-,named,named) %dir %{_var}/run/named
279     
280
281%files libs
[6036]282%defattr(-,root,root)
[2124]283%{_libdir}/*.so.*
284
285%files utils
286%defattr(-,root,root)
287%{_bindir}/dig
288%{_bindir}/host
289%{_bindir}/nslookup
290%{_bindir}/nsupdate
291%{_mandir}/man1/host.1*
292%{_mandir}/man1/nsupdate.1*
293%{_mandir}/man1/dig.1*
294%{_mandir}/man5/resolver.5*
295%{_mandir}/man1/nslookup.1*
296%{_mandir}/man8/nslookup.8*
297
298%files devel
299%defattr(-,root,root)
300%{_libdir}/*.so
301%{_libdir}/*.a
302%{_includedir}/*
303%{_mandir}/man3/*
[9333]304%{_mandir}/man1/bind9-config.1*
[2124]305%{_mandir}/man1/isc-config.sh.1*
[9333]306%{_bindir}/bind9-config
[2124]307%{_bindir}/isc-config.sh
308
309%changelog
[9467]310* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
311- rebuilt without readline to avoid GPL infection
312
[9391]313* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
314- new upstream release with secrity fix (CVE-2015-1349)
315- added BR: readline-devel
316
[9333]317* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
318- new upstream release with secrity fix (CVE-2014-8500) 
[9391]319- used "3" as release number because of being newer than Vine Linux/6 updates
[9333]320
[7883]321* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
322- update to 9.9.4(ESV)
[7598]323
[7883]324* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
325- update to 9.9.2-P2
326- remove .la
327- remove Conflicts/Obsoletes from libs subpackage.
328- add configure options
329  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
[7606]330
[7883]331* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
332- new upstream release.
333- added an option "--with-dlz-dlopen".
[7606]334
[7883]335* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
336- Obosoletes: bind.* < 1:9.6.ESV.R1
337 - fixed <BTS:VineLinux:1139>
[7606]338
[7883]339* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
340- new upstream release with security fix (CVE-2011-1910)
[6000]341
[7883]342* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
343- add BuildRequires: libxml2-devel, libcap-devel
[6632]344
[7883]345* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
346- new upstream release with security fix (CVE-2011-1907)
347- fix changelog typo
[6036]348
[7883]349* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
350- Obosoletes: bind.* < 1:9.6.ESV.R1
[4281]351
[7883]352* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
353- update to 9.8.0
354- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
[3985]355
[7883]356* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
[2483]357- rebuild with openssl-1.0.0c
358
[7883]359* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
360- fix Req: in bind package
[2452]361
[7883]362* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
363- change package name bind -> bind-current
364- add epoch 1
365- new upstream release
[2124]366
[7883]367* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
368- new upstream release
[2124]369
[7883]370* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
371- rebuilt with gcc-4.4.3-3 on ppc
[2124]372
[7883]373* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
374- rebuilt with new toolchains (for VineSeed)
375- s/BuildPrereq/BuildRequires/
[2124]376
377* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
378- add man1/isc-config.sh.1 into devel file list
379
380* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
381- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
382
383* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
384- new upstream release with security fix (CVE-2009-4022)
385
386* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
387- new upstream release with security fix
388
389* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
390- new upstream release
391- clean up %%post/%%pre scriptlet
392  - create named user and group in %%pre
393  - don't remove named user/group in %%preun
394  - use rndc-confgen to create rndc.key
395
396* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
397- new upstream release
398- drop patch0 and patch14, merged in upstream
399
[7598]400* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
[2124]401- new upstream release with security fix
402
403* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
404- new upstream release with security fix
405- new versioning policy
406
407* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
408- new upstream release with security fix
409
410* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
411- new upstream release
412- build with new openssl/toolchain
413
414* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
415- new upstream release with security fix
416
417* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
418- new upstream release
419
420* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
421- add Prereq sed
422
423* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
424- new upstream release for security fix (CVE-2006-4095,4096)
425
426* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
427- separate -libs package
428- remove old named.conf.5.gz
429  - newer version is contained in source
430
431* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
432- add bsdcompat patch (Patch4)
433- add fix_h_errno patch from FC
434  - h_errno not being accessed / set correctly in libbind
435
436* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
437- new upstream release
438
439* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
440- added PreReq to bind-utils (see: [VineSeed:09555])
441
442* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
443- new upstream release
444
445* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
446- fix /etc/init.d/named to use rndc
447
448* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
449- rebuild to remove unneeded dependancy
450
451* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
452- new upstream release
453
454* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
455- new upstream release
456
457* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
458- fix dependancies.
459
460* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
461- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
462- change package name to bind for VineSeed.
463- use more macros.
464
465* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
466- fixed some macros
467- add conflicts: to bind-* in bind9-devel and bind9-utils
468- add provides: bind = %%{version}
469
470* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
471- use %%configure macros
472
473* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
474- fixed inconsistent dependency
475
476* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
477- updated to 9.2.2rc1
478
479* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
480- updated to bind9(9.2.1), test packages ;)
481        -- based on Rawhide's bind-9.2.0-8
482        -- changed name bind9
483        -- added Conflicts: bind
484
485* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
486- release 8.3.1 includes security fixes
487
488* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
489- Upgraded to current stable release 8.3.0
490
491* Mon Oct  8 2001 <zn@mbf.nifty.com>
492- 8.2.5-0vl0: Upgraded to new upstream version.
493
494* Thu May 24 2001 <sagami@vinelinux.org>
495- 8.2.4-0vl1: eliminate CVS related files from %%doc
496
497* Thu May 17 2001 <sagami@vinelinux.org>
498- 8.2.4-0vl0
499
500* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
501- 8.2.3-1vl2
502- built on VineSeed
503
504* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
505- add doc/old
506- build for Vine 2.1
507
508* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
509- 8.2.3, fixes several security problems
510
511* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
512- static libraries may be used in shared objects. Build with -fPIC on ia64
513
514* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
515- 8.2.2-P7 (fixes Bug #20546)
516
517* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
518- condrestart fixes
519
520* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
521- change the init script to take condrestart, not cond-restart
522- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
523  the %pre and %post scripts
524
525* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
526- Don't prereq /etc/init.d
527
528* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
529- move initscript back
530
531* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
532- automatic rebuild
533
534* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
535- add "exit 0" for uninstall case
536
537* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
538- add prereq init.d and cleanup install section
539
540* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
541- fix the init script
542
543* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
544- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
545
546* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
547- Fix up the initscript (Bug #13033)
548- Fix build with current glibc (Bug #12755)
549- /etc/rc.d/init.d -> /etc/init.d
550- use %%{_mandir} rather than /usr/share/man
551
552* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
553- fix conflict with man-pages
554- remove compatibilty chkconfig links
555- initscript munging
556
557* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
558- modify logrotate setup to use PID file
559- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
560- actually bump the release this time
561
562* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- FHS compliance
564
565* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
566- clean up restart patch
567
568* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
569- provide /var/named (fix for bugs #9847, #10205)
570- preserve args when restarted via ndc(8) (bug #10227)
571- make resolv.conf(5) a link to resolver(5) (bug #10245)
572- fix SYSTYPE bug in all makefiles
573- move creation of named user from %%post into %%pre
574
575* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
576- Fix TTL (patch from ISC, Bug #9820)
577
578* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
579- fix typo in spec (it's %post, without a leading blank) introduced in -6
580- change SYSTYPE to linux
581
[7598]582* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
[2124]583- pick a standard < 100 uid/gid for named
584
[7598]585* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
[2124]586- Pass named a '-u named' parameter by default, and add/remove user.
587
588* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
589- fix host mx bug (Bug #9021)
590
591* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
592- rebuild to fix dependencies
593- man pages are compressed
594
595* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
596- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
597
598* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
599- Fix up location of named-bootconf.pl and make it executable
600  (Bug #8028)
601- bind-devel requires bind
602
603* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
604- update to 8.2.2-P5
605
606* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
607- update to 8.2.2-P3
608
609* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
610- add patch to stop a cache only server from complaining about lame servers
611  on every request.
612
613* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
614- use real stop and start in named.init for restart, not ndc restart, it has
615  problems when named has changed during a package update... (# 4890)
616
617* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
618- chkconfig --del in %preun, not %postun
619
620* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
621- initscript munging
622
623* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
624- fix installed chkconfig links to match init file
625
626* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
627- conflict with new (in man-1.24) man pages (#3876,#3877).
628
629* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
630- fix named.logrotate (wrong %SOURCE)
631
632* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
633- update to 8.2.1.
634- add named.logrotate (#3571).
635- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
636- vet file list.
637
638* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
639- don't run by default
640
641* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
642- nslookup fixes (#2463).
643- missing files (#3152).
644
645* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
646- nslookup patched:
647  to count numRecords properly
648  to fix subsequent calls to ls -d
649  to parse "view" and "finger" commands properly
650  the view hack updated for bind-8 (using sed)
651
652* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
653- add ISC patch
654- add quick hack to make host not crash
655- add more docs
656
657* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
658- add probing information in the init file to keep linuxconf happy
659- dont strip libbind
660
661* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
662- auto rebuild in the new build environment (release 3)
663
664* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
665- removed 'done' output at named shutdown.
666
667* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
668- version 8.2
669
670* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
671- patch to use the __FDS_BITS macro
672- build for glibc 2.1
673
674* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
675- change named.restart to /usr/sbin/ndc restart
676
677* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
678- install man pages correctly.
679- change K10named to K45named.
680
681* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
682- don't start if /etc/named.conf doesn't exist.
683
684* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
685- autmagically create /etc/named.conf from /etc/named.boot in %post
686- remove echo in %post
687
688* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
689- merge in 5.1 mods
690
691* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
692- Several essential modifications to build and install correctly.
693- Modified 'ndc' to avoid deprecated use of '-'
694
695* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
696- Used buildroot
697- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
698  on Redhat 5.0 instead of <nlist.h>
699
Note: See TracBrowser for help on using the repository browser.