source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 2127

Revision 2127, 19.6 KB checked in by iwamoto, 14 years ago (diff)

fix Req: tag

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.7.2P2
6%define sversion 9.7.2-P2
7%define bind_epoch 1
8
9%define bind_uid  25
10%define bind_gid  25
11
12Summary: A DNS (Domain Name System) server.
13Summary(ja): DNS (Domain Name System) サーバ
14Name: %{pname}
15Version: %{pversion}
16Release: 2%{?_dist_release}
17Epoch: %{bind_epoch}
18License: distributable
19Group: System Environment/Daemons
20Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
21Source1: bind-manpages.tar.bz2
22Source2: named.sysconfig
23Source3: named.init
24Source4: named.logrotate
25Source5: keygen.c
26URL: http://www.isc.org/bind.html
27Patch1: bind-9.3.3rc2-rndckey.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: openssl-devel glibc-devel libtool
31Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
32Requires(pre): shadow-utils
33Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
34Requires(post): coreutils, chkconfig
35Requires(preun): initscripts, chkconfig
36Requires(triggerpostun): chkconfig
37Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
38Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
39Provides: bind = %{bind_epoch}:%{version}-%{release}
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46BIND (Berkeley Internet Name Domain) is an implementation of the DNS
47(Domain Name System) protocols. BIND includes a DNS server (named),
48which resolves host names to IP addresses, and a resolver library
49(routines for applications to use when interfacing with DNS).  A DNS
50server allows clients to name resources or objects and share the
51information with other network machines.  The named DNS server can be
52used on workstations as a caching name server, but is generally only
53needed on one machine for an entire network.  Note that the
54configuration files for making BIND act as a simple caching nameserver
55are included in the caching-nameserver package. 
56
57Install the bind package if you need a DNS server for your network.  If
58you want bind to act a caching name server, you will also need to install
59the caching-nameserver package.
60
61
62%package libs
63Summary: Libraries used by various DNS packages
64Group: System Environment/Libraries
65Conflicts: bind9-libs <= 9.2.1-0vl5
66Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
67Obsoletes: bind9-libs <= 9.2.1-0vl5
68Obsoletes: bind-libs < %{bind_epoch}:%{version}-%{release}
69Provides: bind-libs = %{bind_epoch}:%{version}-%{release}
70
71%description libs
72Contains libraries used by both the bind server package as well as the utils packages.
73
74
75%package utils
76Summary: Utilities for querying DNS name servers.
77Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
78Group: Applications/System
79Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
80Conflicts: bind9-utils <= 9.2.1-0vl5
81Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
82Obsoletes: bind9-utils <= 9.2.1-0vl5
83Obsoletes: bind-utils < %{bind_epoch}:%{version}-%{release}
84Provides: bind-utils = %{bind_epoch}:%{version}-%{release}
85
86%description utils
87Bind-utils contains a collection of utilities for querying DNS (Domain
88Name Service) name servers to find out information about Internet hosts.
89These tools will provide you with the IP addresses for given host names,
90as well as other information about registered domains and network
91addresses.
92
93You should install bind-utils if you need to get information from DNS name
94servers.
95
96
97%package devel
98Summary: Include files and libraries needed for bind DNS development.
99Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
100Group: Development/Libraries
101Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
102Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
103Conflicts: bind9-devel <= 9.2.1-0vl5
104Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
105Obsoletes: bind9-devel <= 9.2.1-0vl5
106Obsoletes: bind-devel < %{bind_epoch}:%{version}-%{release}
107Provides: bind-devel = %{bind_epoch}:%{version}-%{release}
108
109%description devel
110The bind-devel package contains all the include files and the
111library required for DNS (Domain Name Service) development for
112BIND versions 9.x.x.
113
114You should install bind-devel if you want to develop bind DNS
115applications. If you install bind-devel, you'll also need to install
116bind.
117#'
118
119%prep
120%setup -n bind-%{sversion} -q
121%patch1 -p1 -b .key
122
123%build
124libtoolize --copy --force
125aclocal
126autoconf
127%configure --with-libtool --with-openssl=/usr --enable-threads
128make %{?_smp_mflags}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
133mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
134mkdir -p ${RPM_BUILD_ROOT}/var/named
135mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
136mkdir -p ${RPM_BUILD_ROOT}/var/run/named
137
138make DESTDIR=$RPM_BUILD_ROOT install
139install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
140install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
141install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
142install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
143touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
144gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
145cd $RPM_BUILD_ROOT%{_mandir}
146tar xjf %{SOURCE1}
147# newer version is contained in source
148rm -f man5/named.conf.5.gz
149mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
150cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
151
152
153%pre
154if [ "$1" -eq 1 ]; then
155  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
156  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
157fi;
158:;
159
160%post
161/sbin/ldconfig
162/sbin/chkconfig --add named
163if [ "$1" -eq 1 ]; then
164  if [ ! -e /etc/rndc.key ]; then
165    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
166  fi
167  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
168  # rndc.key has to have correct perms and ownership, CVE-2007-6283
169  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
170  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
171
172  # Check DNSSEC settings if this is a fresh install
173  if [ -r /etc/sysconfig/dnssec ]; then
174    . /etc/sysconfig/dnssec
175    [ -x /usr/sbin/dnssec-configure ] && \
176      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
177        /dev/null 2>&1
178  fi;
179fi
180:;
181
182%preun
183if [ "$1" -eq 0 ]; then
184   /sbin/service named stop >/dev/null 2>&1 || :
185   /sbin/chkconfig --del named ||:
186fi
187exit 0
188
189
190%postun
191if [ "$1" -ge 1 ]; then
192        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
193fi
194/sbin/ldconfig
195
196%triggerpostun -- bind < 8.2.2_P5-15
197/sbin/chkconfig --add named
198/sbin/ldconfig
199
200%clean
201rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
202
203
204%post libs -p /sbin/ldconfig
205
206%postun libs -p /sbin/ldconfig
207
208
209%files
210%defattr(-,root,root)
211%doc CHANGES README
212%doc doc/arm doc/draft doc/rfc doc/misc
213%config(noreplace) %{_sysconfdir}/logrotate.d/named
214%config %{_sysconfdir}/rc.d/init.d/named
215%config(noreplace) %{_sysconfdir}/sysconfig/named
216%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
217%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
218
219%{_sbindir}/dnssec*
220%{_sbindir}/lwresd
221%{_sbindir}/named
222%{_sbindir}/named-bootconf
223%{_sbindir}/named-check*
224%{_sbindir}/named-compilezone
225%{_sbindir}/rndc*
226%{_sbindir}/dns-keygen
227
228#%{_libdir}/libbind9.so.*
229#%{_libdir}/libisccc.so.*
230#%{_libdir}/libisccfg.so.*
231
232%{_mandir}/man5/resolv.conf.5*
233%{_mandir}/man5/named.conf.5*
234%{_mandir}/man5/rndc.conf.5*
235%{_mandir}/man8/rndc.8*
236%{_mandir}/man8/named.8*
237%{_mandir}/man8/lwresd.8*
238%{_mandir}/man8/dnssec*.8*
239%{_mandir}/man8/named-checkconf.8*
240%{_mandir}/man8/named-checkzone.8*
241%{_mandir}/man8/named-compilezone.8*
242%{_mandir}/man8/rndc-confgen.8*
243
244%attr(-,named,named) %dir %{_var}/named
245%attr(-,named,named) %dir %{_var}/run/named
246     
247
248%files libs
249%defattr(-,root,root)
250%{_libdir}/*.so.*
251
252%files utils
253%defattr(-,root,root)
254%{_bindir}/dig
255%{_bindir}/host
256%{_bindir}/nslookup
257%{_bindir}/nsupdate
258#%{_libdir}/libdns.so.*
259#%{_libdir}/libisc.so.*
260#%{_libdir}/liblwres.so.*
261%{_mandir}/man1/host.1*
262%{_mandir}/man1/nsupdate.1*
263%{_mandir}/man1/dig.1*
264%{_mandir}/man5/resolver.5*
265%{_mandir}/man1/nslookup.1*
266%{_mandir}/man8/nslookup.8*
267
268
269%files devel
270%defattr(-,root,root)
271%{_libdir}/*.so
272%{_libdir}/*.la
273%{_libdir}/*.a
274%{_includedir}/*
275%{_mandir}/man3/*
276%{_mandir}/man1/isc-config.sh.1*
277%{_bindir}/isc-config.sh
278
279%changelog
280* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
281- fix Req: in bind package
282
283* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
284- change package name bind -> bind-current
285- add epoch 1
286- new upstream release
287
288* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
289- new upstream release
290
291* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
292- rebuilt with gcc-4.4.3-3 on ppc
293
294* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
295- rebuilt with new toolchains (for VineSeed)
296- s/BuildPrereq/BuildRequires/
297
298* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
299- add man1/isc-config.sh.1 into devel file list
300
301* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
302- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
303
304* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
305- new upstream release with security fix (CVE-2009-4022)
306
307* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
308- new upstream release with security fix
309
310* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
311- new upstream release
312- clean up %%post/%%pre scriptlet
313  - create named user and group in %%pre
314  - don't remove named user/group in %%preun
315  - use rndc-confgen to create rndc.key
316
317* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
318- new upstream release
319- drop patch0 and patch14, merged in upstream
320
321* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
322- new upstream release with security fix
323
324* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
325- new upstream release with security fix
326- new versioning policy
327
328* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
329- new upstream release with security fix
330
331* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
332- new upstream release
333- build with new openssl/toolchain
334
335* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
336- new upstream release with security fix
337
338* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
339- new upstream release
340
341* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
342- add Prereq sed
343
344* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
345- new upstream release for security fix (CVE-2006-4095,4096)
346
347* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
348- separate -libs package
349- remove old named.conf.5.gz
350  - newer version is contained in source
351
352* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
353- add bsdcompat patch (Patch4)
354- add fix_h_errno patch from FC
355  - h_errno not being accessed / set correctly in libbind
356
357* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
358- new upstream release
359
360* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
361- added PreReq to bind-utils (see: [VineSeed:09555])
362
363* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
364- new upstream release
365
366* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
367- fix /etc/init.d/named to use rndc
368
369* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
370- rebuild to remove unneeded dependancy
371
372* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
373- new upstream release
374
375* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
376- new upstream release
377
378* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
379- fix dependancies.
380
381* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
382- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
383- change package name to bind for VineSeed.
384- use more macros.
385
386* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
387- fixed some macros
388- add conflicts: to bind-* in bind9-devel and bind9-utils
389- add provides: bind = %%{version}
390
391* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
392- use %%configure macros
393
394* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
395- fixed inconsistent dependency
396
397* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
398- updated to 9.2.2rc1
399
400* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
401- updated to bind9(9.2.1), test packages ;)
402        -- based on Rawhide's bind-9.2.0-8
403        -- changed name bind9
404        -- added Conflicts: bind
405
406* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
407- release 8.3.1 includes security fixes
408
409* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
410- Upgraded to current stable release 8.3.0
411
412* Mon Oct  8 2001 <zn@mbf.nifty.com>
413- 8.2.5-0vl0: Upgraded to new upstream version.
414
415* Thu May 24 2001 <sagami@vinelinux.org>
416- 8.2.4-0vl1: eliminate CVS related files from %%doc
417
418* Thu May 17 2001 <sagami@vinelinux.org>
419- 8.2.4-0vl0
420
421* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
422- 8.2.3-1vl2
423- built on VineSeed
424
425* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
426- add doc/old
427- build for Vine 2.1
428
429* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
430- 8.2.3, fixes several security problems
431
432* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
433- static libraries may be used in shared objects. Build with -fPIC on ia64
434
435* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
436- 8.2.2-P7 (fixes Bug #20546)
437
438* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
439- condrestart fixes
440
441* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
442- change the init script to take condrestart, not cond-restart
443- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
444  the %pre and %post scripts
445
446* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
447- Don't prereq /etc/init.d
448
449* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
450- move initscript back
451
452* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
453- automatic rebuild
454
455* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
456- add "exit 0" for uninstall case
457
458* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
459- add prereq init.d and cleanup install section
460
461* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
462- fix the init script
463
464* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
465- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
466
467* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
468- Fix up the initscript (Bug #13033)
469- Fix build with current glibc (Bug #12755)
470- /etc/rc.d/init.d -> /etc/init.d
471- use %%{_mandir} rather than /usr/share/man
472
473* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
474- fix conflict with man-pages
475- remove compatibilty chkconfig links
476- initscript munging
477
478* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
479- modify logrotate setup to use PID file
480- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
481- actually bump the release this time
482
483* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
484- FHS compliance
485
486* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
487- clean up restart patch
488
489* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
490- provide /var/named (fix for bugs #9847, #10205)
491- preserve args when restarted via ndc(8) (bug #10227)
492- make resolv.conf(5) a link to resolver(5) (bug #10245)
493- fix SYSTYPE bug in all makefiles
494- move creation of named user from %%post into %%pre
495
496* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
497- Fix TTL (patch from ISC, Bug #9820)
498
499* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
500- fix typo in spec (it's %post, without a leading blank) introduced in -6
501- change SYSTYPE to linux
502
503* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
504- pick a standard < 100 uid/gid for named
505
506* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
507- Pass named a '-u named' parameter by default, and add/remove user.
508
509* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
510- fix host mx bug (Bug #9021)
511
512* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
513- rebuild to fix dependencies
514- man pages are compressed
515
516* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
517- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
518
519* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
520- Fix up location of named-bootconf.pl and make it executable
521  (Bug #8028)
522- bind-devel requires bind
523
524* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
525- update to 8.2.2-P5
526
527* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
528- update to 8.2.2-P3
529
530* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
531- add patch to stop a cache only server from complaining about lame servers
532  on every request.
533
534* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
535- use real stop and start in named.init for restart, not ndc restart, it has
536  problems when named has changed during a package update... (# 4890)
537
538* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
539- chkconfig --del in %preun, not %postun
540
541* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
542- initscript munging
543
544* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
545- fix installed chkconfig links to match init file
546
547* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
548- conflict with new (in man-1.24) man pages (#3876,#3877).
549
550* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
551- fix named.logrotate (wrong %SOURCE)
552
553* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
554- update to 8.2.1.
555- add named.logrotate (#3571).
556- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
557- vet file list.
558
559* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
560- don't run by default
561
562* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
563- nslookup fixes (#2463).
564- missing files (#3152).
565
566* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
567- nslookup patched:
568  to count numRecords properly
569  to fix subsequent calls to ls -d
570  to parse "view" and "finger" commands properly
571  the view hack updated for bind-8 (using sed)
572
573* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
574- add ISC patch
575- add quick hack to make host not crash
576- add more docs
577
578* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
579- add probing information in the init file to keep linuxconf happy
580- dont strip libbind
581
582* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
583- auto rebuild in the new build environment (release 3)
584
585* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
586- removed 'done' output at named shutdown.
587
588* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
589- version 8.2
590
591* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
592- patch to use the __FDS_BITS macro
593- build for glibc 2.1
594
595* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
596- change named.restart to /usr/sbin/ndc restart
597
598* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
599- install man pages correctly.
600- change K10named to K45named.
601
602* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
603- don't start if /etc/named.conf doesn't exist.
604
605* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
606- autmagically create /etc/named.conf from /etc/named.boot in %post
607- remove echo in %post
608
609* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
610- merge in 5.1 mods
611
612* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
613- Several essential modifications to build and install correctly.
614- Modified 'ndc' to avoid deprecated use of '-'
615
616* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
617- Used buildroot
618- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
619  on Redhat 5.0 instead of <nlist.h>
620
Note: See TracBrowser for help on using the repository browser.