source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 2123

Revision 2123, 19.5 KB checked in by iwamoto, 14 years ago (diff)

bind is changed to 9.6.ESV
bind-current is latest bind version package

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.7.2P2
6%define sversion 9.7.2-P2
7%define bind_epoch 1
8
9%define bind_uid  25
10%define bind_gid  25
11
12Summary: A DNS (Domain Name System) server.
13Summary(ja): DNS (Domain Name System) サーバ
14Name: %{pname}
15Version: %{pversion}
16Release: 1%{?_dist_release}
17Epoch: %{bind_epoch}
18License: distributable
19Group: System Environment/Daemons
20Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
21Source1: bind-manpages.tar.bz2
22Source2: named.sysconfig
23Source3: named.init
24Source4: named.logrotate
25Source5: keygen.c
26URL: http://www.isc.org/bind.html
27Patch1: bind-9.3.3rc2-rndckey.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: openssl-devel glibc-devel libtool
31Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
32Requires(pre): shadow-utils
33Requires(post): %{pname}-utils = %{version}-%{release}
34Requires(post): coreutils, chkconfig
35Requires(preun): initscripts, chkconfig
36Requires(triggerpostun): chkconfig
37Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
38Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
39Provides: bind = %{bind_epoch}:%{version}-%{release}
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46BIND (Berkeley Internet Name Domain) is an implementation of the DNS
47(Domain Name System) protocols. BIND includes a DNS server (named),
48which resolves host names to IP addresses, and a resolver library
49(routines for applications to use when interfacing with DNS).  A DNS
50server allows clients to name resources or objects and share the
51information with other network machines.  The named DNS server can be
52used on workstations as a caching name server, but is generally only
53needed on one machine for an entire network.  Note that the
54configuration files for making BIND act as a simple caching nameserver
55are included in the caching-nameserver package. 
56
57Install the bind package if you need a DNS server for your network.  If
58you want bind to act a caching name server, you will also need to install
59the caching-nameserver package.
60
61
62%package libs
63Summary: Libraries used by various DNS packages
64Group: System Environment/Libraries
65Conflicts: bind9-libs <= 9.2.1-0vl5
66Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
67Obsoletes: bind9-libs <= 9.2.1-0vl5
68Obsoletes: bind-libs < %{bind_epoch}:%{version}-%{release}
69Provides: bind-libs = %{bind_epoch}:%{version}-%{release}
70
71%description libs
72Contains libraries used by both the bind server package as well as the utils packages.
73
74
75%package utils
76Summary: Utilities for querying DNS name servers.
77Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
78Group: Applications/System
79Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
80Conflicts: bind9-utils <= 9.2.1-0vl5
81Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
82Obsoletes: bind9-utils <= 9.2.1-0vl5
83Obsoletes: bind-utils < %{bind_epoch}:%{version}-%{release}
84Provides: bind-utils = %{bind_epoch}:%{version}-%{release}
85
86%description utils
87Bind-utils contains a collection of utilities for querying DNS (Domain
88Name Service) name servers to find out information about Internet hosts.
89These tools will provide you with the IP addresses for given host names,
90as well as other information about registered domains and network
91addresses.
92
93You should install bind-utils if you need to get information from DNS name
94servers.
95
96
97%package devel
98Summary: Include files and libraries needed for bind DNS development.
99Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
100Group: Development/Libraries
101Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
102Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
103Conflicts: bind9-devel <= 9.2.1-0vl5
104Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
105Obsoletes: bind9-devel <= 9.2.1-0vl5
106Obsoletes: bind-devel < %{bind_epoch}:%{version}-%{release}
107Provides: bind-devel = %{bind_epoch}:%{version}-%{release}
108
109%description devel
110The bind-devel package contains all the include files and the
111library required for DNS (Domain Name Service) development for
112BIND versions 9.x.x.
113
114You should install bind-devel if you want to develop bind DNS
115applications. If you install bind-devel, you'll also need to install
116bind.
117#'
118
119%prep
120%setup -n bind-%{sversion} -q
121%patch1 -p1 -b .key
122
123%build
124libtoolize --copy --force
125aclocal
126autoconf
127%configure --with-libtool --with-openssl=/usr --enable-threads
128make %{?_smp_mflags}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
133mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
134mkdir -p ${RPM_BUILD_ROOT}/var/named
135mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
136mkdir -p ${RPM_BUILD_ROOT}/var/run/named
137
138make DESTDIR=$RPM_BUILD_ROOT install
139install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
140install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
141install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
142install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
143touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
144gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
145cd $RPM_BUILD_ROOT%{_mandir}
146tar xjf %{SOURCE1}
147# newer version is contained in source
148rm -f man5/named.conf.5.gz
149mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
150cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
151
152
153%pre
154if [ "$1" -eq 1 ]; then
155  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
156  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
157fi;
158:;
159
160%post
161/sbin/ldconfig
162/sbin/chkconfig --add named
163if [ "$1" -eq 1 ]; then
164  if [ ! -e /etc/rndc.key ]; then
165    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
166  fi
167  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
168  # rndc.key has to have correct perms and ownership, CVE-2007-6283
169  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
170  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
171
172  # Check DNSSEC settings if this is a fresh install
173  if [ -r /etc/sysconfig/dnssec ]; then
174    . /etc/sysconfig/dnssec
175    [ -x /usr/sbin/dnssec-configure ] && \
176      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
177        /dev/null 2>&1
178  fi;
179fi
180:;
181
182%preun
183if [ "$1" -eq 0 ]; then
184   /sbin/service named stop >/dev/null 2>&1 || :
185   /sbin/chkconfig --del named ||:
186fi
187exit 0
188
189
190%postun
191if [ "$1" -ge 1 ]; then
192        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
193fi
194/sbin/ldconfig
195
196%triggerpostun -- bind < 8.2.2_P5-15
197/sbin/chkconfig --add named
198/sbin/ldconfig
199
200%clean
201rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
202
203
204%post libs -p /sbin/ldconfig
205
206%postun libs -p /sbin/ldconfig
207
208
209%files
210%defattr(-,root,root)
211%doc CHANGES README
212%doc doc/arm doc/draft doc/rfc doc/misc
213%config(noreplace) %{_sysconfdir}/logrotate.d/named
214%config %{_sysconfdir}/rc.d/init.d/named
215%config(noreplace) %{_sysconfdir}/sysconfig/named
216%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
217%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
218
219%{_sbindir}/dnssec*
220%{_sbindir}/lwresd
221%{_sbindir}/named
222%{_sbindir}/named-bootconf
223%{_sbindir}/named-check*
224%{_sbindir}/named-compilezone
225%{_sbindir}/rndc*
226%{_sbindir}/dns-keygen
227
228#%{_libdir}/libbind9.so.*
229#%{_libdir}/libisccc.so.*
230#%{_libdir}/libisccfg.so.*
231
232%{_mandir}/man5/resolv.conf.5*
233%{_mandir}/man5/named.conf.5*
234%{_mandir}/man5/rndc.conf.5*
235%{_mandir}/man8/rndc.8*
236%{_mandir}/man8/named.8*
237%{_mandir}/man8/lwresd.8*
238%{_mandir}/man8/dnssec*.8*
239%{_mandir}/man8/named-checkconf.8*
240%{_mandir}/man8/named-checkzone.8*
241%{_mandir}/man8/named-compilezone.8*
242%{_mandir}/man8/rndc-confgen.8*
243
244%attr(-,named,named) %dir %{_var}/named
245%attr(-,named,named) %dir %{_var}/run/named
246     
247
248%files libs
249%defattr(-,root,root)
250%{_libdir}/*.so.*
251
252%files utils
253%defattr(-,root,root)
254%{_bindir}/dig
255%{_bindir}/host
256%{_bindir}/nslookup
257%{_bindir}/nsupdate
258#%{_libdir}/libdns.so.*
259#%{_libdir}/libisc.so.*
260#%{_libdir}/liblwres.so.*
261%{_mandir}/man1/host.1*
262%{_mandir}/man1/nsupdate.1*
263%{_mandir}/man1/dig.1*
264%{_mandir}/man5/resolver.5*
265%{_mandir}/man1/nslookup.1*
266%{_mandir}/man8/nslookup.8*
267
268
269%files devel
270%defattr(-,root,root)
271%{_libdir}/*.so
272%{_libdir}/*.la
273%{_libdir}/*.a
274%{_includedir}/*
275%{_mandir}/man3/*
276%{_mandir}/man1/isc-config.sh.1*
277%{_bindir}/isc-config.sh
278
279%changelog
280* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
281- change package name bind -> bind-current
282- add epoch 1
283- new upstream release
284
285* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
286- new upstream release
287
288* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
289- rebuilt with gcc-4.4.3-3 on ppc
290
291* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
292- rebuilt with new toolchains (for VineSeed)
293- s/BuildPrereq/BuildRequires/
294
295* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
296- add man1/isc-config.sh.1 into devel file list
297
298* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
299- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
300
301* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
302- new upstream release with security fix (CVE-2009-4022)
303
304* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
305- new upstream release with security fix
306
307* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
308- new upstream release
309- clean up %%post/%%pre scriptlet
310  - create named user and group in %%pre
311  - don't remove named user/group in %%preun
312  - use rndc-confgen to create rndc.key
313
314* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
315- new upstream release
316- drop patch0 and patch14, merged in upstream
317
318* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
319- new upstream release with security fix
320
321* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
322- new upstream release with security fix
323- new versioning policy
324
325* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
326- new upstream release with security fix
327
328* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
329- new upstream release
330- build with new openssl/toolchain
331
332* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
333- new upstream release with security fix
334
335* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
336- new upstream release
337
338* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
339- add Prereq sed
340
341* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
342- new upstream release for security fix (CVE-2006-4095,4096)
343
344* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
345- separate -libs package
346- remove old named.conf.5.gz
347  - newer version is contained in source
348
349* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
350- add bsdcompat patch (Patch4)
351- add fix_h_errno patch from FC
352  - h_errno not being accessed / set correctly in libbind
353
354* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
355- new upstream release
356
357* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
358- added PreReq to bind-utils (see: [VineSeed:09555])
359
360* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
361- new upstream release
362
363* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
364- fix /etc/init.d/named to use rndc
365
366* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
367- rebuild to remove unneeded dependancy
368
369* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
370- new upstream release
371
372* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
373- new upstream release
374
375* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
376- fix dependancies.
377
378* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
379- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
380- change package name to bind for VineSeed.
381- use more macros.
382
383* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
384- fixed some macros
385- add conflicts: to bind-* in bind9-devel and bind9-utils
386- add provides: bind = %%{version}
387
388* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
389- use %%configure macros
390
391* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
392- fixed inconsistent dependency
393
394* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
395- updated to 9.2.2rc1
396
397* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
398- updated to bind9(9.2.1), test packages ;)
399        -- based on Rawhide's bind-9.2.0-8
400        -- changed name bind9
401        -- added Conflicts: bind
402
403* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
404- release 8.3.1 includes security fixes
405
406* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
407- Upgraded to current stable release 8.3.0
408
409* Mon Oct  8 2001 <zn@mbf.nifty.com>
410- 8.2.5-0vl0: Upgraded to new upstream version.
411
412* Thu May 24 2001 <sagami@vinelinux.org>
413- 8.2.4-0vl1: eliminate CVS related files from %%doc
414
415* Thu May 17 2001 <sagami@vinelinux.org>
416- 8.2.4-0vl0
417
418* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
419- 8.2.3-1vl2
420- built on VineSeed
421
422* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
423- add doc/old
424- build for Vine 2.1
425
426* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
427- 8.2.3, fixes several security problems
428
429* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
430- static libraries may be used in shared objects. Build with -fPIC on ia64
431
432* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
433- 8.2.2-P7 (fixes Bug #20546)
434
435* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
436- condrestart fixes
437
438* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
439- change the init script to take condrestart, not cond-restart
440- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
441  the %pre and %post scripts
442
443* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
444- Don't prereq /etc/init.d
445
446* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
447- move initscript back
448
449* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
450- automatic rebuild
451
452* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
453- add "exit 0" for uninstall case
454
455* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
456- add prereq init.d and cleanup install section
457
458* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
459- fix the init script
460
461* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
462- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
463
464* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
465- Fix up the initscript (Bug #13033)
466- Fix build with current glibc (Bug #12755)
467- /etc/rc.d/init.d -> /etc/init.d
468- use %%{_mandir} rather than /usr/share/man
469
470* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
471- fix conflict with man-pages
472- remove compatibilty chkconfig links
473- initscript munging
474
475* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
476- modify logrotate setup to use PID file
477- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
478- actually bump the release this time
479
480* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
481- FHS compliance
482
483* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
484- clean up restart patch
485
486* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
487- provide /var/named (fix for bugs #9847, #10205)
488- preserve args when restarted via ndc(8) (bug #10227)
489- make resolv.conf(5) a link to resolver(5) (bug #10245)
490- fix SYSTYPE bug in all makefiles
491- move creation of named user from %%post into %%pre
492
493* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
494- Fix TTL (patch from ISC, Bug #9820)
495
496* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
497- fix typo in spec (it's %post, without a leading blank) introduced in -6
498- change SYSTYPE to linux
499
500* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
501- pick a standard < 100 uid/gid for named
502
503* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
504- Pass named a '-u named' parameter by default, and add/remove user.
505
506* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
507- fix host mx bug (Bug #9021)
508
509* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
510- rebuild to fix dependencies
511- man pages are compressed
512
513* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
514- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
515
516* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
517- Fix up location of named-bootconf.pl and make it executable
518  (Bug #8028)
519- bind-devel requires bind
520
521* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
522- update to 8.2.2-P5
523
524* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
525- update to 8.2.2-P3
526
527* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
528- add patch to stop a cache only server from complaining about lame servers
529  on every request.
530
531* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
532- use real stop and start in named.init for restart, not ndc restart, it has
533  problems when named has changed during a package update... (# 4890)
534
535* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
536- chkconfig --del in %preun, not %postun
537
538* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
539- initscript munging
540
541* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
542- fix installed chkconfig links to match init file
543
544* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
545- conflict with new (in man-1.24) man pages (#3876,#3877).
546
547* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
548- fix named.logrotate (wrong %SOURCE)
549
550* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
551- update to 8.2.1.
552- add named.logrotate (#3571).
553- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
554- vet file list.
555
556* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
557- don't run by default
558
559* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
560- nslookup fixes (#2463).
561- missing files (#3152).
562
563* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
564- nslookup patched:
565  to count numRecords properly
566  to fix subsequent calls to ls -d
567  to parse "view" and "finger" commands properly
568  the view hack updated for bind-8 (using sed)
569
570* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
571- add ISC patch
572- add quick hack to make host not crash
573- add more docs
574
575* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
576- add probing information in the init file to keep linuxconf happy
577- dont strip libbind
578
579* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
580- auto rebuild in the new build environment (release 3)
581
582* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
583- removed 'done' output at named shutdown.
584
585* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
586- version 8.2
587
588* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
589- patch to use the __FDS_BITS macro
590- build for glibc 2.1
591
592* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
593- change named.restart to /usr/sbin/ndc restart
594
595* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
596- install man pages correctly.
597- change K10named to K45named.
598
599* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
600- don't start if /etc/named.conf doesn't exist.
601
602* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
603- autmagically create /etc/named.conf from /etc/named.boot in %post
604- remove echo in %post
605
606* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
607- merge in 5.1 mods
608
609* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
610- Several essential modifications to build and install correctly.
611- Modified 'ndc' to avoid deprecated use of '-'
612
613* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
614- Used buildroot
615- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
616  on Redhat 5.0 instead of <nlist.h>
617
Note: See TracBrowser for help on using the repository browser.