source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 3837

Revision 3837, 20.2 KB checked in by Takemikaduchi, 13 years ago (diff)

add BR: libxml2-devel, libcal-devel

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.8.0p1
6%define sversion 9.8.0-P1
7%define bind_epoch 1
8%define old_bind_version 1:9.6.ESV.R4
9
10%define bind_uid  25
11%define bind_gid  25
12
13Summary: A DNS (Domain Name System) server.
14Summary(ja): DNS (Domain Name System) サーバ
15Name: %{pname}
16Version: %{pversion}
17Release: 2%{?_dist_release}
18Epoch: %{bind_epoch}
19License: distributable
20Group: System Environment/Daemons
21Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
22Source1: bind-manpages.tar.bz2
23Source2: named.sysconfig
24Source3: named.init
25Source4: named.logrotate
26Source5: keygen.c
27URL: http://www.isc.org/bind.html
28Patch1: bind-9.3.3rc2-rndckey.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel glibc-devel libtool
32BuildRequires: libxml2-devel
33BuildRequires: libcap-devel
34Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
35Requires(pre): shadow-utils
36Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
37Requires(post): coreutils, chkconfig
38Requires(preun): initscripts, chkconfig
39Requires(triggerpostun): chkconfig
40Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
41Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: daisuke
46
47%description
48BIND (Berkeley Internet Name Domain) is an implementation of the DNS
49(Domain Name System) protocols. BIND includes a DNS server (named),
50which resolves host names to IP addresses, and a resolver library
51(routines for applications to use when interfacing with DNS).  A DNS
52server allows clients to name resources or objects and share the
53information with other network machines.  The named DNS server can be
54used on workstations as a caching name server, but is generally only
55needed on one machine for an entire network.  Note that the
56configuration files for making BIND act as a simple caching nameserver
57are included in the caching-nameserver package. 
58
59Install the bind package if you need a DNS server for your network.  If
60you want bind to act a caching name server, you will also need to install
61the caching-nameserver package.
62
63
64%package libs
65Summary: Libraries used by various DNS packages
66Group: System Environment/Libraries
67Conflicts: bind9-libs <= 9.2.1-0vl5
68Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
69Obsoletes: bind9-libs <= 9.2.1-0vl5
70Obsoletes: bind-libs < %{old_bind_version}
71
72%description libs
73Contains libraries used by both the bind server package as well as the utils packages.
74
75
76%package utils
77Summary: Utilities for querying DNS name servers.
78Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
79Group: Applications/System
80Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
81Conflicts: bind9-utils <= 9.2.1-0vl5
82Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
83Obsoletes: bind9-utils <= 9.2.1-0vl5
84Obsoletes: bind-utils < %{old_bind_version}
85
86%description utils
87Bind-utils contains a collection of utilities for querying DNS (Domain
88Name Service) name servers to find out information about Internet hosts.
89These tools will provide you with the IP addresses for given host names,
90as well as other information about registered domains and network
91addresses.
92
93You should install bind-utils if you need to get information from DNS name
94servers.
95
96
97%package devel
98Summary: Include files and libraries needed for bind DNS development.
99Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
100Group: Development/Libraries
101Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
102Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
103Conflicts: bind9-devel <= 9.2.1-0vl5
104Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
105Obsoletes: bind9-devel <= 9.2.1-0vl5
106Obsoletes: bind-devel < %{old_bind_version}
107
108%description devel
109The bind-devel package contains all the include files and the
110library required for DNS (Domain Name Service) development for
111BIND versions 9.x.x.
112
113You should install bind-devel if you want to develop bind DNS
114applications. If you install bind-devel, you'll also need to install
115bind.
116#'
117
118%prep
119%setup -n bind-%{sversion} -q
120%patch1 -p1 -b .key
121
122%build
123libtoolize --copy --force
124aclocal
125autoconf
126%configure --with-libtool --with-openssl=/usr --enable-threads
127make %{?_smp_mflags}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
132mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
133mkdir -p ${RPM_BUILD_ROOT}/var/named
134mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
135mkdir -p ${RPM_BUILD_ROOT}/var/run/named
136
137make DESTDIR=$RPM_BUILD_ROOT install
138install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
139install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
140install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
141install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
142touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
143gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
144cd $RPM_BUILD_ROOT%{_mandir}
145tar xjf %{SOURCE1}
146# newer version is contained in source
147rm -f man5/named.conf.5.gz
148mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
149cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
150
151
152%pre
153if [ "$1" -eq 1 ]; then
154  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
155  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
156fi;
157:;
158
159%post
160/sbin/ldconfig
161/sbin/chkconfig --add named
162if [ "$1" -eq 1 ]; then
163  if [ ! -e /etc/rndc.key ]; then
164    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
165  fi
166  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
167  # rndc.key has to have correct perms and ownership, CVE-2007-6283
168  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
169  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
170
171  # Check DNSSEC settings if this is a fresh install
172  if [ -r /etc/sysconfig/dnssec ]; then
173    . /etc/sysconfig/dnssec
174    [ -x /usr/sbin/dnssec-configure ] && \
175      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
176        /dev/null 2>&1
177  fi;
178fi
179:;
180
181%preun
182if [ "$1" -eq 0 ]; then
183   /sbin/service named stop >/dev/null 2>&1 || :
184   /sbin/chkconfig --del named ||:
185fi
186exit 0
187
188
189%postun
190if [ "$1" -ge 1 ]; then
191        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
192fi
193/sbin/ldconfig
194
195%triggerpostun -- bind < 8.2.2_P5-15
196/sbin/chkconfig --add named
197/sbin/ldconfig
198
199%clean
200rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
201
202
203%post libs -p /sbin/ldconfig
204
205%postun libs -p /sbin/ldconfig
206
207
208%files
209%defattr(-,root,root)
210%doc CHANGES README
211%doc doc/arm doc/draft doc/rfc doc/misc
212%config(noreplace) %{_sysconfdir}/logrotate.d/named
213%config %{_sysconfdir}/rc.d/init.d/named
214%config(noreplace) %{_sysconfdir}/sysconfig/named
215%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
216%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
217%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
218
219%{_sbindir}/dnssec*
220%{_sbindir}/lwresd
221%{_sbindir}/named
222%{_sbindir}/named-bootconf
223%{_sbindir}/named-check*
224%{_sbindir}/named-compilezone
225%{_sbindir}/rndc*
226%{_sbindir}/dns-keygen
227%{_sbindir}/arpaname
228%{_sbindir}/ddns-confgen
229%{_sbindir}/genrandom
230%{_sbindir}/isc-hmac-fixup
231%{_sbindir}/named-journalprint
232%{_sbindir}/nsec3hash
233
234%{_mandir}/man1/arpaname.1*
235%{_mandir}/man5/resolv.conf.5*
236%{_mandir}/man5/named.conf.5*
237%{_mandir}/man5/rndc.conf.5*
238%{_mandir}/man8/rndc.8*
239%{_mandir}/man8/named.8*
240%{_mandir}/man8/lwresd.8*
241%{_mandir}/man8/dnssec*.8*
242%{_mandir}/man8/named-checkconf.8*
243%{_mandir}/man8/named-checkzone.8*
244%{_mandir}/man8/named-compilezone.8*
245%{_mandir}/man8/rndc-confgen.8*
246%{_mandir}/man8/ddns-confgen.8*
247%{_mandir}/man8/genrandom.8*
248%{_mandir}/man8/isc-hmac-fixup.8*
249%{_mandir}/man8/named-journalprint.8*
250%{_mandir}/man8/nsec3hash.8*
251
252%attr(-,named,named) %dir %{_var}/named
253%attr(-,named,named) %dir %{_var}/run/named
254     
255
256%files libs
257%defattr(-,root,root)
258%{_libdir}/*.so.*
259
260%files utils
261%defattr(-,root,root)
262%{_bindir}/dig
263%{_bindir}/host
264%{_bindir}/nslookup
265%{_bindir}/nsupdate
266%{_mandir}/man1/host.1*
267%{_mandir}/man1/nsupdate.1*
268%{_mandir}/man1/dig.1*
269%{_mandir}/man5/resolver.5*
270%{_mandir}/man1/nslookup.1*
271%{_mandir}/man8/nslookup.8*
272
273
274%files devel
275%defattr(-,root,root)
276%{_libdir}/*.so
277%{_libdir}/*.la
278%{_libdir}/*.a
279%{_includedir}/*
280%{_mandir}/man3/*
281%{_mandir}/man1/isc-config.sh.1*
282%{_bindir}/isc-config.sh
283
284%changelog
285* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
286- add BuildRequires: libxml2-devel, libcap-devel
287
288* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
289- new upstream release with security fix (CVE-2011-1907)
290- fix changelog typo
291
292* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
293- Obosoletes: bind.* < 1:9.6.ESV.R1
294
295* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
296- update to 9.8.0
297- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
298
299* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
300- rebuild with openssl-1.0.0c
301
302* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
303- fix Req: in bind package
304
305* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
306- change package name bind -> bind-current
307- add epoch 1
308- new upstream release
309
310* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
311- new upstream release
312
313* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
314- rebuilt with gcc-4.4.3-3 on ppc
315
316* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
317- rebuilt with new toolchains (for VineSeed)
318- s/BuildPrereq/BuildRequires/
319
320* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
321- add man1/isc-config.sh.1 into devel file list
322
323* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
324- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
325
326* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
327- new upstream release with security fix (CVE-2009-4022)
328
329* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
330- new upstream release with security fix
331
332* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
333- new upstream release
334- clean up %%post/%%pre scriptlet
335  - create named user and group in %%pre
336  - don't remove named user/group in %%preun
337  - use rndc-confgen to create rndc.key
338
339* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
340- new upstream release
341- drop patch0 and patch14, merged in upstream
342
343* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
344- new upstream release with security fix
345
346* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
347- new upstream release with security fix
348- new versioning policy
349
350* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
351- new upstream release with security fix
352
353* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
354- new upstream release
355- build with new openssl/toolchain
356
357* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
358- new upstream release with security fix
359
360* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
361- new upstream release
362
363* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
364- add Prereq sed
365
366* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
367- new upstream release for security fix (CVE-2006-4095,4096)
368
369* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
370- separate -libs package
371- remove old named.conf.5.gz
372  - newer version is contained in source
373
374* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
375- add bsdcompat patch (Patch4)
376- add fix_h_errno patch from FC
377  - h_errno not being accessed / set correctly in libbind
378
379* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
380- new upstream release
381
382* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
383- added PreReq to bind-utils (see: [VineSeed:09555])
384
385* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
386- new upstream release
387
388* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
389- fix /etc/init.d/named to use rndc
390
391* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
392- rebuild to remove unneeded dependancy
393
394* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
395- new upstream release
396
397* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
398- new upstream release
399
400* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
401- fix dependancies.
402
403* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
404- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
405- change package name to bind for VineSeed.
406- use more macros.
407
408* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
409- fixed some macros
410- add conflicts: to bind-* in bind9-devel and bind9-utils
411- add provides: bind = %%{version}
412
413* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
414- use %%configure macros
415
416* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
417- fixed inconsistent dependency
418
419* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
420- updated to 9.2.2rc1
421
422* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
423- updated to bind9(9.2.1), test packages ;)
424        -- based on Rawhide's bind-9.2.0-8
425        -- changed name bind9
426        -- added Conflicts: bind
427
428* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
429- release 8.3.1 includes security fixes
430
431* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
432- Upgraded to current stable release 8.3.0
433
434* Mon Oct  8 2001 <zn@mbf.nifty.com>
435- 8.2.5-0vl0: Upgraded to new upstream version.
436
437* Thu May 24 2001 <sagami@vinelinux.org>
438- 8.2.4-0vl1: eliminate CVS related files from %%doc
439
440* Thu May 17 2001 <sagami@vinelinux.org>
441- 8.2.4-0vl0
442
443* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
444- 8.2.3-1vl2
445- built on VineSeed
446
447* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
448- add doc/old
449- build for Vine 2.1
450
451* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
452- 8.2.3, fixes several security problems
453
454* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
455- static libraries may be used in shared objects. Build with -fPIC on ia64
456
457* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- 8.2.2-P7 (fixes Bug #20546)
459
460* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
461- condrestart fixes
462
463* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
464- change the init script to take condrestart, not cond-restart
465- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
466  the %pre and %post scripts
467
468* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
469- Don't prereq /etc/init.d
470
471* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
472- move initscript back
473
474* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
475- automatic rebuild
476
477* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
478- add "exit 0" for uninstall case
479
480* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
481- add prereq init.d and cleanup install section
482
483* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
484- fix the init script
485
486* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
487- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
488
489* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
490- Fix up the initscript (Bug #13033)
491- Fix build with current glibc (Bug #12755)
492- /etc/rc.d/init.d -> /etc/init.d
493- use %%{_mandir} rather than /usr/share/man
494
495* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
496- fix conflict with man-pages
497- remove compatibilty chkconfig links
498- initscript munging
499
500* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
501- modify logrotate setup to use PID file
502- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
503- actually bump the release this time
504
505* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
506- FHS compliance
507
508* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
509- clean up restart patch
510
511* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
512- provide /var/named (fix for bugs #9847, #10205)
513- preserve args when restarted via ndc(8) (bug #10227)
514- make resolv.conf(5) a link to resolver(5) (bug #10245)
515- fix SYSTYPE bug in all makefiles
516- move creation of named user from %%post into %%pre
517
518* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
519- Fix TTL (patch from ISC, Bug #9820)
520
521* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
522- fix typo in spec (it's %post, without a leading blank) introduced in -6
523- change SYSTYPE to linux
524
525* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
526- pick a standard < 100 uid/gid for named
527
528* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
529- Pass named a '-u named' parameter by default, and add/remove user.
530
531* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
532- fix host mx bug (Bug #9021)
533
534* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
535- rebuild to fix dependencies
536- man pages are compressed
537
538* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
540
541* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- Fix up location of named-bootconf.pl and make it executable
543  (Bug #8028)
544- bind-devel requires bind
545
546* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
547- update to 8.2.2-P5
548
549* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
550- update to 8.2.2-P3
551
552* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
553- add patch to stop a cache only server from complaining about lame servers
554  on every request.
555
556* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
557- use real stop and start in named.init for restart, not ndc restart, it has
558  problems when named has changed during a package update... (# 4890)
559
560* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
561- chkconfig --del in %preun, not %postun
562
563* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
564- initscript munging
565
566* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
567- fix installed chkconfig links to match init file
568
569* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
570- conflict with new (in man-1.24) man pages (#3876,#3877).
571
572* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
573- fix named.logrotate (wrong %SOURCE)
574
575* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
576- update to 8.2.1.
577- add named.logrotate (#3571).
578- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
579- vet file list.
580
581* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
582- don't run by default
583
584* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
585- nslookup fixes (#2463).
586- missing files (#3152).
587
588* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
589- nslookup patched:
590  to count numRecords properly
591  to fix subsequent calls to ls -d
592  to parse "view" and "finger" commands properly
593  the view hack updated for bind-8 (using sed)
594
595* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
596- add ISC patch
597- add quick hack to make host not crash
598- add more docs
599
600* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
601- add probing information in the init file to keep linuxconf happy
602- dont strip libbind
603
604* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
605- auto rebuild in the new build environment (release 3)
606
607* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
608- removed 'done' output at named shutdown.
609
610* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
611- version 8.2
612
613* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
614- patch to use the __FDS_BITS macro
615- build for glibc 2.1
616
617* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
618- change named.restart to /usr/sbin/ndc restart
619
620* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
621- install man pages correctly.
622- change K10named to K45named.
623
624* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
625- don't start if /etc/named.conf doesn't exist.
626
627* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
628- autmagically create /etc/named.conf from /etc/named.boot in %post
629- remove echo in %post
630
631* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
632- merge in 5.1 mods
633
634* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
635- Several essential modifications to build and install correctly.
636- Modified 'ndc' to avoid deprecated use of '-'
637
638* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
639- Used buildroot
640- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
641  on Redhat 5.0 instead of <nlist.h>
642
Note: See TracBrowser for help on using the repository browser.