source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 3986

Revision 3986, 20.4 KB checked in by iwamoto, 13 years ago (diff)

bind-current: new release with secutity fix

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.8.0p2
6%define sversion 9.8.0-P2
7%define bind_epoch 1
8%define old_bind_version 1:9.6.ESV.R4.P1
9
10%define bind_uid  25
11%define bind_gid  25
12
13Summary: A DNS (Domain Name System) server.
14Summary(ja): DNS (Domain Name System) サーバ
15Name: %{pname}
16Version: %{pversion}
17Release: 1%{?_dist_release}
18Epoch: %{bind_epoch}
19License: distributable
20Group: System Environment/Daemons
21Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
22Source1: bind-manpages.tar.bz2
23Source2: named.sysconfig
24Source3: named.init
25Source4: named.logrotate
26Source5: keygen.c
27URL: http://www.isc.org/bind.html
28Patch1: bind-9.3.3rc2-rndckey.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel glibc-devel libtool
32BuildRequires: libxml2-devel
33BuildRequires: libcap-devel
34Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
35Requires(pre): shadow-utils
36Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
37Requires(post): coreutils, chkconfig
38Requires(preun): initscripts, chkconfig
39Requires(triggerpostun): chkconfig
40Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
41Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: daisuke
46
47%description
48BIND (Berkeley Internet Name Domain) is an implementation of the DNS
49(Domain Name System) protocols. BIND includes a DNS server (named),
50which resolves host names to IP addresses, and a resolver library
51(routines for applications to use when interfacing with DNS).  A DNS
52server allows clients to name resources or objects and share the
53information with other network machines.  The named DNS server can be
54used on workstations as a caching name server, but is generally only
55needed on one machine for an entire network.  Note that the
56configuration files for making BIND act as a simple caching nameserver
57are included in the caching-nameserver package. 
58
59Install the bind package if you need a DNS server for your network.  If
60you want bind to act a caching name server, you will also need to install
61the caching-nameserver package.
62
63
64%package libs
65Summary: Libraries used by various DNS packages
66Group: System Environment/Libraries
67Conflicts: bind9-libs <= 9.2.1-0vl5
68Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
69Obsoletes: bind9-libs <= 9.2.1-0vl5
70Obsoletes: bind-libs < %{old_bind_version}
71
72%description libs
73Contains libraries used by both the bind server package as well as the utils packages.
74
75
76%package utils
77Summary: Utilities for querying DNS name servers.
78Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
79Group: Applications/System
80Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
81Conflicts: bind9-utils <= 9.2.1-0vl5
82Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
83Obsoletes: bind9-utils <= 9.2.1-0vl5
84Obsoletes: bind-utils < %{old_bind_version}
85
86%description utils
87Bind-utils contains a collection of utilities for querying DNS (Domain
88Name Service) name servers to find out information about Internet hosts.
89These tools will provide you with the IP addresses for given host names,
90as well as other information about registered domains and network
91addresses.
92
93You should install bind-utils if you need to get information from DNS name
94servers.
95
96
97%package devel
98Summary: Include files and libraries needed for bind DNS development.
99Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
100Group: Development/Libraries
101Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
102Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
103Conflicts: bind9-devel <= 9.2.1-0vl5
104Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
105Obsoletes: bind9-devel <= 9.2.1-0vl5
106Obsoletes: bind-devel < %{old_bind_version}
107
108%description devel
109The bind-devel package contains all the include files and the
110library required for DNS (Domain Name Service) development for
111BIND versions 9.x.x.
112
113You should install bind-devel if you want to develop bind DNS
114applications. If you install bind-devel, you'll also need to install
115bind.
116#'
117
118%prep
119%setup -n bind-%{sversion} -q
120%patch1 -p1 -b .key
121
122%build
123libtoolize --copy --force
124aclocal
125autoconf
126%configure --with-libtool --with-openssl=/usr --enable-threads
127make %{?_smp_mflags}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
132mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
133mkdir -p ${RPM_BUILD_ROOT}/var/named
134mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
135mkdir -p ${RPM_BUILD_ROOT}/var/run/named
136
137make DESTDIR=$RPM_BUILD_ROOT install
138install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
139install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
140install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
141install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
142touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
143gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
144cd $RPM_BUILD_ROOT%{_mandir}
145tar xjf %{SOURCE1}
146# newer version is contained in source
147rm -f man5/named.conf.5.gz
148mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
149cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
150
151
152%pre
153if [ "$1" -eq 1 ]; then
154  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
155  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
156fi;
157:;
158
159%post
160/sbin/ldconfig
161/sbin/chkconfig --add named
162if [ "$1" -eq 1 ]; then
163  if [ ! -e /etc/rndc.key ]; then
164    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
165  fi
166  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
167  # rndc.key has to have correct perms and ownership, CVE-2007-6283
168  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
169  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
170
171  # Check DNSSEC settings if this is a fresh install
172  if [ -r /etc/sysconfig/dnssec ]; then
173    . /etc/sysconfig/dnssec
174    [ -x /usr/sbin/dnssec-configure ] && \
175      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
176        /dev/null 2>&1
177  fi;
178fi
179:;
180
181%preun
182if [ "$1" -eq 0 ]; then
183   /sbin/service named stop >/dev/null 2>&1 || :
184   /sbin/chkconfig --del named ||:
185fi
186exit 0
187
188
189%postun
190if [ "$1" -ge 1 ]; then
191        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
192fi
193/sbin/ldconfig
194
195%triggerpostun -- bind < 8.2.2_P5-15
196/sbin/chkconfig --add named
197/sbin/ldconfig
198
199%clean
200rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
201
202
203%post libs -p /sbin/ldconfig
204
205%postun libs -p /sbin/ldconfig
206
207
208%files
209%defattr(-,root,root)
210%doc CHANGES README
211%doc doc/arm doc/draft doc/rfc doc/misc
212%config(noreplace) %{_sysconfdir}/logrotate.d/named
213%config %{_sysconfdir}/rc.d/init.d/named
214%config(noreplace) %{_sysconfdir}/sysconfig/named
215%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
216%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
217%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
218
219%{_sbindir}/dnssec*
220%{_sbindir}/lwresd
221%{_sbindir}/named
222%{_sbindir}/named-bootconf
223%{_sbindir}/named-check*
224%{_sbindir}/named-compilezone
225%{_sbindir}/rndc*
226%{_sbindir}/dns-keygen
227%{_sbindir}/arpaname
228%{_sbindir}/ddns-confgen
229%{_sbindir}/genrandom
230%{_sbindir}/isc-hmac-fixup
231%{_sbindir}/named-journalprint
232%{_sbindir}/nsec3hash
233
234%{_mandir}/man1/arpaname.1*
235%{_mandir}/man5/resolv.conf.5*
236%{_mandir}/man5/named.conf.5*
237%{_mandir}/man5/rndc.conf.5*
238%{_mandir}/man8/rndc.8*
239%{_mandir}/man8/named.8*
240%{_mandir}/man8/lwresd.8*
241%{_mandir}/man8/dnssec*.8*
242%{_mandir}/man8/named-checkconf.8*
243%{_mandir}/man8/named-checkzone.8*
244%{_mandir}/man8/named-compilezone.8*
245%{_mandir}/man8/rndc-confgen.8*
246%{_mandir}/man8/ddns-confgen.8*
247%{_mandir}/man8/genrandom.8*
248%{_mandir}/man8/isc-hmac-fixup.8*
249%{_mandir}/man8/named-journalprint.8*
250%{_mandir}/man8/nsec3hash.8*
251
252%attr(-,named,named) %dir %{_var}/named
253%attr(-,named,named) %dir %{_var}/run/named
254     
255
256%files libs
257%defattr(-,root,root)
258%{_libdir}/*.so.*
259
260%files utils
261%defattr(-,root,root)
262%{_bindir}/dig
263%{_bindir}/host
264%{_bindir}/nslookup
265%{_bindir}/nsupdate
266%{_mandir}/man1/host.1*
267%{_mandir}/man1/nsupdate.1*
268%{_mandir}/man1/dig.1*
269%{_mandir}/man5/resolver.5*
270%{_mandir}/man1/nslookup.1*
271%{_mandir}/man8/nslookup.8*
272
273
274%files devel
275%defattr(-,root,root)
276%{_libdir}/*.so
277%{_libdir}/*.la
278%{_libdir}/*.a
279%{_includedir}/*
280%{_mandir}/man3/*
281%{_mandir}/man1/isc-config.sh.1*
282%{_bindir}/isc-config.sh
283
284%changelog
285* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
286- new upstream release with security fix (CVE-2011-1910)
287
288* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
289- add BuildRequires: libxml2-devel, libcap-devel
290
291* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
292- new upstream release with security fix (CVE-2011-1907)
293- fix changelog typo
294
295* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
296- Obosoletes: bind.* < 1:9.6.ESV.R1
297
298* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
299- update to 9.8.0
300- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
301
302* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
303- rebuild with openssl-1.0.0c
304
305* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
306- fix Req: in bind package
307
308* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
309- change package name bind -> bind-current
310- add epoch 1
311- new upstream release
312
313* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
314- new upstream release
315
316* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
317- rebuilt with gcc-4.4.3-3 on ppc
318
319* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
320- rebuilt with new toolchains (for VineSeed)
321- s/BuildPrereq/BuildRequires/
322
323* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
324- add man1/isc-config.sh.1 into devel file list
325
326* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
327- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
328
329* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
330- new upstream release with security fix (CVE-2009-4022)
331
332* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
333- new upstream release with security fix
334
335* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
336- new upstream release
337- clean up %%post/%%pre scriptlet
338  - create named user and group in %%pre
339  - don't remove named user/group in %%preun
340  - use rndc-confgen to create rndc.key
341
342* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
343- new upstream release
344- drop patch0 and patch14, merged in upstream
345
346* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
347- new upstream release with security fix
348
349* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
350- new upstream release with security fix
351- new versioning policy
352
353* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
354- new upstream release with security fix
355
356* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
357- new upstream release
358- build with new openssl/toolchain
359
360* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
361- new upstream release with security fix
362
363* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
364- new upstream release
365
366* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
367- add Prereq sed
368
369* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
370- new upstream release for security fix (CVE-2006-4095,4096)
371
372* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
373- separate -libs package
374- remove old named.conf.5.gz
375  - newer version is contained in source
376
377* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
378- add bsdcompat patch (Patch4)
379- add fix_h_errno patch from FC
380  - h_errno not being accessed / set correctly in libbind
381
382* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
383- new upstream release
384
385* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
386- added PreReq to bind-utils (see: [VineSeed:09555])
387
388* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
389- new upstream release
390
391* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
392- fix /etc/init.d/named to use rndc
393
394* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
395- rebuild to remove unneeded dependancy
396
397* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
398- new upstream release
399
400* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
401- new upstream release
402
403* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
404- fix dependancies.
405
406* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
407- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
408- change package name to bind for VineSeed.
409- use more macros.
410
411* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
412- fixed some macros
413- add conflicts: to bind-* in bind9-devel and bind9-utils
414- add provides: bind = %%{version}
415
416* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
417- use %%configure macros
418
419* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
420- fixed inconsistent dependency
421
422* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
423- updated to 9.2.2rc1
424
425* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
426- updated to bind9(9.2.1), test packages ;)
427        -- based on Rawhide's bind-9.2.0-8
428        -- changed name bind9
429        -- added Conflicts: bind
430
431* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
432- release 8.3.1 includes security fixes
433
434* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
435- Upgraded to current stable release 8.3.0
436
437* Mon Oct  8 2001 <zn@mbf.nifty.com>
438- 8.2.5-0vl0: Upgraded to new upstream version.
439
440* Thu May 24 2001 <sagami@vinelinux.org>
441- 8.2.4-0vl1: eliminate CVS related files from %%doc
442
443* Thu May 17 2001 <sagami@vinelinux.org>
444- 8.2.4-0vl0
445
446* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
447- 8.2.3-1vl2
448- built on VineSeed
449
450* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
451- add doc/old
452- build for Vine 2.1
453
454* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
455- 8.2.3, fixes several security problems
456
457* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
458- static libraries may be used in shared objects. Build with -fPIC on ia64
459
460* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
461- 8.2.2-P7 (fixes Bug #20546)
462
463* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
464- condrestart fixes
465
466* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
467- change the init script to take condrestart, not cond-restart
468- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
469  the %pre and %post scripts
470
471* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
472- Don't prereq /etc/init.d
473
474* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
475- move initscript back
476
477* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
478- automatic rebuild
479
480* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
481- add "exit 0" for uninstall case
482
483* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
484- add prereq init.d and cleanup install section
485
486* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
487- fix the init script
488
489* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
490- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
491
492* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
493- Fix up the initscript (Bug #13033)
494- Fix build with current glibc (Bug #12755)
495- /etc/rc.d/init.d -> /etc/init.d
496- use %%{_mandir} rather than /usr/share/man
497
498* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
499- fix conflict with man-pages
500- remove compatibilty chkconfig links
501- initscript munging
502
503* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
504- modify logrotate setup to use PID file
505- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
506- actually bump the release this time
507
508* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
509- FHS compliance
510
511* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
512- clean up restart patch
513
514* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
515- provide /var/named (fix for bugs #9847, #10205)
516- preserve args when restarted via ndc(8) (bug #10227)
517- make resolv.conf(5) a link to resolver(5) (bug #10245)
518- fix SYSTYPE bug in all makefiles
519- move creation of named user from %%post into %%pre
520
521* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
522- Fix TTL (patch from ISC, Bug #9820)
523
524* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
525- fix typo in spec (it's %post, without a leading blank) introduced in -6
526- change SYSTYPE to linux
527
528* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
529- pick a standard < 100 uid/gid for named
530
531* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
532- Pass named a '-u named' parameter by default, and add/remove user.
533
534* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
535- fix host mx bug (Bug #9021)
536
537* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
538- rebuild to fix dependencies
539- man pages are compressed
540
541* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
543
544* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- Fix up location of named-bootconf.pl and make it executable
546  (Bug #8028)
547- bind-devel requires bind
548
549* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
550- update to 8.2.2-P5
551
552* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
553- update to 8.2.2-P3
554
555* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
556- add patch to stop a cache only server from complaining about lame servers
557  on every request.
558
559* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
560- use real stop and start in named.init for restart, not ndc restart, it has
561  problems when named has changed during a package update... (# 4890)
562
563* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
564- chkconfig --del in %preun, not %postun
565
566* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
567- initscript munging
568
569* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
570- fix installed chkconfig links to match init file
571
572* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
573- conflict with new (in man-1.24) man pages (#3876,#3877).
574
575* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
576- fix named.logrotate (wrong %SOURCE)
577
578* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
579- update to 8.2.1.
580- add named.logrotate (#3571).
581- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
582- vet file list.
583
584* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
585- don't run by default
586
587* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
588- nslookup fixes (#2463).
589- missing files (#3152).
590
591* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
592- nslookup patched:
593  to count numRecords properly
594  to fix subsequent calls to ls -d
595  to parse "view" and "finger" commands properly
596  the view hack updated for bind-8 (using sed)
597
598* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
599- add ISC patch
600- add quick hack to make host not crash
601- add more docs
602
603* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
604- add probing information in the init file to keep linuxconf happy
605- dont strip libbind
606
607* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
608- auto rebuild in the new build environment (release 3)
609
610* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
611- removed 'done' output at named shutdown.
612
613* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
614- version 8.2
615
616* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
617- patch to use the __FDS_BITS macro
618- build for glibc 2.1
619
620* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
621- change named.restart to /usr/sbin/ndc restart
622
623* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
624- install man pages correctly.
625- change K10named to K45named.
626
627* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
628- don't start if /etc/named.conf doesn't exist.
629
630* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
631- autmagically create /etc/named.conf from /etc/named.boot in %post
632- remove echo in %post
633
634* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
635- merge in 5.1 mods
636
637* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
638- Several essential modifications to build and install correctly.
639- Modified 'ndc' to avoid deprecated use of '-'
640
641* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
642- Used buildroot
643- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
644  on Redhat 5.0 instead of <nlist.h>
645
Note: See TracBrowser for help on using the repository browser.