source: projects/specs/trunk/b/beecrypt/beecrypt-vl.spec @ 521

Revision 521, 9.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define with_python     --with-python
3%define with_python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
4#define with_java               --with-java
5
6Summary: An open source cryptography library.
7Name: beecrypt
8Version: 4.1.2
9Release: 13%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL
12URL: http://sourceforge.net/projects/beecrypt
13Source0: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
14Source1: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz.sig
15Patch0: beecrypt-4.1.2-base64.patch
16Patch1: beecrypt-4.1.2-python-api.patch
17#BuildRequires: doxygen
18%if %{?with_python:1}0
19BuildRequires: python-devel >= %{with_python_version}
20%endif
21BuildRoot: %{_tmppath}/%{name}-root
22Obsoletes: beecrypt-java =< 4.1.2-2
23
24%description
25Beecrypt is a general-purpose cryptography library.
26
27%package devel
28Summary: Files needed for developing applications with beecrypt.
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33Beecrypt is a general-purpose cryptography library.  This package contains
34files needed for developing applications with beecrypt.
35
36## to build compat32 for x86_64 architecture support
37%package -n compat32-%{name}
38Summary: An open source cryptography library.
39Group: System Environment/Libraries
40#BuildPreReq: doxygen
41
42%description -n compat32-%{name}
43Beecrypt is a general-purpose cryptography library.
44
45%package -n compat32-%{name}-devel
46Summary: Files needed for developing applications with beecrypt.
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description -n compat32-%{name}-devel
51Beecrypt is a general-purpose cryptography library.  This package contains
52files needed for developing applications with beecrypt.
53
54
55%if %{?with_python:1}0
56%package python
57Summary: Files needed for python applications using beecrypt.
58Group: Development/Libraries
59Requires: python >= %{with_python_version}
60Requires: %{name} = %{version}-%{release}
61
62%description python
63Beecrypt is a general-purpose cryptography library.  This package contains
64files needed for using python with beecrypt.
65%endif
66
67%if %{?with_java:1}0
68%package java
69Summary: Files needed for java applications using beecrypt.
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description java
74Beecrypt is a general-purpose cryptography library.  This package contains
75files needed for using java with beecrypt.
76%endif
77
78%prep
79%setup -q
80%patch0 -p1 -b .base64
81%patch1 -p1 -b .python-api
82
83%build
84%configure --enable-shared --enable-static \
85    %{?with_python}%{!?with_python:--with-python=no} \
86    %{?with_java}%{!?with_java:--with-java=no} \
87        --with-cplusplus=no
88
89make %{?_smp_mflags} \
90        %{?with_python:pythondir="%{_libdir}/python%{with_python_version}/site-packages"}
91#doxygen
92
93%install
94rm -fr $RPM_BUILD_ROOT
95make install DESTDIR=$RPM_BUILD_ROOT \
96  %{?with_python:pythondir="%{_libdir}/python%{with_python_version}/site-packages"}
97
98# XXX nuke unpackaged files, artifacts from using libtool to produce module
99rm -f ${RPM_BUILD_ROOT}%{_libdir}/python%{with_python_version}/site-packages/_bc.*a
100
101# XXX delete next line to build with legacy, non-check aware, rpmbuild.
102make check || :
103cat /proc/cpuinfo
104make bench || :
105
106## remove unuse files
107rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
108
109
110%clean
111rm -fr $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%post -n compat32-%{name} -p /sbin/ldconfig
118%postun -n compat32-%{name} -p /sbin/ldconfig
119
120%files
121%defattr(-,root,root)
122%doc README BENCHMARKS
123%{_libdir}/libbeecrypt.so.*
124
125%files devel
126%defattr(-,root,root)
127%doc BUGS
128%{_includedir}/%{name}
129%{_libdir}/libbeecrypt.a
130#%{_libdir}/libbeecrypt.la
131%{_libdir}/libbeecrypt.so
132
133%if %{?with_python:1}0
134%files python
135%defattr(-,root,root)
136%{_libdir}/python%{with_python_version}/site-packages/_bc.so
137%endif
138
139%if %{?with_java:1}0
140%files java
141%defattr(-,root,root)
142%{_libdir}/libbeecrypt_java.a
143#%{_libdir}/libbeecrypt_java.la
144%{_libdir}/libbeecrypt_java.so*
145%endif
146
147## to build compat32 for x86_64 architecture support
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/libbeecrypt.so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root)
155%{_libdir}/libbeecrypt.a
156#%{_libdir}/libbeecrypt.la
157%{_libdir}/libbeecrypt.so
158%endif
159
160%changelog
161* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-13
162- rebuilt with gcc-4.4.3-3 on ppc
163
164* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-12
165- rebuilt with rpm-4.8.0-3 (on ppc)
166
167* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 4.1.2-11
168- rebuild with python-2.6
169
170* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.2-10vl5
171- applied new versioning policy
172- removed *.la
173
174* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.2-9vl5
175- removed %%if !%%{build_compat32} case condition
176
177* Wed May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.2-9vl4
178- rebuilt with new toolchain
179
180* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl3
181- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
182
183* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl2
184- added compat32-* packages for x86_64 architecture support
185- dropt doxygen
186
187* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1,2-9vl1
188- initial build for Vine Linux based on FC-devel
189
190* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
191- Use -with-cplusplus=no. The libs still require libstdc++, so
192  this needs further cleanup.
193
194* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-8
195- Remove dependencies on private symbols not present in Python 2.4 from
196  beecrypt-python
197
198* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-7
199- Doh, actually apply the patch
200
201* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-6
202- Fix b64encode() for data starting with NUL (#123650)
203
204* Fri Apr 01 2005 Warren Togami <wtogami@redhat.com> 4.1.2-5
205- remove huge API docs
206
207* Fri Apr 01 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-4
208- Obsolete older beecrypt-java
209
210* Tue Mar 29 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-3
211- Disable beecrypt-java (#151294)
212
213* Fri Mar  4 2005 Jeff Johnson <jbj@redhat.com> 4.1.2-2
214- rebuild with gcc4.
215
216* Sat Feb  5 2005 Jeff Johnson <jbj@jbj.org> 4.1.2-1
217- upgrade to 4.1.2
218- put java components in sub-package.
219- check that /usr/lib64 is not used on alpha (#146583).
220
221* Fri Feb  4 2005 Miloslav Trmac <mitr@redhat.com> - 3.1.0-7
222- Rebuild against Python 2.4
223
224* Sun Aug 08 2004 Alan Cox <alan@redhat.com> 3.1.0-6
225- Build requires libtool (Steve Grubb)
226
227* Fri Jul 02 2004 Elliot Lee <sopwith@redhat.com> 3.1.0-5
228- rebuilt
229- Add _smp_mflags
230
231* Wed Mar 24 2004 Jeff Johnson <jbj@redhat.com> 3.1.0-3
232- fix: extgcd_w problem fixed by upgrading from CVS.
233
234* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
235- rebuilt
236
237* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
238- rebuilt
239
240* Mon Dec 22 2003 Jeff Johnson <jbj@jbj.org> 3.1.0-1
241- upgrade to 3.1.0.
242- recompile against python-2.3.3.
243
244* Mon Jun 30 2003 Jeff Johnson <jbj@redhat.com> 3.0.1-0.20030630
245- upstream fixes for DSA and ppc64.
246
247* Mon Jun 23 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-2
248- upgrade to 3.0.0 final.
249- fix for DSA (actually, modulo inverse) sometimes failing.
250
251* Fri Jun 20 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030619
252- avoid asm borkage on ppc64.
253
254* Thu Jun 19 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030618
255- rebuild for release bump.
256
257* Tue Jun 17 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030616
258- try to out smart libtool a different way.
259- use $bc_target_cpu, not $bc_target_arch, to detect /usr/lib64.
260
261* Mon Jun 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030615
262- use -mcpu=powerpc64 on ppc64.
263
264* Fri Jun 13 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030613
265- upgrade to latest snapshot.
266
267* Fri Jun  6 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030605
268- rebuild into another tree.
269
270* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
271- rebuilt
272
273* Tue Jun  3 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030603
274- update to 3.0.0 snapshot, fix mpmod (and DSA) on 64b platforms.
275
276* Mon Jun  2 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030602
277- update to 3.0.0 snapshot, merge patches, fix gcd rshift and ppc problems.
278
279* Thu May 29 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030529
280- update to 3.0.0 snapshot, fix ia64/x86_64 build problems.
281
282* Wed May 28 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030528
283- upgrade to 3.0.0 snapshot, adding rpm specific base64.[ch] changes.
284- add PYTHONPATH=.. so that "make check" can test the just built _bc.so module.
285- grab cpuinfo and run "make bench".
286- continue ignoring "make check" failures, LD_LIBRARY_PATH needed for _bc.so.
287- skip asm build failure on ia64 for now.
288- ignore "make bench" exit codes too, x86_64 has AES segfault.
289
290* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030521
291- upgrade to 3.0.0 snapshot, including python subpackage.
292- ignore "make check" failure for now.
293
294* Fri May 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030516
295- upgrade to 3.0.0 snapshot, including ia64 and x86_64 fixes.
296- add %%check.
297- ignore "make check" failure on ia64 for now.
298
299* Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030512
300- upgrade to 3.0.0 snapshot.
301- add doxygen doco.
302- use /dev/urandom as default entropy source.
303- avoid known broken compilation for now.
304
305* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
306- rebuilt
307
308* Tue Nov 19 2002 Tim Powers <timp@redhat.com>
309- rebuild on all arches
310
311* Fri Aug  2 2002 Jeff Johnson <jbj@redhat.com> 2.2.0-6
312- install types.h (#68999).
313
314* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
315- automated rebuild
316
317* Wed Jun  5 2002 Jeff Johnson <jbj@redhat.com>
318- run ldconfig when installing/erasing (#65974).
319
320* Thu May 23 2002 Tim Powers <timp@redhat.com>
321- automated rebuild
322
323* Mon May 13 2002 Jeff Johnson <jbj@redhat.com>
324- upgrade to latest 2.2.0 (from cvs.rpm.org).
325
326* Mon Jan 21 2002 Jeff Johnson <jbj@redhat.com>
327- use the same beecrypt-2.2.0 that rpm is using internally.
328
329* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 2.1.0-1
330- initial package
Note: See TracBrowser for help on using the repository browser.