source: projects/specs/trunk/b/beecrypt/beecrypt-vl.spec @ 10365

Revision 10365, 10.0 KB checked in by tomop, 8 years ago (diff)

beecrypt-4.2.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define with_python     --with-python
3%define with_python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
4#define with_java               --with-java
5
6Summary: An open source cryptography library.
7Name: beecrypt
8Version: 4.2.1
9Release: 1%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL
12URL: http://sourceforge.net/projects/beecrypt
13Source0: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
14Source1: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz.sig
15Patch0: beecrypt-4.1.2-biarch.patch
16Patch1: beecrypt-4.2.1-no-c++.patch
17#BuildRequires: doxygen
18%if %{?with_python:1}0
19BuildRequires: python-devel >= %{with_python_version}
20%endif
21BuildRoot: %{_tmppath}/%{name}-root
22Obsoletes: beecrypt-java =< 4.1.2-2
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28Beecrypt is a general-purpose cryptography library.
29
30%package devel
31Summary: Files needed for developing applications with beecrypt.
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36Beecrypt is a general-purpose cryptography library.  This package contains
37files needed for developing applications with beecrypt.
38
39## to build compat32 for x86_64 architecture support
40%package -n compat32-%{name}
41Summary: An open source cryptography library.
42Group: System Environment/Libraries
43#BuildPreReq: doxygen
44
45%description -n compat32-%{name}
46Beecrypt is a general-purpose cryptography library.
47
48%package -n compat32-%{name}-devel
49Summary: Files needed for developing applications with beecrypt.
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}-devel
54Beecrypt is a general-purpose cryptography library.  This package contains
55files needed for developing applications with beecrypt.
56
57
58%if %{?with_python:1}0
59%package python
60Summary: Files needed for python applications using beecrypt.
61Group: Development/Libraries
62Requires: python >= %{with_python_version}
63Requires: %{name} = %{version}-%{release}
64
65%description python
66Beecrypt is a general-purpose cryptography library.  This package contains
67files needed for using python with beecrypt.
68%endif
69
70%if %{?with_java:1}0
71%package java
72Summary: Files needed for java applications using beecrypt.
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75
76%description java
77Beecrypt is a general-purpose cryptography library.  This package contains
78files needed for using java with beecrypt.
79%endif
80
81%prep
82%setup -q
83%patch0 -p1 -b .biarch
84%patch1 -p1 -b .no-c++
85
86libtoolize
87autoreconf -i
88
89%build
90export PYTHON=`which python`
91
92%configure \
93 %{?with_python}%{!?with_python:--with-python=no} \
94 %{?with_java}%{!?with_java:--with-java=no} \
95 --with-cplusplus=no
96
97make %{?_smp_mflags} \
98        %{?with_python:pythondir="%{python_sitelib}"}
99#doxygen
100
101%check
102make check || :
103
104%install
105rm -fr $RPM_BUILD_ROOT
106make install DESTDIR=$RPM_BUILD_ROOT \
107  %{?with_python:pythondir="%{python_sitelib}"}
108
109iconv -f ISO-8859-1 -t UTF-8 CONTRIBUTORS -o CONTRIBUTORS.utf8
110mv -f CONTRIBUTORS.utf8 CONTRIBUTORS
111
112rm -f $RPM_BUILD_ROOT{%{_libdir},%{python_sitelib}}/*.{a,la}
113
114#cat /proc/cpuinfo
115#make bench || :
116
117## remove unuse files
118rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
119
120
121%clean
122rm -fr $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%post -n compat32-%{name} -p /sbin/ldconfig
129%postun -n compat32-%{name} -p /sbin/ldconfig
130
131%files
132%defattr(-,root,root)
133%doc AUTHORS BENCHMARKS CONTRIBUTORS
134%doc COPYING COPYING.LIB NEWS README
135%{_libdir}/libbeecrypt.so.*
136
137%files devel
138%defattr(-,root,root)
139%doc BUGS
140%{_includedir}/%{name}
141%{_libdir}/libbeecrypt.so
142
143%if %{?with_python:1}0
144%files python
145%defattr(-,root,root)
146%{python_sitelib}/_bc.so
147%endif
148
149%if %{?with_java:1}0
150%files java
151%defattr(-,root,root)
152%{_libdir}/libbeecrypt_java.a
153%{_libdir}/libbeecrypt_java.so*
154%endif
155
156## to build compat32 for x86_64 architecture support
157%if %{build_compat32}
158%files -n compat32-%{name}
159%defattr(-,root,root)
160%{_libdir}/libbeecrypt.so.*
161
162%files -n compat32-%{name}-devel
163%defattr(-,root,root)
164%{_libdir}/libbeecrypt.so
165%endif
166
167%changelog
168* Wed Jun  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
169- new upstream release.
170- removed all patches.
171- imported Patch0 and Patch1 from rawhide.
172
173* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.1.2-15
174- rebuild with python-2.7.2
175
176* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 4.1.2-14
177- rebuilt with rpm-4.8.1-3
178
179* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-13
180- rebuilt with gcc-4.4.3-3 on ppc
181
182* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-12
183- rebuilt with rpm-4.8.0-3 (on ppc)
184
185* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 4.1.2-11
186- rebuild with python-2.6
187
188* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.2-10vl5
189- applied new versioning policy
190- removed *.la
191
192* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.2-9vl5
193- removed %%if !%%{build_compat32} case condition
194
195* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.2-9vl4
196- rebuilt with new toolchain
197
198* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl3
199- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
200
201* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl2
202- added compat32-* packages for x86_64 architecture support
203- dropt doxygen
204
205* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1,2-9vl1
206- initial build for Vine Linux based on FC-devel
207
208* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
209- Use -with-cplusplus=no. The libs still require libstdc++, so
210  this needs further cleanup.
211
212* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-8
213- Remove dependencies on private symbols not present in Python 2.4 from
214  beecrypt-python
215
216* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-7
217- Doh, actually apply the patch
218
219* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-6
220- Fix b64encode() for data starting with NUL (#123650)
221
222* Fri Apr 01 2005 Warren Togami <wtogami@redhat.com> 4.1.2-5
223- remove huge API docs
224
225* Fri Apr 01 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-4
226- Obsolete older beecrypt-java
227
228* Tue Mar 29 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-3
229- Disable beecrypt-java (#151294)
230
231* Fri Mar  4 2005 Jeff Johnson <jbj@redhat.com> 4.1.2-2
232- rebuild with gcc4.
233
234* Sat Feb  5 2005 Jeff Johnson <jbj@jbj.org> 4.1.2-1
235- upgrade to 4.1.2
236- put java components in sub-package.
237- check that /usr/lib64 is not used on alpha (#146583).
238
239* Fri Feb  4 2005 Miloslav Trmac <mitr@redhat.com> - 3.1.0-7
240- Rebuild against Python 2.4
241
242* Sun Aug 08 2004 Alan Cox <alan@redhat.com> 3.1.0-6
243- Build requires libtool (Steve Grubb)
244
245* Fri Jul 02 2004 Elliot Lee <sopwith@redhat.com> 3.1.0-5
246- rebuilt
247- Add _smp_mflags
248
249* Wed Mar 24 2004 Jeff Johnson <jbj@redhat.com> 3.1.0-3
250- fix: extgcd_w problem fixed by upgrading from CVS.
251
252* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
253- rebuilt
254
255* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
256- rebuilt
257
258* Mon Dec 22 2003 Jeff Johnson <jbj@jbj.org> 3.1.0-1
259- upgrade to 3.1.0.
260- recompile against python-2.3.3.
261
262* Mon Jun 30 2003 Jeff Johnson <jbj@redhat.com> 3.0.1-0.20030630
263- upstream fixes for DSA and ppc64.
264
265* Mon Jun 23 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-2
266- upgrade to 3.0.0 final.
267- fix for DSA (actually, modulo inverse) sometimes failing.
268
269* Fri Jun 20 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030619
270- avoid asm borkage on ppc64.
271
272* Thu Jun 19 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030618
273- rebuild for release bump.
274
275* Tue Jun 17 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030616
276- try to out smart libtool a different way.
277- use $bc_target_cpu, not $bc_target_arch, to detect /usr/lib64.
278
279* Mon Jun 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030615
280- use -mcpu=powerpc64 on ppc64.
281
282* Fri Jun 13 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030613
283- upgrade to latest snapshot.
284
285* Fri Jun  6 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030605
286- rebuild into another tree.
287
288* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
289- rebuilt
290
291* Tue Jun  3 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030603
292- update to 3.0.0 snapshot, fix mpmod (and DSA) on 64b platforms.
293
294* Mon Jun  2 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030602
295- update to 3.0.0 snapshot, merge patches, fix gcd rshift and ppc problems.
296
297* Thu May 29 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030529
298- update to 3.0.0 snapshot, fix ia64/x86_64 build problems.
299
300* Wed May 28 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030528
301- upgrade to 3.0.0 snapshot, adding rpm specific base64.[ch] changes.
302- add PYTHONPATH=.. so that "make check" can test the just built _bc.so module.
303- grab cpuinfo and run "make bench".
304- continue ignoring "make check" failures, LD_LIBRARY_PATH needed for _bc.so.
305- skip asm build failure on ia64 for now.
306- ignore "make bench" exit codes too, x86_64 has AES segfault.
307
308* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030521
309- upgrade to 3.0.0 snapshot, including python subpackage.
310- ignore "make check" failure for now.
311
312* Fri May 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030516
313- upgrade to 3.0.0 snapshot, including ia64 and x86_64 fixes.
314- add %%check.
315- ignore "make check" failure on ia64 for now.
316
317* Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030512
318- upgrade to 3.0.0 snapshot.
319- add doxygen doco.
320- use /dev/urandom as default entropy source.
321- avoid known broken compilation for now.
322
323* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
324- rebuilt
325
326* Tue Nov 19 2002 Tim Powers <timp@redhat.com>
327- rebuild on all arches
328
329* Fri Aug  2 2002 Jeff Johnson <jbj@redhat.com> 2.2.0-6
330- install types.h (#68999).
331
332* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
333- automated rebuild
334
335* Wed Jun  5 2002 Jeff Johnson <jbj@redhat.com>
336- run ldconfig when installing/erasing (#65974).
337
338* Thu May 23 2002 Tim Powers <timp@redhat.com>
339- automated rebuild
340
341* Mon May 13 2002 Jeff Johnson <jbj@redhat.com>
342- upgrade to latest 2.2.0 (from cvs.rpm.org).
343
344* Mon Jan 21 2002 Jeff Johnson <jbj@redhat.com>
345- use the same beecrypt-2.2.0 that rpm is using internally.
346
347* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 2.1.0-1
348- initial package
Note: See TracBrowser for help on using the repository browser.