source: projects/specs/trunk/b/bash/bash-vl.spec @ 6893

Revision 6893, 17.6 KB checked in by iwamoto, 12 years ago (diff)

bash: remove postun script

Line 
1%define bashversion 4.2
2%define patchlevel 37
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      2%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-001
23Patch2: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-002
24Patch3: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-003
25Patch4: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-004
26Patch5: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-005
27Patch6: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-006
28Patch7: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-007
29Patch8: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-008
30Patch9: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-009
31Patch10: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-010
32Patch11: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-011
33Patch12: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-012
34Patch13: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-013
35Patch14: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-014
36Patch15: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-015
37Patch16: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-016
38Patch17: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-017
39Patch18: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-018
40Patch19: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-019
41Patch20: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-020
42Patch21: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-021
43Patch22: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-022
44Patch23: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-023
45Patch24: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-024
46Patch25: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-025
47Patch26: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-026
48Patch27: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-027
49Patch28: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-028
50Patch29: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-029
51Patch30: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-030
52Patch31: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-031
53Patch32: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-032
54Patch33: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-033
55Patch34: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-034
56Patch35: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-035
57Patch36: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-036
58Patch37: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-037
59
60# Other patches
61Patch101: bash-2.02-security.patch
62Patch102: bash-2.03-paths.patch
63Patch103: bash-2.03-profile.patch
64Patch104: bash-2.05a-interpreter.patch
65Patch105: bash-2.05b-debuginfo.patch
66Patch106: bash-2.05b-manso.patch
67Patch107: bash-2.05b-pgrp_sync.patch
68Patch108: bash-2.05b-readline-oom.patch
69Patch109: bash-2.05b-xcc.patch
70Patch110: bash-3.2-audit.patch
71Patch111: bash-3.2-ssh_source_bash.patch
72Patch112: bash-bashbug.patch
73Patch113: bash-infotags.patch
74Patch114: bash-requires.patch
75Patch115: bash-setlocale.patch
76Patch116: bash-tty-tests.patch
77
78# 484809, check if interp section is NOBITS
79Patch117: bash-4.0-nobits.patch
80
81# Do the same CFLAGS in generated Makefile in examples
82Patch118: bash-4.1-examples.patch
83
84# Builtins like echo and printf won't report errors
85# when output does not succeed due to EPIPE
86Patch119: bash-4.1-broken_pipe.patch
87
88# Enable system-wide .bash_logout for login shells
89Patch120: bash-4.2-rc2-logout.patch
90
91# Static analyzis shows some issues in bash-2.05a-interpreter.patch
92Patch121: bash-4.2-coverity.patch
93
94Buildroot:    %{_tmppath}/%{name}-%{version}-root
95BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
96Obsoletes:    bash <= 1.14.7
97Obsoletes:    bash2
98
99
100%description
101Bash is a GNU project sh-compatible shell or command language
102interpreter. Bash (Bourne Again shell) incorporates useful features
103from the Korn shell (ksh) and the C shell (csh). Most sh scripts
104can be run by bash without modification.
105
106Bash offers several improvements over sh, including command line
107editing, unlimited size command history, job control, shell
108functions and aliases, indexed arrays of unlimited size and
109integer arithmetic in any base from two to 64. Bash is ultimately
110intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
111Tools standard.
112
113
114%package doc
115Summary:  Documentation for the GNU Bourne Again shell (bash).
116Summary:  GNU Bourne Again シェル向けドキュメント
117Group:    Applications/Documentation
118Requires: %{name} = %{version}-%{release}
119
120Obsoletes: bash2-doc
121
122%description doc
123This is a separate documentation package for the GNU Bourne
124Again shell.
125
126
127%prep
128%setup -q -n %{name}-%{bashversion}
129
130# Official upstream patches
131%patch1 -p0 -b .001
132%patch2 -p0 -b .002
133%patch3 -p0 -b .003
134%patch4 -p0 -b .004
135%patch5 -p0 -b .005
136%patch6 -p0 -b .006
137%patch7 -p0 -b .007
138%patch8 -p0 -b .008
139%patch9 -p0 -b .009
140%patch10 -p0 -b .010
141%patch11 -p0 -b .011
142%patch12 -p0 -b .012
143%patch13 -p0 -b .013
144%patch14 -p0 -b .014
145%patch15 -p0 -b .015
146%patch16 -p0 -b .016
147%patch17 -p0 -b .017
148%patch18 -p0 -b .018
149%patch19 -p0 -b .019
150%patch20 -p0 -b .020
151%patch21 -p0 -b .021
152%patch22 -p0 -b .022
153%patch23 -p0 -b .023
154%patch24 -p0 -b .024
155%patch25 -p0 -b .025
156%patch26 -p0 -b .026
157%patch27 -p0 -b .027
158%patch28 -p0 -b .028
159%patch29 -p0 -b .029
160%patch30 -p0 -b .030
161%patch31 -p0 -b .031
162%patch32 -p0 -b .032
163%patch33 -p0 -b .033
164%patch34 -p0 -b .034
165%patch35 -p0 -b .035
166%patch36 -p0 -b .036
167%patch37 -p0 -b .037
168
169# Other patches
170%patch101 -p1 -b .security
171%patch102 -p1 -b .paths
172%patch103 -p1 -b .profile
173%patch104 -p1 -b .interpreter
174%patch105 -p1 -b .debuginfo
175%patch106 -p1 -b .manso
176%patch107 -p1 -b .pgrp_sync
177%patch108 -p1 -b .readline_oom
178%patch109 -p1 -b .xcc
179%patch110 -p1 -b .audit
180%patch111 -p1 -b .ssh_source_bash
181%patch112 -p1 -b .bashbug
182%patch113 -p1 -b .infotags
183%patch114 -p1 -b .requires
184%patch115 -p1 -b .setlocale
185%patch116 -p1 -b .tty_tests
186%patch117 -p1 -b .nobits
187%patch118 -p1 -b .examples
188%patch119 -p1 -b .broken_pipe
189%patch120 -p1 -b .logout
190%patch121 -p1 -b .coverity
191
192echo %{version} > _distribution
193echo %{release} |sed 's/vl.*//' > _patchlevel
194
195
196%build
197%configure --with-bash-malloc=no
198make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
199
200%install
201rm -rf %{buildroot}
202
203# Fix bug #83776
204perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
205
206make DESTDIR=$RPM_BUILD_ROOT install
207
208pushd $RPM_BUILD_ROOT
209 mkdir ./bin
210 mv ./usr/bin/bash ./bin/bash
211 ln -s bash ./bin/sh
212 rm -f .%{_infodir}/dir
213popd
214
215ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
216
217# make manpages for bash builtins as per suggestion in DOC/README
218pushd doc
219sed -e '
220/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
221/^\.SH NAME/d
222s/^bash, //
223s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
224s/,//g
225b
226}
227d
228' builtins.1 > man.pages
229for i in echo pwd test kill; do
230  perl -pi -e "s,$i,,g" man.pages
231  perl -pi -e "s,  , ,g" man.pages
232done
233
234install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
235
236for i in `cat man.pages` ; do
237  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
238  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
239done
240
241mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
242install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
243
244# Not for printf, false and true (conflict with coreutils)
245rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
246rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
247rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
248
249popd
250
251%find_lang %{name}
252
253%clean
254rm -rf %{buildroot}
255
256# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
257# to prevent prereq loops
258
259# post is in lua so that we can run it without any external deps.  Helps
260# for bootstrapping a new install.
261# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
262%post -p <lua>
263bashfound = false;
264shfound = false;
265 
266f = io.open("/etc/shells", "r");
267if f == nil
268then
269  f = io.open("/etc/shells", "w");
270else
271  repeat
272    t = f:read();
273    if t == "/bin/bash"
274    then
275      bashfound = true;
276    end
277    if t == "/bin/sh"
278    then
279      shfound = true;
280    end
281  until t == nil;
282end
283f:close()
284 
285f = io.open("/etc/shells", "a");
286if not bashfound
287then
288  f:write("/bin/bash\n")
289end
290if not shfound
291then
292  f:write("/bin/sh\n")
293end
294f:close()
295
296%files -f %{name}.lang
297%defattr(-,root,root)
298%doc CHANGES COPYING
299%doc examples
300%config(noreplace) /etc/bashrc
301/bin/bash
302/bin/sh
303%{_infodir}/bash.info*
304%{_mandir}/*/*
305%{_mandir}/*/..1*
306%{_bindir}/bashbug
307
308
309%files doc
310%defattr(-,root,root)
311%doc COMPAT NEWS NOTES POSIX RBASH
312%doc examples/bashdb/ examples/functions/ examples/misc/
313%doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
314%doc examples/startup-files/ examples/complete/ examples/loadables/
315%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
316%doc doc/FAQ doc/INTRO doc/article.ms doc/README
317
318
319%changelog
320* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
321- remove postun lua script because bash will be never uninstalled
322
323* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
324- update to 4.2 patch level 37
325
326* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
327- update to 4.2 patch level 20
328
329* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
330- update to 4.2 patch level 8
331- use lua script in post/postun
332- update patches from fedora
333
334* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
335- update to 4.1 patch level 7
336
337* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
338- check if /bin/grep exists on %%post script
339
340* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
341- rebuilt with gcc-4.4.3-3 on ppc
342
343* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
344- rebuilt with new toolchain
345
346* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
347- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
348
349* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
350- add Requires(post): grep
351
352* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
353- remove obsolete /bin/bash2 entry from /etc/shells
354
355* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
356- add Requires(post): ncurses (should be added by find-requires..)
357
358* Mon Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
359- add upstream patch (from 040 to 048)
360- build against ncurses-devel (libtinfo)
361- spec in utf-8
362
363* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
364- added upstream patch (from 026 to 039)
365- added Japanese summary
366- applied new versioning policy
367
368* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
369- rebuilt with libtermcap-devel
370
371* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
372- new upstream release
373- add upstream patch (from 001 to 025)
374- remove Provides: bash2
375
376* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
377- rebuilt with new toolchain
378
379* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
380- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
381- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
382
383* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
384- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
385
386* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
387- update to 2.05b
388- rebuild with new toolchains
389- add make check
390- add %postun script based on Fedora development
391- README file moved doc package
392- update Patch5 and Patch8 from Fedora development
393- change Patch6
394- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
395- add Patch11--39 from Fedora development 2.05b-36
396  * Tim Waugh <twaugh@redhat.com>
397  - Fix parameter expansion in multibyte locales (bug #112657).
398  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
399    bug #110777).
400  - Apply upstream patches (bug #109269 among others).
401  - Fix bash.info (bug #83776).
402  - Add bash205b-007 patch to fix bug #106876.
403  - Avoid crashing on multibyte input when locale is set incorrectly
404    (bug #74266).
405  - LFS support (bug #103627).
406  - Fix completion display when multibyte or control characters are to be
407    shown (bug #90201).
408  - Fix a warning message (bug #79629).
409  - Don't build with AFS support (bug #86514).
410  - Don't explicitly strip binaries (bug #85995).
411  - Really fix bug #83331 for good.
412  - Fix builtins.1.
413  - Actually apply the patch (bug #83331).
414  - Fix history/UTF-8 bug (bug #83331).
415  - More tab-completion fixing (bug #72512).
416  - Force pgrp synchronization (bug #81653).
417  - Prevent prompt overwriting output (bug #74383).
418  - Fix '-rbash' (bug #78455).
419  - Add readline-init patch (bug #74925).
420  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
421  - Ship '.' man page, which doesn't get picked up by glob.
422  - Locale shell variables fix (bug #74701).
423  * Elliot Lee <sopwith@redhat.com>
424  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
425    cross compiles.
426
427* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
428- update to 2.05
429- add README.jpatch to %doc
430- remove patch4 (bash2): revert command name in man pages to "bash"
431  - fix perl command to remove man pages conflict with sh-utils
432- remove section of config.h.in from patch0 to prevent remake of configure
433- change patch9: define in config-top.h to avoid conflict with patch100
434- remove patches 7, 10 & 101
435
436* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
437- made a link for man sh
438
439* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
440- added missing %%post and %%triggerpostun section
441
442* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
443- 2.04-1vl12
444- now bash2 is finally bash
445
446* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
447- build for Playstation2
448
449* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
450- 2.04-1vl10
451- Provides: bash = %%{version}
452
453* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
454- added Provides: bash
455
456* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
457- Obsoletes: bash
458- changed Copyright to License
459
460* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
461- 2.04-1vl7
462- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
463- corrected: bashrc-vine -> bashrc
464
465* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
466- combined bash-1.x and bash-2.x packages
467- added some patches from bash-2.04-13mdk
468
469* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
470- fix spec macros
471- added tests
472
473* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
474- build with gcc-2.95.3
475- partially used rpmmacros
476
477* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
478- minor bug fix in spec file
479
480* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
481- 2.04-1vl3
482- modified %install and %files section to handle compressed man page(s)
483
484* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
485- added pcomplete patch to fix complete if the candidate list is NULL.
486
487* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
488- updated to 2.04
489
490* Fri Sep 14 1999 Dale Lovelace <dale@redhat.com>
491- Remove annoying ^H's from documentation
492
493* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
494- patch to detect what executables are required by a script.
495
496* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
497- auto rebuild in the new build environment (release 4)
498
499* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
500- strip binaries.
501- include bash-doc correctly.
502
503* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
504- fixed post/postun /etc/shells work.
505
506* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
507- updated again text in the spec file
508
509* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
510- updated text in spec file.
511- update to 2.03.
512
513* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
514- build it as bash2 instead of bash
515
516* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
517- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
518
519* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
520- rename man pages in bash-doc to avoid packaging conflicts (#606).
521
522* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
523- patch for the arm
524- use $RPM_ARCH-redhat-linux as the build target
525
526* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
527- rewrite %pre, axe %postun (to avoid prereq loops)
528
529* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
530- resurrect for RH 6.0.
531
532* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
533- update to 2.02.1
534
535* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
536- Package for 5.2.
537
538* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
539- added POSIX.NOTES doc file
540- some extraneous doc files removed
541- minor .spec file changes
542
543* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
544- upgraded to version 2.02
545- Alpha, MIPS & Sparc patches removed due to lack of test platforms
546- glibc & signal patches no longer required
547- added documentation subpackage (doc)
548
549* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
550- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
551  is based on a change made in bash 2.0.  Should fix some early exit
552  problems with suspends and fg.
553
554* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
555- added %clean
556
557* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
558- added comment explaining why install-info isn't used
559- added mips patch
560
561* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
562- added BuildRoot
563
564* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
565- built against glibc
Note: See TracBrowser for help on using the repository browser.