source: projects/specs/trunk/b/bash/bash-vl.spec @ 12321

Revision 12321, 18.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bash-5.0.16-1

gtk-doc-1.32-3

libmariadb-3.1.7-1

libpq-12.2-1

librsvg2-2.46.4-1

postgresql-12.2-1

python-pygments-2.5.2-1

Line 
1%define bashversion 5.0
2%define patchlevel 16
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      1%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
23Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
24Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
25Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
26Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
27Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
28Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
29Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
30Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
31Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
32Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
33Patch12: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-012
34Patch13: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-013
35Patch14: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-014
36Patch15: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-015
37Patch16: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-016
38
39# Other patches
40#Patch101: bash-2.02-security.patch
41Patch102: bash-2.03-paths.patch
42Patch103: bash-2.03-profile.patch
43Patch104: bash-2.05a-interpreter.patch
44Patch105: bash-2.05b-debuginfo.patch
45#Patch106: bash-2.05b-manso.patch
46Patch107: bash-2.05b-pgrp_sync.patch
47#Patch108: bash-2.05b-readline-oom.patch
48#Patch109: bash-2.05b-xcc.patch
49Patch110: bash-3.2-audit.patch
50Patch111: bash-3.2-ssh_source_bash.patch
51#Patch112: bash-bashbug.patch
52Patch113: bash-infotags.patch
53Patch114: bash-requires.patch
54Patch115: bash-setlocale.patch
55Patch116: bash-tty-tests.patch
56
57# 484809, check if interp section is NOBITS
58Patch117: bash-4.0-nobits.patch
59
60# Do the same CFLAGS in generated Makefile in examples
61Patch118: bash-4.1-examples.patch
62
63# Builtins like echo and printf won't report errors
64# when output does not succeed due to EPIPE
65Patch119: bash-4.1-broken_pipe.patch
66
67# Enable system-wide .bash_logout for login shells
68Patch120: bash-4.2-rc2-logout.patch
69
70# Static analyzis shows some issues in bash-2.05a-interpreter.patch
71Patch121: bash-4.2-coverity.patch
72
73# Don't call malloc in signal handler
74#Patch122: bash-4.1-defer-sigchld-trap.patch
75
76# 799958, updated info about trap
77Patch123: bash-4.2-manpage_trap.patch
78
79# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
80Patch125: bash-4.2-size_type.patch
81
82# 1112710 - mention ulimit -c and -f POSIX block size
83Patch128: bash-4.3-man-ulimit.patch
84
85# A series of patches emitted by upstream since 4.3-18
86#Patch134: bash-4.3-pathexp-globignore-delim.patch
87
88# 1102815 - fix double echoes in vi visual mode
89Patch135: bash-4.3-noecho.patch
90
91# 1182278 - bash crashes on `select' if REPLY is readonly
92#Patch137: bash-4.3-select-readonly.patch
93
94#1241533,1224855 - bash leaks memory when LC_ALL set
95Patch138: bash-4.3-memleak-lc_all.patch
96
97#1245233 - old memleak reappeared, taken from upstream
98#Patch139: bash-4.3-old-memleak.patch
99
100# bash-4.4 builds loadable builtin examples by default
101# this patch disables it
102Patch140: bash-4.4-no-loadable-builtins.patch
103
104
105Buildroot:    %{_tmppath}/%{name}-%{version}-root
106BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
107Obsoletes:    bash <= 1.14.7
108Obsoletes:    bash2
109
110
111%description
112Bash is a GNU project sh-compatible shell or command language
113interpreter. Bash (Bourne Again shell) incorporates useful features
114from the Korn shell (ksh) and the C shell (csh). Most sh scripts
115can be run by bash without modification.
116
117Bash offers several improvements over sh, including command line
118editing, unlimited size command history, job control, shell
119functions and aliases, indexed arrays of unlimited size and
120integer arithmetic in any base from two to 64. Bash is ultimately
121intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
122Tools standard.
123
124
125%package doc
126Summary:  Documentation for the GNU Bourne Again shell (bash).
127Summary(ja):  GNU Bourne Again シェル向けドキュメント
128Group:    Applications/Documentation
129Requires: %{name} = %{version}-%{release}
130
131Obsoletes: bash2-doc
132
133%description doc
134This is a separate documentation package for the GNU Bourne
135Again shell.
136
137
138%prep
139%setup -q -n %{name}-%{bashversion}
140
141# Official upstream patches
142%patch1 -p0 -b .001
143%patch2 -p0 -b .002
144%patch3 -p0 -b .003
145%patch4 -p0 -b .004
146%patch5 -p0 -b .005
147%patch6 -p0 -b .006
148%patch7 -p0 -b .007
149%patch8 -p0 -b .008
150%patch9 -p0 -b .009
151%patch10 -p0 -b .010
152%patch11 -p0 -b .011
153%patch12 -p0 -b .012
154%patch13 -p0 -b .013
155%patch14 -p0 -b .014
156%patch15 -p0 -b .015
157%patch16 -p0 -b .016
158
159# Other patches
160%patch102 -p1 -b .paths
161%patch103 -p1 -b .profile
162%patch104 -p1 -b .interpreter
163%patch105 -p1 -b .debuginfo
164%patch107 -p1 -b .pgrp_sync
165%patch110 -p1 -b .audit
166%patch111 -p1 -b .ssh_source_bash
167%patch113 -p1 -b .infotags
168%patch114 -p1 -b .requires
169%patch115 -p1 -b .setlocale
170%patch116 -p1 -b .tty_tests
171%patch117 -p1 -b .nobits
172%patch118 -p1 -b .examples
173%patch119 -p1 -b .broken_pipe
174%patch120 -p1 -b .logout
175%patch121 -p1 -b .coverity
176%patch123 -p1
177%patch125 -p1 -b .size_type
178%patch128 -p1 -b .ulimit
179%patch135 -p1 -b .noecho
180%patch138 -p1 -b .lc_all
181%patch140 -p1 -b .no_loadable_builtin
182
183echo %{version} > _distribution
184echo %{release} |sed 's/vl.*//' > _patchlevel
185
186
187%build
188%configure --with-bash-malloc=no
189make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
190
191%install
192rm -rf %{buildroot}
193
194# Fix bug #83776
195perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
196
197make DESTDIR=$RPM_BUILD_ROOT install
198
199pushd $RPM_BUILD_ROOT
200 mkdir ./bin
201 mv ./usr/bin/bash ./bin/bash
202 ln -s bash ./bin/sh
203 rm -f .%{_infodir}/dir
204popd
205
206ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
207
208# make manpages for bash builtins as per suggestion in DOC/README
209pushd doc
210sed -e '
211/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
212/^\.SH NAME/d
213s/^bash, //
214s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
215s/,//g
216b
217}
218d
219' builtins.1 > man.pages
220for i in echo pwd test kill; do
221  perl -pi -e "s,$i,,g" man.pages
222  perl -pi -e "s,  , ,g" man.pages
223done
224
225install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
226
227for i in `cat man.pages` ; do
228  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
229  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
230done
231
232mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
233install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
234
235# Not for printf, false and true (conflict with coreutils)
236rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
237rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
238rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
239
240popd
241
242%find_lang %{name}
243
244rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
245
246%clean
247rm -rf %{buildroot}
248
249# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
250# to prevent prereq loops
251
252# post is in lua so that we can run it without any external deps.  Helps
253# for bootstrapping a new install.
254# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
255%post -p <lua>
256bashfound = false;
257shfound = false;
258 
259f = io.open("/etc/shells", "r");
260if f == nil
261then
262  f = io.open("/etc/shells", "w");
263else
264  repeat
265    t = f:read();
266    if t == "/bin/bash"
267    then
268      bashfound = true;
269    end
270    if t == "/bin/sh"
271    then
272      shfound = true;
273    end
274  until t == nil;
275end
276f:close()
277 
278f = io.open("/etc/shells", "a");
279if not bashfound
280then
281  f:write("/bin/bash\n")
282end
283if not shfound
284then
285  f:write("/bin/sh\n")
286end
287f:close()
288
289%files -f %{name}.lang
290%defattr(-,root,root)
291%license COPYING
292%doc CHANGES
293%doc examples
294%config(noreplace) /etc/bashrc
295/bin/bash
296/bin/sh
297%{_infodir}/bash.info*
298%{_mandir}/*/*
299%{_mandir}/*/..1*
300%{_bindir}/bashbug
301
302
303%files doc
304%defattr(-,root,root)
305%doc COMPAT NEWS NOTES POSIX RBASH
306%doc examples/functions/ examples/misc/
307%doc examples/scripts*/
308%doc examples/startup-files/ examples/complete/ examples/loadables/
309%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
310%doc doc/FAQ doc/INTRO doc/article.ms doc/README
311
312
313%changelog
314* Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
315- updated to 5.0 patch level 16.
316
317* Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
318- updated to 5.0 patch level 11.
319
320* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
321- updated to 5.0 patch level 9.
322- dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
323- imported Patch140 from rawhide.
324
325* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
326- updated to 4.3 patch level 46.
327
328* Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
329- updated to 4.3 patch level 42.
330- imported patch 128-139 from RawHide.
331
332* Fri Oct  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
333- updated to 4.3 patch level 29.
334- removed patch1000 (included in 4.3.26).
335
336* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
337- added patch1000 to fix CVE-2014-7169.
338
339* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
340- updated to 4.3 patch level 25.
341
342* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
343- update to 4.3 patch level 18
344
345* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
346- update to 4.3 patch level 11
347
348* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
349- update to 4.2 patch level 45
350- import some patch from fedora package (122-127)
351  - patch122: Don't call malloc in signal handler
352  - patch123: #799958, updated info about trap
353  - patch124: #695656, block the signal and unblock it after the
354    new handler is installed
355  - patch125: Use unsigned type for size
356    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
357  - patch126: #903833, Fix missing close(), fixes fd leaks
358
359* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
360- remove postun lua script because bash will be never uninstalled
361
362* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
363- update to 4.2 patch level 37
364
365* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
366- update to 4.2 patch level 20
367
368* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
369- update to 4.2 patch level 8
370- use lua script in post/postun
371- update patches from fedora
372
373* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
374- update to 4.1 patch level 7
375
376* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
377- check if /bin/grep exists on %%post script
378
379* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
380- rebuilt with gcc-4.4.3-3 on ppc
381
382* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
383- rebuilt with new toolchain
384
385* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
386- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
387
388* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
389- add Requires(post): grep
390
391* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
392- remove obsolete /bin/bash2 entry from /etc/shells
393
394* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
395- add Requires(post): ncurses (should be added by find-requires..)
396
397* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
398- add upstream patch (from 040 to 048)
399- build against ncurses-devel (libtinfo)
400- spec in utf-8
401
402* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
403- added upstream patch (from 026 to 039)
404- added Japanese summary
405- applied new versioning policy
406
407* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
408- rebuilt with libtermcap-devel
409
410* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
411- new upstream release
412- add upstream patch (from 001 to 025)
413- remove Provides: bash2
414
415* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
416- rebuilt with new toolchain
417
418* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
419- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
420- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
421
422* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
423- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
424
425* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
426- update to 2.05b
427- rebuild with new toolchains
428- add make check
429- add %postun script based on Fedora development
430- README file moved doc package
431- update Patch5 and Patch8 from Fedora development
432- change Patch6
433- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
434- add Patch11--39 from Fedora development 2.05b-36
435  * Tim Waugh <twaugh@redhat.com>
436  - Fix parameter expansion in multibyte locales (bug #112657).
437  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
438    bug #110777).
439  - Apply upstream patches (bug #109269 among others).
440  - Fix bash.info (bug #83776).
441  - Add bash205b-007 patch to fix bug #106876.
442  - Avoid crashing on multibyte input when locale is set incorrectly
443    (bug #74266).
444  - LFS support (bug #103627).
445  - Fix completion display when multibyte or control characters are to be
446    shown (bug #90201).
447  - Fix a warning message (bug #79629).
448  - Don't build with AFS support (bug #86514).
449  - Don't explicitly strip binaries (bug #85995).
450  - Really fix bug #83331 for good.
451  - Fix builtins.1.
452  - Actually apply the patch (bug #83331).
453  - Fix history/UTF-8 bug (bug #83331).
454  - More tab-completion fixing (bug #72512).
455  - Force pgrp synchronization (bug #81653).
456  - Prevent prompt overwriting output (bug #74383).
457  - Fix '-rbash' (bug #78455).
458  - Add readline-init patch (bug #74925).
459  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
460  - Ship '.' man page, which doesn't get picked up by glob.
461  - Locale shell variables fix (bug #74701).
462  * Elliot Lee <sopwith@redhat.com>
463  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
464    cross compiles.
465
466* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
467- update to 2.05
468- add README.jpatch to %doc
469- remove patch4 (bash2): revert command name in man pages to "bash"
470  - fix perl command to remove man pages conflict with sh-utils
471- remove section of config.h.in from patch0 to prevent remake of configure
472- change patch9: define in config-top.h to avoid conflict with patch100
473- remove patches 7, 10 & 101
474
475* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
476- made a link for man sh
477
478* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
479- added missing %%post and %%triggerpostun section
480
481* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
482- 2.04-1vl12
483- now bash2 is finally bash
484
485* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
486- build for Playstation2
487
488* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
489- 2.04-1vl10
490- Provides: bash = %%{version}
491
492* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
493- added Provides: bash
494
495* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
496- Obsoletes: bash
497- changed Copyright to License
498
499* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
500- 2.04-1vl7
501- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
502- corrected: bashrc-vine -> bashrc
503
504* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
505- combined bash-1.x and bash-2.x packages
506- added some patches from bash-2.04-13mdk
507
508* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
509- fix spec macros
510- added tests
511
512* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
513- build with gcc-2.95.3
514- partially used rpmmacros
515
516* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
517- minor bug fix in spec file
518
519* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
520- 2.04-1vl3
521- modified %install and %files section to handle compressed man page(s)
522
523* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
524- added pcomplete patch to fix complete if the candidate list is NULL.
525
526* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
527- updated to 2.04
528
529* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
530- Remove annoying ^H's from documentation
531
532* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
533- patch to detect what executables are required by a script.
534
535* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
536- auto rebuild in the new build environment (release 4)
537
538* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
539- strip binaries.
540- include bash-doc correctly.
541
542* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
543- fixed post/postun /etc/shells work.
544
545* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
546- updated again text in the spec file
547
548* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
549- updated text in spec file.
550- update to 2.03.
551
552* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
553- build it as bash2 instead of bash
554
555* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
556- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
557
558* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
559- rename man pages in bash-doc to avoid packaging conflicts (#606).
560
561* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
562- patch for the arm
563- use $RPM_ARCH-redhat-linux as the build target
564
565* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
566- rewrite %pre, axe %postun (to avoid prereq loops)
567
568* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
569- resurrect for RH 6.0.
570
571* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
572- update to 2.02.1
573
574* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
575- Package for 5.2.
576
577* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
578- added POSIX.NOTES doc file
579- some extraneous doc files removed
580- minor .spec file changes
581
582* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
583- upgraded to version 2.02
584- Alpha, MIPS & Sparc patches removed due to lack of test platforms
585- glibc & signal patches no longer required
586- added documentation subpackage (doc)
587
588* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
589- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
590  is based on a change made in bash 2.0.  Should fix some early exit
591  problems with suspends and fg.
592
593* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
594- added %clean
595
596* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
597- added comment explaining why install-info isn't used
598- added mips patch
599
600* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
601- added BuildRoot
602
603* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
604- built against glibc
Note: See TracBrowser for help on using the repository browser.