source: projects/specs/trunk/b/bash/bash-vl.spec @ 9754

Revision 9754, 20.3 KB checked in by tomop, 9 years ago (diff)

bash-4.3.42-1

Line 
1%define bashversion 4.3
2%define patchlevel 42
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      1%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
23Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
24Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
25Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
26Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
27Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
28Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
29Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
30Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
31Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
32Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
33Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
34Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
35Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
36Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
37Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
38Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
39Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
40Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
41Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
42Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
43Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
44Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
45Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
46Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
47Patch26: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-026
48Patch27: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-027
49Patch28: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-028
50Patch29: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-029
51Patch30: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-030
52Patch31: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-031
53Patch32: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-032
54Patch33: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-033
55Patch34: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-034
56Patch35: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-035
57Patch36: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-036
58Patch37: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-037
59Patch38: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-038
60Patch39: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-039
61Patch40: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-040
62Patch41: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-041
63Patch42: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-042
64
65# Other patches
66Patch101: bash-2.02-security.patch
67Patch102: bash-2.03-paths.patch
68Patch103: bash-2.03-profile.patch
69Patch104: bash-2.05a-interpreter.patch
70Patch105: bash-2.05b-debuginfo.patch
71Patch106: bash-2.05b-manso.patch
72Patch107: bash-2.05b-pgrp_sync.patch
73Patch108: bash-2.05b-readline-oom.patch
74Patch109: bash-2.05b-xcc.patch
75Patch110: bash-3.2-audit.patch
76Patch111: bash-3.2-ssh_source_bash.patch
77Patch112: bash-bashbug.patch
78Patch113: bash-infotags.patch
79Patch114: bash-requires.patch
80Patch115: bash-setlocale.patch
81Patch116: bash-tty-tests.patch
82
83# 484809, check if interp section is NOBITS
84Patch117: bash-4.0-nobits.patch
85
86# Do the same CFLAGS in generated Makefile in examples
87Patch118: bash-4.1-examples.patch
88
89# Builtins like echo and printf won't report errors
90# when output does not succeed due to EPIPE
91Patch119: bash-4.1-broken_pipe.patch
92
93# Enable system-wide .bash_logout for login shells
94Patch120: bash-4.2-rc2-logout.patch
95
96# Static analyzis shows some issues in bash-2.05a-interpreter.patch
97Patch121: bash-4.2-coverity.patch
98
99# Don't call malloc in signal handler
100Patch122: bash-4.1-defer-sigchld-trap.patch
101
102# 799958, updated info about trap
103Patch123: bash-4.2-manpage_trap.patch
104
105# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
106Patch125: bash-4.2-size_type.patch
107
108# 1112710 - mention ulimit -c and -f POSIX block size
109Patch128: bash-4.3-man-ulimit.patch
110
111# A series of patches emitted by upstream since 4.3-18
112Patch134: bash-4.3-pathexp-globignore-delim.patch
113
114# 1102815 - fix double echoes in vi visual mode
115Patch135: bash-4.3-noecho.patch
116
117# 1182278 - bash crashes on `select' if REPLY is readonly
118Patch137: bash-4.3-select-readonly.patch
119
120#1241533,1224855 - bash leaks memory when LC_ALL set
121Patch138: bash-4.3-memleak-lc_all.patch
122
123#1245233 - old memleak reappeared, taken from upstream
124Patch139: bash-4.3-old-memleak.patch
125
126Buildroot:    %{_tmppath}/%{name}-%{version}-root
127BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
128Obsoletes:    bash <= 1.14.7
129Obsoletes:    bash2
130
131
132%description
133Bash is a GNU project sh-compatible shell or command language
134interpreter. Bash (Bourne Again shell) incorporates useful features
135from the Korn shell (ksh) and the C shell (csh). Most sh scripts
136can be run by bash without modification.
137
138Bash offers several improvements over sh, including command line
139editing, unlimited size command history, job control, shell
140functions and aliases, indexed arrays of unlimited size and
141integer arithmetic in any base from two to 64. Bash is ultimately
142intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
143Tools standard.
144
145
146%package doc
147Summary:  Documentation for the GNU Bourne Again shell (bash).
148Summary:  GNU Bourne Again シェル向けドキュメント
149Group:    Applications/Documentation
150Requires: %{name} = %{version}-%{release}
151
152Obsoletes: bash2-doc
153
154%description doc
155This is a separate documentation package for the GNU Bourne
156Again shell.
157
158
159%prep
160%setup -q -n %{name}-%{bashversion}
161
162# Official upstream patches
163%patch1 -p0 -b .001
164%patch2 -p0 -b .002
165%patch3 -p0 -b .003
166%patch4 -p0 -b .004
167%patch5 -p0 -b .005
168%patch6 -p0 -b .006
169%patch7 -p0 -b .007
170%patch8 -p0 -b .008
171%patch9 -p0 -b .009
172%patch10 -p0 -b .010
173%patch11 -p0 -b .011
174%patch12 -p0 -b .012
175%patch13 -p0 -b .013
176%patch14 -p0 -b .014
177%patch15 -p0 -b .015
178%patch16 -p0 -b .016
179%patch17 -p0 -b .017
180%patch18 -p0 -b .018
181%patch19 -p0 -b .019
182%patch20 -p0 -b .020
183%patch21 -p0 -b .021
184%patch22 -p0 -b .022
185%patch23 -p0 -b .023
186%patch24 -p0 -b .024
187%patch25 -p0 -b .025
188%patch26 -p0 -b .026
189%patch27 -p0 -b .027
190%patch28 -p0 -b .028
191%patch29 -p0 -b .029
192%patch30 -p0 -b .030
193%patch31 -p0 -b .031
194%patch32 -p0 -b .032
195%patch33 -p0 -b .033
196%patch34 -p0 -b .034
197%patch35 -p0 -b .035
198%patch36 -p0 -b .036
199%patch37 -p0 -b .037
200%patch38 -p0 -b .038
201%patch39 -p0 -b .039
202%patch40 -p0 -b .040
203%patch41 -p0 -b .041
204%patch42 -p0 -b .042
205
206# Other patches
207%patch101 -p1 -b .security
208%patch102 -p1 -b .paths
209%patch103 -p1 -b .profile
210%patch104 -p1 -b .interpreter
211%patch105 -p1 -b .debuginfo
212%patch106 -p1 -b .manso
213%patch107 -p1 -b .pgrp_sync
214%patch108 -p1 -b .readline_oom
215%patch109 -p1 -b .xcc
216%patch110 -p1 -b .audit
217%patch111 -p1 -b .ssh_source_bash
218%patch112 -p1 -b .bashbug
219%patch113 -p1 -b .infotags
220%patch114 -p1 -b .requires
221%patch115 -p1 -b .setlocale
222%patch116 -p1 -b .tty_tests
223%patch117 -p1 -b .nobits
224%patch118 -p1 -b .examples
225%patch119 -p1 -b .broken_pipe
226%patch120 -p1 -b .logout
227%patch121 -p1 -b .coverity
228%patch122 -p1 -b .defer_sigchld_trap
229%patch123 -p1
230%patch125 -p1 -b .size_type
231%patch128 -p1 -b .ulimit
232%patch134 -p0 -b .delim
233%patch135 -p1 -b .noecho
234%patch137 -p1 -b .readonly
235%patch138 -p1 -b .lc_all
236%patch139 -p1 -b .oldleak
237
238echo %{version} > _distribution
239echo %{release} |sed 's/vl.*//' > _patchlevel
240
241
242%build
243%configure --with-bash-malloc=no
244make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
245
246%install
247rm -rf %{buildroot}
248
249# Fix bug #83776
250perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
251
252make DESTDIR=$RPM_BUILD_ROOT install
253
254pushd $RPM_BUILD_ROOT
255 mkdir ./bin
256 mv ./usr/bin/bash ./bin/bash
257 ln -s bash ./bin/sh
258 rm -f .%{_infodir}/dir
259popd
260
261ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
262
263# make manpages for bash builtins as per suggestion in DOC/README
264pushd doc
265sed -e '
266/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
267/^\.SH NAME/d
268s/^bash, //
269s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
270s/,//g
271b
272}
273d
274' builtins.1 > man.pages
275for i in echo pwd test kill; do
276  perl -pi -e "s,$i,,g" man.pages
277  perl -pi -e "s,  , ,g" man.pages
278done
279
280install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
281
282for i in `cat man.pages` ; do
283  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
284  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
285done
286
287mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
288install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
289
290# Not for printf, false and true (conflict with coreutils)
291rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
292rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
293rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
294
295popd
296
297%find_lang %{name}
298
299rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
300
301%clean
302rm -rf %{buildroot}
303
304# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
305# to prevent prereq loops
306
307# post is in lua so that we can run it without any external deps.  Helps
308# for bootstrapping a new install.
309# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
310%post -p <lua>
311bashfound = false;
312shfound = false;
313 
314f = io.open("/etc/shells", "r");
315if f == nil
316then
317  f = io.open("/etc/shells", "w");
318else
319  repeat
320    t = f:read();
321    if t == "/bin/bash"
322    then
323      bashfound = true;
324    end
325    if t == "/bin/sh"
326    then
327      shfound = true;
328    end
329  until t == nil;
330end
331f:close()
332 
333f = io.open("/etc/shells", "a");
334if not bashfound
335then
336  f:write("/bin/bash\n")
337end
338if not shfound
339then
340  f:write("/bin/sh\n")
341end
342f:close()
343
344%files -f %{name}.lang
345%defattr(-,root,root)
346%doc CHANGES COPYING
347%doc examples
348%config(noreplace) /etc/bashrc
349/bin/bash
350/bin/sh
351%{_infodir}/bash.info*
352%{_mandir}/*/*
353%{_mandir}/*/..1*
354%{_bindir}/bashbug
355
356
357%files doc
358%defattr(-,root,root)
359%doc COMPAT NEWS NOTES POSIX RBASH
360%doc examples/functions/ examples/misc/
361%doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
362%doc examples/startup-files/ examples/complete/ examples/loadables/
363%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
364%doc doc/FAQ doc/INTRO doc/article.ms doc/README
365
366
367%changelog
368* Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
369- updated to 4.3 patch level 42.
370- imported patch 128-139 from RawHide.
371
372* Fri Oct  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
373- updated to 4.3 patch level 29.
374- removed patch1000 (included in 4.3.26).
375
376* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
377- added patch1000 to fix CVE-2014-7169.
378
379* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
380- updated to 4.3 patch level 25.
381
382* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
383- update to 4.3 patch level 18
384
385* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
386- update to 4.3 patch level 11
387
388* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
389- update to 4.2 patch level 45
390- import some patch from fedora package (122-127)
391  - patch122: Don't call malloc in signal handler
392  - patch123: #799958, updated info about trap
393  - patch124: #695656, block the signal and unblock it after the
394    new handler is installed
395  - patch125: Use unsigned type for size
396    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
397  - patch126: #903833, Fix missing close(), fixes fd leaks
398
399* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
400- remove postun lua script because bash will be never uninstalled
401
402* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
403- update to 4.2 patch level 37
404
405* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
406- update to 4.2 patch level 20
407
408* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
409- update to 4.2 patch level 8
410- use lua script in post/postun
411- update patches from fedora
412
413* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
414- update to 4.1 patch level 7
415
416* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
417- check if /bin/grep exists on %%post script
418
419* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
420- rebuilt with gcc-4.4.3-3 on ppc
421
422* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
423- rebuilt with new toolchain
424
425* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
426- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
427
428* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
429- add Requires(post): grep
430
431* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
432- remove obsolete /bin/bash2 entry from /etc/shells
433
434* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
435- add Requires(post): ncurses (should be added by find-requires..)
436
437* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
438- add upstream patch (from 040 to 048)
439- build against ncurses-devel (libtinfo)
440- spec in utf-8
441
442* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
443- added upstream patch (from 026 to 039)
444- added Japanese summary
445- applied new versioning policy
446
447* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
448- rebuilt with libtermcap-devel
449
450* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
451- new upstream release
452- add upstream patch (from 001 to 025)
453- remove Provides: bash2
454
455* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
456- rebuilt with new toolchain
457
458* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
459- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
460- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
461
462* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
463- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
464
465* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
466- update to 2.05b
467- rebuild with new toolchains
468- add make check
469- add %postun script based on Fedora development
470- README file moved doc package
471- update Patch5 and Patch8 from Fedora development
472- change Patch6
473- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
474- add Patch11--39 from Fedora development 2.05b-36
475  * Tim Waugh <twaugh@redhat.com>
476  - Fix parameter expansion in multibyte locales (bug #112657).
477  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
478    bug #110777).
479  - Apply upstream patches (bug #109269 among others).
480  - Fix bash.info (bug #83776).
481  - Add bash205b-007 patch to fix bug #106876.
482  - Avoid crashing on multibyte input when locale is set incorrectly
483    (bug #74266).
484  - LFS support (bug #103627).
485  - Fix completion display when multibyte or control characters are to be
486    shown (bug #90201).
487  - Fix a warning message (bug #79629).
488  - Don't build with AFS support (bug #86514).
489  - Don't explicitly strip binaries (bug #85995).
490  - Really fix bug #83331 for good.
491  - Fix builtins.1.
492  - Actually apply the patch (bug #83331).
493  - Fix history/UTF-8 bug (bug #83331).
494  - More tab-completion fixing (bug #72512).
495  - Force pgrp synchronization (bug #81653).
496  - Prevent prompt overwriting output (bug #74383).
497  - Fix '-rbash' (bug #78455).
498  - Add readline-init patch (bug #74925).
499  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
500  - Ship '.' man page, which doesn't get picked up by glob.
501  - Locale shell variables fix (bug #74701).
502  * Elliot Lee <sopwith@redhat.com>
503  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
504    cross compiles.
505
506* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
507- update to 2.05
508- add README.jpatch to %doc
509- remove patch4 (bash2): revert command name in man pages to "bash"
510  - fix perl command to remove man pages conflict with sh-utils
511- remove section of config.h.in from patch0 to prevent remake of configure
512- change patch9: define in config-top.h to avoid conflict with patch100
513- remove patches 7, 10 & 101
514
515* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
516- made a link for man sh
517
518* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
519- added missing %%post and %%triggerpostun section
520
521* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
522- 2.04-1vl12
523- now bash2 is finally bash
524
525* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
526- build for Playstation2
527
528* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
529- 2.04-1vl10
530- Provides: bash = %%{version}
531
532* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
533- added Provides: bash
534
535* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
536- Obsoletes: bash
537- changed Copyright to License
538
539* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
540- 2.04-1vl7
541- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
542- corrected: bashrc-vine -> bashrc
543
544* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
545- combined bash-1.x and bash-2.x packages
546- added some patches from bash-2.04-13mdk
547
548* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
549- fix spec macros
550- added tests
551
552* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
553- build with gcc-2.95.3
554- partially used rpmmacros
555
556* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
557- minor bug fix in spec file
558
559* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
560- 2.04-1vl3
561- modified %install and %files section to handle compressed man page(s)
562
563* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
564- added pcomplete patch to fix complete if the candidate list is NULL.
565
566* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
567- updated to 2.04
568
569* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
570- Remove annoying ^H's from documentation
571
572* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
573- patch to detect what executables are required by a script.
574
575* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
576- auto rebuild in the new build environment (release 4)
577
578* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
579- strip binaries.
580- include bash-doc correctly.
581
582* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
583- fixed post/postun /etc/shells work.
584
585* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
586- updated again text in the spec file
587
588* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
589- updated text in spec file.
590- update to 2.03.
591
592* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
593- build it as bash2 instead of bash
594
595* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
596- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
597
598* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
599- rename man pages in bash-doc to avoid packaging conflicts (#606).
600
601* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
602- patch for the arm
603- use $RPM_ARCH-redhat-linux as the build target
604
605* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
606- rewrite %pre, axe %postun (to avoid prereq loops)
607
608* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
609- resurrect for RH 6.0.
610
611* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
612- update to 2.02.1
613
614* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
615- Package for 5.2.
616
617* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
618- added POSIX.NOTES doc file
619- some extraneous doc files removed
620- minor .spec file changes
621
622* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
623- upgraded to version 2.02
624- Alpha, MIPS & Sparc patches removed due to lack of test platforms
625- glibc & signal patches no longer required
626- added documentation subpackage (doc)
627
628* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
629- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
630  is based on a change made in bash 2.0.  Should fix some early exit
631  problems with suspends and fg.
632
633* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
634- added %clean
635
636* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
637- added comment explaining why install-info isn't used
638- added mips patch
639
640* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
641- added BuildRoot
642
643* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
644- built against glibc
Note: See TracBrowser for help on using the repository browser.