source: projects/specs/trunk/b/bash/bash-vl.spec @ 12208

Revision 12208, 18.0 KB checked in by tomop, 5 years ago (diff)

bash-5.0.11-1

RevLine 
[12208]1%define bashversion 5.0
2%define patchlevel 11
[3421]3
[521]4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
[3421]8Version:      %{bashversion}.%{patchlevel}
[8989]9Release:      1%{?_dist_release}
[521]10
11Group:        System Environment/Shells
[6039]12License:      GPLv3+
[521]13
14Vendor:       Project Vine
15Distribution: Vine Linux
[6039]16Packager:     daisuke
[521]17
[12208]18Source0:      http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
[521]19Source10:     bashrc-vine
20
21# Official upstream patches
[12208]22Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
23Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
24Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
25Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
26Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
27Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
28Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
29Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
30Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
31Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
32Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
[1751]33
[521]34# Other patches
[12208]35#Patch101: bash-2.02-security.patch
[1751]36Patch102: bash-2.03-paths.patch
37Patch103: bash-2.03-profile.patch
38Patch104: bash-2.05a-interpreter.patch
39Patch105: bash-2.05b-debuginfo.patch
[12208]40#Patch106: bash-2.05b-manso.patch
[1751]41Patch107: bash-2.05b-pgrp_sync.patch
[12208]42#Patch108: bash-2.05b-readline-oom.patch
43#Patch109: bash-2.05b-xcc.patch
[1751]44Patch110: bash-3.2-audit.patch
[3421]45Patch111: bash-3.2-ssh_source_bash.patch
[12208]46#Patch112: bash-bashbug.patch
[3421]47Patch113: bash-infotags.patch
48Patch114: bash-requires.patch
49Patch115: bash-setlocale.patch
50Patch116: bash-tty-tests.patch
[521]51
[3421]52# 484809, check if interp section is NOBITS
53Patch117: bash-4.0-nobits.patch
54
55# Do the same CFLAGS in generated Makefile in examples
56Patch118: bash-4.1-examples.patch
57
58# Builtins like echo and printf won't report errors
59# when output does not succeed due to EPIPE
60Patch119: bash-4.1-broken_pipe.patch
61
62# Enable system-wide .bash_logout for login shells
63Patch120: bash-4.2-rc2-logout.patch
64
65# Static analyzis shows some issues in bash-2.05a-interpreter.patch
66Patch121: bash-4.2-coverity.patch
67
[7561]68# Don't call malloc in signal handler
[12208]69#Patch122: bash-4.1-defer-sigchld-trap.patch
[7561]70
71# 799958, updated info about trap
72Patch123: bash-4.2-manpage_trap.patch
73
74# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
75Patch125: bash-4.2-size_type.patch
76
[9754]77# 1112710 - mention ulimit -c and -f POSIX block size
78Patch128: bash-4.3-man-ulimit.patch
79
80# A series of patches emitted by upstream since 4.3-18
[12208]81#Patch134: bash-4.3-pathexp-globignore-delim.patch
[9754]82
83# 1102815 - fix double echoes in vi visual mode
84Patch135: bash-4.3-noecho.patch
85
86# 1182278 - bash crashes on `select' if REPLY is readonly
[12208]87#Patch137: bash-4.3-select-readonly.patch
[9754]88
89#1241533,1224855 - bash leaks memory when LC_ALL set
90Patch138: bash-4.3-memleak-lc_all.patch
91
92#1245233 - old memleak reappeared, taken from upstream
[12208]93#Patch139: bash-4.3-old-memleak.patch
[9754]94
[12208]95# bash-4.4 builds loadable builtin examples by default
96# this patch disables it
97Patch140: bash-4.4-no-loadable-builtins.patch
98
99
[3421]100Buildroot:    %{_tmppath}/%{name}-%{version}-root
101BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
[521]102Obsoletes:    bash <= 1.14.7
103Obsoletes:    bash2
104
105
106%description
107Bash is a GNU project sh-compatible shell or command language
108interpreter. Bash (Bourne Again shell) incorporates useful features
109from the Korn shell (ksh) and the C shell (csh). Most sh scripts
110can be run by bash without modification.
111
112Bash offers several improvements over sh, including command line
113editing, unlimited size command history, job control, shell
114functions and aliases, indexed arrays of unlimited size and
115integer arithmetic in any base from two to 64. Bash is ultimately
116intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
117Tools standard.
118
119
120%package doc
121Summary:  Documentation for the GNU Bourne Again shell (bash).
[10540]122Summary(ja):  GNU Bourne Again シェル向けドキュメント
[521]123Group:    Applications/Documentation
124Requires: %{name} = %{version}-%{release}
125
126Obsoletes: bash2-doc
127
128%description doc
129This is a separate documentation package for the GNU Bourne
130Again shell.
131
132
133%prep
[3421]134%setup -q -n %{name}-%{bashversion}
135
[521]136# Official upstream patches
137%patch1 -p0 -b .001
138%patch2 -p0 -b .002
139%patch3 -p0 -b .003
140%patch4 -p0 -b .004
141%patch5 -p0 -b .005
142%patch6 -p0 -b .006
143%patch7 -p0 -b .007
[3421]144%patch8 -p0 -b .008
[6039]145%patch9 -p0 -b .009
146%patch10 -p0 -b .010
147%patch11 -p0 -b .011
[521]148
149# Other patches
[1751]150%patch102 -p1 -b .paths
151%patch103 -p1 -b .profile
152%patch104 -p1 -b .interpreter
153%patch105 -p1 -b .debuginfo
154%patch107 -p1 -b .pgrp_sync
155%patch110 -p1 -b .audit
[3421]156%patch111 -p1 -b .ssh_source_bash
157%patch113 -p1 -b .infotags
158%patch114 -p1 -b .requires
159%patch115 -p1 -b .setlocale
160%patch116 -p1 -b .tty_tests
161%patch117 -p1 -b .nobits
162%patch118 -p1 -b .examples
163%patch119 -p1 -b .broken_pipe
164%patch120 -p1 -b .logout
165%patch121 -p1 -b .coverity
[7561]166%patch123 -p1
167%patch125 -p1 -b .size_type
[9754]168%patch128 -p1 -b .ulimit
169%patch135 -p1 -b .noecho
170%patch138 -p1 -b .lc_all
[12208]171%patch140 -p1 -b .no_loadable_builtin
[521]172
173echo %{version} > _distribution
[1751]174echo %{release} |sed 's/vl.*//' > _patchlevel
[521]175
176
177%build
178%configure --with-bash-malloc=no
[1751]179make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
[521]180
181%install
182rm -rf %{buildroot}
183
184# Fix bug #83776
185perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
186
[3421]187make DESTDIR=$RPM_BUILD_ROOT install
[521]188
189pushd $RPM_BUILD_ROOT
[3421]190 mkdir ./bin
191 mv ./usr/bin/bash ./bin/bash
192 ln -s bash ./bin/sh
193 rm -f .%{_infodir}/dir
[521]194popd
195
196ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
197
198# make manpages for bash builtins as per suggestion in DOC/README
199pushd doc
200sed -e '
201/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
202/^\.SH NAME/d
203s/^bash, //
204s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
205s/,//g
206b
207}
208d
209' builtins.1 > man.pages
210for i in echo pwd test kill; do
211  perl -pi -e "s,$i,,g" man.pages
212  perl -pi -e "s,  , ,g" man.pages
213done
214
215install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
216
217for i in `cat man.pages` ; do
218  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
219  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
220done
221
222mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
223install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
224
[1751]225# Not for printf, false and true (conflict with coreutils)
[521]226rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
[1751]227rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
228rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
[521]229
230popd
231
232%find_lang %{name}
233
[8436]234rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
235
[521]236%clean
237rm -rf %{buildroot}
238
239# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
240# to prevent prereq loops
241
[3421]242# post is in lua so that we can run it without any external deps.  Helps
243# for bootstrapping a new install.
244# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
245%post -p <lua>
246bashfound = false;
247shfound = false;
248 
249f = io.open("/etc/shells", "r");
250if f == nil
251then
252  f = io.open("/etc/shells", "w");
253else
254  repeat
255    t = f:read();
256    if t == "/bin/bash"
257    then
258      bashfound = true;
259    end
260    if t == "/bin/sh"
261    then
262      shfound = true;
263    end
264  until t == nil;
265end
266f:close()
267 
268f = io.open("/etc/shells", "a");
269if not bashfound
270then
271  f:write("/bin/bash\n")
272end
273if not shfound
274then
275  f:write("/bin/sh\n")
276end
277f:close()
[521]278
279%files -f %{name}.lang
280%defattr(-,root,root)
[10540]281%license COPYING
282%doc CHANGES
[521]283%doc examples
284%config(noreplace) /etc/bashrc
285/bin/bash
286/bin/sh
287%{_infodir}/bash.info*
288%{_mandir}/*/*
289%{_mandir}/*/..1*
290%{_bindir}/bashbug
291
292
293%files doc
294%defattr(-,root,root)
295%doc COMPAT NEWS NOTES POSIX RBASH
[8436]296%doc examples/functions/ examples/misc/
[10540]297%doc examples/scripts*/
[521]298%doc examples/startup-files/ examples/complete/ examples/loadables/
299%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
300%doc doc/FAQ doc/INTRO doc/article.ms doc/README
301
302
303%changelog
[12208]304* Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
305- updated to 5.0 patch level 11.
306
307* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
308- updated to 5.0 patch level 9.
309- dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
310- imported Patch140 from rawhide.
311
[10540]312* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
313- updated to 4.3 patch level 46.
314
[9754]315* Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
316- updated to 4.3 patch level 42.
317- imported patch 128-139 from RawHide.
318
319* Fri Oct  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
320- updated to 4.3 patch level 29.
[8989]321- removed patch1000 (included in 4.3.26).
322
[8970]323* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
324- added patch1000 to fix CVE-2014-7169.
325
[8968]326* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
[9754]327- updated to 4.3 patch level 25.
[8968]328
[8543]329* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
330- update to 4.3 patch level 18
331
[8436]332* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
333- update to 4.3 patch level 11
334
[7561]335* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
336- update to 4.2 patch level 45
337- import some patch from fedora package (122-127)
338  - patch122: Don't call malloc in signal handler
339  - patch123: #799958, updated info about trap
340  - patch124: #695656, block the signal and unblock it after the
341    new handler is installed
342  - patch125: Use unsigned type for size
343    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
344  - patch126: #903833, Fix missing close(), fixes fd leaks
345
[6893]346* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
347- remove postun lua script because bash will be never uninstalled
348
[6826]349* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
350- update to 4.2 patch level 37
351
[6039]352* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
353- update to 4.2 patch level 20
354
[3421]355* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
356- update to 4.2 patch level 8
357- use lua script in post/postun
358- update patches from fedora
359
[1751]360* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
361- update to 4.1 patch level 7
362
[521]363* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
364- check if /bin/grep exists on %%post script
365
366* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
367- rebuilt with gcc-4.4.3-3 on ppc
368
369* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
370- rebuilt with new toolchain
371
372* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
373- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
374
375* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
376- add Requires(post): grep
377
378* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
379- remove obsolete /bin/bash2 entry from /etc/shells
380
381* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
382- add Requires(post): ncurses (should be added by find-requires..)
383
[7561]384* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
[521]385- add upstream patch (from 040 to 048)
386- build against ncurses-devel (libtinfo)
387- spec in utf-8
388
389* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
390- added upstream patch (from 026 to 039)
391- added Japanese summary
392- applied new versioning policy
393
394* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
395- rebuilt with libtermcap-devel
396
397* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
398- new upstream release
399- add upstream patch (from 001 to 025)
400- remove Provides: bash2
401
402* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
403- rebuilt with new toolchain
404
405* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
406- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
407- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
408
409* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
410- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
411
412* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
413- update to 2.05b
414- rebuild with new toolchains
415- add make check
416- add %postun script based on Fedora development
417- README file moved doc package
418- update Patch5 and Patch8 from Fedora development
419- change Patch6
420- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
421- add Patch11--39 from Fedora development 2.05b-36
422  * Tim Waugh <twaugh@redhat.com>
423  - Fix parameter expansion in multibyte locales (bug #112657).
424  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
425    bug #110777).
426  - Apply upstream patches (bug #109269 among others).
427  - Fix bash.info (bug #83776).
428  - Add bash205b-007 patch to fix bug #106876.
429  - Avoid crashing on multibyte input when locale is set incorrectly
430    (bug #74266).
431  - LFS support (bug #103627).
432  - Fix completion display when multibyte or control characters are to be
433    shown (bug #90201).
434  - Fix a warning message (bug #79629).
435  - Don't build with AFS support (bug #86514).
436  - Don't explicitly strip binaries (bug #85995).
437  - Really fix bug #83331 for good.
438  - Fix builtins.1.
439  - Actually apply the patch (bug #83331).
440  - Fix history/UTF-8 bug (bug #83331).
441  - More tab-completion fixing (bug #72512).
442  - Force pgrp synchronization (bug #81653).
443  - Prevent prompt overwriting output (bug #74383).
444  - Fix '-rbash' (bug #78455).
445  - Add readline-init patch (bug #74925).
446  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
447  - Ship '.' man page, which doesn't get picked up by glob.
448  - Locale shell variables fix (bug #74701).
449  * Elliot Lee <sopwith@redhat.com>
450  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
451    cross compiles.
452
453* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
454- update to 2.05
455- add README.jpatch to %doc
456- remove patch4 (bash2): revert command name in man pages to "bash"
457  - fix perl command to remove man pages conflict with sh-utils
458- remove section of config.h.in from patch0 to prevent remake of configure
459- change patch9: define in config-top.h to avoid conflict with patch100
460- remove patches 7, 10 & 101
461
462* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
463- made a link for man sh
464
465* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
466- added missing %%post and %%triggerpostun section
467
468* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
469- 2.04-1vl12
470- now bash2 is finally bash
471
472* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
473- build for Playstation2
474
475* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
476- 2.04-1vl10
477- Provides: bash = %%{version}
478
479* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
480- added Provides: bash
481
482* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
483- Obsoletes: bash
484- changed Copyright to License
485
486* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
487- 2.04-1vl7
488- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
489- corrected: bashrc-vine -> bashrc
490
491* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
492- combined bash-1.x and bash-2.x packages
493- added some patches from bash-2.04-13mdk
494
495* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
496- fix spec macros
497- added tests
498
499* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
500- build with gcc-2.95.3
501- partially used rpmmacros
502
503* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
504- minor bug fix in spec file
505
506* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
507- 2.04-1vl3
508- modified %install and %files section to handle compressed man page(s)
509
510* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
511- added pcomplete patch to fix complete if the candidate list is NULL.
512
513* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
514- updated to 2.04
515
[7561]516* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
[521]517- Remove annoying ^H's from documentation
518
519* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
520- patch to detect what executables are required by a script.
521
522* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
523- auto rebuild in the new build environment (release 4)
524
525* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
526- strip binaries.
527- include bash-doc correctly.
528
529* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
530- fixed post/postun /etc/shells work.
531
532* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
533- updated again text in the spec file
534
535* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
536- updated text in spec file.
537- update to 2.03.
538
539* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
540- build it as bash2 instead of bash
541
542* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
543- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
544
545* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
546- rename man pages in bash-doc to avoid packaging conflicts (#606).
547
548* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
549- patch for the arm
550- use $RPM_ARCH-redhat-linux as the build target
551
552* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
553- rewrite %pre, axe %postun (to avoid prereq loops)
554
555* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
556- resurrect for RH 6.0.
557
558* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
559- update to 2.02.1
560
561* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
562- Package for 5.2.
563
564* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
565- added POSIX.NOTES doc file
566- some extraneous doc files removed
567- minor .spec file changes
568
569* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
570- upgraded to version 2.02
571- Alpha, MIPS & Sparc patches removed due to lack of test platforms
572- glibc & signal patches no longer required
573- added documentation subpackage (doc)
574
575* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
576- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
577  is based on a change made in bash 2.0.  Should fix some early exit
578  problems with suspends and fg.
579
580* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
581- added %clean
582
583* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
584- added comment explaining why install-info isn't used
585- added mips patch
586
587* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
588- added BuildRoot
589
590* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
591- built against glibc
Note: See TracBrowser for help on using the repository browser.