source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 5390

Revision 5390, 8.0 KB checked in by Takemikaduchi, 12 years ago (diff)

glew,gambas3: new upstream release
libprojectm, avogadro, kalzium, mesa-demos: rebuild with glew-1.7.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.0.1
9Release:        9%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16# fix FTBFS with SIP 4.11 (Gentoo#335644)
17# patch submitted: http://bugs.gentoo.org/attachment.cgi?id=247308 (upstream is
18# CCed on the Gentoo bug)
19Patch0:         avogadro-1.0.1-sip411.patch
20# fix crash with current SIP and Python 2.7 (#642248)
21Patch1:         avogadro-1.0.1-pycapsule.patch
22
23BuildRequires:  cmake >= 2.6.0
24BuildRequires:  qt4-devel >= 4.5.1
25BuildRequires:  qt4-tools
26BuildRequires:  eigen2-devel >= 2.0.3
27BuildRequires:  openbabel-devel >= 2.2.2
28BuildRequires:  libboost-devel >= 1.35
29BuildRequires:  libboost-python >= 1.35
30BuildRequires:  glew-devel >= 1.5.0
31BuildRequires:  desktop-file-utils
32BuildRequires:  docbook-utils
33BuildRequires:  sip-devel >= 4.11
34BuildRequires:  numpy
35
36Requires: %{name}-libs = %{version}-%{release}
37
38%description
39An advanced molecular editor designed for
40cross-platform use in computational chemistry,
41molecular modeling, bioinformatics, materials science,
42and related areas, which offers flexible rendering and
43a powerful plugin architecture.
44
45
46%package libs
47Summary: Shared libraries for Avogadro
48Summary(ja): Avogadro の共用ライブラリ
49Group: System Environment/Libraries
50Requires: sip
51
52%description libs
53This package contains the shared libraries for the
54molecular editor Avogadro.
55
56
57%package devel
58Summary: Development files for Avogadro
59Summary(ja): Avogadro の開発用ファイル
60Group: Development/Libraries
61Requires: %{name}-libs = %{version}-%{release}
62Requires: qt4-devel = %{_qt4_version}
63Requires: eigen2-devel >= 2.0.3
64Requires: glew-devel >= 1.5.0
65
66%description devel
67This package contains files to develop applications using
68Avogadros libraries.
69
70
71%prep
72%setup -q
73%patch0 -p1 -b .sip411
74%patch1 -p1 -b .pycapsule
75
76# nuke unpatched copy, use working version included in cmake instead -- Rex
77rm -f cmake/modules/FindPythonLibs.cmake
78
79
80%build
81mkdir -p %{_target_platform}
82pushd %{_target_platform}
83cmake -Wno-dev \
84    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
85    -DBIN_INSTALL_DIR:PATH=bin \
86    -DLIB_INSTALL_DIR:PATH=%{_lib} \
87    -DENABLE_GLSL:BOOL=ON \
88    -DENABLE_PYTHON:BOOL=ON \
89    %{?ENABLE_TESTS} ..
90popd
91make %{?_smp_mflags} -C %{_target_platform}
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
97
98
99%check
100desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
101# all of these currently require an active X session, so will fail
102# in mock
103%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
104
105
106%post libs -p /sbin/ldconfig
107
108%postun libs -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root,-)
112%doc AUTHORS ChangeLog COPYING
113%{_bindir}/avogadro
114%{_bindir}/avopkg
115# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
116%{_datadir}/avogadro/
117%{_datadir}/pixmaps/avogadro-icon.png
118%{_datadir}/applications/avogadro.desktop
119%{_mandir}/man1/avogadro.1*
120%{_mandir}/man1/avopkg.1*
121
122%files devel
123%defattr(-,root,root,-)
124%{_includedir}/avogadro/
125%{_libdir}/libavogadro.so
126%{_libdir}/avogadro/*.cmake
127%{_libdir}/avogadro/1_0/*.cmake
128# these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
129%{_libdir}/avogadro/1_0/cmake/
130%{_qt4_prefix}/mkspecs/features/avogadro.prf
131
132%files libs
133%defattr(-,root,root,-)
134%{python_sitelib}/Avogadro.so
135%{_datadir}/libavogadro/
136%{_libdir}/libavogadro.so.1*
137%dir %{_libdir}/avogadro/
138%dir %{_libdir}/avogadro/1_0/
139%{_libdir}/avogadro/1_0/colors/
140%{_libdir}/avogadro/1_0/extensions/
141%{_libdir}/avogadro/1_0/engines/
142%{_libdir}/avogadro/1_0/tools/
143
144
145%changelog
146* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
147- rebuild with qt4-4.8.0 and glew-1.7.0
148
149* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
150- rebuilt with qt4-4.7.2
151- BR: qt4-tools instead of qt4-designer
152
153* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
154- added BR: libboost-python
155- added R: glew-devel, eigen2-devel to devel package
156
157* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
158- rebuilt with qt4-4.7.1
159- added Patch0 and 1 from Fedora
160
161* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
162- rebuilt with libboost-1.45.0
163
164* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
165- Initial build for Vine Linux
166
167* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
168- Rebuild for Boost soname bump
169- Update to match current guidelines
170
171* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
172- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
173
174* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
175- avogadro-1.0.1
176- -devel: move cmake-related files here
177- -devel: Req: qt4-devel
178- %%files: track lib sonames
179- %%check section
180
181* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
182- reenable plugin builds and libs subpackage
183- fix their build with sip 4.10
184
185* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
186- disable plugin builds and libs subpackage
187
188* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
189- rebuild (sip)
190
191* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
192- rebuild (for qt-4.6.0-rc1, f13+)
193
194* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
195- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
196- Requires: %%{name}-libs ...
197
198* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
199- update to new upstream release
200
201* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
202- rebuild (eigen2)
203
204* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
205- fix typo in file list
206
207* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
208- update to new upstream release
209- enable python and glsl support again
210
211* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
213
214* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
215- new upstream release to fix issue with qt 4.5.0 and earlier
216
217* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
218- remove remaining python parts
219- fix files section finally
220
221* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
222- disable python and glsl for now
223- fix files section
224
225* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
226- update to new release
227
228* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
229- update to new release
230
231* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
232- update to new release
233
234* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
235- get desktop file properly installed
236
237* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
238- update to new release
239
240* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
241- update to new release
242
243* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
245
246* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
247- update to new release
248
249* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
250- add handbook to docs
251
252* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
253- add build requirements and fix group names
254
255* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
256- fix typos
257
258* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
259- reorganize spec file
260
261* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
262- rename shared library package and structure spec file
263
264* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
265- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.