source: projects/specs/trunk/a/automake/automake-vl.spec @ 6868

Revision 6868, 7.3 KB checked in by iwamoto, 12 years ago (diff)

update: automake

Line 
1%define api_version 1.11
2
3Summary: A GNU tool for automatically creating Makefiles.
4Summary(ja): Makefile を自動生成するための GNU ツール
5Name: automake
6Version: %{api_version}.1
7Release: 4%{?_dist_release}
8License: GPL
9Group: Development/Tools
10Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.bz2
11Patch100: automake-1.11.1_CVE-2012-3386.patch
12
13URL: http://sources.redhat.com/automake
14Requires: perl, autoconf >= 2.58
15Buildrequires: autoconf >= 2.58
16Requires(pre): install-info
17# Prereq: install-info
18BuildArchitectures: noarch
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke
24
25# run "make check" by default
26%{?_without_check: %define _without_check 1}
27%{!?_without_check: %define _without_check 0}
28
29%description
30Automake is an experimental Makefile generator. Automake was inspired
31by the 4.4BSD make and include files, but aims to be portable and to
32conform to the GNU standards for Makefile variables and targets.
33
34You should install Automake if you are developing software and would
35like to use its ability to automatically generate GNU standard
36Makefiles. If you install Automake, you will also need to install
37GNU's Autoconf package.
38
39
40%prep
41%setup -q -n automake-%{version}
42
43%patch100 -p1 -b .CVE-2012-3386
44
45%build
46./configure --prefix=%{_prefix}
47%{__make} %{?_smp_mflags}
48%if ! %{_without_check}
49  %{__make} check
50%endif
51
52
53%install
54rm -rf ${RPM_BUILD_ROOT}
55%makeinstall
56
57# create this dir empty so we can own it
58mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
59rm -f $RPM_BUILD_ROOT%{_infodir}/dir
60
61
62%clean
63rm -rf ${RPM_BUILD_ROOT}
64
65
66%post
67/sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir
68
69
70%preun
71if [ $1 = 0 ]; then
72    /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir
73fi
74
75
76%files
77%defattr(-,root,root)
78%doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
79%{_bindir}/*
80%{_infodir}/*.info*
81%{_datadir}/automake-%{api_version}
82%{_datadir}/aclocal-%{api_version}
83%dir %{_datadir}/aclocal
84
85
86%changelog
87* Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-4
88- change prereq to Require(pre)
89
90* Sat Aug 11 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-3
91- add patch100 for fix CVE-2012-3386 (world-writable tmp dir)
92
93* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
94- rebuild for Vine 6
95
96* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
97- new upstream release
98
99* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
100- spec in utf-8
101
102* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
103- new upstream release
104
105* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
106- new upstream release
107
108* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
109- new upstream release
110
111* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
112- new upstream release
113
114* Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
115- new upstream release
116
117* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
118- rebuild
119
120* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
121- rebuild
122
123* Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
124- new upstream release
125
126* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
127- based on 1.8-1 from Rawhide and built for Vine Linux
128
129* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
130- new upstream release
131
132* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
133- new upstream release
134
135* Mon Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
136- based on 1.7.5-1 from Rawhide and built for Vine Linux
137
138* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
139- based on 1.7.3-1 from Rawhide and built for Vine Linux
140
141* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
142- based on 1.6.3-1 from Rawhide and built for Vine Linux
143
144* Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
145- bug fix release 1.6.3
146
147* Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
148- add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
149
150* Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
151- 1.6.2 (bug fix release)
152- do "make check" after building
153
154* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
155- automated rebuild
156
157* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
158- 1.6.1
159
160* Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
161- new package based on automake15
162- 1.6
163
164* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
165- better aclocal versioning
166
167* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
168- don't version datadir/automake
169
170* Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
171- version suffix programs and data directories
172- own symlinks to programs and /usr/share/aclocal
173
174* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
175- automated rebuild
176
177* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
178- Completely back out the fix for #56624 for now, it causes more problems
179  than it fixes in either form.
180
181* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
182- Don't use AS_DIRNAME, it doesn't work.
183
184* Tue Jan  7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
185- Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
186
187* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
188- Update to 1.5 - much better to coexist with autoconf 2.52...
189- Fix specfile
190- No patches
191
192* Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
193- dont raise error when there is source in a subdirectory (bug #35156).
194  This was preventing automake from working in binutuls/gas
195  [patch from HJ Lu <hjl@gnu.org>]
196- format long lines of output properly with backslash + newlines as in 1.4
197  (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
198
199* Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
200- 1.4-p5, fixes #48788
201
202* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
203- add the patch from #20559
204- really update to 1.4-p4
205
206* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
207- update to 1.4-p4
208
209* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
210- Version 1.4-p1 to work with libtool-1.4
211
212* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
213- automatic rebuild
214
215* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
216- FHS packaging.
217
218* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
219- fix bug #8870
220
221* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
222- revert to pristine automake-1.4.
223
224* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
225- arm netwinder patch
226
227* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
228- Injected new description and group.
229
230* Mon Feb  8 1999 Jeff Johnson <jbj@redhat.com>
231- add patches from CVS for 6.0beta1
232
233* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
234- update to 1.4.
235
236* Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
237- update to 1.3b.
238- add URL.
239
240* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
241- translations modified for de, fr, tr
242
243* Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
244- updated to 1.3
245
246* Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
247- added BuildRoot; added aclocal files
248
249* Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
250- made it a noarch package
251
252* Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
253- Fixed some tag lines to conform to 5.0 guidelines.
254
255* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
256- updated to 1.2
257
258* Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
259- first version (1.0)
Note: See TracBrowser for help on using the repository browser.