source: projects/specs/trunk/a/automake/automake-vl.spec @ 12546

Revision 12546, 9.1 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1# run "make check" by default
2%bcond_without check
3
4%define api_version 1.16
5
6Summary: A GNU tool for automatically creating Makefiles.
7Summary(ja): Makefile を自動生成するための GNU ツール
8Name: automake
9Version: %{api_version}.3
10Release: 1%{?_dist_release}
11Group: programming
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16License: GPL
17URL: http://sources.redhat.com/automake
18Source: https://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz
19Source2: http://git.savannah.gnu.org/cgit/config.git/plain/config.sub
20Source3: http://git.savannah.gnu.org/cgit/config.git/plain/config.guess
21
22BuildArch: noarch
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires:  autoconf >= 2.58
26BuildRequires:  texinfo
27BuildRequires:  coreutils
28BuildRequires:  findutils
29BuildRequires:  help2man
30BuildRequires:  perl(Thread::Queue)
31BuildRequires:  perl(threads)
32Requires:       perl, autoconf >= 2.58
33# requirements not detected automatically (#919810)
34Requires:       perl(Thread::Queue)
35Requires:       perl(threads)
36Requires(pre):  install-info
37
38# remove bogus Automake perl dependencies and provides
39%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Automake::
40%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Automake::
41
42%description
43Automake is an experimental Makefile generator. Automake was inspired
44by the 4.4BSD make and include files, but aims to be portable and to
45conform to the GNU standards for Makefile variables and targets.
46
47You should install Automake if you are developing software and would
48like to use its ability to automatically generate GNU standard
49Makefiles. If you install Automake, you will also need to install
50GNU's Autoconf package.
51
52
53%prep
54%autosetup -p1
55#autoreconf -vi
56
57for file in %SOURCE2 %SOURCE3; do
58    for dest in $(find -name "$(basename "$file")"); do
59        cp "$file" "$dest"
60    done
61done
62sed -i -e '/t\/vala-.*sh/d' t/list-of-tests.mk
63
64
65%build
66./bootstrap
67%configure
68%{__make} %{?_smp_mflags}
69cp m4/acdir/README README.aclocal
70cp contrib/multilib/README README.multilib
71
72
73%install
74rm -rf ${RPM_BUILD_ROOT}
75make install DESTDIR=${RPM_BUILD_ROOT}
76mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
77
78# create this dir empty so we can own it
79rm -rf ${RPM_BUILD_ROOT}%{_datadir}/aclocal
80mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
81rm -f $RPM_BUILD_ROOT%{_infodir}/dir
82
83
84%check
85%if %{with check}
86%{__make} -k %{?_smp_mflags} check %{?TESTS_FLAGS: TESTS="%{TESTS_FLAGS}"} \
87    || ( cat ./test-suite.log && false )
88%endif
89
90
91%clean
92rm -rf ${RPM_BUILD_ROOT}
93
94
95%post
96/sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir ||:
97
98%preun
99if [ $1 = 0 ]; then
100    /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir  ||:
101fi
102
103
104%files
105%defattr(-,root,root)
106%license COPYING*
107%doc AUTHORS NEWS README THANKS
108%doc REAME.aclocal README.multilib
109%doc %{_pkgdocdir}/amhello-1.0.tar.gz
110%{_bindir}/*
111%{_infodir}/*.info*
112%{_datadir}/automake-%{api_version}
113%{_datadir}/aclocal-%{api_version}
114%{_mandir}/man1/*
115%dir %{_datadir}/aclocal
116
117
118%changelog
119* Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.3-1
120- updated to 1.16.3.
121- dropped Patch0: got same effect by sed.
122- dropped Patch1.
123- imported Patch1 from rawhide.
124
125* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.1-1
126- updated to 1.16.1.
127
128* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-2
129- added Patch0 for perl-5.26.
130
131* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
132- update to 1.14.1
133
134* Sat Sep 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14-1
135- update to 1.14
136- remove Patch1 (automake-1.12.2-vala-fails.patch)
137
138* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.5-1
139- update to 1.12.5
140
141* Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
142- update to 1.12.2
143- add patch1 to skip vala test.
144
145* Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-4
146- change prereq to Require(pre)
147
148* Sat Aug 11 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-3
149- add patch100 for fix CVE-2012-3386 (world-writable tmp dir)
150
151* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
152- rebuild for Vine 6
153
154* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
155- new upstream release
156
157* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
158- spec in utf-8
159
160* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
161- new upstream release
162
163* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
164- new upstream release
165
166* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
167- new upstream release
168
169* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
170- new upstream release
171
172* Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
173- new upstream release
174
175* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
176- rebuild
177
178* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
179- rebuild
180
181* Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
182- new upstream release
183
184* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
185- based on 1.8-1 from Rawhide and built for Vine Linux
186
187* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
188- new upstream release
189
190* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
191- new upstream release
192
193* Sat Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
194- based on 1.7.5-1 from Rawhide and built for Vine Linux
195
196* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
197- based on 1.7.3-1 from Rawhide and built for Vine Linux
198
199* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
200- based on 1.6.3-1 from Rawhide and built for Vine Linux
201
202* Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
203- bug fix release 1.6.3
204
205* Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
206- add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
207
208* Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
209- 1.6.2 (bug fix release)
210- do "make check" after building
211
212* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
213- automated rebuild
214
215* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
216- 1.6.1
217
218* Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
219- new package based on automake15
220- 1.6
221
222* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
223- better aclocal versioning
224
225* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
226- don't version datadir/automake
227
228* Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
229- version suffix programs and data directories
230- own symlinks to programs and /usr/share/aclocal
231
232* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
233- automated rebuild
234
235* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
236- Completely back out the fix for #56624 for now, it causes more problems
237  than it fixes in either form.
238
239* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
240- Don't use AS_DIRNAME, it doesn't work.
241
242* Mon Jan  7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
243- Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
244
245* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
246- Update to 1.5 - much better to coexist with autoconf 2.52...
247- Fix specfile
248- No patches
249
250* Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
251- dont raise error when there is source in a subdirectory (bug #35156).
252  This was preventing automake from working in binutuls/gas
253  [patch from HJ Lu <hjl@gnu.org>]
254- format long lines of output properly with backslash + newlines as in 1.4
255  (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
256
257* Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
258- 1.4-p5, fixes #48788
259
260* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
261- add the patch from #20559
262- really update to 1.4-p4
263
264* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
265- update to 1.4-p4
266
267* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
268- Version 1.4-p1 to work with libtool-1.4
269
270* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
271- automatic rebuild
272
273* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
274- FHS packaging.
275
276* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
277- fix bug #8870
278
279* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
280- revert to pristine automake-1.4.
281
282* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
283- arm netwinder patch
284
285* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
286- Injected new description and group.
287
288* Mon Feb  8 1999 Jeff Johnson <jbj@redhat.com>
289- add patches from CVS for 6.0beta1
290
291* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
292- update to 1.4.
293
294* Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
295- update to 1.3b.
296- add URL.
297
298* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
299- translations modified for de, fr, tr
300
301* Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
302- updated to 1.3
303
304* Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
305- added BuildRoot; added aclocal files
306
307* Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
308- made it a noarch package
309
310* Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
311- Fixed some tag lines to conform to 5.0 guidelines.
312
313* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
314- updated to 1.2
315
316* Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
317- first version (1.0)
Note: See TracBrowser for help on using the repository browser.