source: projects/specs/trunk/a/autofs/autofs-vl.spec @ 8012

Revision 8012, 16.5 KB checked in by Takemikaduchi, 10 years ago (diff)

fix sleep time

Line 
1Summary: A tool for automatically mounting and unmounting filesystems.
2Summary(ja): 自動的にファイルシステムをマウント/アンマウントするツール
3Name: autofs
4Version: 5.0.8
5Release: 2%{?_dist_release}
6Epoch: 1
7License: GPL
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke, kenta
12
13Source: ftp://ftp.kernel.org/pub/linux/daemons/autofs/autofs-%{version}.tar.xz
14# upstream patches
15Patch1: autofs-5.0.8-fix-undefined-authtype_requires_creds-err-if-ldap-en.patch
16Patch2: autofs-5.0.8-fix-master-map-type-check.patch
17Patch3: autofs-5.0.8-fix-task-manager-not-getting-signaled.patch
18
19## Vine Patch(es)
20Patch100: autofs-3.1.7-initdir.patch
21Patch101: autofs-5.0.3-rc.autofs_LSB.patch
22Patch102: autofs-5.0.8-fix-initscript-vine.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: openldap-devel
26BuildRequires: bind-devel, libxml2-devel, openssl-devel
27BuildRequires: util-linux-ng, nfs-utils, e2fsprogs
28BuildRequires: flex, bison
29Requires(post): /sbin/chkconfig
30Requires(preun): /sbin/service
31Requires(postun): /sbin/chkconfig
32Requires(postun): /sbin/service
33Requires: kernel >= 2.6.17
34Requires: bash, sed, gawk, coreutils, grep, module-init-tools, procps
35Provides: autofs-ldap
36Obsoletes: autofs-ldap <= 4.1.4-11vl2
37
38
39%description
40Autofs controls the operation of the automount daemons. The automount
41daemons automatically mount filesystems when you use them and
42unmount them after a period of inactivity. Filesystems can include
43network filesystems, CD-ROMs, floppies and others.
44
45Install this package if you want a program for automatically mounting
46and unmounting filesystems. If your Vine Linux machine is on a
47network, you should install autofs.
48
49%description -l ja
50autofs は automount デーモンの動作を制御します.
51automount デーモンは,ファイルシステムを使う時に自動的にマウントし,
52一定時間使わなければアンマウントしてくれます.
53対象となるファイルシステムには NFS, CD-ROM, フロッピー等があります.
54
55ファイルシステムを自動的にマウント/アンマウントさせたい場合は
56このパッケージをインストールして下さい.Vine Linux をインストールした
57マシンをネットワークに接続しているのならば,autofs をインストール
58すると良いでしょう.
59
60
61%prep
62%setup -q
63echo %{version}-%{release} > .version
64%patch1 -p1
65%patch2 -p1
66%patch3 -p1
67
68## Vine Patch(es)
69if [ "%{_initdir}" = "/etc/rc.d/init.d" ]; then
70    patch -p1 -b --suffix .initdir < %{PATCH100}
71fi
72%patch101 -p1 -b .lsb
73%patch102 -p1 -b .lsb
74
75%build
76CFLAGS="$RPM_OPT_FLAGS -ggdb"; export CFLAGS
77%configure --without-hesiod --without-sasl \
78           --disable-mount-locking --enable-ignore-busy
79make initdir=/etc/rc.d/init.d STRIP=:
80make -C redhat
81
82%install
83[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
84mkdir -p -m755 $RPM_BUILD_ROOT%{_initdir}
85mkdir -p -m755 $RPM_BUILD_ROOT%{_libdir}/autofs
86mkdir -p -m755 $RPM_BUILD_ROOT%{_mandir}/{man5,man8}
87mkdir -p -m755 $RPM_BUILD_ROOT%{_sbindir}
88mkdir -p -m755 $RPM_BUILD_ROOT/etc/sysconfig
89
90make install mandir=%{_mandir} initdir=/etc/rc.d/init.d INSTALLROOT=$RPM_BUILD_ROOT
91make -C redhat
92install -m 755 -d $RPM_BUILD_ROOT/misc
93install -m 755 redhat/autofs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
94install -m 644 redhat/autofs.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/autofs
95
96%clean
97[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
98
99
100%post
101/sbin/chkconfig --add autofs
102
103
104%postun
105if [ $1 -ge 1 ] ; then
106        /sbin/service autofs condrestart > /dev/null 2>&1 || :
107fi
108
109%preun
110if [ "$1" = 0 ] ; then
111        /sbin/service autofs stop > /dev/null 2>&1
112        chkconfig --del autofs
113fi
114
115
116%files
117%defattr(-,root,root)
118%doc CHANGELOG COPYING COPYRIGHT CREDITS patches/*
119%doc samples/*
120%doc README README.*
121%config %{_initdir}/autofs
122%config(noreplace,missingok) /etc/auto.master
123%config(noreplace,missingok) /etc/auto.misc
124%config(noreplace,missingok) /etc/auto.net
125%config(noreplace,missingok) /etc/auto.smb
126%config(noreplace) /etc/autofs_ldap_auth.conf
127%config(noreplace) /etc/sysconfig/autofs
128%{_sbindir}/automount
129%dir /misc
130%dir %{_libdir}/autofs
131%{_libdir}/autofs/*.so
132%{_mandir}/*/*
133
134
135%changelog
136* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.8-2
137- add Patch102 (autofs-5.0.8-fix-initscript-vine.patch)
138
139* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.8-1
140- new upstream release
141- update upstream patches (Patch1-3)
142
143* Sun Apr 17 2011 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.5-2
144- rebuilt on current VineSeed
145
146* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.5-1
147- new upstream release
148- update upstream patches (Patch0-27)
149
150* Wed May 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-4
151- added Patch101: autofs-5.0.3-rc.autofs_LSB.patch to support LSB Header
152
153* Mon Jan 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-3
154- rebuilt with openldap-2.4.11
155
156* Sun Sep 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-2
157- make autofs.init executable. (<BTS:wishes:0160>)
158
159* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-1vl5
160- new upstream release
161- update fedora patches
162
163* Sat Aug 30 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-12vl5
164- applied new versioning policy, spec in utf-8
165
166* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.4-11vl5
167- fix sort option on auto.net (<BTS:490>)
168
169* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl4
170- added patch15 and patch16 imported from Fedora Core 5
171
172* Mon Sep 04 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl3
173- added Obsoletes: autofs-ldap
174- added BuildPrereq: openldap-devel
175
176* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl2
177- removed --without-openldap configure option
178- rebuilt with openldap-2.3.27-0vl1
179
180* Sun Oct 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-11vl1
181- updated based on Fedora
182  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-11
183  - Check the return code of is_local_addr in get_best_mount. (bz #169523)
184  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-10
185  - Fix a buffer overflow with large key lengths
186  - change to the upstream reentrant syslog patch from the band-aid deferred
187    syslog patch.
188  - Get rid of the init script patch that hard-coded the release to redhat.
189    This should be handled properly by all red hat distros.
190  * Wed May  4 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-8
191  - Add in the deferred syslog patch.  This fixes a hung automounter issue
192    related to unsafe calls to syslog in signal handler context.
193  * Tue May  3 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-7
194  - I reversed the checking for multimount entries, breaking those configs!
195    This update puts the code back the way it was before I broke it.
196  * Tue Apr 26 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-6
197  - Fix a race between mounting a share and updating the cache in the parent
198    process.  If the mount completed first, the parent would not expire the
199    stale entry, leaving it first on the list.  This causes map updates to not
200    be recognized (well, worse, they are recognized after the first expire, but
201    not subsequent ones).  Fixes a regression, bug #137026 (rhel3 bug).
202  * Fri Apr 15 2005 Chris Feist <cfeist@redhat.com> - 1:4.1.4-5
203  - Fixed regression with -browse not taking effect.
204  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-4
205  - Finish up with the merge breakage.
206  - Temporary fix for the multimount detection code.  It seems half-baked.
207  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-3
208  - Fix up the one-auto-master patch.  My "improvements" had side-effects.
209  * Wed Oct 27 2004 Chris Feist <cfeist@redhat.com> - 1:4.1.3-34
210  - Added a patch to fix the automounter failing on ldap maps
211    when it couldn't get the whole map.  (ie. when the search
212    limit was lower than the number of results)
213- updated Patch101
214- s/Red Hat/Vines/ in description
215
216* Wed Jun 23 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.1.7-42vl3
217- fix init script (Patch102)
218  not to create lock file when no mountpoints are defined
219
220* Tue Oct 28 2003 Tomoya TAKA <taka@vinelinux.org> 3.1.7-42vl2
221- do not compile/install autofs-ldap-auto-master
222
223* Sun Oct  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.7-42vl1
224- based on Rawhide 3.1.7-42
225  - Fri Apr 25 2003 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-37
226  - sync with current linux/auto_fs.h from the current kernel tree (#88562)
227  - Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-28
228  - try to properly handle nisplus maps (patch from Steve Foster via the
229    autofs mailing list)
230  - override the STRIP makefile variable to not strip binaries (that's the
231    build root policy's job)
232  - Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-21
233  - don't inhibit starting if we have a subsys lock around -- that's the
234    wrong thing to do anyway
235  - don't create a subsys lock if we're unconfigured (#52755)
236- rebuild with new toolchain
237- s/Copyright/License/
238
239* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 3.1.7-2vl2
240- make /etc/vine-release read by autofs.init
241
242* Fri Jan 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
243- 3.1.7-2vl1
244- rebuilt for VineSeed
245- use better macros (%%{_initdir})
246- add Patch100 to cope with initdir :-(
247
248* Thu Jan 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
249- 3.1.7-2vl0
250- based on 3.1.7-2 from Rawhide
251- remove /etc/init.d from PreReq
252- build without openldap and hesiod
253- BuildPreReq: bind-devel again for Vine
254- added Japanese summary and description
255
256* Tue Jan  9 2001 Nalin Dahyabhai <nalin@redhat.com>
257- fix option parsing in lookup_multi (I think)
258- fix multi option handling in our hacked-up init script (reported by Thiago
259  Bartolomei on the autofs mailing list)
260
261* Wed Dec  6 2000 Nalin Dahyabhai <nalin@redhat.com>
262- update to 3.1.7
263- add the man pages back in (fell out in 3.1.6)
264
265* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
266- don't require /etc/auto.master to be there to start
267
268* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
269- update to 3.1.6
270- disable hesiod support because the new bind-devel doesn't include it
271- try to use nsswitch.conf for getting the contents of auto.master
272- only convert YP map names auto_home and auto_mnt
273
274* Fri Sep  8 2000 Nalin Dahyabhai <nalin@redhat.com>
275- add -lresolv to build properly with OpenLDAP 2
276
277* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
278- convert YP map names that start with "auto_" to "auto." (#16753)
279
280* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
281- add an extra pause after the initial shutdown attempt
282
283* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
284- patch init script to not shut down --submount mounts on reload
285- remove temporary files again during reload
286
287* Thu Aug 10 2000 Nalin Dahyabhai <nalin@redhat.com>
288- revert to 3.1.5
289- add 3.1.6pre1 patch to handle LDAP maps
290- add Epoch: to upgrade from Raw Hide or Pinstripe
291- update to 3.1.6pre2
292
293* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
294- work around kernel insmod concurrency problem (#14972) by loading the module
295  at start-time
296
297* Wed Aug  2 2000 Nalin Dahyabhai <nalin@redhat.com>
298- fix duplicate detection for false matches (e.g. "/user" == "/users") (#15183)
299
300* Tue Aug  1 2000 Nalin Dahyabhai <nalin@redhat.com>
301- merge ldap subpackage back into the main one and Obsolete: it
302- clean up build warnings
303- fix errors automounting ext2 filesystems due to uninitialized option string
304
305* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
306- move initscript back
307
308* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
309- automatic rebuild
310
311* Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
312- move the init script to the right place
313
314* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
315- add /net directory to the package
316
317* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
318- do manual unmounting in shutdown script
319- change initscripts prereq to /etc/init.d
320- move autoconf invocation to setup section
321
322* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
323- move condrestart to postun
324- make condrestart check the right file to determine if already running
325
326* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
327- ignore errors in post script
328
329* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
330- use full path to chkconfig
331- full *correct* path to chkconfig
332
333* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
334- smoother starting/stopping on upgrades/removal
335
336* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
337- be more aggressive when shutting down autofs
338- add condrestart support
339
340* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
341- move man pages to %{_mandir}
342
343* Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
344- tweak argument parsing (bug #11801)
345
346* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
347- rebuild in new build environment
348
349* Mon May  8 2000 Nalin Dahyabhai <nalin@redhat.com>
350- fix duplicate detection logic (duh!)
351
352* Tue May  2 2000 Nalin Dahyabhai <nalin@redhat.com>
353- add config: and processname: tags to init script
354
355* Sun Apr 30 2000 Nalin Dahyabhai <nalin@redhat.com>
356- fix shutdown logic (test -z $pid fails with multiple autofs daemons)
357
358* Wed Apr 26 2000 Nalin Dahyabhai <nalin@redhat.com>
359- split off autofs4 for testing & development
360- update patches for autofs4 for feeding back to autofs list
361- make auto.master a noreplace file
362
363* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
364- split lookup_ldap into a subpackage (bug #10874)
365
366* Tue Apr 11 2000 Nalin Dahyabhai <nalin@redhat.com>
367- add LDAP map support, requires openldap
368- tweak init script patch to use fields 2+ for the map name instead of just 2
369
370* Wed Apr 05 2000 Nalin Dahyabhai <nalin@redhat.com>
371- fix bug #10402 by fixing the init script, hopefully for everybody
372- merge patches for the init script into a single patch to send to hpa
373- patch to build on 2.2 and late-series 2.3 kernels
374
375* Tue Feb 29 2000 Nalin Dahyabhai <nalin@redhat.com>
376- enable hesiod support over libbind
377
378* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
379- fix init script bug when startup failed
380- fix option passing in init script
381
382* Sun Feb 13 2000 Nalin Dahyabhai <nalin@redhat.com>
383- make autofs start after ypbind by moving start priority 18, stop to 82
384- make sure that calls to "ps aux" include "www" to avoid snippage
385
386* Wed Feb  2 2000 Nalin Dahyabhai <nalin@redhat.com>
387- make sure all the docs get packaged
388- make init script do status messages like others
389- add "nosuid,nodev" to options for /misc/cd
390- switch to using INSTALLROOT during make install
391
392* Fri Jan 21 2000 Nalin Dahyabhai <nalin@redhat.com>
393- update to 3.1.4
394
395* Mon Sep 20 1999 Cristian Gafton <gafton@redhat.com>
396- use ps axw instead of ps ax in the init script
397
398* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
399- chkconfig --del in %preun, not %postun
400
401* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
402- add patch from HJLu to handle NIS auto.master better
403
404* Wed Aug 25 1999 Cristian Gafton <gafton@redhat.com>
405- fix bug #4708
406
407* Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
408- fix perms on /usr/lib/autofs/*
409- add support for specifying maptype in auto.master
410
411* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
412- add patch from rth to avoid an infinite loop
413
414* Wed Apr 28 1999 Cristian Gafton <gafton@redhat.com>
415- use "autofs" instead of "automount" for /var/lock/subsys lock file
416
417* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
418- enahanced initscript to try to load maps over NIS
419- changed the mount point back to misc (there is a reason we leave /mnt
420  alone)
421- patched back autofs.misc to the version shipped on 5.2 to avoid replacing
422  yet one more config file for those who upgrade
423
424* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
425- upgrade to 3.1.3, fixing smbfs stuff and other things
426- changed mountpoint from /misc to /mnt
427
428* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
429- auto rebuild in the new build environment (release 10)
430
431* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
432- build for kernel-2.2/glibc2.1
433
434* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
435- fix bash2 breakage in init script
436
437* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
438- typo in man page.
439
440* Mon Jul 20 1998 Jeff Johnson <jbj@redhat.com>
441- added sparc to ExclusiveArch.
442
443* Thu May 07 1998 Prospector System <bugs@redhat.com>
444- translations modified for de, fr, tr
445
446* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
447- updated to 3.1.1
448
449* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
450- enhanced initscripts
451
452* Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
453- Link with -lnsl for glibc compliance.
454
455* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
456- exclusivearch for i386 for now, since our kernel packages on
457  other platforms don't include autofs yet.
458- improvements to initscripts.
459
460* Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
461- Built package from 0.3.14 for 5.0
Note: See TracBrowser for help on using the repository browser.