source: projects/specs/trunk/a/autofs/autofs-vl.spec @ 8011

Revision 8011, 16.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1Summary: A tool for automatically mounting and unmounting filesystems.
2Summary(ja): 自動的にファイルシステムをマウント/アンマウントするツール
3Name: autofs
4Version: 5.0.8
5Release: 1%{?_dist_release}
6Epoch: 1
7License: GPL
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke, kenta
12
13Source: ftp://ftp.kernel.org/pub/linux/daemons/autofs/autofs-%{version}.tar.xz
14# upstream patches
15Patch1: autofs-5.0.8-fix-undefined-authtype_requires_creds-err-if-ldap-en.patch
16Patch2: autofs-5.0.8-fix-master-map-type-check.patch
17Patch3: autofs-5.0.8-fix-task-manager-not-getting-signaled.patch
18
19## Vine Patch(es)
20Patch100: autofs-3.1.7-initdir.patch
21Patch101: autofs-5.0.3-rc.autofs_LSB.patch
22
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: openldap-devel
25BuildRequires: bind-devel, libxml2-devel, openssl-devel
26BuildRequires: util-linux-ng, nfs-utils, e2fsprogs
27BuildRequires: flex, bison
28Requires(post): /sbin/chkconfig
29Requires(preun): /sbin/service
30Requires(postun): /sbin/chkconfig
31Requires(postun): /sbin/service
32Requires: kernel >= 2.6.17
33Requires: bash, sed, gawk, coreutils, grep, module-init-tools, procps
34Provides: autofs-ldap
35Obsoletes: autofs-ldap <= 4.1.4-11vl2
36
37
38%description
39Autofs controls the operation of the automount daemons. The automount
40daemons automatically mount filesystems when you use them and
41unmount them after a period of inactivity. Filesystems can include
42network filesystems, CD-ROMs, floppies and others.
43
44Install this package if you want a program for automatically mounting
45and unmounting filesystems. If your Vine Linux machine is on a
46network, you should install autofs.
47
48%description -l ja
49autofs は automount デーモンの動作を制御します.
50automount デーモンは,ファイルシステムを使う時に自動的にマウントし,
51一定時間使わなければアンマウントしてくれます.
52対象となるファイルシステムには NFS, CD-ROM, フロッピー等があります.
53
54ファイルシステムを自動的にマウント/アンマウントさせたい場合は
55このパッケージをインストールして下さい.Vine Linux をインストールした
56マシンをネットワークに接続しているのならば,autofs をインストール
57すると良いでしょう.
58
59
60%prep
61%setup -q
62echo %{version}-%{release} > .version
63%patch1 -p1
64%patch2 -p1
65%patch3 -p1
66
67## Vine Patch(es)
68if [ "%{_initdir}" = "/etc/rc.d/init.d" ]; then
69    patch -p1 -b --suffix .initdir < %{PATCH100}
70fi
71%patch101 -p1 -b .lsb
72
73%build
74CFLAGS="$RPM_OPT_FLAGS -ggdb"; export CFLAGS
75%configure --without-hesiod --without-sasl \
76           --disable-mount-locking --enable-ignore-busy
77make initdir=/etc/rc.d/init.d STRIP=:
78make -C redhat
79
80%install
81[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
82mkdir -p -m755 $RPM_BUILD_ROOT%{_initdir}
83mkdir -p -m755 $RPM_BUILD_ROOT%{_libdir}/autofs
84mkdir -p -m755 $RPM_BUILD_ROOT%{_mandir}/{man5,man8}
85mkdir -p -m755 $RPM_BUILD_ROOT%{_sbindir}
86mkdir -p -m755 $RPM_BUILD_ROOT/etc/sysconfig
87
88make install mandir=%{_mandir} initdir=/etc/rc.d/init.d INSTALLROOT=$RPM_BUILD_ROOT
89make -C redhat
90install -m 755 -d $RPM_BUILD_ROOT/misc
91install -m 755 redhat/autofs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
92install -m 644 redhat/autofs.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/autofs
93
94%clean
95[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
96
97
98%post
99/sbin/chkconfig --add autofs
100
101
102%postun
103if [ $1 -ge 1 ] ; then
104        /sbin/service autofs condrestart > /dev/null 2>&1 || :
105fi
106
107%preun
108if [ "$1" = 0 ] ; then
109        /sbin/service autofs stop > /dev/null 2>&1
110        chkconfig --del autofs
111fi
112
113
114%files
115%defattr(-,root,root)
116%doc CHANGELOG COPYING COPYRIGHT CREDITS patches/*
117%doc samples/*
118%doc README README.*
119%config %{_initdir}/autofs
120%config(noreplace,missingok) /etc/auto.master
121%config(noreplace,missingok) /etc/auto.misc
122%config(noreplace,missingok) /etc/auto.net
123%config(noreplace,missingok) /etc/auto.smb
124%config(noreplace) /etc/autofs_ldap_auth.conf
125%config(noreplace) /etc/sysconfig/autofs
126%{_sbindir}/automount
127%dir /misc
128%dir %{_libdir}/autofs
129%{_libdir}/autofs/*.so
130%{_mandir}/*/*
131
132
133%changelog
134* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.8-1
135- new upstream release
136- update upstream patches (Patch1-3)
137
138* Sun Apr 17 2011 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.5-2
139- rebuilt on current VineSeed
140
141* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.5-1
142- new upstream release
143- update upstream patches (Patch0-27)
144
145* Wed May 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-4
146- added Patch101: autofs-5.0.3-rc.autofs_LSB.patch to support LSB Header
147
148* Mon Jan 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-3
149- rebuilt with openldap-2.4.11
150
151* Sun Sep 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-2
152- make autofs.init executable. (<BTS:wishes:0160>)
153
154* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-1vl5
155- new upstream release
156- update fedora patches
157
158* Sat Aug 30 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-12vl5
159- applied new versioning policy, spec in utf-8
160
161* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.4-11vl5
162- fix sort option on auto.net (<BTS:490>)
163
164* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl4
165- added patch15 and patch16 imported from Fedora Core 5
166
167* Mon Sep 04 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl3
168- added Obsoletes: autofs-ldap
169- added BuildPrereq: openldap-devel
170
171* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl2
172- removed --without-openldap configure option
173- rebuilt with openldap-2.3.27-0vl1
174
175* Sun Oct 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-11vl1
176- updated based on Fedora
177  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-11
178  - Check the return code of is_local_addr in get_best_mount. (bz #169523)
179  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-10
180  - Fix a buffer overflow with large key lengths
181  - change to the upstream reentrant syslog patch from the band-aid deferred
182    syslog patch.
183  - Get rid of the init script patch that hard-coded the release to redhat.
184    This should be handled properly by all red hat distros.
185  * Wed May  4 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-8
186  - Add in the deferred syslog patch.  This fixes a hung automounter issue
187    related to unsafe calls to syslog in signal handler context.
188  * Tue May  3 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-7
189  - I reversed the checking for multimount entries, breaking those configs!
190    This update puts the code back the way it was before I broke it.
191  * Tue Apr 26 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-6
192  - Fix a race between mounting a share and updating the cache in the parent
193    process.  If the mount completed first, the parent would not expire the
194    stale entry, leaving it first on the list.  This causes map updates to not
195    be recognized (well, worse, they are recognized after the first expire, but
196    not subsequent ones).  Fixes a regression, bug #137026 (rhel3 bug).
197  * Fri Apr 15 2005 Chris Feist <cfeist@redhat.com> - 1:4.1.4-5
198  - Fixed regression with -browse not taking effect.
199  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-4
200  - Finish up with the merge breakage.
201  - Temporary fix for the multimount detection code.  It seems half-baked.
202  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-3
203  - Fix up the one-auto-master patch.  My "improvements" had side-effects.
204  * Wed Oct 27 2004 Chris Feist <cfeist@redhat.com> - 1:4.1.3-34
205  - Added a patch to fix the automounter failing on ldap maps
206    when it couldn't get the whole map.  (ie. when the search
207    limit was lower than the number of results)
208- updated Patch101
209- s/Red Hat/Vines/ in description
210
211* Wed Jun 23 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.1.7-42vl3
212- fix init script (Patch102)
213  not to create lock file when no mountpoints are defined
214
215* Tue Oct 28 2003 Tomoya TAKA <taka@vinelinux.org> 3.1.7-42vl2
216- do not compile/install autofs-ldap-auto-master
217
218* Sun Oct  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.7-42vl1
219- based on Rawhide 3.1.7-42
220  - Fri Apr 25 2003 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-37
221  - sync with current linux/auto_fs.h from the current kernel tree (#88562)
222  - Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-28
223  - try to properly handle nisplus maps (patch from Steve Foster via the
224    autofs mailing list)
225  - override the STRIP makefile variable to not strip binaries (that's the
226    build root policy's job)
227  - Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-21
228  - don't inhibit starting if we have a subsys lock around -- that's the
229    wrong thing to do anyway
230  - don't create a subsys lock if we're unconfigured (#52755)
231- rebuild with new toolchain
232- s/Copyright/License/
233
234* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 3.1.7-2vl2
235- make /etc/vine-release read by autofs.init
236
237* Fri Jan 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
238- 3.1.7-2vl1
239- rebuilt for VineSeed
240- use better macros (%%{_initdir})
241- add Patch100 to cope with initdir :-(
242
243* Thu Jan 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
244- 3.1.7-2vl0
245- based on 3.1.7-2 from Rawhide
246- remove /etc/init.d from PreReq
247- build without openldap and hesiod
248- BuildPreReq: bind-devel again for Vine
249- added Japanese summary and description
250
251* Tue Jan  9 2001 Nalin Dahyabhai <nalin@redhat.com>
252- fix option parsing in lookup_multi (I think)
253- fix multi option handling in our hacked-up init script (reported by Thiago
254  Bartolomei on the autofs mailing list)
255
256* Wed Dec  6 2000 Nalin Dahyabhai <nalin@redhat.com>
257- update to 3.1.7
258- add the man pages back in (fell out in 3.1.6)
259
260* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
261- don't require /etc/auto.master to be there to start
262
263* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
264- update to 3.1.6
265- disable hesiod support because the new bind-devel doesn't include it
266- try to use nsswitch.conf for getting the contents of auto.master
267- only convert YP map names auto_home and auto_mnt
268
269* Fri Sep  8 2000 Nalin Dahyabhai <nalin@redhat.com>
270- add -lresolv to build properly with OpenLDAP 2
271
272* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
273- convert YP map names that start with "auto_" to "auto." (#16753)
274
275* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
276- add an extra pause after the initial shutdown attempt
277
278* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
279- patch init script to not shut down --submount mounts on reload
280- remove temporary files again during reload
281
282* Thu Aug 10 2000 Nalin Dahyabhai <nalin@redhat.com>
283- revert to 3.1.5
284- add 3.1.6pre1 patch to handle LDAP maps
285- add Epoch: to upgrade from Raw Hide or Pinstripe
286- update to 3.1.6pre2
287
288* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
289- work around kernel insmod concurrency problem (#14972) by loading the module
290  at start-time
291
292* Wed Aug  2 2000 Nalin Dahyabhai <nalin@redhat.com>
293- fix duplicate detection for false matches (e.g. "/user" == "/users") (#15183)
294
295* Tue Aug  1 2000 Nalin Dahyabhai <nalin@redhat.com>
296- merge ldap subpackage back into the main one and Obsolete: it
297- clean up build warnings
298- fix errors automounting ext2 filesystems due to uninitialized option string
299
300* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
301- move initscript back
302
303* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
304- automatic rebuild
305
306* Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
307- move the init script to the right place
308
309* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
310- add /net directory to the package
311
312* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
313- do manual unmounting in shutdown script
314- change initscripts prereq to /etc/init.d
315- move autoconf invocation to setup section
316
317* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
318- move condrestart to postun
319- make condrestart check the right file to determine if already running
320
321* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
322- ignore errors in post script
323
324* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
325- use full path to chkconfig
326- full *correct* path to chkconfig
327
328* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
329- smoother starting/stopping on upgrades/removal
330
331* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
332- be more aggressive when shutting down autofs
333- add condrestart support
334
335* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
336- move man pages to %{_mandir}
337
338* Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
339- tweak argument parsing (bug #11801)
340
341* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
342- rebuild in new build environment
343
344* Mon May  8 2000 Nalin Dahyabhai <nalin@redhat.com>
345- fix duplicate detection logic (duh!)
346
347* Tue May  2 2000 Nalin Dahyabhai <nalin@redhat.com>
348- add config: and processname: tags to init script
349
350* Sun Apr 30 2000 Nalin Dahyabhai <nalin@redhat.com>
351- fix shutdown logic (test -z $pid fails with multiple autofs daemons)
352
353* Wed Apr 26 2000 Nalin Dahyabhai <nalin@redhat.com>
354- split off autofs4 for testing & development
355- update patches for autofs4 for feeding back to autofs list
356- make auto.master a noreplace file
357
358* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
359- split lookup_ldap into a subpackage (bug #10874)
360
361* Tue Apr 11 2000 Nalin Dahyabhai <nalin@redhat.com>
362- add LDAP map support, requires openldap
363- tweak init script patch to use fields 2+ for the map name instead of just 2
364
365* Wed Apr 05 2000 Nalin Dahyabhai <nalin@redhat.com>
366- fix bug #10402 by fixing the init script, hopefully for everybody
367- merge patches for the init script into a single patch to send to hpa
368- patch to build on 2.2 and late-series 2.3 kernels
369
370* Tue Feb 29 2000 Nalin Dahyabhai <nalin@redhat.com>
371- enable hesiod support over libbind
372
373* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
374- fix init script bug when startup failed
375- fix option passing in init script
376
377* Sun Feb 13 2000 Nalin Dahyabhai <nalin@redhat.com>
378- make autofs start after ypbind by moving start priority 18, stop to 82
379- make sure that calls to "ps aux" include "www" to avoid snippage
380
381* Wed Feb  2 2000 Nalin Dahyabhai <nalin@redhat.com>
382- make sure all the docs get packaged
383- make init script do status messages like others
384- add "nosuid,nodev" to options for /misc/cd
385- switch to using INSTALLROOT during make install
386
387* Fri Jan 21 2000 Nalin Dahyabhai <nalin@redhat.com>
388- update to 3.1.4
389
390* Mon Sep 20 1999 Cristian Gafton <gafton@redhat.com>
391- use ps axw instead of ps ax in the init script
392
393* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
394- chkconfig --del in %preun, not %postun
395
396* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
397- add patch from HJLu to handle NIS auto.master better
398
399* Wed Aug 25 1999 Cristian Gafton <gafton@redhat.com>
400- fix bug #4708
401
402* Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
403- fix perms on /usr/lib/autofs/*
404- add support for specifying maptype in auto.master
405
406* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
407- add patch from rth to avoid an infinite loop
408
409* Wed Apr 28 1999 Cristian Gafton <gafton@redhat.com>
410- use "autofs" instead of "automount" for /var/lock/subsys lock file
411
412* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
413- enahanced initscript to try to load maps over NIS
414- changed the mount point back to misc (there is a reason we leave /mnt
415  alone)
416- patched back autofs.misc to the version shipped on 5.2 to avoid replacing
417  yet one more config file for those who upgrade
418
419* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
420- upgrade to 3.1.3, fixing smbfs stuff and other things
421- changed mountpoint from /misc to /mnt
422
423* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
424- auto rebuild in the new build environment (release 10)
425
426* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
427- build for kernel-2.2/glibc2.1
428
429* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
430- fix bash2 breakage in init script
431
432* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
433- typo in man page.
434
435* Mon Jul 20 1998 Jeff Johnson <jbj@redhat.com>
436- added sparc to ExclusiveArch.
437
438* Thu May 07 1998 Prospector System <bugs@redhat.com>
439- translations modified for de, fr, tr
440
441* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
442- updated to 3.1.1
443
444* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
445- enhanced initscripts
446
447* Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
448- Link with -lnsl for glibc compliance.
449
450* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
451- exclusivearch for i386 for now, since our kernel packages on
452  other platforms don't include autofs yet.
453- improvements to initscripts.
454
455* Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
456- Built package from 0.3.14 for 5.0
Note: See TracBrowser for help on using the repository browser.