source: projects/specs/trunk/a/autoconf/autoconf-vl.spec @ 7938

Revision 7938, 10.7 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3Summary: A GNU tool for automatically configuring source code.
4Summary(ja): ソースコードを自動的に設定するための GNU ツール
5Name: autoconf
6Version: 2.69
7Release: 1%{?_dist_release}
8License: GPL
9Group: Development/Tools
10URL: http://www.gnu.org/software/autoconf/
11
12Source: ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
13
14# Vine Source(s)
15Source10: autoconf-mode-install.sh
16Source11: autoconf-mode-remove.sh
17
18Requires(post,preun): /sbin/install-info
19Requires: gawk, m4, mktemp, perl, textutils
20Obsoletes: autoconf253
21BuildArch: noarch
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24%description
25GNU's Autoconf is a tool for configuring source code and Makefiles.
26Using Autoconf, programmers can create portable and configurable
27packages, since the person building the package is allowed to
28specify various configuration options.
29
30You should install Autoconf if you are developing software and
31would like to create shell scripts that configure your source code
32packages. If you are installing Autoconf, you will also need to
33install the GNU m4 package.
34
35Note that the Autoconf package is not required for the end-user who
36may be configuring software with an Autoconf-generated script;
37Autoconf is only required for the generation of the scripts, not
38their use.
39
40%description -l ja
41GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
42です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
43作ることができます.そのため,パッケージ作成者はさまざまな設定
44オプションを指定できます。
45
46ソフトウェアを開発していてソースコードパッケージを設定するシェル
47スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
48Autoconf をインストールするためには GNU m4 パッケージもインストールする
49必要があります.
50
51Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
52エンドユーザには Autoconf パッケージが必要ないことに注目してください.
53Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
54必要ありません.
55
56%package mode
57Summary: Emacs-lisp autoconf-mode for autoconf/autotest
58Group: Applications/Editors/Emacs
59BuildRequires: emacsen
60%prereq_ge emacsen-common
61Requires: emacsen
62
63%description mode
64Emacs-lisp autoconf-mode for autoconf/autotest
65
66
67%prep
68%setup -q -n autoconf-%{version}
69#patch0 -p1
70
71
72%build
73%configure
74make
75
76#make check
77
78%install
79rm -rf ${RPM_BUILD_ROOT}
80%makeinstall
81
82gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
83
84# We don't want to include the standards.info stuff in the package,
85# because it comes from binutils...
86rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
87# cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
88
89# remove info dir file since it isn't packaged
90rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
91
92# move elisp files
93pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
94mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
95mv *.el autoconf-mode/
96popd
97
98# emacsen-common-ize
99mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
100#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
101#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
102mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
103mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
104
105%_installemacsenscript autoconf-mode %{SOURCE10}
106
107%_removeemacsenscript  autoconf-mode %{SOURCE11}
108
109
110%clean
111rm -rf ${RPM_BUILD_ROOT}
112
113
114%post
115/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
116
117
118%post mode
119
120if [ "$1" = 2 ]; then
121
122%_emacsenPackageRemove autoconf-mode
123
124fi
125
126%_addemacsenlist autoconf-mode
127
128%_emacsenPackageInstall autoconf-mode
129
130
131%preun
132if [ "$1" = 0 ]; then
133    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
134fi
135
136
137%preun mode
138
139if [ "$1" = 0 ]; then
140
141%_emacsenPackageRemove autoconf-mode
142
143%_removeemacsenlist autoconf-mode
144
145fi
146
147
148%files
149%defattr(-,root,root)
150%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
151%{_bindir}/*
152%{_infodir}/*.info*
153%{_datadir}/autoconf
154%{_mandir}/man1/*
155
156
157%files mode
158%defattr(-,root,root)
159%{_datadir}/emacs/site-lisp/autoconf-mode/
160#/usr/lib/emacsen-common/packages/install/autoconf-mode
161#/usr/lib/emacsen-common/packages/remove/autoconf-mode
162%{emacsen_pkgdir}/install/autoconf-mode
163%{emacsen_pkgdir}/remove/autoconf-mode
164
165
166%changelog
167* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.69-1
168- upate to 2.69
169
170* Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
171- new upstream release
172
173* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
174- rebuilt with rpm-4.8.1-3
175
176* Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
177- new upstream release
178
179* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
180- new upstream release
181- dropped Patch0 (merged into upstream)
182
183* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
184- added %%emacsen_pkgdir macro
185- spec in utf-8
186
187* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
188- import Patch0 from Fedora 2.62-2
189  * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
190  - add upstream fix from Eric Blake for #449973,
191    m4_if releated error message from autotest
192
193* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
194- new upstream release
195
196* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
197- new upstream release
198
199* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
200- changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
201- added Japanese summary and description from vinedocs.sourceforge.jp
202- s/Copyright/License/
203
204* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
205- rebuild
206
207* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
208- rebuild
209
210* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
211- update to 2.59 bugfix release
212
213* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
214- new upstream release
215
216* Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
217- source update
218
219* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
220- don't show annoying messages during elisp compilation
221
222* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
223- based on 2.56-1 from Rawhide and built for Vine Linux
224- emacsen-common-ize
225
226* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
227- update to 2.56
228- obsolete autoheader-warn patch
229- no longer provide autoconf253
230- include site-lisp and man files
231- remove info dir which is not in the manifest
232- do not version suffix bin files for now
233
234* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
235- make check
236
237* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
238- update url (#66840)
239- added doc files
240
241* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
242- automated rebuild
243
244* Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
245- automated rebuild
246
247* Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
248- provide autoconf253
249
250* Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
251- obsolete autoconf253
252
253* Wed May  8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
254- patch autoheader so that --warnings=CATEGORY works (#64566)
255  [reported with fix by hjl@gnu.org]
256
257* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
258- update to autoconf-2.53
259- drop mawk patch again
260- version suffix bindir files and add symlinks to unversioned names
261
262* Fri Feb  1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
263- revert to 2.52 (also fixes #58210!)
264- remove relversion variable
265- bring back mawk -> gawk patch
266
267* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
268- automated rebuild
269
270* Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
271- update to 2.52f
272- add URL
273- minor description improvements
274- define relversion to carry version number
275- mawk.patch no longer needed
276
277* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
278- rebuild
279
280* Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
281- restore patch to prefer gawk to mawk
282
283* Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
284- update to 2.52d
285
286* Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
287- update to 2.52
288- remove obsolete patches, since already new version
289- dont install install-sh
290
291* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
292- add patch to include various standard C headers as needed
293  by various autoconf tests (#19114)
294- add patch to autoscan.pl to get a better choice of init
295  file (#42071), to test for CPP after CC (#42072) and to
296  detect C++ source and g++ (#42073).
297
298* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
299- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
300  from version 2.50 to make detection of C++ exit()
301  declaration prototype platform independent.  The check is
302  done in AC_PROG_CXX with the result stored in "confdefs.h".
303  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
304  (fixes #18829)
305
306* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
307- Fix up interoperability with glibc 2.2 and gcc 2.96:
308  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
309  the test code without throwing an exception, causing a conflict
310  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
311  always failed, returning wrong results
312
313* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
314- add textutils as a dependency (#14439)
315
316* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
317- automatic rebuild
318
319* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
320- FHS packaging.
321
322* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
323- fix preun
324
325* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
326- add patch to help autoconf clean after itself and not leave /tmp clobbered
327  with acin.* and acout.* files (can you say annoying?)
328
329* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
330- auto rebuild in the new build environment (release 4)
331- use gawk, not mawk
332
333* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
334- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
335
336* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
337- Injected new description and group.
338
339* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
340- update to 2.13.
341
342* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
343- build against glibc 2.1
344
345* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
346- requires perl
347
348* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
349- patch for fixing /tmp race conditions
350
351* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
352- spec file cleanups
353- made a noarch package
354- uses autoconf
355- uses install-info
356
357* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
358- built with glibc
359
Note: See TracBrowser for help on using the repository browser.