source: projects/specs/trunk/a/autoconf/autoconf-vl.spec @ 12546

Revision 12546, 11.1 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1# run "make check" by default
2%bcond_without check
3
4%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
5
6Summary: A GNU tool for automatically configuring source code.
7Summary(ja): ソースコードを自動的に設定するための GNU ツール
8Name: autoconf
9Version: 2.71
10Release: 1%{?_dist_release}
11Group: programming
12Vendor: Project Vine
13Distribution: Vine Linux
14
15License: GPL
16URL: http://www.gnu.org/software/autoconf/
17
18Source: http://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
19Patch2: autoconf-test38.patch
20
21# Vine Source(s)
22Source10: autoconf-mode-install.sh
23Source11: autoconf-mode-remove.sh
24
25Requires(post,preun): /sbin/install-info
26Requires: gawk, m4, mktemp, perl, textutils
27Obsoletes: autoconf253 < 2.54
28BuildArch: noarch
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31%description
32GNU's Autoconf is a tool for configuring source code and Makefiles.
33Using Autoconf, programmers can create portable and configurable
34packages, since the person building the package is allowed to
35specify various configuration options.
36
37You should install Autoconf if you are developing software and
38would like to create shell scripts that configure your source code
39packages. If you are installing Autoconf, you will also need to
40install the GNU m4 package.
41
42Note that the Autoconf package is not required for the end-user who
43may be configuring software with an Autoconf-generated script;
44Autoconf is only required for the generation of the scripts, not
45their use.
46
47%description -l ja
48GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
49です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
50作ることができます.そのため,パッケージ作成者はさまざまな設定
51オプションを指定できます。
52
53ソフトウェアを開発していてソースコードパッケージを設定するシェル
54スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
55Autoconf をインストールするためには GNU m4 パッケージもインストールする
56必要があります.
57
58Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
59エンドユーザには Autoconf パッケージが必要ないことに注目してください.
60Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
61必要ありません.
62
63
64%package mode
65Summary: Emacs-lisp autoconf-mode for autoconf/autotest
66Group: programming
67BuildRequires: emacs
68%prereq_ge emacsen-common
69Requires: emacsen
70
71%description mode
72Emacs-lisp autoconf-mode for autoconf/autotest
73
74
75%prep
76%setup -q -n autoconf-%{version}
77%patch2 -p1
78
79
80%build
81%configure
82make %{?_smp_mflags}
83
84
85%install
86rm -rf ${RPM_BUILD_ROOT}
87%makeinstall
88
89gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
90
91# We don't want to include the standards.info stuff in the package,
92# because it comes from binutils...
93rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
94# cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
95
96# remove info dir file since it isn't packaged
97rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
98
99# move elisp files
100pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
101mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
102mv *.el autoconf-mode/
103popd
104
105# emacsen-common-ize
106mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
107#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
108#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
109mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
110mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
111
112%_installemacsenscript autoconf-mode %{SOURCE10}
113
114%_removeemacsenscript  autoconf-mode %{SOURCE11}
115
116rm -f %{buildroot}%{_datadir}/emacs/site-lisp/auto*-mode.elc
117
118
119%check
120%if %{with check}
121make check %{?_smp_mflags}
122%endif
123
124
125%clean
126rm -rf ${RPM_BUILD_ROOT}
127
128
129%post
130/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
131
132%post mode
133if [ "$1" = 2 ]; then
134%_emacsenPackageRemove autoconf-mode
135fi
136%_addemacsenlist autoconf-mode
137%_emacsenPackageInstall autoconf-mode
138
139%preun
140if [ "$1" = 0 ]; then
141    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
142fi
143
144
145%preun mode
146if [ "$1" = 0 ]; then
147%_emacsenPackageRemove autoconf-mode
148%_removeemacsenlist autoconf-mode
149fi
150
151
152%files
153%defattr(-,root,root)
154%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
155%{_bindir}/*
156%{_infodir}/*.info*
157%{_datadir}/autoconf
158%{_mandir}/man1/*
159
160%files mode
161%defattr(-,root,root)
162%{_datadir}/emacs/site-lisp/autoconf-mode/
163#/usr/lib/emacsen-common/packages/install/autoconf-mode
164#/usr/lib/emacsen-common/packages/remove/autoconf-mode
165%{emacsen_pkgdir}/install/autoconf-mode
166%{emacsen_pkgdir}/remove/autoconf-mode
167
168
169%changelog
170* Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.71-1
171- updated to 2.71.
172- dropped Patch1 and 3: fixed in upstream.
173- updated Patch2.
174
175* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.69-2
176- added Patch1-3.
177
178* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.69-1
179- update to 2.69
180
181* Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
182- new upstream release
183
184* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
185- rebuilt with rpm-4.8.1-3
186
187* Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
188- new upstream release
189
190* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
191- new upstream release
192- dropped Patch0 (merged into upstream)
193
194* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
195- added %%emacsen_pkgdir macro
196- spec in utf-8
197
198* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
199- import Patch0 from Fedora 2.62-2
200  * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
201  - add upstream fix from Eric Blake for #449973,
202    m4_if releated error message from autotest
203
204* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
205- new upstream release
206
207* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
208- new upstream release
209
210* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
211- changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
212- added Japanese summary and description from vinedocs.sourceforge.jp
213- s/Copyright/License/
214
215* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
216- rebuild
217
218* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
219- rebuild
220
221* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
222- update to 2.59 bugfix release
223
224* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
225- new upstream release
226
227* Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
228- source update
229
230* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
231- don't show annoying messages during elisp compilation
232
233* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
234- based on 2.56-1 from Rawhide and built for Vine Linux
235- emacsen-common-ize
236
237* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
238- update to 2.56
239- obsolete autoheader-warn patch
240- no longer provide autoconf253
241- include site-lisp and man files
242- remove info dir which is not in the manifest
243- do not version suffix bin files for now
244
245* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
246- make check
247
248* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
249- update url (#66840)
250- added doc files
251
252* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
253- automated rebuild
254
255* Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
256- automated rebuild
257
258* Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
259- provide autoconf253
260
261* Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
262- obsolete autoconf253
263
264* Wed May  8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
265- patch autoheader so that --warnings=CATEGORY works (#64566)
266  [reported with fix by hjl@gnu.org]
267
268* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
269- update to autoconf-2.53
270- drop mawk patch again
271- version suffix bindir files and add symlinks to unversioned names
272
273* Fri Feb  1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
274- revert to 2.52 (also fixes #58210!)
275- remove relversion variable
276- bring back mawk -> gawk patch
277
278* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
279- automated rebuild
280
281* Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
282- update to 2.52f
283- add URL
284- minor description improvements
285- define relversion to carry version number
286- mawk.patch no longer needed
287
288* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
289- rebuild
290
291* Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
292- restore patch to prefer gawk to mawk
293
294* Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
295- update to 2.52d
296
297* Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
298- update to 2.52
299- remove obsolete patches, since already new version
300- dont install install-sh
301
302* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
303- add patch to include various standard C headers as needed
304  by various autoconf tests (#19114)
305- add patch to autoscan.pl to get a better choice of init
306  file (#42071), to test for CPP after CC (#42072) and to
307  detect C++ source and g++ (#42073).
308
309* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
310- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
311  from version 2.50 to make detection of C++ exit()
312  declaration prototype platform independent.  The check is
313  done in AC_PROG_CXX with the result stored in "confdefs.h".
314  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
315  (fixes #18829)
316
317* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
318- Fix up interoperability with glibc 2.2 and gcc 2.96:
319  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
320  the test code without throwing an exception, causing a conflict
321  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
322  always failed, returning wrong results
323
324* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
325- add textutils as a dependency (#14439)
326
327* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
328- automatic rebuild
329
330* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
331- FHS packaging.
332
333* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
334- fix preun
335
336* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
337- add patch to help autoconf clean after itself and not leave /tmp clobbered
338  with acin.* and acout.* files (can you say annoying?)
339
340* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
341- auto rebuild in the new build environment (release 4)
342- use gawk, not mawk
343
344* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
345- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
346
347* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
348- Injected new description and group.
349
350* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
351- update to 2.13.
352
353* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
354- build against glibc 2.1
355
356* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
357- requires perl
358
359* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
360- patch for fixing /tmp race conditions
361
362* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
363- spec file cleanups
364- made a noarch package
365- uses autoconf
366- uses install-info
367
368* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
369- built with glibc
370
Note: See TracBrowser for help on using the repository browser.