source: projects/specs/trunk/a/autoconf/autoconf-vl.spec @ 521

Revision 521, 10.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4Summary: A GNU tool for automatically configuring source code.
5Summary(ja): ソースコードを自動的に設定するための GNU ツール
6Name: autoconf
7Version: 2.63
8Release: 1%{?_dist_release}
9License: GPL
10Group: Development/Tools
11URL: http://www.gnu.org/software/autoconf/
12
13Source: ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.bz2
14
15# Vine Source(s)
16Source10: autoconf-mode-install.sh
17Source11: autoconf-mode-remove.sh
18
19Prereq(post,preun): /sbin/install-info
20Requires: gawk, m4, mktemp, perl, textutils
21Obsoletes: autoconf253
22BuildArch: noarch
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25%description
26GNU's Autoconf is a tool for configuring source code and Makefiles.
27Using Autoconf, programmers can create portable and configurable
28packages, since the person building the package is allowed to
29specify various configuration options.
30
31You should install Autoconf if you are developing software and
32would like to create shell scripts that configure your source code
33packages. If you are installing Autoconf, you will also need to
34install the GNU m4 package.
35
36Note that the Autoconf package is not required for the end-user who
37may be configuring software with an Autoconf-generated script;
38Autoconf is only required for the generation of the scripts, not
39their use.
40
41%description -l ja
42GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
43です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
44作ることができます.そのため,パッケージ作成者はさまざまな設定
45オプションを指定できます。
46
47ソフトウェアを開発していてソースコードパッケージを設定するシェル
48スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
49Autoconf をインストールするためには GNU m4 パッケージもインストールする
50必要があります.
51
52Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
53エンドユーザには Autoconf パッケージが必要ないことに注目してください.
54Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
55必要ありません.
56
57%package mode
58Summary: Emacs-lisp autoconf-mode for autoconf/autotest
59Group: Applications/Editors/Emacs
60%prereq_ge emacsen-common
61PreReq: emacsen
62
63%description mode
64Emacs-lisp autoconf-mode for autoconf/autotest
65
66
67%prep
68%setup -q -n autoconf-%{version}
69#patch0 -p1
70
71
72%build
73%configure
74make
75
76#make check
77
78%install
79rm -rf ${RPM_BUILD_ROOT}
80%makeinstall
81
82gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
83
84# We don't want to include the standards.info stuff in the package,
85# because it comes from binutils...
86rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
87# cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
88
89# remove info dir file since it isn't packaged
90rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
91
92# move elisp files
93pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
94mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
95mv *.el autoconf-mode/
96popd
97
98# emacsen-common-ize
99mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
100#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
101#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
102mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
103mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
104
105%_installemacsenscript autoconf-mode %{SOURCE10}
106
107%_removeemacsenscript  autoconf-mode %{SOURCE11}
108
109
110%clean
111rm -rf ${RPM_BUILD_ROOT}
112
113
114%post
115/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
116
117
118%post mode
119
120if [ "$1" = 2 ]; then
121
122%_emacsenPackageRemove autoconf-mode
123
124fi
125
126%_addemacsenlist autoconf-mode
127
128%_emacsenPackageInstall autoconf-mode
129
130
131%preun
132if [ "$1" = 0 ]; then
133    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
134fi
135
136
137%preun mode
138
139if [ "$1" = 0 ]; then
140
141%_emacsenPackageRemove autoconf-mode
142
143%_removeemacsenlist autoconf-mode
144
145fi
146
147
148%files
149%defattr(-,root,root)
150%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
151%{_bindir}/*
152%{_infodir}/*.info*
153%{_datadir}/autoconf
154%{_mandir}/man1/*
155
156
157%files mode
158%defattr(-,root,root)
159%{_datadir}/emacs/site-lisp/autoconf-mode/
160#/usr/lib/emacsen-common/packages/install/autoconf-mode
161#/usr/lib/emacsen-common/packages/remove/autoconf-mode
162%{emacsen_pkgdir}/install/autoconf-mode
163%{emacsen_pkgdir}/remove/autoconf-mode
164
165
166%changelog
167* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
168- new upstream release
169- dropped Patch0 (merged into upstream)
170
171* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
172- added %%emacsen_pkgdir macro
173- spec in utf-8
174
175* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
176- import Patch0 from Fedora 2.62-2
177  * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
178  - add upstream fix from Eric Blake for #449973,
179    m4_if releated error message from autotest
180
181* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
182- new upstream release
183
184* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
185- new upstream release
186
187* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
188- changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
189- added Japanese summary and description from vinedocs.sourceforge.jp
190- s/Copyright/License/
191
192* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
193- rebuild
194
195* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
196- rebuild
197
198* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
199- update to 2.59 bugfix release
200
201* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
202- new upstream release
203
204* Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
205- source update
206
207* Mon Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
208- don't show annoying messages during elisp compilation
209
210* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
211- based on 2.56-1 from Rawhide and built for Vine Linux
212- emacsen-common-ize
213
214* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
215- update to 2.56
216- obsolete autoheader-warn patch
217- no longer provide autoconf253
218- include site-lisp and man files
219- remove info dir which is not in the manifest
220- do not version suffix bin files for now
221
222* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
223- make check
224
225* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
226- update url (#66840)
227- added doc files
228
229* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
230- automated rebuild
231
232* Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
233- automated rebuild
234
235* Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
236- provide autoconf253
237
238* Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
239- obsolete autoconf253
240
241* Wed May  8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
242- patch autoheader so that --warnings=CATEGORY works (#64566)
243  [reported with fix by hjl@gnu.org]
244
245* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
246- update to autoconf-2.53
247- drop mawk patch again
248- version suffix bindir files and add symlinks to unversioned names
249
250* Fri Feb  1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
251- revert to 2.52 (also fixes #58210!)
252- remove relversion variable
253- bring back mawk -> gawk patch
254
255* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
256- automated rebuild
257
258* Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
259- update to 2.52f
260- add URL
261- minor description improvements
262- define relversion to carry version number
263- mawk.patch no longer needed
264
265* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
266- rebuild
267
268* Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
269- restore patch to prefer gawk to mawk
270
271* Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
272- update to 2.52d
273
274* Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
275- update to 2.52
276- remove obsolete patches, since already new version
277- dont install install-sh
278
279* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
280- add patch to include various standard C headers as needed
281  by various autoconf tests (#19114)
282- add patch to autoscan.pl to get a better choice of init
283  file (#42071), to test for CPP after CC (#42072) and to
284  detect C++ source and g++ (#42073).
285
286* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
287- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
288  from version 2.50 to make detection of C++ exit()
289  declaration prototype platform independent.  The check is
290  done in AC_PROG_CXX with the result stored in "confdefs.h".
291  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
292  (fixes #18829)
293
294* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
295- Fix up interoperability with glibc 2.2 and gcc 2.96:
296  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
297  the test code without throwing an exception, causing a conflict
298  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
299  always failed, returning wrong results
300
301* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
302- add textutils as a dependency (#14439)
303
304* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
305- automatic rebuild
306
307* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
308- FHS packaging.
309
310* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
311- fix preun
312
313* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
314- add patch to help autoconf clean after itself and not leave /tmp clobbered
315  with acin.* and acout.* files (can you say annoying?)
316
317* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
318- auto rebuild in the new build environment (release 4)
319- use gawk, not mawk
320
321* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
322- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
323
324* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
325- Injected new description and group.
326
327* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
328- update to 2.13.
329
330* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
331- build against glibc 2.1
332
333* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
334- requires perl
335
336* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
337- patch for fixing /tmp race conditions
338
339* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
340- spec file cleanups
341- made a noarch package
342- uses autoconf
343- uses install-info
344
345* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
346- built with glibc
347
Note: See TracBrowser for help on using the repository browser.