source: projects/specs/trunk/a/autoconf/autoconf-vl.spec @ 12131

Revision 12131, 11.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1# run "make check" by default
2%bcond_without check
3
4%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
5
6Summary: A GNU tool for automatically configuring source code.
7Summary(ja): ソースコードを自動的に設定するための GNU ツール
8Name: autoconf
9Version: 2.69
10Release: 2%{?_dist_release}
11License: GPL
12Group: Development/Tools
13URL: http://www.gnu.org/software/autoconf/
14
15Source: http://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
16Patch1: autoconf-2.69-perl-5.22-autoscan.patch
17Patch2: autoconf-test38.patch
18Patch3: autoconf-test501.patch
19
20# Vine Source(s)
21Source10: autoconf-mode-install.sh
22Source11: autoconf-mode-remove.sh
23
24Requires(post,preun): /sbin/install-info
25Requires: gawk, m4, mktemp, perl, textutils
26Obsoletes: autoconf253
27BuildArch: noarch
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29
30%description
31GNU's Autoconf is a tool for configuring source code and Makefiles.
32Using Autoconf, programmers can create portable and configurable
33packages, since the person building the package is allowed to
34specify various configuration options.
35
36You should install Autoconf if you are developing software and
37would like to create shell scripts that configure your source code
38packages. If you are installing Autoconf, you will also need to
39install the GNU m4 package.
40
41Note that the Autoconf package is not required for the end-user who
42may be configuring software with an Autoconf-generated script;
43Autoconf is only required for the generation of the scripts, not
44their use.
45
46%description -l ja
47GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
48です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
49作ることができます.そのため,パッケージ作成者はさまざまな設定
50オプションを指定できます。
51
52ソフトウェアを開発していてソースコードパッケージを設定するシェル
53スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
54Autoconf をインストールするためには GNU m4 パッケージもインストールする
55必要があります.
56
57Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
58エンドユーザには Autoconf パッケージが必要ないことに注目してください.
59Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
60必要ありません.
61
62%package mode
63Summary: Emacs-lisp autoconf-mode for autoconf/autotest
64Group: Applications/Editors/Emacs
65BuildRequires: emacs
66%prereq_ge emacsen-common
67Requires: emacsen
68
69%description mode
70Emacs-lisp autoconf-mode for autoconf/autotest
71
72
73%prep
74%setup -q -n autoconf-%{version}
75%patch1 -p1
76%patch2 -p1
77%patch3 -p1
78
79
80%build
81%configure
82make %{?_smp_mflags}
83
84#make check
85
86%install
87rm -rf ${RPM_BUILD_ROOT}
88%makeinstall
89
90gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
91
92# We don't want to include the standards.info stuff in the package,
93# because it comes from binutils...
94rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
95# cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
96
97# remove info dir file since it isn't packaged
98rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
99
100# move elisp files
101pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
102mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
103mv *.el autoconf-mode/
104popd
105
106# emacsen-common-ize
107mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
108#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
109#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
110mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
111mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
112
113%_installemacsenscript autoconf-mode %{SOURCE10}
114
115%_removeemacsenscript  autoconf-mode %{SOURCE11}
116
117rm -f %{buildroot}%{_datadir}/emacs/site-lisp/auto*-mode.elc
118
119%check
120%if %{with check}
121make check %{?_smp_mflags}
122%endif
123
124%clean
125rm -rf ${RPM_BUILD_ROOT}
126
127
128%post
129/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
130
131
132%post mode
133
134if [ "$1" = 2 ]; then
135
136%_emacsenPackageRemove autoconf-mode
137
138fi
139
140%_addemacsenlist autoconf-mode
141
142%_emacsenPackageInstall autoconf-mode
143
144
145%preun
146if [ "$1" = 0 ]; then
147    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
148fi
149
150
151%preun mode
152
153if [ "$1" = 0 ]; then
154
155%_emacsenPackageRemove autoconf-mode
156
157%_removeemacsenlist autoconf-mode
158
159fi
160
161
162%files
163%defattr(-,root,root)
164%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
165%{_bindir}/*
166%{_infodir}/*.info*
167%{_datadir}/autoconf
168%{_mandir}/man1/*
169
170
171%files mode
172%defattr(-,root,root)
173%{_datadir}/emacs/site-lisp/autoconf-mode/
174#/usr/lib/emacsen-common/packages/install/autoconf-mode
175#/usr/lib/emacsen-common/packages/remove/autoconf-mode
176%{emacsen_pkgdir}/install/autoconf-mode
177%{emacsen_pkgdir}/remove/autoconf-mode
178
179
180%changelog
181* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.69-2
182- added Patch1-3.
183
184* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.69-1
185- upate to 2.69
186
187* Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
188- new upstream release
189
190* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
191- rebuilt with rpm-4.8.1-3
192
193* Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
194- new upstream release
195
196* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
197- new upstream release
198- dropped Patch0 (merged into upstream)
199
200* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
201- added %%emacsen_pkgdir macro
202- spec in utf-8
203
204* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
205- import Patch0 from Fedora 2.62-2
206  * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
207  - add upstream fix from Eric Blake for #449973,
208    m4_if releated error message from autotest
209
210* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
211- new upstream release
212
213* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
214- new upstream release
215
216* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
217- changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
218- added Japanese summary and description from vinedocs.sourceforge.jp
219- s/Copyright/License/
220
221* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
222- rebuild
223
224* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
225- rebuild
226
227* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
228- update to 2.59 bugfix release
229
230* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
231- new upstream release
232
233* Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
234- source update
235
236* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
237- don't show annoying messages during elisp compilation
238
239* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
240- based on 2.56-1 from Rawhide and built for Vine Linux
241- emacsen-common-ize
242
243* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
244- update to 2.56
245- obsolete autoheader-warn patch
246- no longer provide autoconf253
247- include site-lisp and man files
248- remove info dir which is not in the manifest
249- do not version suffix bin files for now
250
251* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
252- make check
253
254* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
255- update url (#66840)
256- added doc files
257
258* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
259- automated rebuild
260
261* Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
262- automated rebuild
263
264* Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
265- provide autoconf253
266
267* Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
268- obsolete autoconf253
269
270* Wed May  8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
271- patch autoheader so that --warnings=CATEGORY works (#64566)
272  [reported with fix by hjl@gnu.org]
273
274* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
275- update to autoconf-2.53
276- drop mawk patch again
277- version suffix bindir files and add symlinks to unversioned names
278
279* Fri Feb  1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
280- revert to 2.52 (also fixes #58210!)
281- remove relversion variable
282- bring back mawk -> gawk patch
283
284* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
285- automated rebuild
286
287* Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
288- update to 2.52f
289- add URL
290- minor description improvements
291- define relversion to carry version number
292- mawk.patch no longer needed
293
294* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
295- rebuild
296
297* Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
298- restore patch to prefer gawk to mawk
299
300* Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
301- update to 2.52d
302
303* Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
304- update to 2.52
305- remove obsolete patches, since already new version
306- dont install install-sh
307
308* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
309- add patch to include various standard C headers as needed
310  by various autoconf tests (#19114)
311- add patch to autoscan.pl to get a better choice of init
312  file (#42071), to test for CPP after CC (#42072) and to
313  detect C++ source and g++ (#42073).
314
315* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
316- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
317  from version 2.50 to make detection of C++ exit()
318  declaration prototype platform independent.  The check is
319  done in AC_PROG_CXX with the result stored in "confdefs.h".
320  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
321  (fixes #18829)
322
323* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
324- Fix up interoperability with glibc 2.2 and gcc 2.96:
325  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
326  the test code without throwing an exception, causing a conflict
327  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
328  always failed, returning wrong results
329
330* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
331- add textutils as a dependency (#14439)
332
333* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
334- automatic rebuild
335
336* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
337- FHS packaging.
338
339* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
340- fix preun
341
342* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
343- add patch to help autoconf clean after itself and not leave /tmp clobbered
344  with acin.* and acout.* files (can you say annoying?)
345
346* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
347- auto rebuild in the new build environment (release 4)
348- use gawk, not mawk
349
350* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
351- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
352
353* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
354- Injected new description and group.
355
356* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
357- update to 2.13.
358
359* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
360- build against glibc 2.1
361
362* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
363- requires perl
364
365* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
366- patch for fixing /tmp race conditions
367
368* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
369- spec file cleanups
370- made a noarch package
371- uses autoconf
372- uses install-info
373
374* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
375- built with glibc
376
Note: See TracBrowser for help on using the repository browser.