source: projects/specs/trunk/a/authconfig/authconfig-vl.spec @ 6790

Revision 6790, 27.5 KB checked in by Takemikaduchi, 12 years ago (diff)

update to 6.2.3

Line 
1Summary: Command line tool for setting up authentication from network services
2Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
3Name: authconfig
4Version: 6.2.3
5Release: 1%{?_dist_release}
6License: GPLv2+
7ExclusiveOS: Linux
8Group: System Environment/Base
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10URL: https://fedorahosted.org/authconfig
11Source: https://fedorahosted.org/releases/a/u/%{name}/%{name}-%{version}.tar.bz2
12
13Patch10: authconfig-6.2.3-fprintd-pam.patch
14Patch11: authconfig-6.2.3-fix-broken-strings.patch
15
16# for Vine
17Patch101: authconfig-6.2.3-authinfo-vine.patch
18
19Requires: pam
20Conflicts: samba-common < 3.0, samba-client < 3.0
21Conflicts: nss_ldap < 254
22BuildRequires: glib2-devel, python >= 2.4.1, python-devel
23BuildRequires: desktop-file-utils, intltool, gettext, perl-XML-Parser
24
25%description
26Authconfig is a command line utility which can configure a workstation
27to use shadow (more secure) passwords.  Authconfig can also configure a
28system to be a client for certain networked user information and
29authentication schemes.
30
31%description -l ja
32authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
33コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
34サービスを利用するように設定することもできます。
35
36%package gtk
37Summary: Graphical tool for setting up authentication from network services
38Summary(ja): ネットワークサービスからの認証を設定するためのグラフィカルツール
39Group: System Environment/Base
40Requires: %{name} = %{version}-%{release}, pygtk2-libglade
41Requires: usermode-gtk
42
43%description gtk
44Authconfig-gtk is a GUI program which can configure a workstation
45to use shadow (more secure) passwords.  Authconfig-gtk can also configure
46a system to be a client for certain networked user information and
47authentication schemes.
48
49%prep
50%setup -q -n %{name}-%{version}
51%patch10 -p1
52%patch11 -p1
53%patch101 -p1
54
55%build
56CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
57%configure
58make
59
60%install
61rm -rf $RPM_BUILD_ROOT
62make install DESTDIR=$RPM_BUILD_ROOT
63rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.a
64rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.la
65rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
66ln -s authconfig.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
67
68%find_lang %{name}
69find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post gtk
75touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
76
77%postun gtk
78if [ $1 -eq 0 ] ; then
79    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
80    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
81fi
82
83%posttrans gtk
84gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
85
86%triggerin -- authconfig <= 6.2.3
87if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
88        authconfig --updateall --nostart >/dev/null 2>&1 || :
89fi
90if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
91        cd %{_sysconfdir}/pam.d; \
92        ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
93fi
94
95
96%files -f %{name}.lang
97%defattr(-,root,root,-)
98%doc COPYING NOTES TODO README.samba3
99%ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
100%ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
101%ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
102%ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
103%ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
104%ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
105%{_bindir}/authconfig
106%{_bindir}/authconfig-tui
107%{_sbindir}/cacertdir_rehash
108%{_sbindir}/authconfig
109%{_sbindir}/authconfig-tui
110%{_mandir}/man8/*
111%{_mandir}/man5/*
112%{python_sitearch}/acutilmodule.so
113%dir %{_datadir}/%{name}
114%{_datadir}/%{name}/authconfig.py*
115%{_datadir}/%{name}/authconfig-tui.py*
116%{_datadir}/%{name}/authinfo.py*
117%{_datadir}/%{name}/shvfile.py*
118%{_datadir}/%{name}/dnsclient.py*
119%{_datadir}/%{name}/msgarea.py*
120%config(noreplace) %{_sysconfdir}/pam.d/authconfig
121%config(noreplace) %{_sysconfdir}/pam.d/authconfig-tui
122%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig
123%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-tui
124%attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
125
126%files gtk
127%defattr(-,root,root,-)
128%{_bindir}/authconfig-gtk
129%{_bindir}/system-config-authentication
130%{_sbindir}/authconfig-gtk
131%{_sbindir}/system-config-authentication
132%{_datadir}/%{name}/authconfig.glade
133%{_datadir}/%{name}/authconfig-gtk.py*
134%config(noreplace) %{_sysconfdir}/pam.d/authconfig-gtk
135%config(noreplace) %{_sysconfdir}/pam.d/system-config-authentication
136%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-gtk
137%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-authentication
138%{_datadir}/applications/*
139%{_datadir}/icons/hicolor/*/*/*
140
141%changelog
142* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
143- update to 6.2.3
144- update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
145- update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
146- add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
147
148* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
149- rebuild with python-2.7.2
150
151* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
152- rebuilt with rpm-4.8.1-3
153
154* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
155- rebuilt with python-2.6.4
156
157* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
158- update Patch11
159  - old patch does not fix problem on some environment..
160
161* Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
162- add Patch10
163  - Fingerprint auth requires fprintd-pam package not pam_fprintd
164- add Patch11 to fix broken help messages on some locale.
165
166* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
167- new upstream release
168
169* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
170- new upstream release
171- historical changelogs are following:
172  * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
173  - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
174  - added BuildRequires: desktop-file-utils
175  * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
176  - rebuilt with python-2.4.1-0vl1
177  * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
178  - rebuilt with python-2.3.3-0vl1
179  * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
180  - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
181  * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
182  - updated to 4.6.1
183  - updated Patch0 and Source1
184  - rebuild with new toolchains
185  - Reqyires: glib2, BuildRequires: glib2-devel
186  * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
187  - add vinized color palette
188  * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
189  - rebuild for Vine Linux
190  - based on Red Hat Linux 7.2, merged with Vine Linux package.
191    * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
192    - 3.0.3-1vl5
193    - change checkbox color
194    * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
195    - add %patch1 to fix mandir
196    * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
197    - build with gcc-2.95.3
198    - partially used rpmmacros
199    * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
200    - 3.0.3-1vl2
201    - modified %files section to handle compressed man page
202    * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
203    - 3.0.3-1vl1
204    - build for Vine
205
206* Tue Aug  5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
207- do not call domainname when run with --nostart (#457697)
208
209* Fri Jun  6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
210- remove the --enableldapssl alias and add some help to GUI tooltips
211  to clear up some confusion (#220973)
212- add option --enablepreferdns to prefer DNS over NIS or WINS in
213  hostname resolution
214
215* Tue Apr  8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
216- read wins setting from nsswitch.conf correctly (#440459)
217- do not ignore --enablemd5/--disablemd5 options
218
219* Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
220- fixed backup directory in Makefile and spec (#437040)
221
222* Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
223- include config-util in console.apps files
224- add support for saving/restoring backups of configuration
225  files affected by authconfig (#433776)
226- improve the authconfig manual page (#432023, #432938)
227
228* Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
229- correct the fix for bug #237956
230
231* Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
232- update translations
233
234* Wed Jan  9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
235- support new sha256 and sha512 password hash algorithms
236- add support for pam_mkhomedir (#212790)
237- do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
238  the idea how to fix that
239- setup password hash algorithm in /etc/login.defs (#218652)
240- update translations
241
242* Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
243- improve krb5.conf handling (#238766)
244
245* Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
246- remove obsolete pam_krb5afs support (#250704)
247- add support for pam_access (#251360)
248- update translations
249
250* Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
251- license tag fix
252
253* Thu Aug  9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
254- require newt-python (#251359)
255
256* Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
257- add support for winbind offline login (#232955)
258
259* Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
260- dnsclient fixes by Simo Sorce
261- add Categories to .desktop file (#245868)
262- fixed traceback when calling joinDomain (#245374)
263- disable smart card action setting when gnome-screensaver
264  not installed (#209643)
265- do not change protocols and services in nsswitch.conf (#236669)
266
267* Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
268- authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
269- drop explicit requirement on python version as it is now
270  generated automatically
271- improve writing /etc/samba/smb.conf (based on patch by
272  Simo Sorce)
273- merge changes upstream
274 
275* Fri May  4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
276- local nis domain is obtained from sysconfig/network (#235927)
277- set "local authorization is sufficient" on by default
278
279* Thu Apr  5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
280- minor changes and cleanups for merge review (#225293)
281
282* Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
283- nss_ldap is now in /usr/lib (#232975)
284
285* Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
286- another traceback in --probe and other fixes (#218874)
287- make smbRealm a default realm when appropriate (#219300)
288- added missing languages in LINGUAS
289
290* Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
291- when pam_krb5 auth fails with smartcard login don't enforce it
292  in the account stack (#214931)
293- updated translations (#216570)
294- winbind should be added only to user tables (#216862)
295
296* Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
297- fixed --smartcardaction command line option (#211552)
298
299* Fri Oct  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
300- fixed passwd PAM stack when PKCS11 enabled (#195960)
301- make authconfig --probe work again (#209676)
302
303* Mon Oct  2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
304- updated translations (#207095)
305- correctly write pam_smb.conf with only one server specified (#208365)
306
307* Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
308- move options to another tab to fit on 800x600 screen (#207357)
309
310* Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
311- improve PAM setup for smart card login
312- support smart card login with kerberos (PKINIT)
313- add pam_pkcs11 to password PAM stack
314
315* Mon Sep  4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
316- skip pam_unix for session for crond service
317- fixed a bug in saving when smartcard settings changed (#204838)
318- removed allow_ypbind setsebool as it is now handled in ypbind
319
320* Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
321- improve smart card related UI strings
322- removed possibility to set smart card type from authconfig-gtk
323  as only coolkey will be supported for now
324
325* Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
326- pass options given to authconfig-gtk to authconfig (#203955)
327
328* Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
329- write out new "wait_for_card" config option if we're
330  forcing smart card authentication
331- add "use_uid" option to smart card pam_succeed_if line to
332  work around bug where pam_succeed_if checks user information
333  even in cases where the conditional doesn't depend on it.
334- remove unimplemented "logout" smart card removal action from
335  settings
336- remove unnecessary "card_only" argument
337
338* Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
339- don't start sceventd when smartcard login is enabled
340- improve pam config for smartcard login
341
342* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
343- don't require pam_pkcs11 to run
344
345* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
346- screensavers should be authenticated by smartcard too
347- add feature to download a CA certificate for LDAP from
348  an URL (#197103)
349- add pam_keyinit session module to the PAM configuration (#198638)
350
351* Fri Jul  7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
352- added support for smartcard authentication
353- fixed parsing kerberos realms
354
355* Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
356- write ldap servers as URIs and not HOSTs (#191842)
357- fix a typo in --test output
358- updated summary, converted changelog to UTF-8
359
360* Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
361- added crond to the services restarted after firstboot (#187334)
362- when checking nscd status redirect output to /dev/null (#188555)
363
364* Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
365- make smb.conf and krb5.conf loading more robust (#185766)
366
367* Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
368- add try_first_pass option to pam_unix for better integration
369  with individual service configurations (#182350)
370- updated translations
371
372* Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
373- don't crash in TUI when some options aren't set (#182151)
374
375* Fri Feb  3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
376- redesigned GUI (#178112)
377- added man page for system-config-ac (#179584)
378- disable authentication of system accounts by network services
379  by default, added option for changing that (#179009)
380- updated translations, new languages
381
382* Mon Jan  9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
383- fixed regression when saving nsswitch.conf
384
385* Fri Jan  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
386- print warning if PAM module is missing when the PAM configuration
387  is saved (#168880)
388
389* Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
390- make child dialog preset code more robust (#176462)
391
392* Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
393- update only configuration files which settings were modified (#72290)
394
395* Mon Dec  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
396- don't ignore krb5realm command line option (#174838)
397- read dns_lookup_realm and dns_lookup_kdc values correctly
398- the PAM configuration is now written in system-auth-ac file
399  which is then symlinked from system-auth, the symlink is not
400  overwritten so local PAM configuration is now possible (#165342)
401
402* Mon Nov  7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
403- add symlinks to python scripts in sbindir
404- don't override nullok setting from system-auth (#96996)
405
406* Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
407- authinfo-tui.py is now symlink
408- reword the CA certificate message (#154317)
409- use include instead of pam_stack in pam config
410- don't break yp.conf with multiple domains (#127306)
411
412* Mon Sep  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
413- fixed a few errors catched by pychecker
414
415* Sat Sep  3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
416- C code completely rewritten in Python
417- some bugs fixed in the process (and no doubt new introduced)
418- TUI deprecated, opens only when run as authconfig-tui
419
420* Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
421- set domain and ypserver option correctly when multiple servers
422  specified in kickstart (#159214)
423
424* Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
425- replaced deprecated gtk.TRUE/FALSE (#153034)
426- updated translations
427
428* Fri Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
429- propagate the --enablewinbindauth option to the configuration (#151018)
430
431* Fri Mar  4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
432- changed version propagation
433
434* Thu Mar  3 2005 Tomas Mraz <tmraz@redhat.com>
435- updated translations
436- fixed build on gcc4
437
438* Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
439- updated translations
440
441* Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
442- improved the code that writes tls_cacertdir to ldap.conf
443
444* Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
445- renamed functions in authconfigmodule to be more clear
446- implemented cacertdir for LDAP with TLS
447
448* Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
449- fixed a bug in authinfo_differs when called from python
450
451* Wed Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
452- add option for making local authorization sufficient for local users
453  this is attempt to 'solve/workaround' the problem with blocking local logins by
454  pulling out network cable (#115181)
455
456* Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
457- remove dependency on nscd
458- don't show warning messages when switching options off
459
460* Mon Dec  6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
461- updated translations
462- winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
463- use GtkComboBox instead of deprecated GtkOptionMenu
464- disable options with not installed binaries, remove unnecessary deps of
465  authconfig-gtk
466
467* Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
468- merged patches from dist
469- fix versioning
470
471* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
472- rebuild against python 2.4
473
474* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
475- Fix setsebool patch to turn off boolean
476
477* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
478- Add setsebool for NIS
479
480* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
481- force broken_shadow option on network auth (#136760)
482
483* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
484- force restart of autofs on firstboot call when using NIS (#133035, #124498)
485
486* Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
487- require python to install (#134654)
488
489* Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
490- updated translations from upstream
491- autogeneration of build stripts in prep phase
492
493* Fri Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
494- fixed man page
495- added dependency on nscd
496
497* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
498- regenerated build scripts
499
500* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
501- fixed all po files to translate correctly messages with modified accelerators (#133742)
502- added translations for Arabic, Bulgarian and other languages (#133716, #133158)
503
504* Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
505- added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
506
507* Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
508- corrected package dependencies #132411
509- regenerated glade.strings.h #132369
510
511* Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
512- modified authconfig-gtk interface to fit lower resolution screens (#127175)
513- modified accelerators in authconfig-gtk (#125797)
514- updated package dependencies (#125306)
515
516* Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
517- updated configure scripts
518- warnfixes and minor hacks
519
520* Mon Jun  7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
521- tweak account management to fix #55193 correctly
522- require anything we might want to run in the gui subpackage because it
523  doesn't warn about missing things and you don't have a terminal to see
524  error messages about missing commands
525- properly display the domain in the GUI join dialog (#124621)
526
527* Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
528- omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
529- properly warn about missing "net" (samba-client) and libnss_winbind and
530  pam_winbind (samba-common) in text mode (#122802)
531
532* Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
533- learn all about pam_passwdqc
534- preserve arguments to pam_cracklib and pam_passwdqc
535- short-circuit PAM authorization checks for users with UID < 100
536- remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
537
538* Fri Feb  6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
539- fix man page: --enableldapssl should be --enableldaptls
540- make --enableldapssl an alias for --enableldaptls
541
542* Thu Jan  8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
543- authconfig-gtk.py: require rhpl, which is required by the script (#104209)
544- both: require usermode (authconfig-gtk transitively), else leave a dangling
545  symlink (#104209)
546- the great redhat-config-authentication/system-config-authentication renaming,
547  as was foretold in the fedora-config-list archives
548
549* Wed Jan  7 2004 Nalin Dahyabhai <nalin@redhat.com>
550- preserve "compat" if it's used in /etc/nsswitch.conf
551
552* Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
553- add options for toggling krb5's use of DNS
554
555* Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
556- rework tui to include winbind options. there wasn't enough room in the old
557  dialog to include the important options, so the whole thing's been reworked
558
559* Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
560- conflict with older versions of samba which expect different configuration
561
562* Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
563- initial support for configuring winbind
564
565* Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
566- make pam_cracklib requisite instead of required in generated PAM configs
567
568* Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
569- rebuild with current translations
570
571* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
572- make the tarball name include the release number
573
574* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
575- authconfig-gtk: condrestart certain additional services if invoked with
576  the --firstboot flag (half of #91268, needs cooperating firstboot)
577- translation updates
578
579* Mon Jul  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
580- translation updates
581
582* Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
583- add 'redhat-config-authentication' as an alias for authconfig-gtk
584- make authconfig-gtk exec authconfig if gui startup fails and it looks like
585  we're connected to a tty
586
587* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
588- rebuilt
589
590* Mon May  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
591- translation updates
592- close unusable file descriptors if locking fails
593
594* Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
595- learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
596
597* Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
598- look in /lib64 for modules for nsswitch and PAM by default on
599  x86_64, ppc64, and s390x (#83049)
600
601* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
602- rebuilt
603 
604* Mon Nov  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
605- update translations
606- update copyright strings (only took 10 months!)
607
608* Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
609- require a version of PAM (0.75-43) which supports $ISA
610- use $ISA in our own PAM config files
611
612* Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
613- add $ISA to the name of the directory in which we expect PAMs to be stored
614
615* Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
616- build with -fPIC, necessary on some arches
617
618* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
619- update translations
620
621* Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
622- Update translations
623
624* Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
625- modify spacing and layout in authconfig-gtk
626
627* Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
628- translation updates
629- rebuild to pick up dependency changes
630
631* Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
632- include the userhelper configuration file
633- require sufficiently-new pam package in the gui subpackage
634
635* Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
636- actually include the icon in the package
637- translation updates
638
639* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
640- use desktop-file-install (#69376)
641- include an icon for the menu item (#68577)
642
643* Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
644- own the pkgdatadir
645- pull in translation updates
646
647* Mon Jun  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
648- add --enable-experimental to enable some of that experimental code
649- add --enable-local to enable local policies
650- update translations
651
652* Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
653- use the current revision of python by default
654- get the intltool/gettext situation sorted out
655
656* Thu May 23 2002 Tim Powers <timp@redhat.com>
657- automated rebuild
658
659* Fri May  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
660- remove bogus buildrequires left over from when authconfig-gtk was C code
661- buildrequires python-devel in addition to python (to build the python module,
662  but we still need python to byte-compile the python script)
663
664* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
665- add missing translations back in
666- convert .mo files at install-time
667
668* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
669- refresh translations
670
671* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
672- actually add the .desktop files
673
674* Tue Apr  9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
675- refresh translations
676- destroy the python object correctly
677
678* Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
679- add the .desktop file
680
681* Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
682- rework the auth stack logic to require all applicable auth modules
683
684* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
685- allow pam_krb5afs to be used for account management, too
686
687* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
688- refresh translations
689
690* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
691- refresh translations
692
693* Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
694- actually free authInfo structures when asked to
695- use pam_krb5's account management facilities
696- conflict with versions of pam_krb5 which don't offer account management
697
698* Mon Feb  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
699- add python bindings for the back-end
700- redo the gui so that it exercises the python bindings
701- take a shot at getting authconfig to work in a firstboot container
702
703* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
704- rebuild again
705
706* Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
707- rebuilt against new glib
708
709* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
710- rebuild in new environment
711
712* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
713- add some more experimental options
714- clean up the glade files a bit
715- don't destroy a garbage pointer on main cancel, destroy the main dialog
716
717* Thu Jan  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
718- bump release and rebuild
719
720* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
721- make setting of experimental options only possible through
722  /etc/sysconfig/authconfig, to keep accidents from happening
723- add some more support for experimental stuff
724
725* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
726- fix setting of LDAP TLS option in authconfig-gtk
727- change Apply to Ok, Close to Cancel, because that's how they work
728
729* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
730- add the glade XML file to the -gtk subpackage (fix from katzj)
731
732* Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
733- port to glib2
734- move post code to the back-end
735- add a libglade GUI in a -gtk subpackage
736- set up to use userhelper
Note: See TracBrowser for help on using the repository browser.