source: projects/specs/trunk/a/audit/audit-vl.spec @ 9487

Revision 9487, 24.2 KB checked in by Takemikaduchi, 9 years ago (diff)

libgit2: add BR
libgit2-glib: rebuild
gitg, http-parser: new package
audit: create compat32 package
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define sca_version 0.4.10
4%define sca_release 2
5
6Summary: User space tools for 2.6 kernel auditing
7Name: audit
8Version: 1.7.18
9Release: 3%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Daemons
12URL: http://people.redhat.com/sgrubb/audit/
13Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
14Source1: system-config-audit-ja.po
15Patch10: audit-1.7.18-pthread.patch
16Patch11: audit-1.7.18-krb5.patch
17Patch12: audit-1.7.18-libaudit.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: gettext intltool libtool swig python-devel
21BuildRequires: tcp_wrappers
22BuildRequires: krb5-devel
23BuildRequires: kernel-headers >= 2.6.18
24BuildRequires: automake >= 1.9
25BuildRequires: autoconf >= 2.59
26Requires: %{name}-libs = %{version}-%{release}
27Requires: chkconfig
28Requires(pre): coreutils
29
30%description
31The audit package contains the user space utilities for
32storing and searching the audit records generate by
33the audit subsystem in the Linux 2.6 kernel.
34
35%package libs
36Summary: Dynamic library for libaudit
37License: LGPLv2+
38Group: Development/Libraries
39
40%description libs
41The audit-libs package contains the dynamic libraries needed for
42applications to use the audit framework.
43
44%package libs-devel
45Summary: Header files and static library for libaudit
46License: LGPLv2+
47Group: Development/Libraries
48Requires: %{name}-libs = %{version}-%{release}
49Requires: kernel-headers >= 2.6.18
50
51%description libs-devel
52The audit-libs-devel package contains the static libraries and header
53files needed for developing applications that need to use the audit
54framework libraries.
55
56%package libs-python
57Summary: Python bindings for libaudit
58License: LGPLv2+
59Group: Development/Libraries
60Requires: %{name}-libs = %{version}-%{release}
61
62%description libs-python
63The audit-libs-python package contains the bindings so that libaudit
64and libauparse can be used by python.
65
66%package -n audispd-plugins
67Summary: Plugins for the audit event dispatcher
68License: GPLv2+
69Group: System Environment/Daemons
70BuildRequires: openldap-devel
71Requires: %{name} = %{version}-%{release}
72Requires: %{name}-libs = %{version}-%{release}
73Requires: openldap
74
75%description -n audispd-plugins
76The audispd-plugins package provides plugins for the real-time
77interface to the audit system, audispd. These plugins can do things
78like relay events to remote machines or analyze events for suspicious
79behavior.
80
81%package -n system-config-audit
82Summary: Utility for editing audit configuration
83Version: %{sca_version}
84Release: %{sca_release}%{?_dist_release}
85License: GPLv2+
86Group: Applications/System
87BuildRequires: desktop-file-utils
88Requires: pygtk2-libglade usermode usermode-gtk
89
90%description -n system-config-audit
91A graphical utility for editing audit configuration.
92
93%package -n compat32-%{name}-libs
94Summary: Dynamic library for libaudit
95License: LGPLv2+
96Group: Development/Libraries
97
98%description -n compat32-%{name}-libs
99The audit-libs package contains the dynamic libraries needed for
100applications to use the audit framework.
101
102%prep
103%setup -q
104%patch10 -p1
105%patch11 -p1
106%patch12 -p1
107cp -f %{SOURCE1} system-config-audit/po/ja.po
108
109%build
110(cd system-config-audit; %configure)
111%configure --sbindir=/sbin --libdir=/%{_lib} --with-libwrap --enable-gssapi-krb5=yes
112make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d}}
117mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
118mkdir -p $RPM_BUILD_ROOT/%{_lib}
119mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
120mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
121make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
122make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
123
124mkdir -p $RPM_BUILD_ROOT/%{_libdir}
125# This winds up in the wrong place when libtool is involved
126mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
127mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
128curdir=`pwd`
129cd $RPM_BUILD_ROOT/%{_libdir}
130LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
131ln -s ../../%{_lib}/$LIBNAME libaudit.so
132LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
133ln -s ../../%{_lib}/$LIBNAME libauparse.so
134cd $curdir
135# Remove these items so they don't get picked up.
136rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
137rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
138rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.la
139rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.la
140rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.a
141rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.la
142rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.a
143rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
144rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.a
145rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.la
146
147# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
148touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
149
150%find_lang system-config-audit
151
152desktop-file-install                                    \
153        --dir $RPM_BUILD_ROOT/%{_datadir}/applications  \
154        --delete-original                               \
155        system-config-audit/system-config-audit.desktop
156
157#% check
158#make check
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162rm -rf zos-remote-policy
163
164%post libs -p /sbin/ldconfig
165
166%post
167/sbin/chkconfig --add auditd
168# This is to migrate users from audit-1.0.x installations
169if [ -f /etc/auditd.conf ]; then
170   mv /etc/auditd.conf /etc/audit/auditd.conf
171fi
172if [ -f /etc/audit.rules ]; then
173   mv /etc/audit.rules /etc/audit/audit.rules
174fi
175# This is to enable the dispatcher option which was commented out
176if [ -f /etc/audit/auditd.conf ]; then
177   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
178   if [ $? -eq 1 ] ; then
179      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
180      if [ -n $tmp ]; then
181         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
182         cat $tmp > /etc/audit/auditd.conf
183         rm -f $tmp
184      fi
185   fi
186fi
187
188%post -n compat32-%{name}-libs -p /sbin/ldconfig
189
190%preun
191if [ $1 -eq 0 ]; then
192   /sbin/service auditd stop > /dev/null 2>&1
193   /sbin/chkconfig --del auditd
194fi
195
196%postun libs -p /sbin/ldconfig
197
198%postun
199if [ $1 -ge 1 ]; then
200   /sbin/service auditd condrestart > /dev/null 2>&1 || :
201fi
202
203%postun -n compat32-%{name}-libs -p /sbin/ldconfig
204
205%files libs
206%defattr(-,root,root)
207%attr(755,root,root) /%{_lib}/libaudit.*
208%attr(755,root,root) /%{_lib}/libauparse.*
209%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
210
211%files libs-devel
212%defattr(-,root,root)
213%doc contrib/skeleton.c contrib/plugin
214%{_libdir}/libaudit.a
215%{_libdir}/libauparse.a
216%{_libdir}/libaudit.so
217%{_libdir}/libauparse.so
218%{_includedir}/libaudit.h
219%{_includedir}/auparse.h
220%{_includedir}/auparse-defs.h
221%{_mandir}/man3/*
222
223%files libs-python
224%defattr(-,root,root)
225%attr(755,root,root) %{python_sitearch}/_audit.so
226%attr(755,root,root) %{python_sitearch}/auparse.so
227%{python_sitearch}/audit.py*
228
229%files
230%defattr(-,root,root,-)
231%doc  README COPYING ChangeLog contrib/capp.rules contrib/nispom.rules contrib/lspp.rules contrib/stig.rules init.d/auditd.cron
232%attr(644,root,root) %{_mandir}/man8/audispd.8.gz
233%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
234%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
235%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
236%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
237%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
238%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
239%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
240%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
241%attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
242%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
243%attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
244%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
245%attr(750,root,root) /sbin/auditctl
246%attr(750,root,root) /sbin/auditd
247%attr(755,root,root) /sbin/ausearch
248%attr(755,root,root) /sbin/aureport
249%attr(750,root,root) /sbin/autrace
250%attr(750,root,root) /sbin/audispd
251%attr(750,root,root) %{_bindir}/aulastlog
252%attr(750,root,root) %{_bindir}/aulast
253%attr(755,root,root) %{_bindir}/ausyscall
254%attr(755,root,root) /etc/rc.d/init.d/auditd
255%attr(750,root,root) %{_var}/log/audit
256%attr(750,root,root) %dir /etc/audit
257%attr(750,root,root) %dir /etc/audisp
258%attr(750,root,root) %dir /etc/audisp/plugins.d
259%attr(750,root,root) %dir %{_libdir}/audit
260%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
261%config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
262%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
263%config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
264%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
265
266%files -n audispd-plugins
267%defattr(-,root,root,-)
268%attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
269%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
270%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
271%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
272%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
273%attr(750,root,root) /sbin/audispd-zos-remote
274%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
275%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
276%attr(750,root,root) /sbin/audisp-remote
277%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
278%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
279
280%files -n system-config-audit -f system-config-audit.lang
281%defattr(-,root,root,-)
282%doc system-config-audit/AUTHORS
283%doc system-config-audit/COPYING
284%doc system-config-audit/ChangeLog
285%doc system-config-audit/NEWS
286%doc system-config-audit/README
287%{_bindir}/system-config-audit
288%{_datadir}/applications/system-config-audit.desktop
289%{_datadir}/system-config-audit
290%{_libexecdir}/system-config-audit-server-real
291%{_libexecdir}/system-config-audit-server
292%config(noreplace) %{_sysconfdir}/pam.d/system-config-audit-server
293%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
294
295%if %{build_compat32}
296%files -n compat32-%{name}-libs
297%defattr(-,root,root)
298%attr(755,root,root) /%{_lib}/libaudit.*
299%attr(755,root,root) /%{_lib}/libauparse.*
300%endif
301
302%changelog
303* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
304- create compat32-audit-libs subpackage
305
306* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
307- rebuild with python-2.7.2
308- add Patch12 (audit-1.7.18-libaudit.patch)
309
310* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
311- new upstream release
312- rebuild with krb5-1.8.2
313
314* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
315- forgot to increment sca_release macro (why on earth is sca_release
316  individually defined from main package's release number anyway?)
317
318* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
319- rebuilt with gcc-4.4.3-3 on ppc
320
321* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
322- rebuilt with rpm-4.8.0-3 (on ppc)
323
324* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
325- rebuild with python-2.6
326
327* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
328- rebuild with openldap-2.4.11
329
330* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
331- initial build for Vine Linux
332- disable krb5, prelude and selinux
333- add ja.po (XXX: minimal)
334
335* Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
336- Add subject to audit daemon events (Chu Li)
337- Add tcp_wrappers support for auditd
338- Updated syscall tables for 2.6.27 kernel
339- Audit connect/disconnect of remote clients
340- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
341
342* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
343- Update system-config-audit to 0.4.8
344- Whole lot of bug fixes - see ChangeLog for details
345- Reimplement auditd main loop using libev
346- Add TCP listener to auditd to receive remote events
347- Fix scheduler problem (#457061)
348
349* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
350- Move ausearch-expression to main package (#453437)
351
352* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
353- Fix interpreting of keys in syscall records
354- Don't error on name=(null) PATH records in ausearch/report
355- Add key report to aureport
356- Update system-config-audit to 0.4.7 (Miloslav Trmac)
357- Add support for the filetype field option in auditctl new to 2.6.26 kernels
358
359* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
360- Fix output of keys in ausearch interpretted mode
361- Fix ausearch/report --start now to not be reset to midnight
362- audispd now has a priority boost config option
363- Look for laddr in avcs reported via prelude
364- Detect page 0 mmaps and alert via prelude
365
366* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
367- Fix overflow in audit_log_user_command, better (#438840)
368- ausearch was not matching path in avc records
369- audisp-prelude attempt to reposition index after examining each type
370- correct building of mls policy
371- Fix auparse iterating in auparse_find_field and next_field
372- Don't alert on USER_AVC's - they are not quite right
373
374* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
375- Fix buffer overflow in audit_log_user_command, again (#438840)
376- Fix memory leak in EOE code in auditd (#440075)
377- In auditctl, don't use new operators in legacy rule format
378- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
379
380* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
381- Fix memleak in auditd eoe code
382
383* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
384- Remove LSB headers from init scripts
385- Fix buffer overflow in audit_log_user_command again
386
387* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
388- Handle user space avcs in prelude plugin
389- Fix watched account login detection for some failed login attempts
390- Couple fixups in audit logging functions (Miloslav Trmac)
391- Add support in auditctl for virtual keys
392- auparse_find_field_next was not iterating correctly, fixed it
393- Add idmef alerts for access or execution of watched file
394- Fix buffer overflow in audit_log_user_command
395- Add basic remote logging plugin - only sends & no flow control
396- Update ausearch with interpret fixes from auparse
397
398* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
399- Apply hidden attribute cleanup patch (Miloslav Trmac)
400- Apply auparse expression interface patch (Miloslav Trmac)
401- Fix potential memleak in audit event dispatcher
402- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
403- audisp-prelude alerts now controlled by config file
404- Updated syscall table for 2.6.25 kernel
405- Apply patch correcting acct field being misencoded (Miloslav Trmac)
406- Added watched account login detection for prelude plugin
407
408* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
409- Update for gcc 4.3
410- Cleanup descriptors in audispd before running plugin
411- Fix 'recent' keyword for aureport/search
412- Fix SE Linux policy for zos_remote plugin
413- Add event type for group password authentication attempts
414- Couple of updates to the translation tables
415- Add detection of failed group authentication to audisp-prelude
416
417* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
418- In ausearch/report, prefer -if to stdin
419- In ausearch/report, add new command line option --input-logs (#428860)
420- Updated audisp-prelude based on feedback from prelude-devel
421- Added prelude alert for promiscuous socket being opened
422- Added prelude alert for SE Linux policy enforcement changes
423- Added prelude alerts for Forbidden Login Locations and Time
424- Applied patch to auparse fixing error handling of searching by
425  interpreted value (Miloslav Trmac)
426
427* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
428- Add prelude IDS plugin for IDMEF alerts
429- Add --user option to aulastlog command
430- Use desktop-file-install for system-config-audit
431- Avoid touching auditd.conf most of the time (#408501)
432
433* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
434- Updates for spec file review
435- Adjust permission on selinux policy file
436
437* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
438- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
439- Check for audit log being writable by owner in auditd
440- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
441- Updated CAPP, LSPP, and NISPOM rules for new capabilities
442- Added aulastlog utility
443
444* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
445- Allow 0600 file perms for audit logs
446
447* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
448- fchmod of log file was on wrong variable (#426934)
449- Allow use of errno strings for exit codes in audit rules
450
451* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
452- Don't fchmod() /dev/null to mode 0400 (#426934)
453
454* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
455- Add kernel release string to DEAMON_START events
456- Fix keep_logs when num_logs option disabled (#325561)
457- Fix auparse to handle node fields for syscall records
458- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
459- Add keyword week-ago to aureport & ausearch start/end times
460- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
461- Add RACF zos remote audispd plugin (Klaus Kiwi)
462- Add event queue overflow action to audispd
463
464* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
465- Don't retry if the rt queue is full.
466
467* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
468- Add support for searching by posix regular expressions in auparse
469- Route DEAMON events into rt interface
470- If event pipe is full, try again after doing local logging
471- Optionally add node/machine name to records in audit daemon
472- Update ausearch/aureport to specify nodes to search on
473- Fix segfault interpretting saddr fields in avcs
474
475* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
476- Fix uninitialized variable in auparse (John Dennis)
477
478* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
479- External plugin support in place
480- Fix reference counting in auparse python bindings (#263961)
481- Moved default af_unix plugin socket to /var/run/audispd_events
482
483* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
484- Add newline to audispd string formatted events
485
486* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
487- spec file cleanups
488- Update to s-c-audit 0.4.3
489
490* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
491- Update Licence tags
492- Adding perm field should not set syscall added flag in auditctl
493- Fix segfault when aureport -if option is used
494- Fix auditctl to better check keys on rule lines
495- Add support for audit by TTY and other new event types
496- Auditd config option for group permission of audit logs
497- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
498- New audit event dispatcher
499- Update syscall tables for 2.6.23 kernel
500
501* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
502- Fix potential buffer overflow in print clone flags of auparse
503- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
504- Update auditctl to handle legacy kernels when putting a watch on a dir
505- Fix acct interpretation in auparse
506
507* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
508- Fix a double free when auditd receives SIGHUP
509- Move the system-config-audit menu entry to the Administration menu
510
511* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
512- Add system-config-audit (Miloslav Trmac)
513- Correct bug in audit_make_equivalent function (Al Viro)
514
515* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
516- Add feed interface to auparse library (John Dennis)
517- Apply patch to libauparse for unresolved symbols (#241178)
518- Apply patch to add line numbers for file events in libauparse (John Dennis)
519- Change seresults to seresult in libauparse (John Dennis)
520- Add unit32_t definition to swig (#244210)
521- Add support for directory auditing
522- Update acct field to be escaped
523
524* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
525- Change buffer size to prevent truncation of DAEMON events with large labels
526- Fix memory leaks in auparse (John Dennis)
527- Update syscall tables for 2.6.21 kernel
528- Update capp & lspp rules
529- New python bindings for libauparse (John Dennis)
530
531* Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
532- New event dispatcher (James Antill)
533- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
534- Apply patch correcting python libs permissions (Philipp Hahn)
535- Fix auditd segfault on reload
536- Fix bug in auparse library for file pointers and descriptors
537- Extract subject information out of daemon events for ausearch
538
539* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
540- Remove requires kernel-headers for python-libs
541- Apply patch to prevent segfaults on auditd reload
542
543* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
544- Updated autrace to monitor *at syscalls
545- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
546- Finish reworking auditd config parser
547- In auparse, interpret open, fcntl, and clone flags
548- In auparse, when interpreting execve record types, run args through unencode
549- Add support for OBJ_PID message type
550- Event dispatcher updates
551
552* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
553- rebuild
554
555* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
556- NEW audit dispatcher program & plugin framework
557- Correct hidden variables in libauparse
558- Added NISPOM sample rules
559- Verify accessibility of files passed in auparse_init
560- Fix bug in parser library interpreting socketcalls
561- Add support for stdio FILE pointer in auparse_init
562- Adjust init script to allow anyone to status auditd (#230626)
563
564* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
565- Add man pages
566- Reduce text relocations in parser library
567- Add -n option to auditd for no fork
568- Add exec option to space_left, admin_space_left, disk_full,
569  and disk_error - eg EXEC /usr/local/script
570
571* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
572- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
573- Finished search options for audit parsing library
574- Fix ausearch -se to work correctly
575- Fix auditd init script for /usr on netdev (#228528)
576- Parse avc seperms better when there are more than one
577
578* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
579- New report about authentication attempts
580- Updates for python 2.5
581- update autrace to have resource usage mode
582- update auditctl to support immutable config
583- added audit_log_user_command function to libaudit api
584- interpret capabilities
585- added audit event parsing library
586- updates for 2.6.20 kernel
587
588* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
589- Make more adjustments for python 2.5
590
591* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
592- Fix a couple parsing problems (#217952)
593- Add tgkill to S390* syscall tables (#218484)
594- Fix error messages in ausearch/aureport
595
596* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
597- rebuild against python 2.5
598
599* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
600- Fix timestamp for libaudit.conf (#218053)
601
602* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
603- Fix minor parsing problem and add new msg types
604
605* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
606- ausearch & aureport implement uid/gid caching
607- In ausearch & aureport, extract addr when hostname is unknown
608- In ausearch & aureport, test audit log presence O_RDONLY
609- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
610- Added --add & --delete option to aureport
611- Update res parsing in config change events
612- Increase the size on audit daemon buffers
613- Parse avc_path records in ausearch/aureport
614- ausearch has new output mode, raw, for extracting events
615- ausearch/aureport can now read stdin
616- Rework AVC processing in ausearch/aureport
617- Added long options to ausearch and aureport
618
619* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
620- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
621- Fix some defines in libaudit.h
622- Some auditd config strings were not initialized in aureport (#211443)
623- Updated man pages
624- Add Netlabel event types to libaudit
625- Update aureports to current audit event types
626- Update autrace a little
627- Deprecated all the old audit_rule functions from public API
628- Drop auparse library for the moment
629
630* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
631- Add dist tag and bump version (#208532)
632- Make internal auditd buffers bigger for context info
633- Correct address resolving of hostname in logging functions
634- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
635- Only =, != operators for arch & inode fields in auditctl (#206427)
636- Updated audit message type table
637- Remove watches from aureport since FS_WATCH is deprecated
638- Add audit_log_avc back temporarily (#208152)
639 
Note: See TracBrowser for help on using the repository browser.