source: projects/specs/trunk/a/audit/audit-vl.spec @ 5701

Revision 5701, 23.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define sca_version 0.4.10
2%define sca_release 1
3
4Summary: User space tools for 2.6 kernel auditing
5Name: audit
6Version: 1.7.18
7Release: 2%{?_dist_release}
8License: GPLv2+
9Group: System Environment/Daemons
10URL: http://people.redhat.com/sgrubb/audit/
11Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
12Source1: system-config-audit-ja.po
13Patch10: audit-1.7.18-pthread.patch
14Patch11: audit-1.7.18-krb5.patch
15Patch12: audit-1.7.18-libaudit.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: gettext intltool libtool swig python-devel
19BuildRequires: tcp_wrappers
20BuildRequires: krb5-devel
21BuildRequires: kernel-headers >= 2.6.18
22BuildRequires: automake >= 1.9
23BuildRequires: autoconf >= 2.59
24Requires: %{name}-libs = %{version}-%{release}
25Requires: chkconfig
26Requires(pre): coreutils
27
28%description
29The audit package contains the user space utilities for
30storing and searching the audit records generate by
31the audit subsystem in the Linux 2.6 kernel.
32
33%package libs
34Summary: Dynamic library for libaudit
35License: LGPLv2+
36Group: Development/Libraries
37
38%description libs
39The audit-libs package contains the dynamic libraries needed for
40applications to use the audit framework.
41
42%package libs-devel
43Summary: Header files and static library for libaudit
44License: LGPLv2+
45Group: Development/Libraries
46Requires: %{name}-libs = %{version}-%{release}
47Requires: kernel-headers >= 2.6.18
48
49%description libs-devel
50The audit-libs-devel package contains the static libraries and header
51files needed for developing applications that need to use the audit
52framework libraries.
53
54%package libs-python
55Summary: Python bindings for libaudit
56License: LGPLv2+
57Group: Development/Libraries
58Requires: %{name}-libs = %{version}-%{release}
59
60%description libs-python
61The audit-libs-python package contains the bindings so that libaudit
62and libauparse can be used by python.
63
64%package -n audispd-plugins
65Summary: Plugins for the audit event dispatcher
66License: GPLv2+
67Group: System Environment/Daemons
68BuildRequires: openldap-devel
69Requires: %{name} = %{version}-%{release}
70Requires: %{name}-libs = %{version}-%{release}
71Requires: openldap
72
73%description -n audispd-plugins
74The audispd-plugins package provides plugins for the real-time
75interface to the audit system, audispd. These plugins can do things
76like relay events to remote machines or analyze events for suspicious
77behavior.
78
79%package -n system-config-audit
80Summary: Utility for editing audit configuration
81Version: %{sca_version}
82Release: %{sca_release}%{?_dist_release}
83License: GPLv2+
84Group: Applications/System
85BuildRequires: desktop-file-utils
86Requires: pygtk2-libglade usermode usermode-gtk
87
88%description -n system-config-audit
89A graphical utility for editing audit configuration.
90
91%prep
92%setup -q
93%patch10 -p1
94%patch11 -p1
95%patch12 -p1
96cp -f %{SOURCE1} system-config-audit/po/ja.po
97
98%build
99(cd system-config-audit; %configure)
100%configure --sbindir=/sbin --libdir=/%{_lib} --with-libwrap --enable-gssapi-krb5=yes
101make %{?_smp_mflags}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d}}
106mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
107mkdir -p $RPM_BUILD_ROOT/%{_lib}
108mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
109mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
110make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
111make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
112
113mkdir -p $RPM_BUILD_ROOT/%{_libdir}
114# This winds up in the wrong place when libtool is involved
115mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
116mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
117curdir=`pwd`
118cd $RPM_BUILD_ROOT/%{_libdir}
119LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
120ln -s ../../%{_lib}/$LIBNAME libaudit.so
121LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
122ln -s ../../%{_lib}/$LIBNAME libauparse.so
123cd $curdir
124# Remove these items so they don't get picked up.
125rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
126rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
127rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.la
128rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.la
129rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.a
130rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.la
131rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.a
132rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
133rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.a
134rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.la
135
136# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
137touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
138
139%find_lang system-config-audit
140
141desktop-file-install                                    \
142        --dir $RPM_BUILD_ROOT/%{_datadir}/applications  \
143        --delete-original                               \
144        system-config-audit/system-config-audit.desktop
145
146#% check
147#make check
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151rm -rf zos-remote-policy
152
153%post libs -p /sbin/ldconfig
154
155%post
156/sbin/chkconfig --add auditd
157# This is to migrate users from audit-1.0.x installations
158if [ -f /etc/auditd.conf ]; then
159   mv /etc/auditd.conf /etc/audit/auditd.conf
160fi
161if [ -f /etc/audit.rules ]; then
162   mv /etc/audit.rules /etc/audit/audit.rules
163fi
164# This is to enable the dispatcher option which was commented out
165if [ -f /etc/audit/auditd.conf ]; then
166   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
167   if [ $? -eq 1 ] ; then
168      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
169      if [ -n $tmp ]; then
170         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
171         cat $tmp > /etc/audit/auditd.conf
172         rm -f $tmp
173      fi
174   fi
175fi
176
177%preun
178if [ $1 -eq 0 ]; then
179   /sbin/service auditd stop > /dev/null 2>&1
180   /sbin/chkconfig --del auditd
181fi
182
183%postun libs -p /sbin/ldconfig
184
185%postun
186if [ $1 -ge 1 ]; then
187   /sbin/service auditd condrestart > /dev/null 2>&1 || :
188fi
189
190%files libs
191%defattr(-,root,root)
192%attr(755,root,root) /%{_lib}/libaudit.*
193%attr(755,root,root) /%{_lib}/libauparse.*
194%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
195
196%files libs-devel
197%defattr(-,root,root)
198%doc contrib/skeleton.c contrib/plugin
199%{_libdir}/libaudit.a
200%{_libdir}/libauparse.a
201%{_libdir}/libaudit.so
202%{_libdir}/libauparse.so
203%{_includedir}/libaudit.h
204%{_includedir}/auparse.h
205%{_includedir}/auparse-defs.h
206%{_mandir}/man3/*
207
208%files libs-python
209%defattr(-,root,root)
210%attr(755,root,root) %{python_sitearch}/_audit.so
211%attr(755,root,root) %{python_sitearch}/auparse.so
212%{python_sitearch}/audit.py*
213
214%files
215%defattr(-,root,root,-)
216%doc  README COPYING ChangeLog contrib/capp.rules contrib/nispom.rules contrib/lspp.rules contrib/stig.rules init.d/auditd.cron
217%attr(644,root,root) %{_mandir}/man8/audispd.8.gz
218%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
219%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
220%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
221%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
222%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
223%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
224%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
225%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
226%attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
227%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
228%attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
229%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
230%attr(750,root,root) /sbin/auditctl
231%attr(750,root,root) /sbin/auditd
232%attr(755,root,root) /sbin/ausearch
233%attr(755,root,root) /sbin/aureport
234%attr(750,root,root) /sbin/autrace
235%attr(750,root,root) /sbin/audispd
236%attr(750,root,root) %{_bindir}/aulastlog
237%attr(750,root,root) %{_bindir}/aulast
238%attr(755,root,root) %{_bindir}/ausyscall
239%attr(755,root,root) /etc/rc.d/init.d/auditd
240%attr(750,root,root) %{_var}/log/audit
241%attr(750,root,root) %dir /etc/audit
242%attr(750,root,root) %dir /etc/audisp
243%attr(750,root,root) %dir /etc/audisp/plugins.d
244%attr(750,root,root) %dir %{_libdir}/audit
245%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
246%config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
247%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
248%config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
249%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
250
251%files -n audispd-plugins
252%defattr(-,root,root,-)
253%attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
254%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
255%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
256%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
257%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
258%attr(750,root,root) /sbin/audispd-zos-remote
259%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
260%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
261%attr(750,root,root) /sbin/audisp-remote
262%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
263%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
264
265%files -n system-config-audit -f system-config-audit.lang
266%defattr(-,root,root,-)
267%doc system-config-audit/AUTHORS
268%doc system-config-audit/COPYING
269%doc system-config-audit/ChangeLog
270%doc system-config-audit/NEWS
271%doc system-config-audit/README
272%{_bindir}/system-config-audit
273%{_datadir}/applications/system-config-audit.desktop
274%{_datadir}/system-config-audit
275%{_libexecdir}/system-config-audit-server-real
276%{_libexecdir}/system-config-audit-server
277%config(noreplace) %{_sysconfdir}/pam.d/system-config-audit-server
278%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
279
280%changelog
281* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
282- rebuild with python-2.7.2
283- add Patch12 (audit-1.7.18-libaudit.patch)
284
285* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
286- new upstream release
287- rebuild with krb5-1.8.2
288
289* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
290- forgot to increment sca_release macro (why on earth is sca_release
291  individually defined from main package's release number anyway?)
292
293* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
294- rebuilt with gcc-4.4.3-3 on ppc
295
296* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
297- rebuilt with rpm-4.8.0-3 (on ppc)
298
299* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
300- rebuild with python-2.6
301
302* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
303- rebuild with openldap-2.4.11
304
305* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
306- initial build for Vine Linux
307- disable krb5, prelude and selinux
308- add ja.po (XXX: minimal)
309
310* Wed Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
311- Add subject to audit daemon events (Chu Li)
312- Add tcp_wrappers support for auditd
313- Updated syscall tables for 2.6.27 kernel
314- Audit connect/disconnect of remote clients
315- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
316
317* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
318- Update system-config-audit to 0.4.8
319- Whole lot of bug fixes - see ChangeLog for details
320- Reimplement auditd main loop using libev
321- Add TCP listener to auditd to receive remote events
322- Fix scheduler problem (#457061)
323
324* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
325- Move ausearch-expression to main package (#453437)
326
327* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
328- Fix interpreting of keys in syscall records
329- Don't error on name=(null) PATH records in ausearch/report
330- Add key report to aureport
331- Update system-config-audit to 0.4.7 (Miloslav Trmac)
332- Add support for the filetype field option in auditctl new to 2.6.26 kernels
333
334* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
335- Fix output of keys in ausearch interpretted mode
336- Fix ausearch/report --start now to not be reset to midnight
337- audispd now has a priority boost config option
338- Look for laddr in avcs reported via prelude
339- Detect page 0 mmaps and alert via prelude
340
341* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
342- Fix overflow in audit_log_user_command, better (#438840)
343- ausearch was not matching path in avc records
344- audisp-prelude attempt to reposition index after examining each type
345- correct building of mls policy
346- Fix auparse iterating in auparse_find_field and next_field
347- Don't alert on USER_AVC's - they are not quite right
348
349* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
350- Fix buffer overflow in audit_log_user_command, again (#438840)
351- Fix memory leak in EOE code in auditd (#440075)
352- In auditctl, don't use new operators in legacy rule format
353- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
354
355* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
356- Fix memleak in auditd eoe code
357
358* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
359- Remove LSB headers from init scripts
360- Fix buffer overflow in audit_log_user_command again
361
362* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
363- Handle user space avcs in prelude plugin
364- Fix watched account login detection for some failed login attempts
365- Couple fixups in audit logging functions (Miloslav Trmac)
366- Add support in auditctl for virtual keys
367- auparse_find_field_next was not iterating correctly, fixed it
368- Add idmef alerts for access or execution of watched file
369- Fix buffer overflow in audit_log_user_command
370- Add basic remote logging plugin - only sends & no flow control
371- Update ausearch with interpret fixes from auparse
372
373* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
374- Apply hidden attribute cleanup patch (Miloslav Trmac)
375- Apply auparse expression interface patch (Miloslav Trmac)
376- Fix potential memleak in audit event dispatcher
377- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
378- audisp-prelude alerts now controlled by config file
379- Updated syscall table for 2.6.25 kernel
380- Apply patch correcting acct field being misencoded (Miloslav Trmac)
381- Added watched account login detection for prelude plugin
382
383* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
384- Update for gcc 4.3
385- Cleanup descriptors in audispd before running plugin
386- Fix 'recent' keyword for aureport/search
387- Fix SE Linux policy for zos_remote plugin
388- Add event type for group password authentication attempts
389- Couple of updates to the translation tables
390- Add detection of failed group authentication to audisp-prelude
391
392* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
393- In ausearch/report, prefer -if to stdin
394- In ausearch/report, add new command line option --input-logs (#428860)
395- Updated audisp-prelude based on feedback from prelude-devel
396- Added prelude alert for promiscuous socket being opened
397- Added prelude alert for SE Linux policy enforcement changes
398- Added prelude alerts for Forbidden Login Locations and Time
399- Applied patch to auparse fixing error handling of searching by
400  interpreted value (Miloslav Trmac)
401
402* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
403- Add prelude IDS plugin for IDMEF alerts
404- Add --user option to aulastlog command
405- Use desktop-file-install for system-config-audit
406- Avoid touching auditd.conf most of the time (#408501)
407
408* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
409- Updates for spec file review
410- Adjust permission on selinux policy file
411
412* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
413- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
414- Check for audit log being writable by owner in auditd
415- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
416- Updated CAPP, LSPP, and NISPOM rules for new capabilities
417- Added aulastlog utility
418
419* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
420- Allow 0600 file perms for audit logs
421
422* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
423- fchmod of log file was on wrong variable (#426934)
424- Allow use of errno strings for exit codes in audit rules
425
426* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
427- Don't fchmod() /dev/null to mode 0400 (#426934)
428
429* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
430- Add kernel release string to DEAMON_START events
431- Fix keep_logs when num_logs option disabled (#325561)
432- Fix auparse to handle node fields for syscall records
433- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
434- Add keyword week-ago to aureport & ausearch start/end times
435- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
436- Add RACF zos remote audispd plugin (Klaus Kiwi)
437- Add event queue overflow action to audispd
438
439* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
440- Don't retry if the rt queue is full.
441
442* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
443- Add support for searching by posix regular expressions in auparse
444- Route DEAMON events into rt interface
445- If event pipe is full, try again after doing local logging
446- Optionally add node/machine name to records in audit daemon
447- Update ausearch/aureport to specify nodes to search on
448- Fix segfault interpretting saddr fields in avcs
449
450* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
451- Fix uninitialized variable in auparse (John Dennis)
452
453* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
454- External plugin support in place
455- Fix reference counting in auparse python bindings (#263961)
456- Moved default af_unix plugin socket to /var/run/audispd_events
457
458* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
459- Add newline to audispd string formatted events
460
461* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
462- spec file cleanups
463- Update to s-c-audit 0.4.3
464
465* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
466- Update Licence tags
467- Adding perm field should not set syscall added flag in auditctl
468- Fix segfault when aureport -if option is used
469- Fix auditctl to better check keys on rule lines
470- Add support for audit by TTY and other new event types
471- Auditd config option for group permission of audit logs
472- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
473- New audit event dispatcher
474- Update syscall tables for 2.6.23 kernel
475
476* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
477- Fix potential buffer overflow in print clone flags of auparse
478- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
479- Update auditctl to handle legacy kernels when putting a watch on a dir
480- Fix acct interpretation in auparse
481
482* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
483- Fix a double free when auditd receives SIGHUP
484- Move the system-config-audit menu entry to the Administration menu
485
486* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
487- Add system-config-audit (Miloslav Trmac)
488- Correct bug in audit_make_equivalent function (Al Viro)
489
490* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
491- Add feed interface to auparse library (John Dennis)
492- Apply patch to libauparse for unresolved symbols (#241178)
493- Apply patch to add line numbers for file events in libauparse (John Dennis)
494- Change seresults to seresult in libauparse (John Dennis)
495- Add unit32_t definition to swig (#244210)
496- Add support for directory auditing
497- Update acct field to be escaped
498
499* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
500- Change buffer size to prevent truncation of DAEMON events with large labels
501- Fix memory leaks in auparse (John Dennis)
502- Update syscall tables for 2.6.21 kernel
503- Update capp & lspp rules
504- New python bindings for libauparse (John Dennis)
505
506* Thu Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
507- New event dispatcher (James Antill)
508- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
509- Apply patch correcting python libs permissions (Philipp Hahn)
510- Fix auditd segfault on reload
511- Fix bug in auparse library for file pointers and descriptors
512- Extract subject information out of daemon events for ausearch
513
514* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
515- Remove requires kernel-headers for python-libs
516- Apply patch to prevent segfaults on auditd reload
517
518* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
519- Updated autrace to monitor *at syscalls
520- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
521- Finish reworking auditd config parser
522- In auparse, interpret open, fcntl, and clone flags
523- In auparse, when interpreting execve record types, run args through unencode
524- Add support for OBJ_PID message type
525- Event dispatcher updates
526
527* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
528- rebuild
529
530* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
531- NEW audit dispatcher program & plugin framework
532- Correct hidden variables in libauparse
533- Added NISPOM sample rules
534- Verify accessibility of files passed in auparse_init
535- Fix bug in parser library interpreting socketcalls
536- Add support for stdio FILE pointer in auparse_init
537- Adjust init script to allow anyone to status auditd (#230626)
538
539* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
540- Add man pages
541- Reduce text relocations in parser library
542- Add -n option to auditd for no fork
543- Add exec option to space_left, admin_space_left, disk_full,
544  and disk_error - eg EXEC /usr/local/script
545
546* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
547- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
548- Finished search options for audit parsing library
549- Fix ausearch -se to work correctly
550- Fix auditd init script for /usr on netdev (#228528)
551- Parse avc seperms better when there are more than one
552
553* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
554- New report about authentication attempts
555- Updates for python 2.5
556- update autrace to have resource usage mode
557- update auditctl to support immutable config
558- added audit_log_user_command function to libaudit api
559- interpret capabilities
560- added audit event parsing library
561- updates for 2.6.20 kernel
562
563* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
564- Make more adjustments for python 2.5
565
566* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
567- Fix a couple parsing problems (#217952)
568- Add tgkill to S390* syscall tables (#218484)
569- Fix error messages in ausearch/aureport
570
571* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
572- rebuild against python 2.5
573
574* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
575- Fix timestamp for libaudit.conf (#218053)
576
577* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
578- Fix minor parsing problem and add new msg types
579
580* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
581- ausearch & aureport implement uid/gid caching
582- In ausearch & aureport, extract addr when hostname is unknown
583- In ausearch & aureport, test audit log presence O_RDONLY
584- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
585- Added --add & --delete option to aureport
586- Update res parsing in config change events
587- Increase the size on audit daemon buffers
588- Parse avc_path records in ausearch/aureport
589- ausearch has new output mode, raw, for extracting events
590- ausearch/aureport can now read stdin
591- Rework AVC processing in ausearch/aureport
592- Added long options to ausearch and aureport
593
594* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
595- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
596- Fix some defines in libaudit.h
597- Some auditd config strings were not initialized in aureport (#211443)
598- Updated man pages
599- Add Netlabel event types to libaudit
600- Update aureports to current audit event types
601- Update autrace a little
602- Deprecated all the old audit_rule functions from public API
603- Drop auparse library for the moment
604
605* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
606- Add dist tag and bump version (#208532)
607- Make internal auditd buffers bigger for context info
608- Correct address resolving of hostname in logging functions
609- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
610- Only =, != operators for arch & inode fields in auditctl (#206427)
611- Updated audit message type table
612- Remove watches from aureport since FS_WATCH is deprecated
613- Add audit_log_avc back temporarily (#208152)
614 
Note: See TracBrowser for help on using the repository browser.