source: projects/specs/trunk/a/audit/audit-vl.spec @ 521

Revision 521, 23.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define sca_version 0.4.8
2%define sca_release 6
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4
5Summary: User space tools for 2.6 kernel auditing
6Name: audit
7Version: 1.7.6
8Release: 6%{?_dist_release}
9License: GPLv2+
10Group: System Environment/Daemons
11URL: http://people.redhat.com/sgrubb/audit/
12Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
13Source1: system-config-audit-ja.po
14Patch1: audit-1.7.5-policy.patch
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: gettext intltool libtool swig python-devel
17BuildRequires: tcp_wrappers
18BuildRequires: kernel-headers >= 2.6.18
19BuildRequires: automake >= 1.9
20BuildRequires: autoconf >= 2.59
21Requires: %{name}-libs = %{version}-%{release}
22Requires: chkconfig
23Requires(pre): coreutils
24
25%description
26The audit package contains the user space utilities for
27storing and searching the audit records generate by
28the audit subsystem in the Linux 2.6 kernel.
29
30%package libs
31Summary: Dynamic library for libaudit
32License: LGPLv2+
33Group: Development/Libraries
34
35%description libs
36The audit-libs package contains the dynamic libraries needed for
37applications to use the audit framework.
38
39%package libs-devel
40Summary: Header files and static library for libaudit
41License: LGPLv2+
42Group: Development/Libraries
43Requires: %{name}-libs = %{version}-%{release}
44Requires: kernel-headers >= 2.6.18
45
46%description libs-devel
47The audit-libs-devel package contains the static libraries and header
48files needed for developing applications that need to use the audit
49framework libraries.
50
51%package libs-python
52Summary: Python bindings for libaudit
53License: LGPLv2+
54Group: Development/Libraries
55Requires: %{name}-libs = %{version}-%{release}
56
57%description libs-python
58The audit-libs-python package contains the bindings so that libaudit
59and libauparse can be used by python.
60
61%package -n audispd-plugins
62Summary: Plugins for the audit event dispatcher
63License: GPLv2+
64Group: System Environment/Daemons
65BuildRequires: openldap-devel
66Requires: %{name} = %{version}-%{release}
67Requires: %{name}-libs = %{version}-%{release}
68Requires: openldap
69
70%description -n audispd-plugins
71The audispd-plugins package provides plugins for the real-time
72interface to the audit system, audispd. These plugins can do things
73like relay events to remote machines or analyze events for suspicious
74behavior.
75
76%package -n system-config-audit
77Summary: Utility for editing audit configuration
78Version: %{sca_version}
79Release: %{sca_release}%{?_dist_release}
80License: GPLv2+
81Group: Applications/System
82BuildRequires: desktop-file-utils
83Requires: pygtk2-libglade usermode usermode-gtk
84
85%description -n system-config-audit
86A graphical utility for editing audit configuration.
87
88%prep
89%setup -q
90%patch1 -p1
91cp -f %{SOURCE1} system-config-audit/po/ja.po
92
93%build
94(cd system-config-audit; ./autogen.sh)
95%configure --sbindir=/sbin --libdir=/%{_lib} --with-libwrap
96make %{?_smp_mflags}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d}}
101mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
102mkdir -p $RPM_BUILD_ROOT/%{_lib}
103mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
104mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
105make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
106make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
107
108mkdir -p $RPM_BUILD_ROOT/%{_libdir}
109# This winds up in the wrong place when libtool is involved
110mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
111mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
112curdir=`pwd`
113cd $RPM_BUILD_ROOT/%{_libdir}
114LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
115ln -s ../../%{_lib}/$LIBNAME libaudit.so
116LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
117ln -s ../../%{_lib}/$LIBNAME libauparse.so
118cd $curdir
119# Remove these items so they don't get picked up.
120rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
121rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
122rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.la
123rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.la
124rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.a
125rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.la
126rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.a
127rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
128rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.a
129rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.la
130
131# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
132touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
133
134%find_lang system-config-audit
135
136desktop-file-install                                    \
137        --dir $RPM_BUILD_ROOT/%{_datadir}/applications  \
138        --delete-original                               \
139        system-config-audit/system-config-audit.desktop
140
141#% check
142#make check
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146rm -rf zos-remote-policy
147
148%post libs -p /sbin/ldconfig
149
150%post
151/sbin/chkconfig --add auditd
152# This is to migrate users from audit-1.0.x installations
153if [ -f /etc/auditd.conf ]; then
154   mv /etc/auditd.conf /etc/audit/auditd.conf
155fi
156if [ -f /etc/audit.rules ]; then
157   mv /etc/audit.rules /etc/audit/audit.rules
158fi
159# This is to enable the dispatcher option which was commented out
160if [ -f /etc/audit/auditd.conf ]; then
161   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
162   if [ $? -eq 1 ] ; then
163      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
164      if [ -n $tmp ]; then
165         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
166         cat $tmp > /etc/audit/auditd.conf
167         rm -f $tmp
168      fi
169   fi
170fi
171
172%preun
173if [ $1 -eq 0 ]; then
174   /sbin/service auditd stop > /dev/null 2>&1
175   /sbin/chkconfig --del auditd
176fi
177
178%postun libs -p /sbin/ldconfig
179
180%postun
181if [ $1 -ge 1 ]; then
182   /sbin/service auditd condrestart > /dev/null 2>&1 || :
183fi
184
185%files libs
186%defattr(-,root,root)
187%attr(755,root,root) /%{_lib}/libaudit.*
188%attr(755,root,root) /%{_lib}/libauparse.*
189%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
190
191%files libs-devel
192%defattr(-,root,root)
193%doc contrib/skeleton.c contrib/plugin
194%{_libdir}/libaudit.a
195%{_libdir}/libauparse.a
196%{_libdir}/libaudit.so
197%{_libdir}/libauparse.so
198%{_includedir}/libaudit.h
199%{_includedir}/auparse.h
200%{_includedir}/auparse-defs.h
201%{_mandir}/man3/*
202
203%files libs-python
204%defattr(-,root,root)
205%attr(755,root,root) %{_libdir}/python?.?/site-packages/_audit.so
206%attr(755,root,root) %{_libdir}/python?.?/site-packages/auparse.so
207#%{_libdir}/python?.?/site-packages/auparse-*.egg-info
208%{python_sitelib}/audit.py*
209
210%files
211%defattr(-,root,root,-)
212%doc  README COPYING ChangeLog contrib/capp.rules contrib/nispom.rules contrib/lspp.rules contrib/stig.rules init.d/auditd.cron
213%attr(644,root,root) %{_mandir}/man8/audispd.8.gz
214%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
215%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
216%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
217%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
218%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
219%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
220%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
221%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
222%attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
223%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
224%attr(750,root,root) /sbin/auditctl
225%attr(750,root,root) /sbin/auditd
226%attr(755,root,root) /sbin/ausearch
227%attr(755,root,root) /sbin/aureport
228%attr(750,root,root) /sbin/autrace
229%attr(750,root,root) /sbin/audispd
230%attr(750,root,root) %{_bindir}/aulastlog
231%attr(755,root,root) %{_bindir}/ausyscall
232%attr(755,root,root) /etc/rc.d/init.d/auditd
233%attr(750,root,root) %{_var}/log/audit
234%attr(750,root,root) %dir /etc/audit
235%attr(750,root,root) %dir /etc/audisp
236%attr(750,root,root) %dir /etc/audisp/plugins.d
237%attr(750,root,root) %dir %{_libdir}/audit
238%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
239%config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
240%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
241%config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
242%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
243
244%files -n audispd-plugins
245%defattr(-,root,root,-)
246%attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
247%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
248%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
249%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
250%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
251%attr(750,root,root) /sbin/audispd-zos-remote
252%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
253%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
254%attr(750,root,root) /sbin/audisp-remote
255%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
256%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
257
258%files -n system-config-audit -f system-config-audit.lang
259%defattr(-,root,root,-)
260%doc system-config-audit/AUTHORS
261%doc system-config-audit/COPYING
262%doc system-config-audit/ChangeLog
263%doc system-config-audit/NEWS
264%doc system-config-audit/README
265%{_bindir}/system-config-audit
266%{_datadir}/applications/system-config-audit.desktop
267%{_datadir}/system-config-audit
268%{_libexecdir}/system-config-audit-server-real
269%{_libexecdir}/system-config-audit-server
270%config(noreplace) %{_sysconfdir}/pam.d/system-config-audit-server
271%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
272
273%changelog
274* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
275- forgot to increment sca_release macro (why on earth is sca_release
276  individually defined from main package's release number anyway?)
277
278* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
279- rebuilt with gcc-4.4.3-3 on ppc
280
281* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
282- rebuilt with rpm-4.8.0-3 (on ppc)
283
284* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
285- rebuild with python-2.6
286
287* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
288- rebuild with openldap-2.4.11
289
290* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
291- initial build for Vine Linux
292- disable krb5, prelude and selinux
293- add ja.po (XXX: minimal)
294
295* Wed Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
296- Add subject to audit daemon events (Chu Li)
297- Add tcp_wrappers support for auditd
298- Updated syscall tables for 2.6.27 kernel
299- Audit connect/disconnect of remote clients
300- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
301
302* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
303- Update system-config-audit to 0.4.8
304- Whole lot of bug fixes - see ChangeLog for details
305- Reimplement auditd main loop using libev
306- Add TCP listener to auditd to receive remote events
307- Fix scheduler problem (#457061)
308
309* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
310- Move ausearch-expression to main package (#453437)
311
312* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
313- Fix interpreting of keys in syscall records
314- Don't error on name=(null) PATH records in ausearch/report
315- Add key report to aureport
316- Update system-config-audit to 0.4.7 (Miloslav Trmac)
317- Add support for the filetype field option in auditctl new to 2.6.26 kernels
318
319* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
320- Fix output of keys in ausearch interpretted mode
321- Fix ausearch/report --start now to not be reset to midnight
322- audispd now has a priority boost config option
323- Look for laddr in avcs reported via prelude
324- Detect page 0 mmaps and alert via prelude
325
326* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
327- Fix overflow in audit_log_user_command, better (#438840)
328- ausearch was not matching path in avc records
329- audisp-prelude attempt to reposition index after examining each type
330- correct building of mls policy
331- Fix auparse iterating in auparse_find_field and next_field
332- Don't alert on USER_AVC's - they are not quite right
333
334* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
335- Fix buffer overflow in audit_log_user_command, again (#438840)
336- Fix memory leak in EOE code in auditd (#440075)
337- In auditctl, don't use new operators in legacy rule format
338- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
339
340* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
341- Fix memleak in auditd eoe code
342
343* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
344- Remove LSB headers from init scripts
345- Fix buffer overflow in audit_log_user_command again
346
347* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
348- Handle user space avcs in prelude plugin
349- Fix watched account login detection for some failed login attempts
350- Couple fixups in audit logging functions (Miloslav Trmac)
351- Add support in auditctl for virtual keys
352- auparse_find_field_next was not iterating correctly, fixed it
353- Add idmef alerts for access or execution of watched file
354- Fix buffer overflow in audit_log_user_command
355- Add basic remote logging plugin - only sends & no flow control
356- Update ausearch with interpret fixes from auparse
357
358* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
359- Apply hidden attribute cleanup patch (Miloslav Trmac)
360- Apply auparse expression interface patch (Miloslav Trmac)
361- Fix potential memleak in audit event dispatcher
362- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
363- audisp-prelude alerts now controlled by config file
364- Updated syscall table for 2.6.25 kernel
365- Apply patch correcting acct field being misencoded (Miloslav Trmac)
366- Added watched account login detection for prelude plugin
367
368* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
369- Update for gcc 4.3
370- Cleanup descriptors in audispd before running plugin
371- Fix 'recent' keyword for aureport/search
372- Fix SE Linux policy for zos_remote plugin
373- Add event type for group password authentication attempts
374- Couple of updates to the translation tables
375- Add detection of failed group authentication to audisp-prelude
376
377* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
378- In ausearch/report, prefer -if to stdin
379- In ausearch/report, add new command line option --input-logs (#428860)
380- Updated audisp-prelude based on feedback from prelude-devel
381- Added prelude alert for promiscuous socket being opened
382- Added prelude alert for SE Linux policy enforcement changes
383- Added prelude alerts for Forbidden Login Locations and Time
384- Applied patch to auparse fixing error handling of searching by
385  interpreted value (Miloslav Trmac)
386
387* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
388- Add prelude IDS plugin for IDMEF alerts
389- Add --user option to aulastlog command
390- Use desktop-file-install for system-config-audit
391- Avoid touching auditd.conf most of the time (#408501)
392
393* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
394- Updates for spec file review
395- Adjust permission on selinux policy file
396
397* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
398- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
399- Check for audit log being writable by owner in auditd
400- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
401- Updated CAPP, LSPP, and NISPOM rules for new capabilities
402- Added aulastlog utility
403
404* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
405- Allow 0600 file perms for audit logs
406
407* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
408- fchmod of log file was on wrong variable (#426934)
409- Allow use of errno strings for exit codes in audit rules
410
411* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
412- Don't fchmod() /dev/null to mode 0400 (#426934)
413
414* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
415- Add kernel release string to DEAMON_START events
416- Fix keep_logs when num_logs option disabled (#325561)
417- Fix auparse to handle node fields for syscall records
418- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
419- Add keyword week-ago to aureport & ausearch start/end times
420- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
421- Add RACF zos remote audispd plugin (Klaus Kiwi)
422- Add event queue overflow action to audispd
423
424* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
425- Don't retry if the rt queue is full.
426
427* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
428- Add support for searching by posix regular expressions in auparse
429- Route DEAMON events into rt interface
430- If event pipe is full, try again after doing local logging
431- Optionally add node/machine name to records in audit daemon
432- Update ausearch/aureport to specify nodes to search on
433- Fix segfault interpretting saddr fields in avcs
434
435* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
436- Fix uninitialized variable in auparse (John Dennis)
437
438* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
439- External plugin support in place
440- Fix reference counting in auparse python bindings (#263961)
441- Moved default af_unix plugin socket to /var/run/audispd_events
442
443* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
444- Add newline to audispd string formatted events
445
446* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
447- spec file cleanups
448- Update to s-c-audit 0.4.3
449
450* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
451- Update Licence tags
452- Adding perm field should not set syscall added flag in auditctl
453- Fix segfault when aureport -if option is used
454- Fix auditctl to better check keys on rule lines
455- Add support for audit by TTY and other new event types
456- Auditd config option for group permission of audit logs
457- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
458- New audit event dispatcher
459- Update syscall tables for 2.6.23 kernel
460
461* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
462- Fix potential buffer overflow in print clone flags of auparse
463- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
464- Update auditctl to handle legacy kernels when putting a watch on a dir
465- Fix acct interpretation in auparse
466
467* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
468- Fix a double free when auditd receives SIGHUP
469- Move the system-config-audit menu entry to the Administration menu
470
471* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
472- Add system-config-audit (Miloslav Trmac)
473- Correct bug in audit_make_equivalent function (Al Viro)
474
475* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
476- Add feed interface to auparse library (John Dennis)
477- Apply patch to libauparse for unresolved symbols (#241178)
478- Apply patch to add line numbers for file events in libauparse (John Dennis)
479- Change seresults to seresult in libauparse (John Dennis)
480- Add unit32_t definition to swig (#244210)
481- Add support for directory auditing
482- Update acct field to be escaped
483
484* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
485- Change buffer size to prevent truncation of DAEMON events with large labels
486- Fix memory leaks in auparse (John Dennis)
487- Update syscall tables for 2.6.21 kernel
488- Update capp & lspp rules
489- New python bindings for libauparse (John Dennis)
490
491* Thu Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
492- New event dispatcher (James Antill)
493- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
494- Apply patch correcting python libs permissions (Philipp Hahn)
495- Fix auditd segfault on reload
496- Fix bug in auparse library for file pointers and descriptors
497- Extract subject information out of daemon events for ausearch
498
499* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
500- Remove requires kernel-headers for python-libs
501- Apply patch to prevent segfaults on auditd reload
502
503* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
504- Updated autrace to monitor *at syscalls
505- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
506- Finish reworking auditd config parser
507- In auparse, interpret open, fcntl, and clone flags
508- In auparse, when interpreting execve record types, run args through unencode
509- Add support for OBJ_PID message type
510- Event dispatcher updates
511
512* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
513- rebuild
514
515* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
516- NEW audit dispatcher program & plugin framework
517- Correct hidden variables in libauparse
518- Added NISPOM sample rules
519- Verify accessibility of files passed in auparse_init
520- Fix bug in parser library interpreting socketcalls
521- Add support for stdio FILE pointer in auparse_init
522- Adjust init script to allow anyone to status auditd (#230626)
523
524* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
525- Add man pages
526- Reduce text relocations in parser library
527- Add -n option to auditd for no fork
528- Add exec option to space_left, admin_space_left, disk_full,
529  and disk_error - eg EXEC /usr/local/script
530
531* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
532- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
533- Finished search options for audit parsing library
534- Fix ausearch -se to work correctly
535- Fix auditd init script for /usr on netdev (#228528)
536- Parse avc seperms better when there are more than one
537
538* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
539- New report about authentication attempts
540- Updates for python 2.5
541- update autrace to have resource usage mode
542- update auditctl to support immutable config
543- added audit_log_user_command function to libaudit api
544- interpret capabilities
545- added audit event parsing library
546- updates for 2.6.20 kernel
547
548* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
549- Make more adjustments for python 2.5
550
551* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
552- Fix a couple parsing problems (#217952)
553- Add tgkill to S390* syscall tables (#218484)
554- Fix error messages in ausearch/aureport
555
556* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
557- rebuild against python 2.5
558
559* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
560- Fix timestamp for libaudit.conf (#218053)
561
562* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
563- Fix minor parsing problem and add new msg types
564
565* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
566- ausearch & aureport implement uid/gid caching
567- In ausearch & aureport, extract addr when hostname is unknown
568- In ausearch & aureport, test audit log presence O_RDONLY
569- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
570- Added --add & --delete option to aureport
571- Update res parsing in config change events
572- Increase the size on audit daemon buffers
573- Parse avc_path records in ausearch/aureport
574- ausearch has new output mode, raw, for extracting events
575- ausearch/aureport can now read stdin
576- Rework AVC processing in ausearch/aureport
577- Added long options to ausearch and aureport
578
579* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
580- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
581- Fix some defines in libaudit.h
582- Some auditd config strings were not initialized in aureport (#211443)
583- Updated man pages
584- Add Netlabel event types to libaudit
585- Update aureports to current audit event types
586- Update autrace a little
587- Deprecated all the old audit_rule functions from public API
588- Drop auparse library for the moment
589
590* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
591- Add dist tag and bump version (#208532)
592- Make internal auditd buffers bigger for context info
593- Correct address resolving of hostname in logging functions
594- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
595- Only =, != operators for arch & inode fields in auditctl (#206427)
596- Updated audit message type table
597- Remove watches from aureport since FS_WATCH is deprecated
598- Add audit_log_avc back temporarily (#208152)
599 
Note: See TracBrowser for help on using the repository browser.