source: projects/specs/trunk/a/auctex/auctex-vl.spec @ 696

Revision 696, 8.8 KB checked in by munepi, 14 years ago (diff)

updated auctex-vl.spec

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3%define origname        auctex
4%define emacspkg        preview-latex
5
6%define texmf           %{_datadir}/texmf
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
10%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
11
12
13Summary:        Enhanced TeX modes for Emacsen
14Name:           %{origname}
15Version:        11.86
16Release:        1%{?_dist_release}
17Group:          Applications/Editors/Emacs
18License:        GPLv3+
19URL:            http://www.gnu.org/software/auctex/
20Source:         http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
21Source1:        %{origname}-install.sh
22Source2:        %{origname}-remove.sh
23Source3:        %{origname}-init.el
24Source4:        vine-default-%{origname}.el
25
26Source5:        %{emacspkg}-install.sh
27Source6:        %{emacspkg}-remove.sh
28Source7:        %{emacspkg}-init.el
29Source8:        vine-default-%{emacspkg}.el
30
31Patch:          auctex-11.85-vine.patch
32
33Requires:       %{emacspkg} = %{version}-%{release}
34BuildRequires:  texinfo
35BuildRequires:  tetex
36%prereq_ge      emacsen emacsen-common
37Requires(post): /sbin/install-info
38
39Obsoletes:      auctex-emacs auctex-xemacs
40
41BuildArch:      noarch
42BuildRoot:      %{_tmppath}/%{name}-%{version}-root
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       munepi
47
48
49%description
50AUCTeX is an extensible package that supports writing and formatting TeX files
51for most variants of Emacs. 
52
53AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
54Texinfo and basic support for ConTeXt.  Documentation can be found under
55/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
56manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
57page, we provide manuals in various formats.
58
59This version of AUCTeX comes with preview-latex, an addictive productivity
60tool providing a fine-grained interactive folding WYSIWYG display in the
61source buffer.
62
63If you are AUCTeX user and you install both yatex and auctex on your system,
64you may add the following configure in your emacs init file ~/.emacs.el:
65
66;; I'm AUCTeX user!!!
67(setq vine-default-yatex nil)
68
69#'
70
71
72%package -n %{emacspkg}
73Summary:        Emacs/LaTeX inline preview
74Group:          Applications/Editors/Emacs
75Requires(post):       %{origname} = %{version}-%{release}
76BuildRequires:  emacsen
77%prereq_ge      emacsen-common
78
79%description -n %{emacspkg}
80AUCTeX is an extensible package that supports writing and formatting TeX files
81for most variants of Emacs. 
82
83AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
84Texinfo and basic support for ConTeXt.  Documentation can be found under
85/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
86manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
87page, we provide manuals in various formats.
88
89This version of AUCTeX comes with preview-latex, an addictive productivity
90tool providing a fine-grained interactive folding WYSIWYG display in the
91source buffer.
92
93Does your neck hurt from turning between previewer windows and the
94source too often? This Elisp/LaTeX package will render your displayed
95LaTeX equations right into the editing window where they belong.
96
97
98%prep
99%setup -q -n %{origname}-%{version}
100%patch -p1 -b .vine
101
102%build
103%configure --with-emacs INSTALL_INFO=: --without-texmf-dir
104%__make
105
106## output auctex.el
107%__cp -a auctex.el auctex.el.vine
108cat>auctex.el<<EOF
109;;; auctex.el
110;;
111;; This can be used for starting up AUCTeX.  The following somewhat
112;; strange trick causes tex-site.el to be loaded in a way that can be
113;; safely undone using (unload-feature 'tex-site).
114;;
115;; (autoload 'TeX-load-hack
116;;   "/some/where/tex-site.el")
117;; (TeX-load-hack)
118
119;;
120;; No any settings provide in this file.
121;;
122EOF
123
124## remove all *.elc
125find . -type f -name "*.elc" -exec rm -f {} ';'
126
127
128%install
129
130[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
131
132## install preview package
133pushd preview
134%__make install-texmf \
135    previewtexmfdir=%{build_texmf}/tex/latex/preview \
136    previewdocdir=%{build_texmf}/doc/latex/preview
137%__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
138%__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
139popd
140
141
142%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
143%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
144%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
145%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
146%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
147
148
149#
150# install el files
151#
152
153## <auctex>
154%__install -p -m0644 *.el \
155    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
156%__cp -ra images style \
157    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
158
159%__install -p -m0644 %{SOURCE3} %{SOURCE4} \
160    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
161## </auctex>
162
163## <preview-latex>
164pushd preview
165%__install -p -m0644 *.el \
166    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
167%__cp -ra images \
168    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
169popd
170
171%__install -p -m0644 %{SOURCE7} %{SOURCE8} \
172    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
173## </preview-latex>
174
175
176#
177# install info files
178#
179
180%__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
181    ${RPM_BUILD_ROOT}%{_infodir}/
182
183
184#
185# install script (bytecompile el and install elc, remove)
186#
187
188%_installemacsenscript %{origname} %{SOURCE1}
189
190%_removeemacsenscript  %{origname} %{SOURCE2}
191
192%_installemacsenscript %{emacspkg} %{SOURCE5}
193
194%_removeemacsenscript  %{emacspkg} %{SOURCE6}
195
196
197%clean
198[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
199
200
201%post
202#
203# bytecompile and install
204#
205
206if [ "$1" = 2 ]; then
207
208%_emacsenPackageRemove %{origname}
209
210fi
211
212%_addemacsenlist %{origname}
213
214%_emacsenPackageInstall %{origname}
215
216/sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
217  --section="A much enhanced LaTeX mode for GNU Emacs"
218
219
220%post -n %{emacspkg}
221#
222# bytecompile and install
223#
224
225if [ "$1" = 2 ]; then
226
227    %_emacsenPackageRemove %{emacspkg}
228
229fi
230
231%_addemacsenlist %{emacspkg}
232
233%_emacsenPackageInstall %{emacspkg}
234
235/sbin/install-info \
236    %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
237    --section="A much enhanced LaTeX mode for GNU Emacs"
238
239
240%preun
241if [ "$1" = 0 ]; then
242    %_emacsenPackageRemove %{origname}
243
244    %_removeemacsenlist %{origname}
245
246    /sbin/install-info --delete \
247        %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
248        --section="A much enhanced LaTeX mode for GNU Emacs"
249fi
250
251
252%preun -n %{emacspkg}
253if [ "$1" = 0 ]; then
254
255    %_emacsenPackageRemove %{emacspkg}
256
257    %_removeemacsenlist %{emacspkg}
258
259    /sbin/install-info --delete \
260        %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
261        --section="A much enhanced LaTeX mode for GNU Emacs"
262fi
263
264
265%files
266%defattr(-,root,root)
267%doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
268%{_infodir}/%{origname}*
269%{_datadir}/emacs/site-lisp/%{origname}/
270%{emacsen_pkgdir}/install/%{origname}
271%{emacsen_pkgdir}/remove/%{origname}
272
273
274%files -n %{emacspkg}
275%defattr(-,root,root)
276%doc preview/COPYING preview/ChangeLog{,.1}
277%{_infodir}/%{emacspkg}*
278%{texmf}/doc/latex/preview/preview.pdf
279%{texmf}/tex/latex/preview/*
280%{_datadir}/emacs/site-lisp/%{emacspkg}/
281%{emacsen_pkgdir}/install/%{emacspkg}
282%{emacsen_pkgdir}/remove/%{emacspkg}
283
284
285
286%changelog
287* Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
288- new versioning release
289
290* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
291- new versioning release
292- dropped old version patches
293- changed to GPLv3+ in License tag
294- changed to http://www.gnu.org/software/auctex/ in URL tag
295- download from http://ftp.gnu.org/pub/gnu/auctex in Source0
296- added preview-latex package
297- setup vine-default
298
299* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
300- applied new versioning policy, spec in utf-8
301- added macro %%emacsen_pkgdir
302
303* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
304- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
305- s/Copyright/License/
306
307* Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
308- ver.up
309
310* Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
311- minor fix of tex-jp.el
312
313* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
314- emasenize
315
316* Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
317- 10.0g-0vl1
318
319* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
320- 9.10p-0vl2
321- minor modification of spec file
322
323* Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
324- 9.10p-0vl1
325- change directories
326- minor customization
327
328* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
329- 9.10p
330
331* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
332- build auctex for emacs
333
334* Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
335- updated to 9.9p
336
337* Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
338- first release for 9.8l
339
Note: See TracBrowser for help on using the repository browser.