source: projects/specs/trunk/a/auctex/auctex-vl.spec @ 2434

Revision 2434, 9.1 KB checked in by munepi, 13 years ago (diff)

updated ltris, lbreakout2, auctex spec files

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3%define origname        auctex
4%define emacspkg        preview-latex
5
6%define texmf           %{_datadir}/texmf
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
10%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
11
12
13Summary:        Enhanced TeX modes for Emacsen
14Name:           %{origname}
15Version:        11.86
16Release:        2%{?_dist_release}
17Group:          Applications/Editors/Emacs
18License:        GPLv3+
19URL:            http://www.gnu.org/software/auctex/
20Source:         http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
21Source1:        %{origname}-install.sh
22Source2:        %{origname}-remove.sh
23Source3:        %{origname}-init.el
24Source4:        vine-default-%{origname}.el
25
26Source5:        %{emacspkg}-install.sh
27Source6:        %{emacspkg}-remove.sh
28Source7:        %{emacspkg}-init.el
29Source8:        vine-default-%{emacspkg}.el
30
31Patch:          auctex-11.85-vine.patch
32
33Requires:       %{emacspkg} = %{version}-%{release}
34BuildRequires:  texinfo
35%if %{?_dist_release} == "vl5"
36BuildRequires:  tetex
37%else
38BuildRequires:  texlive
39%endif
40## Note: "BR: emacs >= 23.1" need to build auctex
41BuildRequires:  emacs >= 23.1
42
43%prereq_ge      emacsen emacsen-common
44Requires(post): /sbin/install-info
45
46Obsoletes:      auctex-emacs auctex-xemacs
47
48BuildArch:      noarch
49BuildRoot:      %{_tmppath}/%{name}-%{version}-root
50
51Vendor:         Project Vine
52Distribution:   Vine Linux
53Packager:       munepi
54
55
56%description
57AUCTeX is an extensible package that supports writing and formatting TeX files
58for most variants of Emacs. 
59
60AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
61Texinfo and basic support for ConTeXt.  Documentation can be found under
62/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
63manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
64page, we provide manuals in various formats.
65
66This version of AUCTeX comes with preview-latex, an addictive productivity
67tool providing a fine-grained interactive folding WYSIWYG display in the
68source buffer.
69
70If you are AUCTeX user and you install both yatex and auctex on your system,
71you may add the following configure in your emacs init file ~/.emacs.el:
72
73;; I'm AUCTeX user!!!
74(setq vine-default-yatex nil)
75
76#'
77
78
79%package -n %{emacspkg}
80Summary:        Emacs/LaTeX inline preview
81Group:          Applications/Editors/Emacs
82Requires(post):       %{origname} = %{version}-%{release}
83BuildRequires:  emacsen
84%prereq_ge      emacsen-common
85
86%description -n %{emacspkg}
87AUCTeX is an extensible package that supports writing and formatting TeX files
88for most variants of Emacs. 
89
90AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
91Texinfo and basic support for ConTeXt.  Documentation can be found under
92/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
93manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
94page, we provide manuals in various formats.
95
96This version of AUCTeX comes with preview-latex, an addictive productivity
97tool providing a fine-grained interactive folding WYSIWYG display in the
98source buffer.
99
100Does your neck hurt from turning between previewer windows and the
101source too often? This Elisp/LaTeX package will render your displayed
102LaTeX equations right into the editing window where they belong.
103
104
105%prep
106%setup -q -n %{origname}-%{version}
107%patch -p1 -b .vine
108
109%build
110%configure --with-emacs INSTALL_INFO=: --without-texmf-dir
111%__make
112
113## output auctex.el
114%__cp -a auctex.el auctex.el.vine
115cat>auctex.el<<EOF
116;;; auctex.el
117;;
118;; This can be used for starting up AUCTeX.  The following somewhat
119;; strange trick causes tex-site.el to be loaded in a way that can be
120;; safely undone using (unload-feature 'tex-site).
121;;
122;; (autoload 'TeX-load-hack
123;;   "/some/where/tex-site.el")
124;; (TeX-load-hack)
125
126;;
127;; No any settings provide in this file.
128;;
129EOF
130
131## remove all *.elc
132find . -type f -name "*.elc" -exec rm -f {} ';'
133
134
135%install
136
137[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
138
139## install preview package
140pushd preview
141%__make install-texmf \
142    previewtexmfdir=%{build_texmf}/tex/latex/preview \
143    previewdocdir=%{build_texmf}/doc/latex/preview
144%__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
145%__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
146popd
147
148
149%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
150%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
151%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
152%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
153%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
154
155
156#
157# install el files
158#
159
160## <auctex>
161%__install -p -m0644 *.el \
162    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
163%__cp -ra images style \
164    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
165
166%__install -p -m0644 %{SOURCE3} %{SOURCE4} \
167    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
168## </auctex>
169
170## <preview-latex>
171pushd preview
172%__install -p -m0644 *.el \
173    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
174%__cp -ra images \
175    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
176popd
177
178%__install -p -m0644 %{SOURCE7} %{SOURCE8} \
179    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
180## </preview-latex>
181
182
183#
184# install info files
185#
186
187%__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
188    ${RPM_BUILD_ROOT}%{_infodir}/
189
190
191#
192# install script (bytecompile el and install elc, remove)
193#
194
195%_installemacsenscript %{origname} %{SOURCE1}
196
197%_removeemacsenscript  %{origname} %{SOURCE2}
198
199%_installemacsenscript %{emacspkg} %{SOURCE5}
200
201%_removeemacsenscript  %{emacspkg} %{SOURCE6}
202
203
204%clean
205[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
206
207
208%post
209#
210# bytecompile and install
211#
212
213if [ "$1" = 2 ]; then
214
215%_emacsenPackageRemove %{origname}
216
217fi
218
219%_addemacsenlist %{origname}
220
221%_emacsenPackageInstall %{origname}
222
223/sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
224  --section="A much enhanced LaTeX mode for GNU Emacs"
225
226
227%post -n %{emacspkg}
228#
229# bytecompile and install
230#
231
232if [ "$1" = 2 ]; then
233
234    %_emacsenPackageRemove %{emacspkg}
235
236fi
237
238%_addemacsenlist %{emacspkg}
239
240%_emacsenPackageInstall %{emacspkg}
241
242/sbin/install-info \
243    %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
244    --section="A much enhanced LaTeX mode for GNU Emacs"
245
246
247%preun
248if [ "$1" = 0 ]; then
249    %_emacsenPackageRemove %{origname}
250
251    %_removeemacsenlist %{origname}
252
253    /sbin/install-info --delete \
254        %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
255        --section="A much enhanced LaTeX mode for GNU Emacs"
256fi
257
258
259%preun -n %{emacspkg}
260if [ "$1" = 0 ]; then
261
262    %_emacsenPackageRemove %{emacspkg}
263
264    %_removeemacsenlist %{emacspkg}
265
266    /sbin/install-info --delete \
267        %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
268        --section="A much enhanced LaTeX mode for GNU Emacs"
269fi
270
271
272%files
273%defattr(-,root,root)
274%doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
275%{_infodir}/%{origname}*
276%{_datadir}/emacs/site-lisp/%{origname}/
277%{emacsen_pkgdir}/install/%{origname}
278%{emacsen_pkgdir}/remove/%{origname}
279
280
281%files -n %{emacspkg}
282%defattr(-,root,root)
283%doc preview/COPYING preview/ChangeLog{,.1}
284%{_infodir}/%{emacspkg}*
285%{texmf}/doc/latex/preview/preview.pdf
286%{texmf}/tex/latex/preview/*
287%{_datadir}/emacs/site-lisp/%{emacspkg}/
288%{emacsen_pkgdir}/install/%{emacspkg}
289%{emacsen_pkgdir}/remove/%{emacspkg}
290
291
292
293%changelog
294* Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-2
295- fixed requirements
296  - set BuildRequires: emacs >= 23.1
297  - set BuildRequires: texlive (for vl6)
298
299* Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
300- new versioning release
301
302* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
303- new versioning release
304- dropped old version patches
305- changed to GPLv3+ in License tag
306- changed to http://www.gnu.org/software/auctex/ in URL tag
307- download from http://ftp.gnu.org/pub/gnu/auctex in Source0
308- added preview-latex package
309- setup vine-default
310
311* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
312- applied new versioning policy, spec in utf-8
313- added macro %%emacsen_pkgdir
314
315* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
316- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
317- s/Copyright/License/
318
319* Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
320- ver.up
321
322* Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
323- minor fix of tex-jp.el
324
325* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
326- emasenize
327
328* Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
329- 10.0g-0vl1
330
331* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
332- 9.10p-0vl2
333- minor modification of spec file
334
335* Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
336- 9.10p-0vl1
337- change directories
338- minor customization
339
340* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
341- 9.10p
342
343* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
344- build auctex for emacs
345
346* Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
347- updated to 9.9p
348
349* Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
350- first release for 9.8l
351
Note: See TracBrowser for help on using the repository browser.