source: projects/specs/trunk/a/auctex/auctex-vl.spec @ 2750

Revision 2750, 9.4 KB checked in by munepi, 13 years ago (diff)

updated emacs, emacs24, wl, yatex, auctex, IIIMECF; added wl-beta; supported new vine-default

RevLine 
[521]1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3%define origname        auctex
4%define emacspkg        preview-latex
5
6%define texmf           %{_datadir}/texmf
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
10%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
11
12
13Summary:        Enhanced TeX modes for Emacsen
14Name:           %{origname}
[696]15Version:        11.86
[2750]16Release:        3%{?_dist_release}
[521]17Group:          Applications/Editors/Emacs
18License:        GPLv3+
19URL:            http://www.gnu.org/software/auctex/
20Source:         http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
21Source1:        %{origname}-install.sh
22Source2:        %{origname}-remove.sh
23Source3:        %{origname}-init.el
24Source4:        vine-default-%{origname}.el
25
26Source5:        %{emacspkg}-install.sh
27Source6:        %{emacspkg}-remove.sh
28Source7:        %{emacspkg}-init.el
29Source8:        vine-default-%{emacspkg}.el
30
31Patch:          auctex-11.85-vine.patch
32
33Requires:       %{emacspkg} = %{version}-%{release}
34BuildRequires:  texinfo
[2434]35%if %{?_dist_release} == "vl5"
[521]36BuildRequires:  tetex
[2434]37%else
38BuildRequires:  texlive
39%endif
40## Note: "BR: emacs >= 23.1" need to build auctex
41BuildRequires:  emacs >= 23.1
42
[521]43%prereq_ge      emacsen emacsen-common
44Requires(post): /sbin/install-info
45
46Obsoletes:      auctex-emacs auctex-xemacs
47
48BuildArch:      noarch
49BuildRoot:      %{_tmppath}/%{name}-%{version}-root
50
51Vendor:         Project Vine
52Distribution:   Vine Linux
53Packager:       munepi
54
55
56%description
57AUCTeX is an extensible package that supports writing and formatting TeX files
58for most variants of Emacs. 
59
60AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
61Texinfo and basic support for ConTeXt.  Documentation can be found under
62/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
63manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
64page, we provide manuals in various formats.
65
66This version of AUCTeX comes with preview-latex, an addictive productivity
67tool providing a fine-grained interactive folding WYSIWYG display in the
68source buffer.
69
70If you are AUCTeX user and you install both yatex and auctex on your system,
[2750]71you may add the following configure in your emacs init file
72%if %{?_dist_release} == "vl5"
73~/.emacs.el:
74%else
75~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
76%endif
[521]77
[2750]78;; I am AUCTeX user!!!
[521]79(setq vine-default-yatex nil)
80
81
82%package -n %{emacspkg}
83Summary:        Emacs/LaTeX inline preview
84Group:          Applications/Editors/Emacs
85Requires(post):       %{origname} = %{version}-%{release}
86BuildRequires:  emacsen
87%prereq_ge      emacsen-common
88
89%description -n %{emacspkg}
90AUCTeX is an extensible package that supports writing and formatting TeX files
91for most variants of Emacs. 
92
93AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
94Texinfo and basic support for ConTeXt.  Documentation can be found under
95/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
96manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
97page, we provide manuals in various formats.
98
99This version of AUCTeX comes with preview-latex, an addictive productivity
100tool providing a fine-grained interactive folding WYSIWYG display in the
101source buffer.
102
103Does your neck hurt from turning between previewer windows and the
104source too often? This Elisp/LaTeX package will render your displayed
105LaTeX equations right into the editing window where they belong.
106
107
108%prep
109%setup -q -n %{origname}-%{version}
110%patch -p1 -b .vine
111
112%build
113%configure --with-emacs INSTALL_INFO=: --without-texmf-dir
114%__make
115
116## output auctex.el
117%__cp -a auctex.el auctex.el.vine
118cat>auctex.el<<EOF
119;;; auctex.el
120;;
121;; This can be used for starting up AUCTeX.  The following somewhat
122;; strange trick causes tex-site.el to be loaded in a way that can be
123;; safely undone using (unload-feature 'tex-site).
124;;
125;; (autoload 'TeX-load-hack
126;;   "/some/where/tex-site.el")
127;; (TeX-load-hack)
128
129;;
130;; No any settings provide in this file.
131;;
132EOF
133
134## remove all *.elc
135find . -type f -name "*.elc" -exec rm -f {} ';'
136
137
138%install
139
140[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
141
142## install preview package
143pushd preview
144%__make install-texmf \
145    previewtexmfdir=%{build_texmf}/tex/latex/preview \
146    previewdocdir=%{build_texmf}/doc/latex/preview
147%__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
148%__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
149popd
150
151
152%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
153%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
154%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
155%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
156%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
157
158
159#
160# install el files
161#
162
163## <auctex>
164%__install -p -m0644 *.el \
165    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
166%__cp -ra images style \
167    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
168
169%__install -p -m0644 %{SOURCE3} %{SOURCE4} \
170    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
171## </auctex>
172
173## <preview-latex>
174pushd preview
175%__install -p -m0644 *.el \
176    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
177%__cp -ra images \
178    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
179popd
180
181%__install -p -m0644 %{SOURCE7} %{SOURCE8} \
182    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
183## </preview-latex>
184
185
186#
187# install info files
188#
189
190%__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
191    ${RPM_BUILD_ROOT}%{_infodir}/
192
193
194#
195# install script (bytecompile el and install elc, remove)
196#
197
198%_installemacsenscript %{origname} %{SOURCE1}
199
200%_removeemacsenscript  %{origname} %{SOURCE2}
201
202%_installemacsenscript %{emacspkg} %{SOURCE5}
203
204%_removeemacsenscript  %{emacspkg} %{SOURCE6}
205
206
207%clean
208[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
209
210
211%post
212#
213# bytecompile and install
214#
215
216if [ "$1" = 2 ]; then
217
218%_emacsenPackageRemove %{origname}
219
220fi
221
222%_addemacsenlist %{origname}
223
224%_emacsenPackageInstall %{origname}
225
226/sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
227  --section="A much enhanced LaTeX mode for GNU Emacs"
228
229
230%post -n %{emacspkg}
231#
232# bytecompile and install
233#
234
235if [ "$1" = 2 ]; then
236
237    %_emacsenPackageRemove %{emacspkg}
238
239fi
240
241%_addemacsenlist %{emacspkg}
242
243%_emacsenPackageInstall %{emacspkg}
244
245/sbin/install-info \
246    %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
247    --section="A much enhanced LaTeX mode for GNU Emacs"
248
249
250%preun
251if [ "$1" = 0 ]; then
252    %_emacsenPackageRemove %{origname}
253
254    %_removeemacsenlist %{origname}
255
256    /sbin/install-info --delete \
257        %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
258        --section="A much enhanced LaTeX mode for GNU Emacs"
259fi
260
261
262%preun -n %{emacspkg}
263if [ "$1" = 0 ]; then
264
265    %_emacsenPackageRemove %{emacspkg}
266
267    %_removeemacsenlist %{emacspkg}
268
269    /sbin/install-info --delete \
270        %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
271        --section="A much enhanced LaTeX mode for GNU Emacs"
272fi
273
274
275%files
276%defattr(-,root,root)
277%doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
278%{_infodir}/%{origname}*
279%{_datadir}/emacs/site-lisp/%{origname}/
280%{emacsen_pkgdir}/install/%{origname}
281%{emacsen_pkgdir}/remove/%{origname}
282
283
284%files -n %{emacspkg}
285%defattr(-,root,root)
286%doc preview/COPYING preview/ChangeLog{,.1}
287%{_infodir}/%{emacspkg}*
288%{texmf}/doc/latex/preview/preview.pdf
289%{texmf}/tex/latex/preview/*
290%{_datadir}/emacs/site-lisp/%{emacspkg}/
291%{emacsen_pkgdir}/install/%{emacspkg}
292%{emacsen_pkgdir}/remove/%{emacspkg}
293
294
295
296%changelog
[2750]297* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-3
298- updated auctex-init.el and preview-latex-init.el
299  - output "Loading vine-default-xxxxx ..." to the buffer *Messages*
300
[2434]301* Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-2
302- fixed requirements
303  - set BuildRequires: emacs >= 23.1
304  - set BuildRequires: texlive (for vl6)
305
[696]306* Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
307- new versioning release
308
[521]309* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
310- new versioning release
311- dropped old version patches
312- changed to GPLv3+ in License tag
313- changed to http://www.gnu.org/software/auctex/ in URL tag
314- download from http://ftp.gnu.org/pub/gnu/auctex in Source0
315- added preview-latex package
316- setup vine-default
317
318* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
319- applied new versioning policy, spec in utf-8
320- added macro %%emacsen_pkgdir
321
322* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
323- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
324- s/Copyright/License/
325
326* Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
327- ver.up
328
329* Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
330- minor fix of tex-jp.el
331
332* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
333- emasenize
334
335* Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
336- 10.0g-0vl1
337
338* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
339- 9.10p-0vl2
340- minor modification of spec file
341
342* Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
343- 9.10p-0vl1
344- change directories
345- minor customization
346
347* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
348- 9.10p
349
350* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
351- build auctex for emacs
352
353* Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
354- updated to 9.9p
355
356* Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
357- first release for 9.8l
358
Note: See TracBrowser for help on using the repository browser.