source: projects/specs/trunk/a/attr/attr-vl.spec @ 521

Revision 521, 9.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Utilities for managing filesystem extended attributes
4Name: attr
5Version: 2.4.43
6Release: 2%{?_dist_release}
7Conflicts: xfsdump < 2.0.0
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
9Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_%{version}-1.tar.gz
10Patch1: attr-2.2.0-multilib.patch
11Patch2: attr-2.4.32-build.patch
12License: GPL
13URL: http://oss.sgi.com/projects/xfs/
14Group: System Environment/Base
15BuildRequires: autoconf, libtool >= 1.5, gettext
16
17%description
18A set of tools for manipulating extended attributes on filesystem
19objects, in particular getfattr(1) and setfattr(1).
20An attr(1) command is also provided which is largely compatible
21with the SGI IRIX tool of the same name.
22
23%package -n libattr
24Summary: Dynamic library for extended attribute support
25Group: System Environment/Libraries
26License: LGPL
27
28%description -n libattr
29This package contains the libattr.so dynamic library which contains
30the extended attribute system calls and library functions.
31
32%package -n libattr-devel
33Summary: Extended attribute static libraries and headers
34Group: Development/Libraries
35License: LGPL
36Requires: libattr = %{version}-%{release}
37
38%description -n libattr-devel
39This package contains the libraries and header files needed to
40develop programs which make use of extended attributes.
41For Linux programs, the documented system call API is the
42recommended interface, but an SGI IRIX compatibility interface
43is also provided.
44
45Currently only ext2, ext3 and XFS support extended attributes.
46The SGI IRIX compatibility API built above the Linux system calls is
47used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
48
49You should install libattr-devel if you want to develop programs
50which make use of extended attributes.  If you install libattr-devel,
51you'll also want to install attr.
52
53# compat32
54%package -n compat32-libattr
55Summary: Dynamic library for extended attribute support
56Group: System Environment/Libraries
57License: LGPL
58
59%description -n compat32-libattr
60This package contains the libattr.so dynamic library which contains
61the extended attribute system calls and library functions.
62
63%package -n compat32-libattr-devel
64Summary: Extended attribute static libraries and headers
65Group: Development/Libraries
66License: LGPL
67Requires: libattr-devel = %{version}-%{release}
68Requires: compat32-libattr = %{version}-%{release}
69
70%description -n compat32-libattr-devel
71This package contains the libraries and header files needed to
72develop programs which make use of extended attributes.
73For Linux programs, the documented system call API is the
74recommended interface, but an SGI IRIX compatibility interface
75is also provided.
76
77Currently only ext2, ext3 and XFS support extended attributes.
78The SGI IRIX compatibility API built above the Linux system calls is
79used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
80
81You should install libattr-devel if you want to develop programs
82which make use of extended attributes.  If you install libattr-devel,
83you'll also want to install attr.
84
85
86%prep
87%setup -q
88# We need to turn off executable permissions on the script in %doc
89# because we don't want to drag perl into the base.  Users advanced
90# enough to have used ACLs before they were added to the distro can
91# figure out how to chmod and how to install perl.  :-)
92%patch1 -p1 -b .multilib
93%patch2 -p1 -b .build
94
95autoconf
96
97%build
98# attr abuses libexecdir
99%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
100make LIBTOOL="libtool --tag=CC"
101
102%install
103rm -rf $RPM_BUILD_ROOT
104make install DESTDIR=$RPM_BUILD_ROOT
105make install-dev DESTDIR=$RPM_BUILD_ROOT
106make install-lib DESTDIR=$RPM_BUILD_ROOT
107
108# get rid of libattr.la
109rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.la
110
111# fix links to shared libs and permissions
112rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.so
113ln -sf ../../%{_lib}/libattr.so $RPM_BUILD_ROOT/%{_libdir}/libattr.so
114chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libattr.so.*.*.*
115
116%find_lang %{name}
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -n libattr -p /sbin/ldconfig
122
123%postun -n libattr -p /sbin/ldconfig
124
125%post -n compat32-libattr -p /sbin/ldconfig
126
127%postun -n compat32-libattr -p /sbin/ldconfig
128
129%files -f %{name}.lang
130%defattr(-,root,root)
131%doc doc
132%{_bindir}/attr
133%{_bindir}/getfattr
134%{_bindir}/setfattr
135%{_mandir}/man1/attr.1*
136%{_mandir}/man1/getfattr.1*
137%{_mandir}/man1/setfattr.1*
138%{_mandir}/man5/attr.5*
139
140%files -n libattr-devel
141%defattr(-,root,root)
142/%{_lib}/libattr.so
143%{_includedir}/attr
144%{_libdir}/libattr.*
145%{_mandir}/man2/*attr.2*
146%{_mandir}/man3/attr_*.3.*
147
148%files -n libattr
149/%{_lib}/libattr.so.*
150
151# compat32
152%if %{build_compat32}
153%files -n compat32-libattr-devel
154%defattr(-,root,root)
155/%{_lib}/libattr.so
156%{_libdir}/libattr.*
157
158%files -n compat32-libattr
159/%{_lib}/libattr.so.*
160%endif
161
162%changelog
163* Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
164- added compat32 package for x86_64 arch support
165
166* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
167- new upstream release
168
169* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
170- initial build for Vine Linux
171
172* Tue Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
173- New version 2.4.41
174- Removed useless attr-2.0.8-docperms.patch
175
176* Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
177- New version 2.4.39
178- Resolves #284121
179
180* Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
181- Removed explicit Requires(post + postun)
182- Resolves #225290
183
184* Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
185- New version 2.4.38
186- Resolves #245415
187
188* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
189- add disttag
190- remove trailing dot from summary
191- fix buildroot
192- -devel package requires same libattr version
193- change prereq to Requires(post)
194- escape macro in changelog
195- replace absolute link with relative link (libattr.so)
196- use %%doc macro
197
198* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
199- rebuild
200
201* Wed Jul  5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
202- new version 2.4.32
203- fixes segmentation fault in attr, which affects #189106
204
205* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
206- rebuild for -devel deps
207
208* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
209- bump again for double-long bug on ppc(64)
210
211* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
212- rebuilt for new gcc4.1 snapshot and glibc changes
213
214* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
215- new version 2.4.28
216
217* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
218- rebuilt
219
220* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
221- spec file cleanup
222- mark po files as lang specific
223
224* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
225- 2.4.24
226
227* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
228- update to 2.4.23
229
230* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
231- get rid of *.la files
232- remove duplicate doc files
233
234* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
235- Rebuild
236
237* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
238- Build requires libtool >= 1.5
239
240* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
241- Make libattr.so.* executable.
242
243* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
244- Update to latest upstream version.
245
246* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
247- Fix bug #125304 (Steve Grubb: build requires gettext)
248
249* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
250- rebuilt
251
252* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
253- Add missing %%defattr
254
255* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
256- Add /usr/include/attr to files manifest
257- Fix location of doc files, add main doc dir to files manifest
258
259* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
260- rebuilt
261
262* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
263- rebuilt
264
265* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
266- Fix libtool
267
268* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
269- update to attr-2.4.1
270
271* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
272- update/rebuild
273
274* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
275- set execute bits on library so that requires are generated.
276
277* Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
278- Redo multilib patch to work everywhere
279
280* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
281- Added fix to install libs in correct directory on 64bit machine
282
283* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
284- Made the package only own the one directory that is unique to it:
285  /usr/include/attr
286
287* Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
288- get perl out of base with attr-2.0.8-docperms.patch
289
290* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
291- Initial Red Hat package
292  Made as few changes as possible relative to upstream packaging to
293  make it easier to maintain long-term.  This means that some of
294  the techniques used here are definitely not standard Red Hat
295  techniques.  If you are looking for an example package to fit
296  into Red Hat Linux transparently, this would not be the one to
297  pick.
298- attr-devel -> libattr-devel
Note: See TracBrowser for help on using the repository browser.