source: projects/specs/trunk/a/atk/atk-vl.spec @ 805

Revision 805, 8.2 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.24.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 1.30.0
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/1.28/atk-%{version}.tar.bz2
16URL: http://developer.gnome.org/projects/gap/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19
20%description
21The ATK library provides a set of interfaces for adding accessibility
22support to applications and graphical user interface toolkits. By
23supporting the ATK interfaces, an application or toolkit can be used
24with tools such as screen readers, magnifiers, and alternative input
25devices.
26
27%package -n compat32-%{name}
28Summary: Interfaces for accessibility support.
29Summary(ja): アクセシビリティサポートのためのインタフェース
30Group: System Environment/Libraries
31Requires: atk = %{version}
32
33%description -n compat32-%{name}
34The ATK library provides a set of interfaces for adding accessibility
35support to applications and graphical user interface toolkits. By
36supporting the ATK interfaces, an application or toolkit can be used
37with tools such as screen readers, magnifiers, and alternative input
38devices.
39
40%package devel
41Summary: Accessability Toolkit development files
42Summary(ja): アクセシビリティツールキットの開発用ファイル
43Group: Development/Libraries
44Requires: atk = %{version}
45Requires: glib2-devel >= %{glib2_version}
46
47%description devel
48The atk-devel package includes the static libraries, header files, and
49developer docs for the atk package.
50
51Install atk-devel if you want to develop programs which will use ATK.
52
53%package -n compat32-%{name}-devel
54Summary: Accessability Toolkit development files
55Summary(ja): アクセシビリティツールキットの開発用ファイル
56Group: Development/Libraries
57Requires: %{name}-devel    = %{version}
58Requires: compat32-%{name} = %{version}
59
60%description -n compat32-%{name}-devel
61The atk-devel package includes the static libraries, header files, and
62developer docs for the atk package.
63
64Install atk-devel if you want to develop programs which will use ATK.
65
66%prep
67%setup -q -n atk-%{version}
68
69%build
70#libtoolize --force --copy
71#aclocal
72#autoconf
73%configure --disable-gtk-doc
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79%makeinstall
80
81%find_lang atk10
82
83# remove unpackaged files
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97
98%files -f atk10.lang
99%defattr(-, root, root)
100%doc README AUTHORS COPYING ChangeLog
101%{_libdir}/libatk*.so.*
102
103%files devel
104%defattr(-, root, root)
105%{_includedir}/*
106%{_libdir}/libatk*.so
107%{_libdir}/pkgconfig/*.pc
108%{_datadir}/gtk-doc/*
109
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-, root, root)
113%{_libdir}/libatk*.so.*
114
115%files -n compat32-%{name}-devel
116%defattr(-, root, root)
117%{_libdir}/libatk*.so
118%{_libdir}/pkgconfig/*.pc
119%endif
120
121%changelog
122* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
123- new upstream release
124
125* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
126- new upstream release
127
128* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
129- new upstream release
130
131* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
132- new upstream release
133- spec in UTF-8
134
135* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
136- used %%{?_dist_release}
137
138* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
139- new upstream release
140
141* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
142- new upstream release
143
144* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
145- new upstream release
146
147* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
148- new upstream release
149
150* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
151- new upstream release
152
153* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
154- added compat32-* packages for x86_64 architecture support
155
156* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
157- new upstream release
158
159* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
160- new upstream release
161
162* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
163- new upstream release
164
165* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
166- new upstream release
167
168* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
169- new upstream release
170
171* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
172- new upstream release
173
174* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
175- new upstream release
176
177* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
178- new upstream release
179
180* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
181- new upstream release
182- fix kanji code of spec file.
183
184* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
185- new upstream release
186
187* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
188- new upstream release
189
190* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
191- new upstream release
192
193* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
194- new upstream release
195
196* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
197- new upstream release
198
199* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
200- new upstream release
201
202* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
203- new upstream release
204- build for Vine Linux
205
206* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
207- Remove fixed-ltmain.sh
208- Version 1.0.3
209
210* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
211- automated rebuild
212
213* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
214- rebuild in different environment
215
216* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
217- 1.0.2
218
219* Thu May 23 2002 Tim Powers <timp@redhat.com>
220- automated rebuild
221
222* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
223 - rebuild in different environment
224
225* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
226- Update to version 1.0.1
227
228* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
229- Version 1.0.0
230
231* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
232- Update to 0.13
233
234* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
235- Bump for rebuild
236
237* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
238- rebuild for glib 1.3.14
239
240* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
241- add horrible buildrequires hack
242
243* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
244- 0.12.90 cvs snap
245
246* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
247- Version 0.10
248
249* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
250- automated rebuild
251
252* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
253- new snap 0.8.90
254
255* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
256- rebuild with glib hacked to work on 64-bit
257
258* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
259- Version 0.7
260- add explicit check for required glib2 version before we do the build,
261  so we don't end up with bad RPMs on --nodeps builds
262
263* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
264- rebuild due to hosage on ia64 build system causing link to old glib
265
266* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
267- Version 0.6
268
269* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
270- 0.5
271- sync with Owen's version
272
273* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
274- 0.4
275- fix requires
276- --enable-static
277- put static libs back in file list
278
279* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
280- update to CVS snapshot
281
282* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
283- require specific pango version
284- fix ltmain.sh to destroy all relinking BS
285
286* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
287- Version 0.2
288
289* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
290- Configure with --disable-gtk-doc
291
292* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
293- Add post- and postun-sections running ldconfig
294
295* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
296- 0.2
297
298* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
299- Initial version
Note: See TracBrowser for help on using the repository browser.