source: projects/specs/trunk/a/atk/atk-vl.spec @ 1851

Revision 1851, 8.3 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21790]

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.24.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 1.30.0
12Release: 2%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/1.28/atk-%{version}.tar.bz2
16URL: http://developer.gnome.org/projects/gap/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19
20%description
21The ATK library provides a set of interfaces for adding accessibility
22support to applications and graphical user interface toolkits. By
23supporting the ATK interfaces, an application or toolkit can be used
24with tools such as screen readers, magnifiers, and alternative input
25devices.
26
27%package -n compat32-%{name}
28Summary: Interfaces for accessibility support.
29Summary(ja): アクセシビリティサポートのためのインタフェース
30Group: System Environment/Libraries
31Requires: atk = %{version}
32
33%description -n compat32-%{name}
34The ATK library provides a set of interfaces for adding accessibility
35support to applications and graphical user interface toolkits. By
36supporting the ATK interfaces, an application or toolkit can be used
37with tools such as screen readers, magnifiers, and alternative input
38devices.
39
40%package devel
41Summary: Accessability Toolkit development files
42Summary(ja): アクセシビリティツールキットの開発用ファイル
43Group: Development/Libraries
44Requires: atk = %{version}
45Requires: glib2-devel >= %{glib2_version}
46
47%description devel
48The atk-devel package includes the static libraries, header files, and
49developer docs for the atk package.
50
51Install atk-devel if you want to develop programs which will use ATK.
52
53%package -n compat32-%{name}-devel
54Summary: Accessability Toolkit development files
55Summary(ja): アクセシビリティツールキットの開発用ファイル
56Group: Development/Libraries
57Requires: %{name}-devel    = %{version}
58Requires: compat32-%{name} = %{version}
59
60%description -n compat32-%{name}-devel
61The atk-devel package includes the static libraries, header files, and
62developer docs for the atk package.
63
64Install atk-devel if you want to develop programs which will use ATK.
65
66%prep
67%setup -q -n atk-%{version}
68
69%build
70#libtoolize --force --copy
71#aclocal
72#autoconf
73%configure --disable-gtk-doc
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79%makeinstall
80
81%find_lang atk10
82
83# remove unpackaged files
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97
98%files -f atk10.lang
99%defattr(-, root, root)
100%doc README AUTHORS COPYING ChangeLog
101%{_libdir}/libatk*.so.*
102
103%files devel
104%defattr(-, root, root)
105%{_includedir}/*
106%{_libdir}/libatk*.so
107%{_libdir}/pkgconfig/*.pc
108%{_datadir}/gtk-doc/*
109
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-, root, root)
113%{_libdir}/libatk*.so.*
114
115%files -n compat32-%{name}-devel
116%defattr(-, root, root)
117%{_libdir}/libatk*.so
118%{_libdir}/pkgconfig/*.pc
119%endif
120
121%changelog
122* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
123- build with rpm-4.8.1-1 for pkg-config file
124
125* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
126- new upstream release
127
128* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
129- new upstream release
130
131* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
132- new upstream release
133
134* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
135- new upstream release
136- spec in UTF-8
137
138* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
139- used %%{?_dist_release}
140
141* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
142- new upstream release
143
144* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
145- new upstream release
146
147* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
148- new upstream release
149
150* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
151- new upstream release
152
153* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
154- new upstream release
155
156* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
157- added compat32-* packages for x86_64 architecture support
158
159* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
160- new upstream release
161
162* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
163- new upstream release
164
165* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
166- new upstream release
167
168* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
169- new upstream release
170
171* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
172- new upstream release
173
174* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
175- new upstream release
176
177* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
178- new upstream release
179
180* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
181- new upstream release
182
183* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
184- new upstream release
185- fix kanji code of spec file.
186
187* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
188- new upstream release
189
190* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
191- new upstream release
192
193* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
194- new upstream release
195
196* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
197- new upstream release
198
199* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
200- new upstream release
201
202* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
203- new upstream release
204
205* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
206- new upstream release
207- build for Vine Linux
208
209* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
210- Remove fixed-ltmain.sh
211- Version 1.0.3
212
213* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
214- automated rebuild
215
216* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
217- rebuild in different environment
218
219* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
220- 1.0.2
221
222* Thu May 23 2002 Tim Powers <timp@redhat.com>
223- automated rebuild
224
225* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
226 - rebuild in different environment
227
228* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
229- Update to version 1.0.1
230
231* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
232- Version 1.0.0
233
234* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
235- Update to 0.13
236
237* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
238- Bump for rebuild
239
240* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
241- rebuild for glib 1.3.14
242
243* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
244- add horrible buildrequires hack
245
246* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
247- 0.12.90 cvs snap
248
249* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
250- Version 0.10
251
252* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
253- automated rebuild
254
255* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
256- new snap 0.8.90
257
258* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
259- rebuild with glib hacked to work on 64-bit
260
261* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
262- Version 0.7
263- add explicit check for required glib2 version before we do the build,
264  so we don't end up with bad RPMs on --nodeps builds
265
266* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
267- rebuild due to hosage on ia64 build system causing link to old glib
268
269* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
270- Version 0.6
271
272* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
273- 0.5
274- sync with Owen's version
275
276* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
277- 0.4
278- fix requires
279- --enable-static
280- put static libs back in file list
281
282* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
283- update to CVS snapshot
284
285* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
286- require specific pango version
287- fix ltmain.sh to destroy all relinking BS
288
289* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
290- Version 0.2
291
292* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
293- Configure with --disable-gtk-doc
294
295* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
296- Add post- and postun-sections running ldconfig
297
298* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
299- 0.2
300
301* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
302- Initial version
Note: See TracBrowser for help on using the repository browser.