source: projects/specs/trunk/a/at/at-vl.spec @ 7095

Revision 7095, 14.3 KB checked in by daisuke, 12 years ago (diff)

at:

  • remove Patch10
    • atd doesn't execute queued job until the next jobs is queued.
Line 
1%bcond_without pam
2
3Summary: Job spooling tools.
4Summary(ja): ジョブスプーリングツール
5Name: at
6Version: 3.1.13
7Release: 3%{?_dist_release}
8License: GPLv2+ and ISC
9Group: System Environment/Daemons
10URL: http://ftp.debian.org/debian/pool/main/a/at
11
12Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{version}.orig.tar.gz
13Source1: pam_atd
14Source2: atd.init
15Source3: atd.sysconf
16
17Patch1:  at-3.1.13-makefile.patch
18Patch2:  at-3.1.12-opt_V.patch
19Patch3:  at-3.1.12-shell.patch
20Patch4:  at-3.1.13-nitpicks.patch
21Patch5:  at-3.1.13-pam.patch
22Patch6:  at-3.1.13-selinux.patch
23Patch7:  at-3.1.12-nowrap.patch
24Patch8:  at-3.1.12-fix_no_export.patch
25Patch9:  at-3.1.13-mailwithhostname.patch
26# Patch10: at-3.1.13-usePOSIXtimers.patch
27Patch11: at-3.1.13-help.patch
28
29BuildRequires: fileutils
30BuildRequires: chkconfig
31BuildRequires: flex
32BuildRequires: bison
33BuildRequires: autoconf
34
35%if %{with pam}
36BuildRequires: pam-devel
37%endif
38Conflicts: crontabs <= 1.5
39# No, I'm not kidding
40BuildRequires: smtpdaemon
41Buildroot: %{_tmppath}/%{name}-%{version}-root
42
43%description
44At and batch read commands from standard input or from a specified
45file. At allows you to specify that a command will be run at a
46particular time. Batch will execute commands when the system load
47levels drop to a particular level. Both commands use /bin/sh.
48
49You should install the at package if you need a utility for
50time-oriented job control. Note: If it is a recurring job that will
51need to be repeated at the same time every day/week, etc. you should
52use crontab instead.
53
54%description -l ja
55at と batch は標準入力や指定されたファイルからコマンドを読み取ります。
56at を使用して特定の時間にコマンドを実行するように指定することが可能です。
57batch はシステムの負荷レベルが特定のレベルを下回るとコマンドを実行します。
58両コマンドとも /bin/sh を使います。
59
60あなたが時間志向のジョブ管理のためのユーティリティを必要とするならば、at
61パッケージをインストールしてください。
62
63メモ: もし毎日/週などの同じ時間にくり返される必要があるジョブであれば、
64代わりに crontab を使うべきでしょう。
65
66%prep
67%setup -q
68cp %{SOURCE1} .
69%patch1 -p1 -b .make
70%patch2 -p1 -b .opt_V
71%patch3 -p1 -b .shell
72%patch4 -p1 -b .nit
73%patch5 -p1 -b .pam
74%patch6 -p1 -b .selinux
75%patch7 -p1 -b .nowrap
76%patch8 -p1 -b .export
77%patch9 -p1 -b .mail
78#patch10 -p1 -b .posix
79%patch11 -p1 -b .help
80
81%build
82# patch10 touches configure.in
83autoconf
84# for patch11
85rm -f lex.yy.* y.tab.*
86%configure --with-atspool=%{_localstatedir}/spool/at/spool \
87           --with-jobdir=%{_localstatedir}/spool/at \
88           --with-daemon_username=root  \
89           --with-daemon_groupname=root \
90%if %{with pam}
91           --with-pam
92%endif
93
94make
95
96%check
97# don't run "make test" by default
98%{?_without_check: %define _without_check 1}
99%{!?_without_check: %define _without_check 1}
100
101%if ! %{_without_check}                                                                                                       
102        LANG=C make test > /dev/null
103%endif
104
105%install
106rm -rf %{buildroot}
107make install \
108        DAEMON_USERNAME=`id -nu`\
109        DAEMON_GROUPNAME=`id -ng` \
110        DESTDIR=%{buildroot}\
111        sbindir=%{buildroot}%{_prefix}/sbin\
112        bindir=%{buildroot}%{_bindir}\
113        prefix=%{buildroot}%{_prefix}\
114        exec_prefix=%{buildroot}%{_prefix}\
115        docdir=%{buildroot}/usr/doc\
116        mandir=%{buildroot}%{_mandir}\
117        etcdir=%{buildroot}%{_sysconfdir} \
118        ATJOB_DIR=%{buildroot}%{_localstatedir}/spool/at \
119        ATSPOOL_DIR=%{buildroot}%{_localstatedir}/spool/at/spool \
120        INSTALL_ROOT_USER=`id -nu` \
121        INSTALL_ROOT_GROUP=`id -nu`;
122
123echo > %{buildroot}%{_sysconfdir}/at.deny
124mkdir docs
125cp $RPM_BUILD_ROOT/%{_prefix}/doc/at/* docs/
126
127mkdir -p %{buildroot}%{_sysconfdir}/pam.d
128install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/atd
129
130mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
131install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/atd
132
133mkdir -p %{buildroot}/etc/sysconfig
134install -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/atd
135
136# remove unpackaged files from the buildroot
137rm -r  %{buildroot}%{_prefix}/doc
138
139%clean
140rm -rf %{buildroot}
141
142%post
143touch %{_localstatedir}/spool/at/.SEQ
144chmod 600 %{_localstatedir}/spool/at/.SEQ
145chown daemon.daemon %{_localstatedir}/spool/at/.SEQ
146# must be in chkconfig on
147/sbin/chkconfig --add atd
148
149%preun
150if [ "$1" = 0 ] ; then
151  /sbin/service atd stop
152  /sbin/chkconfig --del atd
153fi
154
155%postun
156if [ "$1" -ge "1" ]; then
157  /sbin/service atd condrestart
158fi
159
160%files
161%defattr(-,root,root)
162%doc docs/*
163%config %{_sysconfdir}/at.deny
164%attr(0700,root,root)           %{_sysconfdir}/rc.d/init.d/atd
165%attr(0700,root,root)           %{_sysconfdir}/sysconfig/atd
166%attr(0700,daemon,daemon)       %dir %{_localstatedir}/spool/at
167%attr(0600,daemon,daemon)       %verify(not md5 size mtime) %ghost %{_localstatedir}/spool/at/.SEQ
168%attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at/spool
169%attr(0640,root,daemon) %config(noreplace) /etc/pam.d/atd
170%{_sbindir}/atrun
171%attr(0755,root,root)   %{_sbindir}/atd
172%{_mandir}/man*/*
173%{_bindir}/batch
174%{_bindir}/atrm
175%{_bindir}/atq
176%attr(4755,root,root) %{_bindir}/at
177
178%changelog
179* Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-3
180- remove Patch10
181  - atd doesn't execute queued job until the next jobs is queued.
182
183* Thu Nov 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-2
184- fix pam_atd to use system-auth instead of password-auth
185
186* Tue Nov 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-1
187- update to 3.1.13
188- update patches to sync with fedora 3.1.13-10.
189
190* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10.1-17
191- rebuild with rpm-4.8.1
192
193* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10.1-16
194- spec in utf-8
195
196* Tue May 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10.1-15
197- new upstream release
198- apply new versioning policy
199
200* Thu Jul 12 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10-14vl1
201- update based on fedora development 3.1.10-14.
202- build with new toolchains.
203  * Tue Jul  9 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-14
204  - feature: add configuration file
205  - fix -V option
206  - fix init script
207
208  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-13
209  - Resolves: rhbz#243064
210
211  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-12
212  - crashing atd
213  - work only for root, still broken some functions
214  - Resolves: rhbz#243064
215
216  * Tue Mar 27 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-11
217  - mistake in pam_atd
218  - rhbz#234120
219
220  * Tue Mar 05 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-10
221  - rhbz#224597
222
223  * Mon Mar 03 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-9
224  - review
225 
226  * Wed Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-8
227  - review
228  - rhbz#225288
229 
230  * Tue Jan 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-7
231  - no debug file - useless
232  - new pam configuration
233  - rhbz#224597
234 
235  * Tue Oct 27 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-6
236  - fix daylight-saving again
237  - fix #214759 - problem with seteuid
238 
239  * Wed Oct 25 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-5
240  - daylight-saving
241 
242  * Tue Oct 24 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-3
243  - new version from upstream 3.1.10
244 
245  * Thu Aug 23 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.8-82.fc6
246  - #176486 don't fork option added (patch from Enrico Scholz)
247
248  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.2
249  - rebuild
250 
251  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.1
252  - bump again for double-long bug on ppc(64)
253 
254  * Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 3.1.8-81
255  - rebuild for new gcc, glibc, glibc-kernheaders
256  - workaround new refusal of /usr/bin/install to chown
257 
258  * Fri Dec 18 2005 Jason Vas Dias<jvdias@redhat.com> - 3.1.8-80.2
259  - rebuild for new flex
260 
261  * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
262  - rebuilt for new gcj
263 
264  * Fri Oct 14 2005 Dan Walsh <dwalsh@redhat.com> - 3.1.8-80
265  - Add seuserbyname support
266 
267  * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 3.1.8-79
268  - use include instead of pam_stack in pam config
269 
270  * Fri Jun 03 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-78
271  - fix bug 159220: add pam_loginuid to pam session stack in /etc/pam.d/atd
272  - fix bug 102341: add '-r' synonym for '-d' / atrm for POSIX / SuS conformance
273 
274  * Fri Apr 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-77
275  - always call pam_setcred(pamh, PAM_DELETE_CRED) before session
276  - close
277 
278  * Tue Apr 05 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-70
279  - always call pam_close_session on PAM_FAIL or pam_end
280 
281  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-68
282  - Put PAM authentication check in 'check_permissions()', so
283  - user can know when using at(1) if PAM permission is denied.
284 
285  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-67
286  - better fix for bug 150131: change DAEMON_USERNAME and
287  - DAEMON_GROUPNAME to 'root' .
288 
289  * Mon Mar 07 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-66
290  - fix bug 150131: atd should not relinquish root privilege if
291  - doing su(1) equivalent with PAM .
292 
293  * Tue Jan 25 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-64
294  - bugs 5160/146132: add PAM authentication control to atd
295
296* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.8-60vl1
297- based on Fedora development 3.1.8-60
298  * Tue Oct 05 2004 Jason Vas Dias <jvdias@redhat.com> 3.1.8-60
299  - fix bug 131510: no_export env. var. blacklisting should not
300  - remove 'SHELL' when only 'SHELLOPTS' is blacklisted.
301  - at(1) man-page should not say 'commands are run with /bin/sh'
302  - and should explain usage of SHELL environement variable and
303  - details of blacklisted variables.
304  * Tue Sep 28 2004 Rik van Riel <riel@redhat.com> 3.1.8-58
305  - fix typo in man page, bug 112303
306  - (regenerated at-3.1.8-man-timespec-path.patch with fix)
307  * Tue Aug 03 2004 Jason Vas Dias <jvdias@redhat.com>
308  - fixed bug 125634 - made usage() agree with manpage
309  * Thu Jul 29 2004 Jason Vas Dias <jvdias@redhat.com>
310  - Added POSIX.2 -t option for RFE 127485
311  * Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
312  - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
313  - update at.1 description of shell behaviour (#91233)
314  * Tue Jun 17 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-45
315  - make the job shell default to SHELL instead of "/bin/sh" (#91233)
316  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-43
317  - Replace redundant at-3.1.7-paths.patch by at-3.1.8-man-timespec-path.patch
318    to fix timespec path
319  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-41
320  - update source to at_3.1.8-11 from debian upstream
321    - update source url
322    - at-debian.patch no longer needed
323    - at-3.1.7-paths.patch: the patch to "at.1.in" no longer needed
324    - replace at-3.1.8-lexer.patch with at-3.1.8-11-lexer-parser.diff
325    - at-3.1.8-dst.patch no longer needed
326    - at-3.1.8-lsbdoc.patch no longer needed
327    - at-3.1.8-o_excl.patch no longer needed
328    - bump release number
329- added Japanese summary and description from vinedocs.sf.jp :)
330- rebuild with new toolchains
331
332* Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 3.1.8-23vl1
333- follow 3.1.8-23 (RHSA-2002:015-13)
334- apply docpath patch instead of patch16 (due to brute-force patch2 unrevised)
335- Replace sendmail with /usr/sbin/sendmail (postfix) for BuildPreReq
336
337* Sat Jun 09 2001 <sagami@vinelinux.org>
338- 3.1.8-12vl3: rebuilt for %%{_mandir}
339
340* Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.8-12vl2
341- remove /etc/init.d from PreReq
342
343* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.1.8-12vl1
344- build on Vine Linux with gcc-2.95.3
345
346* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
347- Well, we will likely never really close the UTC issues,
348- because of 1) fractional timezones, and 2) daylight savigns time.
349- but there is a slight tweak to the handling of dst in the UTC patch.
350
351* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
352- fixed bug #15685
353- which had at miscaluclating UTC times.
354
355* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
356- move initscript back
357
358* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
359- automatic rebuild
360
361* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
362- prereq /etc/init.d
363
364* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
365- fix syntax error in init script
366
367* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
368- don't prereq, only require initscripts
369
370* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
371- move init script
372- add condrestart directive
373- fix post/preun/postun scripts
374- prereq initscripts >= 5.20
375
376* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
377- fix verify of /var/spool/at/.SEQ (#12262)
378
379* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
380- fix status checking and syntax error in init script
381
382* Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
383- fix for long usernames (#11321)
384- add some bugfixes from debian
385
386* Mon May  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
387- 3.1.8
388
389* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
390- fix a couple of more typos, null-terminate some strings
391
392* Thu Feb 10 2000 Bill Nottingham <notting@redhat.com>
393- fix many-years-old typo in atd.c
394
395* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
396- handle compressed man pages
397
398* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
399- initscript munging, build as non-root user
400
401* Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
402- correct perms for /var/spool/at after defattr.
403
404* Mon May 24 1999 Jeff Johnson <jbj@redhat.com>
405- reset SIGCHLD before exec (#3016).
406
407* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
408- auto rebuild in the new build environment (release 8)
409
410* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
411- fix handling the 12:00 time
412
413* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
414- configure fix for arm
415
416* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
417- build for glibc 2.1
418
419* Tue May 05 1998 Prospector System <bugs@redhat.com>
420- translations modified for de, fr, tr
421
422* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
423- enhanced initscript
424
425* Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
426- learned to spell
427
428* Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
429- updated to at version 3.1.7
430- updated lock and sequence file handling with %ghost
431- Use chkconfig and atd, now conflicts with old crontabs packages
432
433* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
434- built against glibc
435
Note: See TracBrowser for help on using the repository browser.