source: projects/specs/trunk/a/at/at-vl.spec @ 12364

Revision 12364, 15.7 KB checked in by tomop, 4 years ago (diff)

updated 13 packages

acpid-2.0.32-1

at-3.1.23-1

autofs-5.1.6-1

dracut-050-3

fcgi-2.4.2-1

fcgiwrap-1.1.0.git20200404-2

firefox-68.6.1-1

initscripts-8.91.16-3

iptables-1.8.4-2

lxc-4.0.0-1

libnftnl-1.1.6-1

smp_utils-0.99-1

util-linux-2.35.1-1

Line 
1%bcond_with systemd
2%bcond_without pam
3
4Summary:        Job spooling tools.
5Summary(ja):    ジョブスプーリングツール
6Name:           at
7Version:        3.1.23
8Release:        1%{?_dist_release}
9License:        GPLv3+ and GPLv2+ and ISC and MIT and Public Domain
10URL:            http://ftp.debian.org/debian/pool/main/a/at
11
12Source:         http://ftp.debian.org/debian/pool/main/a/at/at_%{version}.orig.tar.gz
13Source1:        pam_atd
14Source2:        atd.init
15Source3:        atd.sysconf
16Source5:        atd.systemd
17
18Patch0:         at-aarch64.patch
19Patch1:         at-3.1.18-make.patch
20Patch2:         at-3.1.20-pam.patch
21Patch4:         at-3.1.14-opt_V.patch
22Patch5:         at-3.1.20-shell.patch
23Patch6:         at-3.1.18-nitpicks.patch
24Patch8:         at-3.1.14-fix_no_export.patch
25Patch9:         at-3.1.14-mailwithhostname.patch
26Patch10:        at-3.1.14-usePOSIXtimers.patch
27Patch12:        at-3.1.20-aborted-jobs.patch
28Patch13:        at-3.1.18-noabort.patch
29Patch14:        at-3.1.16-fclose-error.patch
30Patch15:        at-3.1.16-clear-nonjobs.patch
31Patch16:        at-3.1.18-utc-dst.patch
32Patch17:        at-3.1.20-lock-locks.patch
33Patch18:        at-3.1.23-document-n.patch
34Patch19:        at-3.1.20-log-jobs.patch
35
36# http://mantis.vinelinux.org/view.php?id=2483
37Patch20:        at-3.1.23-usePOSIXtimers-fix.patch
38
39BuildRequires: fileutils
40BuildRequires: flex
41BuildRequires: bison
42BuildRequires: autoconf
43
44%if %{with systemd}
45Requires(post): systemd-units
46Requires(preun): systemd-units
47Requires(postun): systemd-units
48%else
49BuildRequires: chkconfig
50Requires(post): chkconfig
51Requires(preun): chkconfig
52Requires(postun): chkconfig
53%endif
54
55%if %{with pam}
56BuildRequires: pam-devel
57%endif
58Conflicts: crontabs <= 1.5
59# No, I'm not kidding
60BuildRequires: postfix
61Buildroot: %{_tmppath}/%{name}-%{version}-root
62
63
64%description
65At and batch read commands from standard input or from a specified
66file. At allows you to specify that a command will be run at a
67particular time. Batch will execute commands when the system load
68levels drop to a particular level. Both commands use /bin/sh.
69
70You should install the at package if you need a utility for
71time-oriented job control. Note: If it is a recurring job that will
72need to be repeated at the same time every day/week, etc. you should
73use crontab instead.
74
75%description -l ja
76at と batch は標準入力や指定されたファイルからコマンドを読み取ります。
77at を使用して特定の時間にコマンドを実行するように指定することが可能です。
78batch はシステムの負荷レベルが特定のレベルを下回るとコマンドを実行します。
79両コマンドとも /bin/sh を使います。
80
81あなたが時間志向のジョブ管理のためのユーティリティを必要とするならば、at
82パッケージをインストールしてください。
83
84メモ: もし毎日/週などの同じ時間にくり返される必要があるジョブであれば、
85代わりに crontab を使うべきでしょう。
86
87%prep
88%setup -q
89cp %{SOURCE1} .
90%autopatch -p1
91# patch10 touches configure.in
92autoconf
93# for patch11
94rm -f lex.yy.* y.tab.*
95
96%build
97%configure --with-atspool=%{_localstatedir}/spool/at/spool \
98           --with-jobdir=%{_localstatedir}/spool/at \
99           --with-daemon_username=root  \
100           --with-daemon_groupname=root \
101%if %{with pam}
102           --with-pam
103%endif
104
105make
106
107%check
108# don't run "make test" by default
109%{?_without_check: %define _without_check 1}
110%{!?_without_check: %define _without_check 1}
111
112%if ! %{_without_check}                                                                                                       
113        LANG=C make test > /dev/null
114%endif
115
116%install
117rm -rf %{buildroot}
118make install \
119        DAEMON_USERNAME=`id -nu`\
120        DAEMON_GROUPNAME=`id -ng` \
121        DESTDIR=%{buildroot}\
122        sbindir=%{buildroot}%{_prefix}/sbin\
123        bindir=%{buildroot}%{_bindir}\
124        prefix=%{buildroot}%{_prefix}\
125        exec_prefix=%{buildroot}%{_prefix}\
126        docdir=%{buildroot}/usr/doc\
127        mandir=%{buildroot}%{_mandir}\
128        etcdir=%{buildroot}%{_sysconfdir} \
129        ATJOB_DIR=%{buildroot}%{_localstatedir}/spool/at \
130        ATSPOOL_DIR=%{buildroot}%{_localstatedir}/spool/at/spool \
131        INSTALL_ROOT_USER=`id -nu` \
132        INSTALL_ROOT_GROUP=`id -nu`;
133
134echo > %{buildroot}%{_sysconfdir}/at.deny
135mkdir docs
136cp $RPM_BUILD_ROOT/%{_prefix}/doc/at/* docs/
137
138mkdir -p %{buildroot}%{_sysconfdir}/pam.d
139install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/atd
140
141%if %{with systemd}
142# install systemd initscript
143mkdir -p %{buildroot}/%{_unitdir}/
144install -m 644 %{SOURCE5} %{buildroot}/%{_unitdir}/atd.service
145%else
146mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
147install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/atd
148%endif
149
150mkdir -p %{buildroot}/etc/sysconfig
151install -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/atd
152
153# remove unpackaged files from the buildroot
154rm -r  %{buildroot}%{_prefix}/doc
155
156%clean
157rm -rf %{buildroot}
158
159%post
160touch %{_localstatedir}/spool/at/.SEQ
161chmod 600 %{_localstatedir}/spool/at/.SEQ
162chown daemon.daemon %{_localstatedir}/spool/at/.SEQ
163%if %{with systemd}
164%systemd_post atd.service
165%else
166# must be in chkconfig on
167/sbin/chkconfig --add atd
168%endif
169
170%preun
171%if %{with systemd}
172%systemd_preun atd.service
173%else
174if [ "$1" = 0 ] ; then
175  /sbin/service atd stop
176  /sbin/chkconfig --del atd
177fi
178%endif
179
180%postun
181%if %{with systemd}
182%systemd_postun_with_restart atd.service
183%else
184if [ "$1" -ge "1" ]; then
185  /sbin/service atd condrestart
186fi
187%endif
188
189%files
190%defattr(-,root,root)
191%doc docs/*
192%config %{_sysconfdir}/at.deny
193%if %{with systemd}
194%attr(0644,root,root)           %{_unitdir}/atd.service
195%else
196%attr(0700,root,root)           %{_sysconfdir}/rc.d/init.d/atd
197%endif
198%attr(0700,root,root)           %{_sysconfdir}/sysconfig/atd
199%attr(0700,daemon,daemon)       %dir %{_localstatedir}/spool/at
200%attr(0600,daemon,daemon)       %verify(not md5 size mtime) %ghost %{_localstatedir}/spool/at/.SEQ
201%attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at/spool
202%attr(0640,root,daemon) %config(noreplace) /etc/pam.d/atd
203%{_sbindir}/atrun
204%attr(0755,root,root)   %{_sbindir}/atd
205%{_mandir}/man*/*
206%{_bindir}/batch
207%{_bindir}/atrm
208%{_bindir}/atq
209%attr(4755,root,root) %{_bindir}/at
210
211%changelog
212* Sat Apr 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.23-1
213- new upstream release.
214- imported Patch12-19 from rawhide.
215- updated Patch20.
216
217* Sun Jun 15 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.14-1
218- new upstream release.
219- updated Patch1.
220- removed Patch11 (no longer needed).
221
222* Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-4
223- re-add Patch10 and Patch12 to use posix timer
224  - http://mantis.vinelinux.org/view.php?id=2483
225
226* Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-3
227- remove Patch10
228  - atd doesn't execute queued job until the next jobs is queued.
229
230* Thu Nov 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-2
231- fix pam_atd to use system-auth instead of password-auth
232
233* Tue Nov 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-1
234- update to 3.1.13
235- update patches to sync with fedora 3.1.13-10.
236
237* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10.1-17
238- rebuild with rpm-4.8.1
239
240* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10.1-16
241- spec in utf-8
242
243* Tue May 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10.1-15
244- new upstream release
245- apply new versioning policy
246
247* Thu Jul 12 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10-14vl1
248- update based on fedora development 3.1.10-14.
249- build with new toolchains.
250  * Tue Jul  9 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-14
251  - feature: add configuration file
252  - fix -V option
253  - fix init script
254
255  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-13
256  - Resolves: rhbz#243064
257
258  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-12
259  - crashing atd
260  - work only for root, still broken some functions
261  - Resolves: rhbz#243064
262
263  * Tue Mar 27 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-11
264  - mistake in pam_atd
265  - rhbz#234120
266
267  * Tue Mar 05 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-10
268  - rhbz#224597
269
270  * Mon Mar 03 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-9
271  - review
272 
273  * Wed Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-8
274  - review
275  - rhbz#225288
276 
277  * Tue Jan 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-7
278  - no debug file - useless
279  - new pam configuration
280  - rhbz#224597
281 
282  * Tue Oct 27 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-6
283  - fix daylight-saving again
284  - fix #214759 - problem with seteuid
285 
286  * Wed Oct 25 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-5
287  - daylight-saving
288 
289  * Tue Oct 24 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-3
290  - new version from upstream 3.1.10
291 
292  * Thu Aug 23 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.8-82.fc6
293  - #176486 don't fork option added (patch from Enrico Scholz)
294
295  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.2
296  - rebuild
297 
298  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.1
299  - bump again for double-long bug on ppc(64)
300 
301  * Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 3.1.8-81
302  - rebuild for new gcc, glibc, glibc-kernheaders
303  - workaround new refusal of /usr/bin/install to chown
304 
305  * Fri Dec 18 2005 Jason Vas Dias<jvdias@redhat.com> - 3.1.8-80.2
306  - rebuild for new flex
307 
308  * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
309  - rebuilt for new gcj
310 
311  * Fri Oct 14 2005 Dan Walsh <dwalsh@redhat.com> - 3.1.8-80
312  - Add seuserbyname support
313 
314  * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 3.1.8-79
315  - use include instead of pam_stack in pam config
316 
317  * Fri Jun 03 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-78
318  - fix bug 159220: add pam_loginuid to pam session stack in /etc/pam.d/atd
319  - fix bug 102341: add '-r' synonym for '-d' / atrm for POSIX / SuS conformance
320 
321  * Fri Apr 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-77
322  - always call pam_setcred(pamh, PAM_DELETE_CRED) before session
323  - close
324 
325  * Tue Apr 05 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-70
326  - always call pam_close_session on PAM_FAIL or pam_end
327 
328  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-68
329  - Put PAM authentication check in 'check_permissions()', so
330  - user can know when using at(1) if PAM permission is denied.
331 
332  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-67
333  - better fix for bug 150131: change DAEMON_USERNAME and
334  - DAEMON_GROUPNAME to 'root' .
335 
336  * Mon Mar 07 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-66
337  - fix bug 150131: atd should not relinquish root privilege if
338  - doing su(1) equivalent with PAM .
339 
340  * Tue Jan 25 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-64
341  - bugs 5160/146132: add PAM authentication control to atd
342
343* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.8-60vl1
344- based on Fedora development 3.1.8-60
345  * Tue Oct 05 2004 Jason Vas Dias <jvdias@redhat.com> 3.1.8-60
346  - fix bug 131510: no_export env. var. blacklisting should not
347  - remove 'SHELL' when only 'SHELLOPTS' is blacklisted.
348  - at(1) man-page should not say 'commands are run with /bin/sh'
349  - and should explain usage of SHELL environement variable and
350  - details of blacklisted variables.
351  * Tue Sep 28 2004 Rik van Riel <riel@redhat.com> 3.1.8-58
352  - fix typo in man page, bug 112303
353  - (regenerated at-3.1.8-man-timespec-path.patch with fix)
354  * Tue Aug 03 2004 Jason Vas Dias <jvdias@redhat.com>
355  - fixed bug 125634 - made usage() agree with manpage
356  * Thu Jul 29 2004 Jason Vas Dias <jvdias@redhat.com>
357  - Added POSIX.2 -t option for RFE 127485
358  * Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
359  - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
360  - update at.1 description of shell behaviour (#91233)
361  * Tue Jun 17 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-45
362  - make the job shell default to SHELL instead of "/bin/sh" (#91233)
363  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-43
364  - Replace redundant at-3.1.7-paths.patch by at-3.1.8-man-timespec-path.patch
365    to fix timespec path
366  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-41
367  - update source to at_3.1.8-11 from debian upstream
368    - update source url
369    - at-debian.patch no longer needed
370    - at-3.1.7-paths.patch: the patch to "at.1.in" no longer needed
371    - replace at-3.1.8-lexer.patch with at-3.1.8-11-lexer-parser.diff
372    - at-3.1.8-dst.patch no longer needed
373    - at-3.1.8-lsbdoc.patch no longer needed
374    - at-3.1.8-o_excl.patch no longer needed
375    - bump release number
376- added Japanese summary and description from vinedocs.sf.jp :)
377- rebuild with new toolchains
378
379* Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 3.1.8-23vl1
380- follow 3.1.8-23 (RHSA-2002:015-13)
381- apply docpath patch instead of patch16 (due to brute-force patch2 unrevised)
382- Replace sendmail with /usr/sbin/sendmail (postfix) for BuildPreReq
383
384* Sat Jun 09 2001 <sagami@vinelinux.org>
385- 3.1.8-12vl3: rebuilt for %%{_mandir}
386
387* Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.8-12vl2
388- remove /etc/init.d from PreReq
389
390* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.1.8-12vl1
391- build on Vine Linux with gcc-2.95.3
392
393* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
394- Well, we will likely never really close the UTC issues,
395- because of 1) fractional timezones, and 2) daylight savigns time.
396- but there is a slight tweak to the handling of dst in the UTC patch.
397
398* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
399- fixed bug #15685
400- which had at miscaluclating UTC times.
401
402* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
403- move initscript back
404
405* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
406- automatic rebuild
407
408* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
409- prereq /etc/init.d
410
411* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
412- fix syntax error in init script
413
414* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
415- don't prereq, only require initscripts
416
417* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
418- move init script
419- add condrestart directive
420- fix post/preun/postun scripts
421- prereq initscripts >= 5.20
422
423* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
424- fix verify of /var/spool/at/.SEQ (#12262)
425
426* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
427- fix status checking and syntax error in init script
428
429* Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
430- fix for long usernames (#11321)
431- add some bugfixes from debian
432
433* Mon May  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434- 3.1.8
435
436* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
437- fix a couple of more typos, null-terminate some strings
438
439* Thu Feb 10 2000 Bill Nottingham <notting@redhat.com>
440- fix many-years-old typo in atd.c
441
442* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
443- handle compressed man pages
444
445* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
446- initscript munging, build as non-root user
447
448* Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
449- correct perms for /var/spool/at after defattr.
450
451* Mon May 24 1999 Jeff Johnson <jbj@redhat.com>
452- reset SIGCHLD before exec (#3016).
453
454* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
455- auto rebuild in the new build environment (release 8)
456
457* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
458- fix handling the 12:00 time
459
460* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
461- configure fix for arm
462
463* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
464- build for glibc 2.1
465
466* Tue May 05 1998 Prospector System <bugs@redhat.com>
467- translations modified for de, fr, tr
468
469* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
470- enhanced initscript
471
472* Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
473- learned to spell
474
475* Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
476- updated to at version 3.1.7
477- updated lock and sequence file handling with %ghost
478- Use chkconfig and atd, now conflicts with old crontabs packages
479
480* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
481- built against glibc
482
Note: See TracBrowser for help on using the repository browser.