source: projects/specs/trunk/a/at/at-vl.spec @ 7084

Revision 7084, 14.0 KB checked in by daisuke, 12 years ago (diff)

at: update to 3.1.13, resync with fedora package

Line 
1%bcond_without pam
2
3Summary: Job spooling tools.
4Summary(ja): ジョブスプーリングツール
5Name: at
6Version: 3.1.13
7Release: 1%{?_dist_release}
8License: GPLv2+ and ISC
9Group: System Environment/Daemons
10URL: http://ftp.debian.org/debian/pool/main/a/at
11
12Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{version}.orig.tar.gz
13Source1: pam_atd
14Source2: atd.init
15Source3: atd.sysconf
16
17Patch1:  at-3.1.13-makefile.patch
18Patch2:  at-3.1.12-opt_V.patch
19Patch3:  at-3.1.12-shell.patch
20Patch4:  at-3.1.13-nitpicks.patch
21Patch5:  at-3.1.13-pam.patch
22Patch6:  at-3.1.13-selinux.patch
23Patch7:  at-3.1.12-nowrap.patch
24Patch8:  at-3.1.12-fix_no_export.patch
25Patch9:  at-3.1.13-mailwithhostname.patch
26Patch10: at-3.1.13-usePOSIXtimers.patch
27Patch11: at-3.1.13-help.patch
28
29BuildRequires: fileutils
30BuildRequires: chkconfig
31BuildRequires: flex
32BuildRequires: bison
33BuildRequires: autoconf
34
35%if %{with pam}
36BuildRequires: pam-devel
37%endif
38Conflicts: crontabs <= 1.5
39# No, I'm not kidding
40BuildRequires: smtpdaemon
41Buildroot: %{_tmppath}/%{name}-%{version}-root
42
43%description
44At and batch read commands from standard input or from a specified
45file. At allows you to specify that a command will be run at a
46particular time. Batch will execute commands when the system load
47levels drop to a particular level. Both commands use /bin/sh.
48
49You should install the at package if you need a utility for
50time-oriented job control. Note: If it is a recurring job that will
51need to be repeated at the same time every day/week, etc. you should
52use crontab instead.
53
54%description -l ja
55at と batch は標準入力や指定されたファイルからコマンドを読み取ります。
56at を使用して特定の時間にコマンドを実行するように指定することが可能です。
57batch はシステムの負荷レベルが特定のレベルを下回るとコマンドを実行します。
58両コマンドとも /bin/sh を使います。
59
60あなたが時間志向のジョブ管理のためのユーティリティを必要とするならば、at
61パッケージをインストールしてください。
62
63メモ: もし毎日/週などの同じ時間にくり返される必要があるジョブであれば、
64代わりに crontab を使うべきでしょう。
65
66%prep
67%setup -q
68cp %{SOURCE1} .
69%patch1 -p1 -b .make
70%patch2 -p1 -b .opt_V
71%patch3 -p1 -b .shell
72%patch4 -p1 -b .nit
73%patch5 -p1 -b .pam
74%patch6 -p1 -b .selinux
75%patch7 -p1 -b .nowrap
76%patch8 -p1 -b .export
77%patch9 -p1 -b .mail
78%patch10 -p1 -b .posix
79%patch11 -p1 -b .help
80
81%build
82# patch10 touches configure.in
83autoconf
84# for patch11
85rm -f lex.yy.* y.tab.*
86%configure --with-atspool=%{_localstatedir}/spool/at/spool \
87           --with-jobdir=%{_localstatedir}/spool/at \
88           --with-daemon_username=root  \
89           --with-daemon_groupname=root \
90%if %{with pam}
91           --with-pam
92%endif
93
94make
95
96%check
97# don't run "make test" by default
98%{?_without_check: %define _without_check 1}
99%{!?_without_check: %define _without_check 1}
100
101%if ! %{_without_check}                                                                                                       
102        LANG=C make test > /dev/null
103%endif
104
105%install
106rm -rf %{buildroot}
107make install \
108        DAEMON_USERNAME=`id -nu`\
109        DAEMON_GROUPNAME=`id -ng` \
110        DESTDIR=%{buildroot}\
111        sbindir=%{buildroot}%{_prefix}/sbin\
112        bindir=%{buildroot}%{_bindir}\
113        prefix=%{buildroot}%{_prefix}\
114        exec_prefix=%{buildroot}%{_prefix}\
115        docdir=%{buildroot}/usr/doc\
116        mandir=%{buildroot}%{_mandir}\
117        etcdir=%{buildroot}%{_sysconfdir} \
118        ATJOB_DIR=%{buildroot}%{_localstatedir}/spool/at \
119        ATSPOOL_DIR=%{buildroot}%{_localstatedir}/spool/at/spool \
120        INSTALL_ROOT_USER=`id -nu` \
121        INSTALL_ROOT_GROUP=`id -nu`;
122
123echo > %{buildroot}%{_sysconfdir}/at.deny
124mkdir docs
125cp $RPM_BUILD_ROOT/%{_prefix}/doc/at/* docs/
126
127mkdir -p %{buildroot}%{_sysconfdir}/pam.d
128install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/atd
129
130mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
131install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/atd
132
133mkdir -p %{buildroot}/etc/sysconfig
134install -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/atd
135
136# remove unpackaged files from the buildroot
137rm -r  %{buildroot}%{_prefix}/doc
138
139%clean
140rm -rf %{buildroot}
141
142%post
143touch %{_localstatedir}/spool/at/.SEQ
144chmod 600 %{_localstatedir}/spool/at/.SEQ
145chown daemon.daemon %{_localstatedir}/spool/at/.SEQ
146# must be in chkconfig on
147/sbin/chkconfig --add atd
148
149%preun
150if [ "$1" = 0 ] ; then
151  /sbin/service atd stop
152  /sbin/chkconfig --del atd
153fi
154
155%postun
156if [ "$1" -ge "1" ]; then
157  /sbin/service atd condrestart
158fi
159
160%files
161%defattr(-,root,root)
162%doc docs/*
163%config %{_sysconfdir}/at.deny
164%attr(0700,root,root)           %{_sysconfdir}/rc.d/init.d/atd
165%attr(0700,root,root)           %{_sysconfdir}/sysconfig/atd
166%attr(0700,daemon,daemon)       %dir %{_localstatedir}/spool/at
167%attr(0600,daemon,daemon)       %verify(not md5 size mtime) %ghost %{_localstatedir}/spool/at/.SEQ
168%attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at/spool
169%attr(0640,root,daemon) %config(noreplace) /etc/pam.d/atd
170%{_sbindir}/atrun
171%attr(0755,root,root)   %{_sbindir}/atd
172%{_mandir}/man*/*
173%{_bindir}/batch
174%{_bindir}/atrm
175%{_bindir}/atq
176%attr(4755,root,root) %{_bindir}/at
177
178%changelog
179* Tue Nov 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-1
180- update to 3.1.13
181- update patches to sync with fedora 3.1.13-10.
182
183* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10.1-17
184- rebuild with rpm-4.8.1
185
186* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10.1-16
187- spec in utf-8
188
189* Tue May 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10.1-15
190- new upstream release
191- apply new versioning policy
192
193* Thu Jul 12 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10-14vl1
194- update based on fedora development 3.1.10-14.
195- build with new toolchains.
196  * Tue Jul  9 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-14
197  - feature: add configuration file
198  - fix -V option
199  - fix init script
200
201  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-13
202  - Resolves: rhbz#243064
203
204  * Tue Jul  3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-12
205  - crashing atd
206  - work only for root, still broken some functions
207  - Resolves: rhbz#243064
208
209  * Tue Mar 27 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-11
210  - mistake in pam_atd
211  - rhbz#234120
212
213  * Tue Mar 05 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-10
214  - rhbz#224597
215
216  * Mon Mar 03 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-9
217  - review
218 
219  * Wed Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-8
220  - review
221  - rhbz#225288
222 
223  * Tue Jan 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-7
224  - no debug file - useless
225  - new pam configuration
226  - rhbz#224597
227 
228  * Tue Oct 27 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-6
229  - fix daylight-saving again
230  - fix #214759 - problem with seteuid
231 
232  * Wed Oct 25 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-5
233  - daylight-saving
234 
235  * Tue Oct 24 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-3
236  - new version from upstream 3.1.10
237 
238  * Thu Aug 23 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.8-82.fc6
239  - #176486 don't fork option added (patch from Enrico Scholz)
240
241  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.2
242  - rebuild
243 
244  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.1
245  - bump again for double-long bug on ppc(64)
246 
247  * Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 3.1.8-81
248  - rebuild for new gcc, glibc, glibc-kernheaders
249  - workaround new refusal of /usr/bin/install to chown
250 
251  * Fri Dec 18 2005 Jason Vas Dias<jvdias@redhat.com> - 3.1.8-80.2
252  - rebuild for new flex
253 
254  * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
255  - rebuilt for new gcj
256 
257  * Fri Oct 14 2005 Dan Walsh <dwalsh@redhat.com> - 3.1.8-80
258  - Add seuserbyname support
259 
260  * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 3.1.8-79
261  - use include instead of pam_stack in pam config
262 
263  * Fri Jun 03 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-78
264  - fix bug 159220: add pam_loginuid to pam session stack in /etc/pam.d/atd
265  - fix bug 102341: add '-r' synonym for '-d' / atrm for POSIX / SuS conformance
266 
267  * Fri Apr 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-77
268  - always call pam_setcred(pamh, PAM_DELETE_CRED) before session
269  - close
270 
271  * Tue Apr 05 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-70
272  - always call pam_close_session on PAM_FAIL or pam_end
273 
274  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-68
275  - Put PAM authentication check in 'check_permissions()', so
276  - user can know when using at(1) if PAM permission is denied.
277 
278  * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-67
279  - better fix for bug 150131: change DAEMON_USERNAME and
280  - DAEMON_GROUPNAME to 'root' .
281 
282  * Mon Mar 07 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-66
283  - fix bug 150131: atd should not relinquish root privilege if
284  - doing su(1) equivalent with PAM .
285 
286  * Tue Jan 25 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-64
287  - bugs 5160/146132: add PAM authentication control to atd
288
289* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.8-60vl1
290- based on Fedora development 3.1.8-60
291  * Tue Oct 05 2004 Jason Vas Dias <jvdias@redhat.com> 3.1.8-60
292  - fix bug 131510: no_export env. var. blacklisting should not
293  - remove 'SHELL' when only 'SHELLOPTS' is blacklisted.
294  - at(1) man-page should not say 'commands are run with /bin/sh'
295  - and should explain usage of SHELL environement variable and
296  - details of blacklisted variables.
297  * Tue Sep 28 2004 Rik van Riel <riel@redhat.com> 3.1.8-58
298  - fix typo in man page, bug 112303
299  - (regenerated at-3.1.8-man-timespec-path.patch with fix)
300  * Tue Aug 03 2004 Jason Vas Dias <jvdias@redhat.com>
301  - fixed bug 125634 - made usage() agree with manpage
302  * Thu Jul 29 2004 Jason Vas Dias <jvdias@redhat.com>
303  - Added POSIX.2 -t option for RFE 127485
304  * Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
305  - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
306  - update at.1 description of shell behaviour (#91233)
307  * Tue Jun 17 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-45
308  - make the job shell default to SHELL instead of "/bin/sh" (#91233)
309  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-43
310  - Replace redundant at-3.1.7-paths.patch by at-3.1.8-man-timespec-path.patch
311    to fix timespec path
312  * Tue Jun  3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-41
313  - update source to at_3.1.8-11 from debian upstream
314    - update source url
315    - at-debian.patch no longer needed
316    - at-3.1.7-paths.patch: the patch to "at.1.in" no longer needed
317    - replace at-3.1.8-lexer.patch with at-3.1.8-11-lexer-parser.diff
318    - at-3.1.8-dst.patch no longer needed
319    - at-3.1.8-lsbdoc.patch no longer needed
320    - at-3.1.8-o_excl.patch no longer needed
321    - bump release number
322- added Japanese summary and description from vinedocs.sf.jp :)
323- rebuild with new toolchains
324
325* Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 3.1.8-23vl1
326- follow 3.1.8-23 (RHSA-2002:015-13)
327- apply docpath patch instead of patch16 (due to brute-force patch2 unrevised)
328- Replace sendmail with /usr/sbin/sendmail (postfix) for BuildPreReq
329
330* Sat Jun 09 2001 <sagami@vinelinux.org>
331- 3.1.8-12vl3: rebuilt for %%{_mandir}
332
333* Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.8-12vl2
334- remove /etc/init.d from PreReq
335
336* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.1.8-12vl1
337- build on Vine Linux with gcc-2.95.3
338
339* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
340- Well, we will likely never really close the UTC issues,
341- because of 1) fractional timezones, and 2) daylight savigns time.
342- but there is a slight tweak to the handling of dst in the UTC patch.
343
344* Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
345- fixed bug #15685
346- which had at miscaluclating UTC times.
347
348* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
349- move initscript back
350
351* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
352- automatic rebuild
353
354* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
355- prereq /etc/init.d
356
357* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
358- fix syntax error in init script
359
360* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
361- don't prereq, only require initscripts
362
363* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
364- move init script
365- add condrestart directive
366- fix post/preun/postun scripts
367- prereq initscripts >= 5.20
368
369* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
370- fix verify of /var/spool/at/.SEQ (#12262)
371
372* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
373- fix status checking and syntax error in init script
374
375* Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
376- fix for long usernames (#11321)
377- add some bugfixes from debian
378
379* Mon May  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
380- 3.1.8
381
382* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
383- fix a couple of more typos, null-terminate some strings
384
385* Thu Feb 10 2000 Bill Nottingham <notting@redhat.com>
386- fix many-years-old typo in atd.c
387
388* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
389- handle compressed man pages
390
391* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
392- initscript munging, build as non-root user
393
394* Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
395- correct perms for /var/spool/at after defattr.
396
397* Mon May 24 1999 Jeff Johnson <jbj@redhat.com>
398- reset SIGCHLD before exec (#3016).
399
400* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
401- auto rebuild in the new build environment (release 8)
402
403* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
404- fix handling the 12:00 time
405
406* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
407- configure fix for arm
408
409* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
410- build for glibc 2.1
411
412* Tue May 05 1998 Prospector System <bugs@redhat.com>
413- translations modified for de, fr, tr
414
415* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
416- enhanced initscript
417
418* Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
419- learned to spell
420
421* Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
422- updated to at version 3.1.7
423- updated lock and sequence file handling with %ghost
424- Use chkconfig and atd, now conflicts with old crontabs packages
425
426* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
427- built against glibc
428
Note: See TracBrowser for help on using the repository browser.