source: projects/specs/trunk/a/asymptote/asymptote-vl.spec @ 1531

Revision 1531, 14.5 KB checked in by munepi, 14 years ago (diff)

updated asymptote: ready for TeX Live

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define texmf           %{_datadir}/texmf
5%define build_texmf     %{buildroot}%{texmf}
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
9
10#% define emacs_sitelisp  %{_datadir}/emacs/site-lisp
11#% define xemacs_sitelisp %{_datadir}/xemacs/site-packages/lisp
12
13%define emacspkg asy-mode
14
15Name:           asymptote
16Version:        1.70
17Release:        5%{?_dist_release}
18Summary:        Descriptive vector graphics language
19Summary(ja):    MetaPost に触発されたスクリプトベースのベクターグラフィック言語
20
21Group:          Applications/Publishing
22License:        GPLv3+
23URL:            http://asymptote.sourceforge.net/
24Source0:        http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
25Source1:        asy.gif
26Source2:        xasy.desktop
27
28Source11:       %{emacspkg}-install.sh
29Source12:       %{emacspkg}-remove.sh
30#Source13:      %{name}-init.el
31
32#Patch0:         asymptote-1.29-settings.patch
33Patch0:         asymptote-1.70-settings-vine.patch
34Patch1:         asymptote-1.63-gcc44.patch
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37BuildRequires:  ncurses-devel
38BuildRequires:  readline-devel
39BuildRequires:  fftw3-devel >= 3.0
40BuildRequires:  gc-devel >= 6.8
41BuildRequires:  gsl-devel
42BuildRequires:  texlive
43BuildRequires:  ghostscript
44BuildRequires:  texinfo
45BuildRequires:  ImageMagick
46BuildRequires:  desktop-file-utils
47BuildRequires:  freeglut-devel
48BuildRequires:  zlib-devel
49
50Requires:       tetex
51
52Requires(post): desktop-file-utils
53Requires(postun): desktop-file-utils
54
55# for /usr/bin/texhash and /sbin/install-info
56Requires(post): tetex, info
57Requires(postun): tetex, info
58
59%define texpkgdir   %{texmf}/tex/latex/%{name}
60
61%description
62Asymptote is a powerful descriptive vector graphics language for technical
63drawings, inspired by MetaPost but with an improved C++-like syntax.
64Asymptote provides for figures the same high-quality level of typesetting
65that LaTeX does for scientific text.
66
67This package is custmized for Japanese.
68
69%description -l ja
70Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
71テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
72Asymptote は科学的なテキストに対して LaTeX がしている組版のと
73同じくらい高品質なレベルの図を提供します.
74
75このパッケージは日本語向けにカスタマイズされています.
76
77
78%package gui
79Summary: A graphical interface for Asymptote
80Summary(ja): Asymptote のためのグラフィカルインターフェース
81Group: Applications/Graphics
82Requires: %{name} = %{version}-%{release}
83Requires:       tkinter
84Requires:       python-imaging
85
86%description gui
87A graphical interface for Asymptote
88
89
90%package -n %{emacspkg}
91Summary: Emacs mode for editing Asymptote source code
92Summary(ja): Asymptote ソースコードを編集するための Emacs モード
93Group: Applications/Editors/Emacs
94Requires: %{name} = %{version}-%{release}
95BuildRequires: emacsen
96%prereq_ge     emacsen-common
97
98%description -n %{emacspkg}
99Emacs mode for editing Asymptote source code
100
101
102%prep
103%setup -q
104%patch0 -p1
105%patch1 -p1 -b .gcc44
106%{__sed} -i 's/\r//' doc/CAD1.asy
107
108# convert to UTF-8
109iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
110mv examples/interpolate1.asy{.utf8,}
111
112%build
113%configure \
114    --enable-gc=system \
115    --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
116    --with-latex=%{texmf}/tex/latex
117%__make %{?_smp_mflags}
118cd doc/
119%__make asymptote.pdf
120
121%install
122%__rm -rf $RPM_BUILD_ROOT
123%__make install-all DESTDIR=$RPM_BUILD_ROOT
124
125%__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
126    $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
127
128# # Emacs mode and init files
129# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
130# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
131# ln -s ../../%{name}/asy-{mode,keywords}.el .
132# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
133# ln -s ../../../%{name}/asy-init.el .
134
135# # Xemacs mode and init files
136# install -dm 755 $RPM_BUILD_ROOT%{xemacs_sitelisp}/site-start.d
137# cd $RPM_BUILD_ROOT%{xemacs_sitelisp}
138# ln -s ../../../%{name}/asy-{mode,keywords}.el .
139# cd $RPM_BUILD_ROOT%{xemacs_sitelisp}/site-start.d
140# ln -s ../../../../%{name}/asy-init.el .
141
142# # Vim syntax file
143# for vimver in 63 64 70 71 ; do
144#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
145#     cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
146#     ln -s ../../../%{name}/asy.vim .
147# done
148
149# copy icon to pixmaps dir
150mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
151cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
152
153mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
154desktop-file-install --vendor "vine"                  \
155        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
156        %{SOURCE2}
157
158# Clean up symlink
159rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
160cd $RPM_BUILD_ROOT%{_bindir}
161ln -s ../share/%{name}/GUI/xasy.py xasy
162
163
164## <asy-mode>
165%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
166%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
167%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
168
169#
170# install el files
171#
172
173# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
174# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
175# ln -s ../../%{name}/asy-{mode,keywords}.el .
176# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
177# ln -s ../../../%{name}/asy-init.el .
178
179%__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
180    $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
181
182
183#
184# install script (bytecompile el and install elc, remove)
185#
186
187%_installemacsenscript %{name} %{SOURCE11}
188
189%_removeemacsenscript  %{name} %{SOURCE12}
190
191## </asy-mode>
192
193
194%clean
195%__rm -rf $RPM_BUILD_ROOT
196
197
198%post
199/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
200/sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
201%{exec_texhash}
202%{exec_updmap}
203
204
205%post -n %{emacspkg}
206if [ "$1" = 2 ]; then
207
208  %_emacsenPackageRemove %{name}
209
210fi
211
212%_addemacsenlist %{name}
213
214%_emacsenPackageInstall %{name}
215     
216
217%postun
218if [ $1 = 0 ]; then
219    /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
220    /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
221    %{exec_texhash}
222    %{exec_updmap}
223fi
224
225
226%preun -n %{emacspkg}
227if [ "$1" = 0 ]; then
228
229  %_emacsenPackageRemove %{name}
230
231  %_removeemacsenlist %{name}
232
233fi
234
235
236%files
237%defattr(-,root,root,-)
238%doc %{_defaultdocdir}/%{name}-%{version}/
239%{_bindir}/asy
240%{_datadir}/%{name}/
241%exclude %{_datadir}/asymptote/GUI/
242%{texpkgdir}/
243%{_mandir}/man*/asy.*
244%{_infodir}/*.info*
245#%{_datadir}/vim/vim*/syntax/asy.vim
246# Strictly speaking, we shouldn't own these dirs.
247# However, we don't require emacs/xemacs, we just enhance them.
248# Thus, its ok for dual ownership.
249#%{_datadir}/emacs*
250#%{_datadir}/xemacs/
251
252
253%files gui
254%{_bindir}/xasy
255%{_datadir}/applications/vine-xasy.desktop
256%{_datadir}/pixmaps/asy.gif
257%{_datadir}/asymptote/GUI/
258%{_mandir}/man*/xasy.*
259
260
261%files -n %{emacspkg}
262%defattr(-,root,root)
263%{_datadir}/emacs/site-lisp/%{name}
264%{_prefix}/lib/emacsen-common/packages/install/%{name}
265%{_prefix}/lib/emacsen-common/packages/remove/%{name}
266
267
268%changelog
269* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
270- TeX Live 2009
271
272* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
273- rebuilt with new toolchain, libsigsegv-2.8
274- appled Patch1 again
275
276* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
277- don't apply Patch1 until gcc44 comes to VineSeed
278
279* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
280- separated Xasy to gui subpackage
281
282* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
283- initial build based on Fedora Development (fc11) package
284- applied asymptote-1.70-settings-vine.patch
285
286* Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
287- update to 1.70
288
289* Tue Apr  7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
290- update to 1.69
291
292* Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
293- update to 1.68
294
295* Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
296- update to 1.67
297
298* Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
299- update to 1.66
300
301* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
302- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
303
304* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
305- more gcc44 fixes with BIG_ENDIAN platforms
306
307* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
308- fix gcc44 issue with BIG_ENDIAN platforms
309
310* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
311- forgot to put in new source
312
313* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
314- 1.63
315
316* Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
317- 1.60
318
319* Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
320- 1.59
321
322* Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
323- 1.58
324
325* Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
326- 1.57
327
328* Tue Dec  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
329- 1.56
330
331* Tue Dec  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
332- 1.54
333
334* Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
335- 1.52
336
337* Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
338- update to 1.51
339
340* Mon Nov  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
341- update to 1.49
342
343* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
344- update to 1.47
345
346* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
347- update to 1.46
348
349* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
350- add missing BuildRequires
351
352* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
353- update to 1.44
354
355* Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
356- update to 1.43
357
358* Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
359- explicitly call "make asymptote.pdf" in doc/
360
361* Fri Apr  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
362- fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
363
364* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
365- update to 1.42
366
367* Wed Feb  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
368- update to 1.41
369- enable desktop file for xasy
370
371* Thu Jan  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
372- bump to 1.37
373- fix gcc43 failures
374- drop triggers
375
376* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
377- Rebuild for selinux ppc32 issue.
378
379* Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
380- Update 1.33.
381
382* Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
383- Update to 1.32.
384- vim-common triggers: correction and improvements (#246131).
385
386* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
387- Update to 1.31.
388
389* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
390- Update to 1.30.
391
392* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
393- Using "evince" as the default PS and PDF viewers (#244151).
394  (patch file: asymptote-1.29-settings.patch)
395- Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
396- Use relative symbolic links in the vim-common triggers.
397
398* Sat Jun  2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
399- Add asy-faq to install-info (#155750).
400- Add support for vim 7.1.
401
402* Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
403- Update to 1.29.
404
405* Tue May  8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
406- Update to 1.28.
407
408* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
409- Update to 1.27.
410
411* Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
412- Update to 1.26.
413
414* Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
415- Update to 1.25.
416
417* Sun Apr  1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
418- Update to 1.24.
419
420* Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
421- Update to 1.23.
422
423* Tue Mar  6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
424- Update to 1.22.
425
426* Sat Mar  3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
427- Update to 1.21.
428
429* Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
430- Update to 1.20.
431
432* Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
433- Update to 1.19.
434
435* Sun Nov  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
436- Update to 1.18.
437
438* Wed Nov  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
439- Update to 1.17.
440
441* Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
442- Update to 1.16.
443
444* Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
445- Update to 1.15.
446
447* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
448- Update to 1.13.
449
450* Thu Aug  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
451- Update to 1.12.
452
453* Thu Jul  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
454- Update to 1.11.
455
456* Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
457- Update to 1.10.
458
459* Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
460- Update to 1.09.
461
462* Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
463- Update to 1.08.
464- Also installs the info file.
465
466* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
467- Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
468
469* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
470- Group: Development/Tools -> Applications/Publishing (#193154).
471
472* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
473- Emacs/Xemacs init file (#193154 comment 6).
474
475* Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
476- Directories ownership (#193154).
477
478* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
479- Update to 1.06.
480- Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
481
482* Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
483- Update to 1.05.
484
485* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
486- Update to 1.04.
487
488* Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
489- Update to 1.03.
490
491* Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
492- First build.
493
494# vim:set ai ts=4 sw=4 sts=4 et:
Note: See TracBrowser for help on using the repository browser.