source: projects/specs/trunk/a/assimp/assimp-vl.spec @ 10585

Revision 10585, 9.7 KB checked in by tomop, 8 years ago (diff)

new: assimp-3.2.0-4

Line 
1%global commit0 c318d648ff73aa2e32b783709d69740ac3e8c072
2%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
3
4%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
5%{!?python3_version: %define python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
6
7Name:           assimp
8Version:        3.2.0
9Release:        4%{?_dist_release}
10Summary:        Library to import various 3D model formats into applications
11
12Group:          Development/Libraries
13# Assimp is BSD, the bundled openddlparser is MIT.
14License:        BSD and MIT
15URL:            http://assimp.sourceforge.net
16#Source0:  https://github.com/assimp/%{name}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
17# Github releases include nonfree models, source tarball must be re-generated
18# using assimp_generate_tarball.sh
19Source0:        %{name}-%{commit0}-free.tar.bz2
20# Strips bundled irrXML out of build files, and allows project to build
21# against system versions of the libraries (not yet submitted upstream)
22Patch0:         %{name}-3.2.0-unbundle.patch
23# Change a doxygen setting so CHM help isn't generated. Fedora-only
24Patch1:         %{name}-3.1.1-docfix.patch
25# Add /usr/lib64 to library lookup paths for python modules
26Patch4:         %{name}-3.2.0-pythonpath.patch
27# Fix library and include paths in assimp-config.cmake
28# Fixes rhbz#1263698, not submitted upstream
29Patch5:         %{name}-3.2.0-cmakefix.patch
30# Fix big endian platforms
31Patch6:         %{name}-3.2.0-bigendian.patch
32
33BuildRequires:  libboost-devel
34BuildRequires:  cmake
35BuildRequires:  dos2unix
36#BuildRequires:  irrlicht-devel
37#BuildRequires:  irrXML-devel
38BuildRequires:  zlib-devel
39BuildRequires:  doxygen
40#BuildRequires:  minizip-devel
41#BuildRequires:  poly2tri-devel
42#BuildRequires:  polyclipping-devel
43BuildRequires:  python-devel
44BuildRequires:  python3-devel
45BuildRequires:  gtest-devel
46
47Provides: bundled(openddl-parser)
48
49%description
50Assimp, the Open Asset Import Library, is a free library to import
51various well-known 3D model formats into applications.  Assimp aims
52to provide a full asset conversion pipeline for use in game
53engines and real-time rendering systems, but is not limited
54to these applications.
55
56%package devel
57Summary: Header files and libraries for assimp
58Group: Development/Libraries
59Requires: %{name}%{?_isa} = %{version}-%{release}
60
61%description devel
62This package contains the header files and libraries
63for assimp. If you would like to develop programs using assimp,
64you will need to install assimp-devel.
65
66%package -n python2-%{name}
67Summary: Python bindings for assimp
68Group: Development/Libraries
69BuildArch: noarch
70Requires: %{name} = %{version}-%{release}
71Requires: python
72Provides: %{name}-python = %{version}-%{release}
73Obsoletes: %{name}-python < 3.1.1
74
75%description -n python2-%{name}
76This package contains the PyAssimp python bindings
77
78%package -n python3-%{name}
79Summary: Python 3 bindings for assimp
80Group: Development/Libraries
81BuildArch: noarch
82Requires: %{name} = %{version}-%{release}
83Requires: python3
84Provides: %{name}-python3 = %{version}-%{release}
85Obsoletes: %{name}-python3 < 3.1.1
86
87%description -n python3-%{name}
88This package contains the PyAssimp3 python bindings
89
90%prep
91%setup -q -n %{name}-%{commit0}
92# Get rid of bundled libs so we can't accidently build against them
93#rm -f code/fast_atof.h
94#rm -rf contrib/cppunit-1.12.1
95#rm -rf contrib/irrXML
96#rm -rf contrib/zlib
97#rm -rf contrib/unzip
98#rm -rf contrib/poly2tri
99#%patch0 -p1 -b .unbundle
100%patch1 -p1 -b .docfix
101%patch4 -p1 -b .pythonpath
102%patch5 -p0 -b .cmakefix
103%patch6 -p1 -b .bigendian
104
105%build
106mkdir build
107pushd build
108%cmake .. \
109 -DASSIMP_LIB_INSTALL_DIR=%{_libdir} \
110 -DASSIMP_BIN_INSTALL_DIR=%{_bindir} \
111 -DASSIMP_INCLUDE_INSTALL_DIR=%{_includedir} \
112 -DIRRXML_LIB_PATH=%{_libdir} \
113 -DIRRXML_INCLUDE_PATH=%{_includedir}/irrlicht/ \
114 -DUSE_EXTERNAL_LIBS=ON  \
115 -DASSIMP_ENABLE_BOOST_WORKAROUND=OFF
116
117# -DPOLY2TRI_INCLUDE_PATH=%{_includedir}/poly2tri \
118# -DCLIPPER_INCLUDE_PATH=%{_includedir}/clipper \
119
120popd
121make %{?_smp_mflags} -C build
122
123# Generate docs, copy assimp logo image and stylesheet into generated docs
124pushd doc
125doxygen Doxyfile
126cp AssimpDoc_Html/dragonsplash.png html/dragonsplash.png
127popd
128
129# Fix file encoding
130dos2unix README LICENSE CREDITS port/PyAssimp/README.md
131iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.conv && mv -f CREDITS.conv CREDITS
132
133%install
134rm -rf %{buildroot}
135make -C build install DESTDIR=%{buildroot}
136mkdir -p %{buildroot}%{python_sitelib}/pyassimp/
137install -m0644 port/PyAssimp/pyassimp/*.py %{buildroot}%{python_sitelib}/pyassimp/
138mkdir -p %{buildroot}%{python3_sitelib}/pyassimp/
139install -m0644 port/PyAssimp/pyassimp/*.py %{buildroot}%{python3_sitelib}/pyassimp/
140
141%clean
142rm -rf %{buildroot}
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148
149%files
150%license LICENSE
151%doc README CREDITS
152%{_bindir}/assimp
153%{_libdir}/*.so.*
154
155%files devel
156%doc doc/html
157%{_includedir}/assimp
158%{_libdir}/*.so
159%{_libdir}/pkgconfig/*.pc
160%{_libdir}/cmake/%{name}-3.2
161
162%files -n python2-%{name}
163%doc port/PyAssimp/README.md
164%{python_sitelib}/pyassimp
165
166%files -n python3-%{name}
167%doc port/PyAssimp/README.md
168%{python3_sitelib}/pyassimp
169
170%changelog
171* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.2.0-4
172- initial build for Vine Linux.
173
174* Fri Jul 01 2016 Dan Horák <dan[at]danny.cz> - 3.2.0-3
175- Fix build on big endian platforms
176
177* Fri Jun 03 2016 Rich Mattes <richmattes@gmail.com> - 3.2.0-2
178- Fix pkgconfig and cmake files (rhbz#1340656)
179
180* Mon May 09 2016 Rich Mattes <richmattes@gmail.com> - 3.2.0-1
181- Update to release 3.2.0 (rhbz#1332434)
182
183* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-9
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
185
186* Thu Jan 14 2016 Jonathan Wakely <jwakely@redhat.com> - 3.1.1-8
187- Rebuilt for Boost 1.60
188
189* Wed Dec 09 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-7
190- Add patch to fix build on big-endian architectures
191
192* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-6
193- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
194
195* Thu Sep 17 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-5
196- Fix assimp-config paths (rhbz#1263698)
197- Build against system boost instead of using included workaround
198
199* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 3.1.1-4
200- Rebuilt for Boost 1.59
201
202* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-3
203- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
204
205* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 3.1.1-2
206- rebuild for Boost 1.58
207
208* Fri Jul 03 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-1
209- Update to release 3.1.1 (rhbz#1206371)
210- Remove upstreamed patches
211- Correct python package names
212- Use license macro
213
214* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-11
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
216
217* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.0.1270-10
218- Rebuilt for GCC 5 C++11 ABI change
219
220* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 3.0.1270-9
221- Rebuild for boost 1.57.0
222
223* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-8
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
225
226* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-7
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
228
229* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.0.1270-6
230- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
231
232* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 3.0.1270-5
233- Rebuild for boost 1.55.0
234
235* Sun Mar 02 2014 Scott K Logan <logans@cottsay.net> - 3.0.1270-4
236- Changed upstream source to Github
237- Un-commented assimp-python, added python-devel to build deps
238- Added assimp-python3 subpackage
239
240* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-3
241- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
242
243* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 3.0.1270-2
244- Rebuild for boost 1.54.0
245
246* Wed May 01 2013 Rich Mattes <richmattes@gmail.com> 3.0.1270-1
247- Update to release 3.0.1270
248
249* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.863-9.20110824svn
250- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
251
252* Thu Oct 25 2012 Rich Mattes <richmattes@gmail.com> - 2.0.863-8.20110824svn
253- Install python bindings
254
255* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.863-7.20110824svn
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
257
258* Tue Jul  3 2012 Tom Callaway <spot@fedoraproject.org> - 2.0.863-6.20110824svn
259- rebuild against new irrlicht/irrxml
260
261* Wed Apr 11 2012 Rich Mattes <richmattes@gmail.com> - 2.0.863-5.20110824svn
262- Changed spec to use buildroot macro
263
264* Sat Dec 17 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-4.20110824svn
265- Fixed pkgconfig paths
266
267* Wed Aug 24 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-3.20110824svn
268- Upgrade to latest svn snapshot
269- Port changes to link against system irrXML
270- Removed upstreamed zlib/unzip unbundling patches
271
272* Thu Mar 24 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-2.20110324svn
273- Upgrade to latest svn snapshot
274- Port changes to link against libIrrXML
275
276* Sat Dec 18 2010 Rich Mattes <richmattes@gmail.com> - 2.0.863-1
277- Upgrade to release 2.0
278
279* Mon Sep 20 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-3
280- Remove extra buildrequires
281- Generate doxygen docs manually
282
283* Mon Sep 20 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-2
284- Included doxygen-generated docs
285- Using original .zip file from project download page
286
287* Sun Sep 19 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-1
288- First build
Note: See TracBrowser for help on using the repository browser.