source: projects/specs/trunk/a/assimp/assimp-vl.spec @ 10590

Revision 10590, 9.8 KB checked in by tomop, 8 years ago (diff)

assimp-3.2.0-5

Line 
1%global commit0 c318d648ff73aa2e32b783709d69740ac3e8c072
2%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
3
4%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
5%{!?python3_version: %define python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
6
7Name:           assimp
8Version:        3.2.0
9Release:        5%{?_dist_release}
10Summary:        Library to import various 3D model formats into applications
11
12Group:          Development/Libraries
13# Assimp is BSD, the bundled openddlparser is MIT.
14License:        BSD and MIT
15URL:            http://assimp.sourceforge.net
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20#Source0:  https://github.com/assimp/%{name}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
21# Github releases include nonfree models, source tarball must be re-generated
22# using assimp_generate_tarball.sh
23Source0:        %{name}-%{commit0}-free.tar.bz2
24# Strips bundled irrXML out of build files, and allows project to build
25# against system versions of the libraries (not yet submitted upstream)
26Patch0:         %{name}-3.2.0-unbundle.patch
27# Change a doxygen setting so CHM help isn't generated. Fedora-only
28Patch1:         %{name}-3.1.1-docfix.patch
29# Add /usr/lib64 to library lookup paths for python modules
30Patch4:         %{name}-3.2.0-pythonpath.patch
31# Fix library and include paths in assimp-config.cmake
32# Fixes rhbz#1263698, not submitted upstream
33Patch5:         %{name}-3.2.0-cmakefix.patch
34# Fix big endian platforms
35Patch6:         %{name}-3.2.0-bigendian.patch
36
37BuildRequires:  libboost-devel
38BuildRequires:  cmake
39BuildRequires:  dos2unix
40#BuildRequires:  irrlicht-devel
41#BuildRequires:  irrXML-devel
42BuildRequires:  zlib-devel
43BuildRequires:  doxygen
44#BuildRequires:  minizip-devel
45#BuildRequires:  poly2tri-devel
46#BuildRequires:  polyclipping-devel
47BuildRequires:  python-devel
48BuildRequires:  python3-devel
49BuildRequires:  gtest-devel
50
51Provides: bundled(openddl-parser)
52
53%description
54Assimp, the Open Asset Import Library, is a free library to import
55various well-known 3D model formats into applications.  Assimp aims
56to provide a full asset conversion pipeline for use in game
57engines and real-time rendering systems, but is not limited
58to these applications.
59
60%package devel
61Summary: Header files and libraries for assimp
62Group: Development/Libraries
63Requires: %{name}%{?_isa} = %{version}-%{release}
64
65%description devel
66This package contains the header files and libraries
67for assimp. If you would like to develop programs using assimp,
68you will need to install assimp-devel.
69
70%package -n python2-%{name}
71Summary: Python bindings for assimp
72Group: Development/Libraries
73BuildArch: noarch
74Requires: %{name} = %{version}-%{release}
75Requires: python
76Provides: %{name}-python = %{version}-%{release}
77Obsoletes: %{name}-python < 3.1.1
78
79%description -n python2-%{name}
80This package contains the PyAssimp python bindings
81
82%package -n python3-%{name}
83Summary: Python 3 bindings for assimp
84Group: Development/Libraries
85BuildArch: noarch
86Requires: %{name} = %{version}-%{release}
87Requires: python3
88Provides: %{name}-python3 = %{version}-%{release}
89Obsoletes: %{name}-python3 < 3.1.1
90
91%description -n python3-%{name}
92This package contains the PyAssimp3 python bindings
93
94%prep
95%setup -q -n %{name}-%{commit0}
96# Get rid of bundled libs so we can't accidently build against them
97#rm -f code/fast_atof.h
98#rm -rf contrib/cppunit-1.12.1
99#rm -rf contrib/irrXML
100#rm -rf contrib/zlib
101#rm -rf contrib/unzip
102#rm -rf contrib/poly2tri
103#%patch0 -p1 -b .unbundle
104%patch1 -p1 -b .docfix
105%patch4 -p1 -b .pythonpath
106%patch5 -p0 -b .cmakefix
107%patch6 -p1 -b .bigendian
108
109%build
110mkdir build
111pushd build
112%cmake .. \
113 -DASSIMP_LIB_INSTALL_DIR=%{_libdir} \
114 -DASSIMP_BIN_INSTALL_DIR=%{_bindir} \
115 -DASSIMP_INCLUDE_INSTALL_DIR=%{_includedir} \
116 -DIRRXML_LIB_PATH=%{_libdir} \
117 -DIRRXML_INCLUDE_PATH=%{_includedir}/irrlicht/ \
118 -DUSE_EXTERNAL_LIBS=ON  \
119 -DASSIMP_ENABLE_BOOST_WORKAROUND=OFF
120
121# -DPOLY2TRI_INCLUDE_PATH=%{_includedir}/poly2tri \
122# -DCLIPPER_INCLUDE_PATH=%{_includedir}/clipper \
123
124popd
125make %{?_smp_mflags} -C build
126
127# Generate docs, copy assimp logo image and stylesheet into generated docs
128pushd doc
129doxygen Doxyfile
130cp AssimpDoc_Html/dragonsplash.png html/dragonsplash.png
131popd
132
133# Fix file encoding
134dos2unix README LICENSE CREDITS port/PyAssimp/README.md
135iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.conv && mv -f CREDITS.conv CREDITS
136
137%install
138rm -rf %{buildroot}
139make -C build install DESTDIR=%{buildroot}
140mkdir -p %{buildroot}%{python_sitelib}/pyassimp/
141install -m0644 port/PyAssimp/pyassimp/*.py %{buildroot}%{python_sitelib}/pyassimp/
142mkdir -p %{buildroot}%{python3_sitelib}/pyassimp/
143install -m0644 port/PyAssimp/pyassimp/*.py %{buildroot}%{python3_sitelib}/pyassimp/
144
145%clean
146rm -rf %{buildroot}
147
148%post -p /sbin/ldconfig
149
150%postun -p /sbin/ldconfig
151
152
153%files
154%license LICENSE
155%doc README CREDITS
156%{_bindir}/assimp
157%{_libdir}/*.so.*
158
159%files devel
160%doc doc/html
161%{_includedir}/assimp
162%{_libdir}/*.so
163%{_libdir}/pkgconfig/*.pc
164%{_libdir}/cmake/%{name}-3.2
165
166%files -n python2-%{name}
167%doc port/PyAssimp/README.md
168%{python_sitelib}/pyassimp
169
170%files -n python3-%{name}
171%doc port/PyAssimp/README.md
172%{python3_sitelib}/pyassimp
173
174%changelog
175* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.2.0-5
176- added tags: Vendor and Distribution.
177
178* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.2.0-4
179- initial build for Vine Linux.
180
181* Fri Jul 01 2016 Dan Horák <dan[at]danny.cz> - 3.2.0-3
182- Fix build on big endian platforms
183
184* Fri Jun 03 2016 Rich Mattes <richmattes@gmail.com> - 3.2.0-2
185- Fix pkgconfig and cmake files (rhbz#1340656)
186
187* Mon May 09 2016 Rich Mattes <richmattes@gmail.com> - 3.2.0-1
188- Update to release 3.2.0 (rhbz#1332434)
189
190* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-9
191- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
192
193* Thu Jan 14 2016 Jonathan Wakely <jwakely@redhat.com> - 3.1.1-8
194- Rebuilt for Boost 1.60
195
196* Wed Dec 09 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-7
197- Add patch to fix build on big-endian architectures
198
199* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-6
200- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
201
202* Thu Sep 17 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-5
203- Fix assimp-config paths (rhbz#1263698)
204- Build against system boost instead of using included workaround
205
206* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 3.1.1-4
207- Rebuilt for Boost 1.59
208
209* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-3
210- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
211
212* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 3.1.1-2
213- rebuild for Boost 1.58
214
215* Fri Jul 03 2015 Rich Mattes <richmattes@gmail.com> - 3.1.1-1
216- Update to release 3.1.1 (rhbz#1206371)
217- Remove upstreamed patches
218- Correct python package names
219- Use license macro
220
221* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-11
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
223
224* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.0.1270-10
225- Rebuilt for GCC 5 C++11 ABI change
226
227* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 3.0.1270-9
228- Rebuild for boost 1.57.0
229
230* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-8
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
232
233* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-7
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
235
236* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.0.1270-6
237- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
238
239* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 3.0.1270-5
240- Rebuild for boost 1.55.0
241
242* Sun Mar 02 2014 Scott K Logan <logans@cottsay.net> - 3.0.1270-4
243- Changed upstream source to Github
244- Un-commented assimp-python, added python-devel to build deps
245- Added assimp-python3 subpackage
246
247* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1270-3
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
249
250* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 3.0.1270-2
251- Rebuild for boost 1.54.0
252
253* Wed May 01 2013 Rich Mattes <richmattes@gmail.com> 3.0.1270-1
254- Update to release 3.0.1270
255
256* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.863-9.20110824svn
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
258
259* Thu Oct 25 2012 Rich Mattes <richmattes@gmail.com> - 2.0.863-8.20110824svn
260- Install python bindings
261
262* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.863-7.20110824svn
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
264
265* Tue Jul  3 2012 Tom Callaway <spot@fedoraproject.org> - 2.0.863-6.20110824svn
266- rebuild against new irrlicht/irrxml
267
268* Wed Apr 11 2012 Rich Mattes <richmattes@gmail.com> - 2.0.863-5.20110824svn
269- Changed spec to use buildroot macro
270
271* Sat Dec 17 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-4.20110824svn
272- Fixed pkgconfig paths
273
274* Wed Aug 24 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-3.20110824svn
275- Upgrade to latest svn snapshot
276- Port changes to link against system irrXML
277- Removed upstreamed zlib/unzip unbundling patches
278
279* Thu Mar 24 2011 Rich Mattes <richmattes@gmail.com> - 2.0.863-2.20110324svn
280- Upgrade to latest svn snapshot
281- Port changes to link against libIrrXML
282
283* Sat Dec 18 2010 Rich Mattes <richmattes@gmail.com> - 2.0.863-1
284- Upgrade to release 2.0
285
286* Mon Sep 20 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-3
287- Remove extra buildrequires
288- Generate doxygen docs manually
289
290* Mon Sep 20 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-2
291- Included doxygen-generated docs
292- Using original .zip file from project download page
293
294* Sun Sep 19 2010 Rich Mattes <richmattes@gmail.com> - 1.1.700-1
295- First build
Note: See TracBrowser for help on using the repository browser.