source: projects/specs/trunk/a/arts/arts-vl.spec @ 633

Revision 633, 15.0 KB checked in by inagaki, 14 years ago (diff)

updated: arts, poppler, poppler-data

Line 
1%define beta 0
2%define alsa 1
3%define run_test 0
4%define make_cvs 1
5
6Name: arts
7Summary: aRts (analog realtime synthesizer) - the KDE 3 sound system
8Summary(ja): aRts - KDE 3 サウンドシステム
9Epoch: 1
10Version: 1.5.10
11%if %{beta}
12Release: 0.%{beta}%{?_dist_release}
13%else
14Release: 3%{?_dist_release}
15%endif
16License: LGPLv2
17URL: http://www.kde.org
18Group: System Environment/Daemons
19
20%if %{beta}
21Source: ftp://ftp.kde.org/pub/kde/unstable/%{version}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
22%else
23Source: ftp://ftp.kde.org/pub/kde/stable/3.5.10/src/%{name}-%{version}.tar.bz2
24%endif
25
26Patch1: arts-1.1.4-debug.patch
27Patch2: arts-1.3.92-glib2.patch
28Patch5: arts-1.3.1-alsa.patch
29Patch6: arts-1.5.8-glibc.patch
30Patch7: arts-1.5.0-check_tmp_dir.patch
31Patch8: arts-1.5.2-multilib.patch
32# don't pop up a dialog on CPU overload (#361891)
33Patch9: arts-1.5.10-cpu-overload-quiet.patch
34# kde#93359
35Patch50: arts-1.5.4-dlopenext.patch
36Patch51: kde-3.5-libtool-shlibext.patch
37# upstream patches
38
39# security patches
40# CVE-2009-3736 libtool: libltdl may load and execute code from a library in the current directory
41Patch200: libltdl-CVE-2009-3736.patch
42
43# tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
44Patch300: arts-acinclude.patch
45
46BuildRoot: %{_tmppath}/%{name}-%{version}-root
47BuildRequires: gcc-c++ libjpeg-devel
48BuildRequires: mesa-libGL-devel mesa-libGLU-devel
49BuildRequires: libmng-devel zlib-devel audiofile-devel
50BuildRequires: qt-devel >= 3.3.2, libpng-devel >= 1.2.5
51BuildRequires: libogg-devel libvorbis-devel glib2-devel
52BuildRequires: esound-devel jack-audio-connection-kit-devel
53BuildRequires: pkgconfig
54%if %{alsa}
55BuildRequires: alsa-lib-devel
56%endif
57%if %{run_test}
58BuildRequires: kdelibs3
59%endif
60
61# We don't want to require X11, Qt or glib2, arts is perfectly usable without
62# them, they're just used by addons the qtmcop, gmcop and x11globalcomm addons
63AutoReq: off
64#Requires: XFree86-gl XFree86-libs freetype2 libjpeg libmng libpng zlib
65#Requires: audiofile glibc
66Obsoletes: kdelibs-sound
67Provides: kdelibs-sound
68
69%description
70arts (analog real-time synthesizer) is the sound system of KDE 3.
71
72The principle of arts is to create/process sound using small modules which do
73certain tasks. These may be create a waveform (oscillators), play samples,
74filter data, add signals, perform effects like delay/flanger/chorus, or
75output the data to the soundcard.
76
77By connecting all those small modules together, you can perform complex
78tasks like simulating a mixer, generating an instrument or things like
79playing a wave file with some effects.
80
81%package devel
82Summary: Development files for the aRts sound server
83Summary(ja): aRts サウンドサーバの開発用ファイル
84Group: Development/Libraries
85Requires: %{name} = %{epoch}:%{version}-%{release}
86Requires: glib2-devel
87Obsoletes: kdelibs-sound-devel
88Provides: kdelibs-sound-devel
89
90%description devel
91arts (analog real-time synthesizer) is the sound system of KDE 3.
92
93The principle of arts is to create/process sound using small modules which do
94certain tasks. These may be create a waveform (oscillators), play samples,
95filter data, add signals, perform effects like delay/flanger/chorus, or
96output the data to the soundcard.
97
98By connecting all those small modules together, you can perform complex
99tasks like simulating a mixer, generating an instrument or things like
100playing a wave file with some effects.
101
102Install arts-devel if you intend to write applications using arts (such as
103KDE applications using sound).
104
105%prep
106%setup -q
107%patch1 -p1 -b .debug
108%patch2 -p1 -b .glib
109%patch5 -p1 -b .alsa
110%patch6 -p1 -b .glibc
111%patch7 -p1 -b .check_tmp_dir
112%patch8 -p1 -b .multilib
113%patch9 -p1 -b .cpu-overload-quiet
114
115%patch50 -p1 -b .dlopenext
116%patch51 -p1 -b .libtool-shlibext
117
118%patch200 -p1 -b .CVE-2009-3736
119
120%patch300 -p1 -b .acinclude
121
122%build
123%if %{make_cvs}
124# hack/fix for newer automake
125  sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
126  make -f admin/Makefile.common cvs
127%endif
128
129unset QTDIR || : ; . /etc/profile.d/qt.sh
130
131%configure \
132    --includedir=%{_includedir}/kde \
133    --with-qt-libraries=$QTDIR/lib \
134    --disable-rpath \
135    --disable-debug --disable-warnings \
136    --disable-dependency-tracking \
137    --enable-new-ldflags \
138    --disable-libmad \
139%if %{alsa}
140    --with-alsa \
141%endif
142    --enable-final
143
144make %{?_smp_mflags}
145
146%if %{run_test}
147make check
148%endif
149
150%install
151rm -rf $RPM_BUILD_ROOT
152export PATH=`pwd`:$PATH
153make DESTDIR=$RPM_BUILD_ROOT install
154
155## remove references to optional external libraries in .la files (#178733)
156find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
157 sed -i \
158 -e "s|-lmad||g" \
159 -e "s|%{_libdir}/libmad.la||g" \
160 -e "s|-lvorbisfile||g" \
161 -e "s|-lvorbisenc||g" \
162 -e "s|-lvorbis||g" \
163 -e "s|-logg||g" \
164 -e "s|-lasound||g" \
165 -e "s|-laudiofile||g" \
166 -e "s|-lesd||g" \
167 -e "s|%{_libdir}/libesd.la||g" \
168 -e "s|-lgmodule-2.0||g" \
169 -e "s|-lgthread-2.0||g" \
170 -e "s|-lglib-2.0||g" \
171 -e "s|-laudio ||g" \
172 -e "s|-lpng -lz ||g" \
173 -e "s|%{_libdir}/libartsc.la||g" \
174 -e "s@-lboost_filesystem@@g" \
175 -e "s@-lboost_regex@@g" \
176 -e "s@-ljack@@g"
177
178#rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
179
180#chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
181
182%clean
183rm -rf $RPM_BUILD_ROOT
184
185%post -p /sbin/ldconfig
186
187%postun -p /sbin/ldconfig
188
189%files
190%defattr(-,root,root)
191%doc COPYING.LIB
192%dir %{_libdir}/mcop
193%dir %{_libdir}/mcop/Arts
194%{_bindir}/arts*
195%exclude %{_bindir}/artsc-config
196%{_libdir}/mcop/Arts/*
197%{_libdir}/mcop/*.mcopclass
198%{_libdir}/mcop/*.mcoptype
199%{_libdir}/lib*.so.*
200%{_libdir}/lib*.la
201
202%files devel
203%defattr(-,root,root)
204%{_bindir}/artsc-config
205%{_bindir}/mcopidl
206%{_includedir}/kde/arts
207%{_includedir}/kde/artsc
208%{_libdir}/lib*.so
209%{_libdir}/pkgconfig/artsc.pc
210
211%changelog
212* Sat Mar 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-3
213- rebuilt with new toolchain
214- added Patch9, 200 and 300 from FC
215  * Wed Dec 16 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.5.10-11
216  - don't pop up a dialog on CPU overload (#361891)
217  * Thu Dec 10 2009 Stepan Kasal <skasal@redhat.com> - 1.5.10-10
218  - patch autoconfigury to build with autoconf >= 2.64
219  * Sun Dec 06 2009 Than Ngo <than@redhat.com> - 1.5.10-9
220  - fix url
221  - fix security issues in libltdl (CVE-2009-3736)
222- added Japanese summary
223- fixed duplicated entry at last changelog
224
225* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
226- added Patch1,2,5,8,50 and 51 from Fedora
227- added lib*.la files again...
228
229* Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
230- updated to 1.5.10
231- added BuildRequires: jack-audio-connection-kit-devel
232- removed static library
233
234* Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
235- applied new versioning policy
236- updated build dependancies
237
238* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
239- rebuild for VineSeed
240
241* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
242- new upstream release
243
244* Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
245- rebuild for VineSeed
246
247* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
248- new upstream release
249
250* Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
251- new upstream release
252
253* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
254- rebuild for VineSeed
255
256* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
257- add Patch0 [VineLinux:0369]
258
259* Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
260- added --with-qt-libraries option
261- removed --libdir=%%{_libdir} option
262
263* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
264- rebuild for VineSeed
265
266* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
267- new upstream release
268
269* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
270- rebuild for VineSeed
271
272* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
273- new upstream release
274- drop Patch0
275
276* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
277- added --libdir=%%{_libdir} to ./configure option
278
279* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
280- rebuild for VineSeed
281
282* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
283- add Patch0 (CVE-2006-2916)
284
285* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
286- rebuild for VineSeed
287
288* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
289- new upstream release
290
291* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
292- rebuild for VineSeed
293
294* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
295- new upstream release
296
297* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
298- rebuild for VineSeed
299
300* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
301- new upstream release
302
303* Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
304- add "%%{epoch}:" to Requires in arts-devel
305
306* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
307- rebuild for VineSeed
308
309* Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
310- new upstream release
311
312* Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
313- new upstream release
314
315* Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
316- new upstream release
317
318* Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
319- new upstream release
320
321* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
322- rebuild for VineSeed
323
324* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
325- new upstream release
326
327* Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
328- add alsa support for VineSeed
329- add --disable-rpath to configure option
330
331* Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
332- new upstream release
333- use %%{?_smp_mflags} for make option
334- add BuildPrereq: esound-devel libmad-devel
335
336* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
337- rebuild for VineSeed
338
339* Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
340- new upstream release
341
342* Tue Mar  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
343- new upstream release (1.4.0-rc1)
344
345* Mon Feb  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
346- new upstream release
347
348* Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
349- new upstream release
350
351* Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
352- rebuild for VineSeed
353
354* Wed Dec  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
355- source upgrade
356
357* Tue Oct  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
358- source upgrade
359- refine %%files
360
361* Sun Sep  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
362- source upgrade
363
364* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
365- rebuild with qt32
366
367* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
368- source upgrade
369- remove lines about vine26
370- BuildPrereq: XOrg-devel XOrg-gl-devel
371
372* Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
373- source upgrade
374
375* Thu Mar  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
376- source upgrade
377
378* Sun Feb  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
379- source upgrade
380- add Requires: glib2 to arts-devel package
381
382* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
383- rebuild for VineSeedPlus
384
385* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
386- source upgrade
387- build for VinePlus/2.6
388- (VinePlus/2.6) BuildPrereq: autoconf258
389
390* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
391- build for VineSeed with new toolchain and qt-3.2.3
392- add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
393
394* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
395- rebuild with qt-3.2.1-0.26vl3
396
397* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
398- rebuild with qt-3.2.1-0vl3
399
400* Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
401- source upgrade
402- build with gcc-3.2.3
403
404* Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
405- source upgrade
406
407* Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
408- change spec to build with gcc295
409- change make option for SMP and add script
410
411* Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
412- build with gcc295
413- add KDEDIR and QTDIR
414
415* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
416- source upgrade
417
418* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
419- rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
420
421* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
422- rebuild with qt-3.1.2-0vl2
423
424* Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
425- source upgrade
426
427* Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
428- rebuild with qt-3.1.1-0vl3
429
430* Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
431- change spec to build both VineSeed and Vine2.5/2.6
432
433* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
434- OOPS! rebuild with spec that changed 1.1-0vl0.2
435
436* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
437- source upgrade to kde-3.1-stable
438
439* Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
440- add '-fPIC' to FLAGS on alpha
441
442* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
443- source upgrade to kde-3.1-rc6
444- stop using objprelink2, it does not work with gcc3
445
446* Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
447- objprelink2 support only i386 (add %ifarch i386 ... again)
448-
449* Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
450- source upgrade
451
452* Tue Oct  8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
453- rebuild with qt-3.0.5-0vl1
454- BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
455
456* Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
457- add BuildPrereq: libogg-devel libvorbis-devel
458
459* Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
460- rebuild
461
462* Mon Jul  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
463- source upgrade
464
465* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
466- source upgrade
467
468* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
469- source upgrade to 1.0.1
470- add BuildPrereq: objprelink for i386
471
472* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
473- add configure option `--with-xinerama'
474- add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
475
476* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
477- source upgrade to 1.0.0
478
479* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
480- source update to cvs-20020329
481- build for VineSeed
482- merged with 3.0-0.cvs20020313.1
483- Epoch: 1
484- add BuildPrereq: autoconf252 automake15
485
486* Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
487- Build with autoconf 2.53, automake 1.5
488
489* Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
490- initial package
Note: See TracBrowser for help on using the repository browser.