source: projects/specs/trunk/a/arts/arts-vl.spec @ 1391

Revision 1391, 14.6 KB checked in by inagaki, 14 years ago (diff)

updated: arts, kdelibs3

Line 
1%define run_test 0
2%define make_cvs 1
3
4Name: arts
5Summary: aRts (analog realtime synthesizer) - the KDE 3 sound system
6Summary(ja): aRts - KDE 3 サウンドシステム
7Epoch: 1
8Version: 1.5.10
9Release: 4%{?_dist_release}
10
11License: LGPLv2
12URL: http://www.kde.org
13Group: System Environment/Daemons
14
15Source: ftp://ftp.kde.org/pub/kde/stable/3.5.10/src/%{name}-%{version}.tar.bz2
16
17Patch1: arts-1.1.4-debug.patch
18Patch2: arts-1.3.92-glib2.patch
19Patch5: arts-1.3.1-alsa.patch
20Patch6: arts-1.5.8-glibc.patch
21Patch7: arts-1.5.0-check_tmp_dir.patch
22Patch8: arts-1.5.2-multilib.patch
23# don't pop up a dialog on CPU overload (#361891)
24Patch9: arts-1.5.10-cpu-overload-quiet.patch
25# kde#93359
26Patch50: arts-1.5.4-dlopenext.patch
27Patch51: kde-3.5-libtool-shlibext.patch
28# upstream patches
29
30# security patches
31# CVE-2009-3736 libtool: libltdl may load and execute code from a library in the current directory
32Patch200: libltdl-CVE-2009-3736.patch
33
34# tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
35Patch300: arts-acinclude.patch
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38BuildRequires: gcc-c++
39BuildRequires: qt-devel >= 3.3.8
40BuildRequires: alsa-lib-devel
41BuildRequires: audiofile-devel
42%if %{make_cvs}
43BuildRequires: automake libtool
44%endif
45BuildRequires: libogg-devel libvorbis-devel glib2-devel
46BuildRequires: esound-devel jack-audio-connection-kit-devel
47BuildRequires: pkgconfig
48%if %{run_test}
49BuildRequires: kdelibs3
50%endif
51
52Obsoletes: kdelibs-sound
53Provides: kdelibs-sound
54
55%description
56arts (analog real-time synthesizer) is the sound system of KDE 3.
57
58The principle of arts is to create/process sound using small modules which do
59certain tasks. These may be create a waveform (oscillators), play samples,
60filter data, add signals, perform effects like delay/flanger/chorus, or
61output the data to the soundcard.
62
63By connecting all those small modules together, you can perform complex
64tasks like simulating a mixer, generating an instrument or things like
65playing a wave file with some effects.
66
67%package devel
68Summary: Development files for the aRts sound server
69Summary(ja): aRts サウンドサーバの開発用ファイル
70Group: Development/Libraries
71Requires: %{name} = %{epoch}:%{version}-%{release}
72Requires: qt-devel
73Requires: glib2-devel
74Requires: pkgconfig
75Obsoletes: kdelibs-sound-devel
76Provides: kdelibs-sound-devel
77
78%description devel
79arts (analog real-time synthesizer) is the sound system of KDE 3.
80
81The principle of arts is to create/process sound using small modules which do
82certain tasks. These may be create a waveform (oscillators), play samples,
83filter data, add signals, perform effects like delay/flanger/chorus, or
84output the data to the soundcard.
85
86By connecting all those small modules together, you can perform complex
87tasks like simulating a mixer, generating an instrument or things like
88playing a wave file with some effects.
89
90Install arts-devel if you intend to write applications using arts (such as
91KDE applications using sound).
92
93%prep
94%setup -q
95%patch1 -p1 -b .debug
96%patch2 -p1 -b .glib
97%patch5 -p1 -b .alsa
98%patch6 -p1 -b .glibc
99%patch7 -p1 -b .check_tmp_dir
100%patch8 -p1 -b .multilib
101%patch9 -p1 -b .cpu-overload-quiet
102
103%patch50 -p1 -b .dlopenext
104%patch51 -p1 -b .libtool-shlibext
105
106%patch200 -p1 -b .CVE-2009-3736
107
108%patch300 -p1 -b .acinclude
109
110%build
111%if %{make_cvs}
112# hack/fix for newer automake
113  sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
114  make -f admin/Makefile.common cvs
115%endif
116
117unset QTDIR || : ; . /etc/profile.d/qt.sh
118
119%configure \
120    --includedir=%{_includedir}/kde \
121    --with-qt-libraries=$QTDIR/lib \
122    --disable-rpath \
123    --disable-debug --disable-warnings \
124    --disable-dependency-tracking \
125    --enable-new-ldflags \
126    --disable-libmad \
127    --with-alsa \
128    --enable-final
129
130make %{?_smp_mflags}
131
132%if %{run_test}
133make check
134%endif
135
136%install
137rm -rf $RPM_BUILD_ROOT
138export PATH=`pwd`:$PATH
139make DESTDIR=$RPM_BUILD_ROOT install
140
141## remove references to optional external libraries in .la files (#178733)
142find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
143 sed -i \
144 -e "s|-lmad||g" \
145 -e "s|%{_libdir}/libmad.la||g" \
146 -e "s|-lvorbisfile||g" \
147 -e "s|-lvorbisenc||g" \
148 -e "s|-lvorbis||g" \
149 -e "s|-logg||g" \
150 -e "s|-lasound||g" \
151 -e "s|-laudiofile||g" \
152 -e "s|-lesd||g" \
153 -e "s|%{_libdir}/libesd.la||g" \
154 -e "s|-lgmodule-2.0||g" \
155 -e "s|-lgthread-2.0||g" \
156 -e "s|-lglib-2.0||g" \
157 -e "s|-laudio ||g" \
158 -e "s|-lpng -lz ||g" \
159 -e "s|%{_libdir}/libartsc.la||g" \
160 -e "s@-lboost_filesystem@@g" \
161 -e "s@-lboost_regex@@g" \
162 -e "s@-ljack@@g"
163
164#rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
165
166#chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
167
168%clean
169rm -rf $RPM_BUILD_ROOT
170
171%post -p /sbin/ldconfig
172
173%postun -p /sbin/ldconfig
174
175%files
176%defattr(-,root,root)
177%doc COPYING.LIB
178%dir %{_libdir}/mcop
179%dir %{_libdir}/mcop/Arts
180%{_bindir}/arts*
181%exclude %{_bindir}/artsc-config
182%{_libdir}/mcop/Arts/*
183%{_libdir}/mcop/*.mcopclass
184%{_libdir}/mcop/*.mcoptype
185%{_libdir}/lib*.so.*
186%{_libdir}/lib*.la
187
188%files devel
189%defattr(-,root,root)
190%{_bindir}/artsc-config
191%{_bindir}/mcopidl
192%{_includedir}/kde/arts
193%{_includedir}/kde/artsc
194%{_libdir}/lib*.so
195%{_libdir}/pkgconfig/artsc.pc
196
197%changelog
198* Sat Jul 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-4
199- disabled AutoReq: off
200
201* Sat Mar 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-3
202- rebuilt with new toolchain
203- added Patch9, 200 and 300 from FC
204  * Wed Dec 16 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.5.10-11
205  - don't pop up a dialog on CPU overload (#361891)
206  * Thu Dec 10 2009 Stepan Kasal <skasal@redhat.com> - 1.5.10-10
207  - patch autoconfigury to build with autoconf >= 2.64
208  * Sun Dec 06 2009 Than Ngo <than@redhat.com> - 1.5.10-9
209  - fix url
210  - fix security issues in libltdl (CVE-2009-3736)
211- added Japanese summary
212- fixed duplicated entry at last changelog
213
214* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
215- added Patch1,2,5,8,50 and 51 from Fedora
216- added lib*.la files again...
217
218* Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
219- updated to 1.5.10
220- added BuildRequires: jack-audio-connection-kit-devel
221- removed static library
222
223* Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
224- applied new versioning policy
225- updated build dependancies
226
227* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
228- rebuild for VineSeed
229
230* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
231- new upstream release
232
233* Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
234- rebuild for VineSeed
235
236* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
237- new upstream release
238
239* Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
240- new upstream release
241
242* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
243- rebuild for VineSeed
244
245* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
246- add Patch0 [VineLinux:0369]
247
248* Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
249- added --with-qt-libraries option
250- removed --libdir=%%{_libdir} option
251
252* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
253- rebuild for VineSeed
254
255* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
256- new upstream release
257
258* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
259- rebuild for VineSeed
260
261* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
262- new upstream release
263- drop Patch0
264
265* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
266- added --libdir=%%{_libdir} to ./configure option
267
268* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
269- rebuild for VineSeed
270
271* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
272- add Patch0 (CVE-2006-2916)
273
274* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
275- rebuild for VineSeed
276
277* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
278- new upstream release
279
280* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
281- rebuild for VineSeed
282
283* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
284- new upstream release
285
286* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
287- rebuild for VineSeed
288
289* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
290- new upstream release
291
292* Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
293- add "%%{epoch}:" to Requires in arts-devel
294
295* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
296- rebuild for VineSeed
297
298* Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
299- new upstream release
300
301* Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
302- new upstream release
303
304* Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
305- new upstream release
306
307* Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
308- new upstream release
309
310* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
311- rebuild for VineSeed
312
313* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
314- new upstream release
315
316* Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
317- add alsa support for VineSeed
318- add --disable-rpath to configure option
319
320* Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
321- new upstream release
322- use %%{?_smp_mflags} for make option
323- add BuildPrereq: esound-devel libmad-devel
324
325* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
326- rebuild for VineSeed
327
328* Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
329- new upstream release
330
331* Tue Mar  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
332- new upstream release (1.4.0-rc1)
333
334* Mon Feb  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
335- new upstream release
336
337* Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
338- new upstream release
339
340* Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
341- rebuild for VineSeed
342
343* Wed Dec  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
344- source upgrade
345
346* Tue Oct  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
347- source upgrade
348- refine %%files
349
350* Sun Sep  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
351- source upgrade
352
353* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
354- rebuild with qt32
355
356* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
357- source upgrade
358- remove lines about vine26
359- BuildPrereq: XOrg-devel XOrg-gl-devel
360
361* Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
362- source upgrade
363
364* Thu Mar  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
365- source upgrade
366
367* Sun Feb  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
368- source upgrade
369- add Requires: glib2 to arts-devel package
370
371* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
372- rebuild for VineSeedPlus
373
374* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
375- source upgrade
376- build for VinePlus/2.6
377- (VinePlus/2.6) BuildPrereq: autoconf258
378
379* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
380- build for VineSeed with new toolchain and qt-3.2.3
381- add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
382
383* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
384- rebuild with qt-3.2.1-0.26vl3
385
386* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
387- rebuild with qt-3.2.1-0vl3
388
389* Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
390- source upgrade
391- build with gcc-3.2.3
392
393* Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
394- source upgrade
395
396* Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
397- change spec to build with gcc295
398- change make option for SMP and add script
399
400* Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
401- build with gcc295
402- add KDEDIR and QTDIR
403
404* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
405- source upgrade
406
407* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
408- rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
409
410* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
411- rebuild with qt-3.1.2-0vl2
412
413* Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
414- source upgrade
415
416* Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
417- rebuild with qt-3.1.1-0vl3
418
419* Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
420- change spec to build both VineSeed and Vine2.5/2.6
421
422* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
423- OOPS! rebuild with spec that changed 1.1-0vl0.2
424
425* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
426- source upgrade to kde-3.1-stable
427
428* Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
429- add '-fPIC' to FLAGS on alpha
430
431* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
432- source upgrade to kde-3.1-rc6
433- stop using objprelink2, it does not work with gcc3
434
435* Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
436- objprelink2 support only i386 (add %ifarch i386 ... again)
437-
438* Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
439- source upgrade
440
441* Tue Oct  8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
442- rebuild with qt-3.0.5-0vl1
443- BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
444
445* Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
446- add BuildPrereq: libogg-devel libvorbis-devel
447
448* Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
449- rebuild
450
451* Mon Jul  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
452- source upgrade
453
454* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
455- source upgrade
456
457* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
458- source upgrade to 1.0.1
459- add BuildPrereq: objprelink for i386
460
461* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
462- add configure option `--with-xinerama'
463- add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
464
465* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
466- source upgrade to 1.0.0
467
468* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
469- source update to cvs-20020329
470- build for VineSeed
471- merged with 3.0-0.cvs20020313.1
472- Epoch: 1
473- add BuildPrereq: autoconf252 automake15
474
475* Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
476- Build with autoconf 2.53, automake 1.5
477
478* Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
479- initial package
Note: See TracBrowser for help on using the repository browser.