source: projects/specs/trunk/a/aptitude/aptitude-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: aptitude
2Version: 0.4.4
3Release: 0vl3
4Summary: A curses-based apt frontend
5Summary(ja): apt ¤Î CUI ¥Õ¥í¥ó¥È¥¨¥ó¥É
6Group: Applications/Administration
7License: GPL
8URL: http://www.debian.org/Packages/unstable/admin/aptitude.html
9Source: http://http.us.debian.org/debian/pool/main/a/%{name}/%{name}-%{version}.tar.bz2
10# apt-rpm patch from ALT linux source rpm
11Patch0: aptitude-0.4.4-alt1.patch
12
13#Source: http://http.us.debian.org/debian/pool/main/a/%{name}/%{name}-%{version}.tar.bz2
14#Patch0: aptitude-0.3.3-alt-cnc-rpm.patch.bz2
15#Patch1: aptitude-0.3.3-automake.patch.bz2
16#Patch5: aptitude-0.3.3-build-fixes.patch.bz2
17#Patch6: aptitude-0.3.3-new-build-fixes.patch.bz2
18
19BuildRequires: apt-devel >= 0.5.15.cnc.7
20BuildRequires: binutils
21BuildRequires: coreutils
22BuildRequires: gzip
23BuildRequires: libsigc++-devel >= 2.0
24#BuildRequires: libstdc++3-devel
25BuildRequires: zlib-devel cppunit-devel
26BuildRequires: ncurses-devel
27BuildRequires: popt rpm-devel
28BuildRequires: gcc-c++ make automake18 autoconf
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31%description
32Aptitude is a curses-based apt frontend with a number of useful extended
33features, including: a mutt-like syntax for matching packages in a flexible
34and extreme flexibility and customization.
35
36%description -l ja
37Aptitude ¤Ï curses ¥Ù¡¼¥¹¤Ç¿ô¡¹¤ÎÊØÍø¤Ê³ÈÄ¥µ¡Ç½¤òÈ÷¤¨¤¿ apt ¥Õ¥í¥ó¥È¥¨¥ó¥É¤Ç¤¹
38¡£mutt ¥é¥¤¥¯¤Ê¥Ñ¥Ã¥±¡¼¥¸¥Þ¥Ã¥Á¥·¥ó¥¿¥Ã¥¯¥¹¤òÈ÷¤¨¡¢½ÀÆð¤Ë¥«¥¹¥¿¥Þ¥¤¥º²Äǽ¤Ê¥Ä
39¡¼¥ë¤Ç¤¹¡£
40
41%prep
42%setup -q -n %{name}-%{version}
43%patch0 -p1 -b .apt-rpm-altlinux
44#patch1 -p1 -b .automake
45#patch5 -p1 -b .build-fix
46#patch6 -p1 -b .new-build-fix
47
48%build
49libtoolize --copy --force
50aclocal -I m4
51autoheader
52automake -a -c
53autoconf
54%configure --disable-werror --disable-docs
55
56make
57make check
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%makeinstall STATEDIR=$RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
62#makeinstall -C doc
63
64rm -rf $RPM_BUILD_ROOT/%{_mandir}
65
66%find_lang %{name}
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files -f %{name}.lang
72%defattr(-,root,root)
73%doc AUTHORS INSTALL NEWS COPYING FAQ README TODO aptitude-hackers-guide.txt
74%{_bindir}/%{name}
75%{_datadir}/%{name}
76%dir %{_localstatedir}/lib/%{name}
77#{_mandir}/man8/aptitude*.8*
78#{_mandir}/*/man8/aptitude.8*
79
80%changelog
81* Sun Sep 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl3
82- rebuild with apt-0.5.15lorg3.93
83
84* Sat Sep 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl2
85- rebuild with rpm-4.4.2.2
86
87* Mon Jul 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.4-0vl1
88- rebuilt with new toolchain
89- changed Group to Appications/Administration
90- updated to 0.4.4
91- added patch from ALT linux
92
93* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.3-0vl2
94- rebuild with apt-0.5.15lorg3
95
96* Sat Dec 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.3-0vl1
97- new upstream release
98- update altlinux apt-rpm patch from MDK package.
99- cleanup specs
100
101* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.15.6-0vl3
102- updated Patch
103  * Fri Oct 08 2004 Gustavo Pichorim Boiko <boiko@conectiva.com.br>
104  + 2004-10-08 15:25:36 (69400)
105  - fixed rpm patch file. It was causing a segfault when trying to
106    see the info of a package. Thanks to Alexey I. Froloff (raorn)
107    by his tip about that.
108
109* Fri Apr  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.15.6-0vl2
110- rebuild with apt 0.5.15.cnc7
111
112* Wed Mar 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.15.6-0vl1
113- new upstream from conectiva package
114  * Fri Sep 17 2004 Gustavo Pichorim Boiko <boiko@conectiva.com.br>
115  + 2004-09-17 14:51:34 (67964)
116  - new upstream release: 0.2.15.6
117  - removed patch file makeinstall because it is not necessary anymore
118  - splitted rpm patch into two: rpm and rpm_po
119    this was done because just the source code part of the patch usually
120    need to be re-done in each new release.
121  - added a patch file fixing the compilation with gcc-3.4
122  - removed old menu entry and references
123- fixed spec file encoding
124
125* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.11.1-0vl1
126- merged with conectiva package
127  * Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
128  - 0.0.7.19-2vl2
129  - Oops, the spec was in Shift_JIS. Fixed.
130  * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.7.19-2vl1
131  - merged with 0.0.7.19-2cl
132  * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.7.6-1vl5
133  - rebuild with apt-0.3.19cnc38-2vl5
134  * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.7.6-1vl2
135  - build for Vine Linux
136  * Sun Dec 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.7.6-1vl1
137  - build for Vine Linux
138
139* Thu Mar 20 2003 Claudio Matsuoka <claudio@conectiva.com>
140+ 2003-03-20 18:28:59 (28803)
141- fixed remaining reference to pkgDPkgPM (closes: #8136)
142
143* Tue Jan 07 2003 Mapi2 <distro@conectiva.com.br>
144+ 2003-01-07 19:01:45 (21359)
145- Copying release 0.2.11.1-21310cl to releases/ directory.
146- Copying release 0.2.11.1-21310cl to pristine/ directory.
147- Removing previous pristine/ directory.
148
149* Tue Jan 07 2003 Ademar de Souza Reis Jr. <ademar@conectiva.com.br>
150+ 2003-01-07 17:04:48 (21310)
151- Increasing release (recompiling with new set of libraries from apt)
152- Enabled parallell build
153
154* Thu Oct 31 2002 Helio Chissini de Castro <helio@conectiva.com.br>
155+ 2002-10-31 13:37:49 (18505)
156- Fixed aptitude-rpm
157
158* Fri Oct 18 2002 Helio Chissini de Castro <helio@conectiva.com.br>
159+ 2002-10-18 10:14:17 (17858)
160- New patch fixing gcc3 compilation.
161
162* Mon Sep 23 2002 Helio Chissini de Castro <helio@conectiva.com.br>
163+ 2002-09-23 19:37:56 (15710)
164- Added large patch to fix compilation with gcc3
165- Fixed template STL headers
166- Changed Makefile -Werror annoying warning to -Wno-deprecated, removing another
167  bad warning
168- Fixed some define problems against bad included libsigc++ header
169- Changed old curses require to ncurses
170- Created whole new automake/autoconf headers/configure.in
171- Changed invalid default declarations in source files
172
173* Tue Sep 03 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
174+ 2002-09-03 14:14:27 (11109)
175- Copying release 0.2.11.1-2cl to releases/ directory.
176
177* Tue Sep 03 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
178+ 2002-09-03 14:14:25 (11108)
179- Copying release 0.2.11.1-2cl to pristine/ directory.
180
181* Tue Sep 03 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
182+ 2002-09-03 14:14:23 (11107)
183- Removing previous pristine/ directory.
184
185* Tue Sep 03 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
186+ 2002-09-03 14:14:20 (11106)
187- Imported package from snapshot.
188
189* Tue Sep 03 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
190+ 2002-09-03 14:14:17 (11105)
191- Created directory for version 0.2.11.1.
192
193* Thu Aug 29 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
194+ 2002-08-29 17:19:11 (7311)
195- Copying release 0.2.8-4cl to releases/ directory.
196
197* Thu Aug 29 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
198+ 2002-08-29 17:19:10 (7310)
199- Copying release 0.2.8-4cl to pristine/ directory.
200
201* Thu Aug 29 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
202+ 2002-08-29 17:19:09 (7309)
203- Removing previous pristine/ directory.
204
205* Thu Aug 29 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
206+ 2002-08-29 17:19:07 (7308)
207- Imported package from 8.0.
208
209* Thu Aug 29 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
210+ 2002-08-29 17:19:04 (7307)
211- Created directory for version 0.2.8.
212
213* Wed Aug 28 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
214+ 2002-08-28 18:07:00 (3656)
215- Copying release 0.0.8.6-2cl to releases/ directory.
216
217* Wed Aug 28 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
218+ 2002-08-28 18:06:59 (3655)
219- Copying release 0.0.8.6-2cl to pristine/ directory.
220
221* Wed Aug 28 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
222+ 2002-08-28 18:06:57 (3654)
223- Removing previous pristine/ directory.
224
225* Wed Aug 28 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
226+ 2002-08-28 18:06:55 (3653)
227- Imported package from 7.0.
228
229* Wed Aug 28 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
230+ 2002-08-28 18:06:53 (3652)
231- Created directory for version 0.0.8.6.
232
233
234
235* Tue Aug 27 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
236+ 2002-08-27 18:40:15 (135)
237- Imported package from 6.0.
238
239* Tue Aug 27 2002 Gustavo Niemeyer <niemeyer@conectiva.com>
240+ 2002-08-27 18:40:12 (134)
241- Created package directory
Note: See TracBrowser for help on using the repository browser.