source: projects/specs/trunk/a/apr/apr-vl.spec @ 4849

Revision 4849, 13.2 KB checked in by inagaki, 13 years ago (diff)

update: apr, apr-util

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.4.5
10Release: 1%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: http://apr.apache.org/
15
16Source0: %{name}-%{version}.tar.bz2
17Source1: apr-wrapper.h
18Patch2: apr-0.9.7-deepbind.patch
19Patch3: apr-1.2.2-locktimeout.patch
20Patch4: apr-1.2.2-libdir.patch
21Patch5: apr-1.3.3-pkgconf.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: autoconf, libtool, python, doxygen
25BuildRequires: libuuid-devel
26Conflicts: subversion < 0.20.1-2
27Obsoletes: apache2-apr
28
29%description
30The mission of the Apache Portable Runtime (APR) is to provide a
31free library of C data structures and routines, forming a system
32portability layer to as many operating systems as possible,
33including Unices, MS Win32, BeOS and OS/2.
34
35%package devel
36Summary: APR library development kit
37Summary(ja): APR ライブラリ開発キット
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Conflicts: subversion-devel < 0.20.1-2
41Obsoletes: apache2-apr-devel
42
43%description devel
44This package provides the support files which can be used to
45build applications using the APR library.  The mission of the
46Apache Portable Runtime (APR) is to provide a free library of
47C data structures and routines.
48
49%prep
50%setup -q
51%patch2 -p1 -b .deepbind
52%patch3 -p1 -b .locktimeout
53%patch4 -p1 -b .libdir
54%patch5 -p1 -b .pkgconf
55
56%build
57# regenerate configure script etc.
58./buildconf
59
60# Forcibly prevent detection of shm_open (which then picks up but
61# does not use -lrt).
62export ac_cv_search_shm_open=no
63
64%configure \
65        --includedir=%{_includedir}/apr-%{aprver} \
66        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
67        --with-devrandom=/dev/urandom \
68        --disable-static \
69        CC=gcc CXX=g++
70make %{?_smp_mflags} && make dox
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# Move docs to more convenient location
77rm -rf html
78mkdir -p html
79cp -pr docs/dox/html/* html/
80# mv docs/dox/html html
81
82# Trim exported dependecies
83sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
84      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
85sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
86      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
87
88%ifarch %{multilib_arches}
89# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
90# packages:
91mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
92   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
93install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
94%endif
95
96# Unpackaged files:
97rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
98rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
99
100%check
101# Fail if LFS support isn't present in a 32-bit build, since this
102# breaks ABI and the soname doesn't change: see #254241
103if grep 'define SIZEOF_VOIDP 4' include/apr.h \
104   && ! grep off64_t include/apr.h; then
105  cat config.log
106  : LFS support not present in 32-bit build
107  exit 1
108fi
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc CHANGES LICENSE NOTICE
120%{_libdir}/libapr-%{aprver}.so.*
121
122%files devel
123%defattr(-,root,root,-)
124%doc docs/APRDesign.html docs/canonical_filenames.html
125%doc docs/incomplete_types docs/non_apr_programs
126%doc --parents html
127%{_bindir}/apr-%{aprver}-config
128#{_libdir}/libapr-%{aprver}.a
129%{_libdir}/libapr-%{aprver}.so
130%{_libdir}/pkgconfig/*.pc
131%dir %{_libdir}/apr-%{aprver}
132%dir %{_libdir}/apr-%{aprver}/build
133%{_libdir}/apr-%{aprver}/build/*
134%dir %{_includedir}/apr-%{aprver}
135%{_includedir}/apr-%{aprver}/*.h
136
137%changelog
138* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
139- new upstream release
140
141* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
142- new upstream release
143- built with rpm-4.8.1
144- removed static libraries from devel package
145
146* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
147- rebuilt with new toolchain
148
149* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
150- new upstream release
151
152* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
153- new upstream release with security fix (CVE-2009-2412)
154
155* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
156- new upstream release
157
158* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
159- new upstream release
160- updated Patch5
161
162* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
163- new upstream release
164- removed Patch1 and 6
165
166* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
167- removed *.la files from devel package
168
169* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
170- new upstream release
171- added Patch2 and 6 from Fedora
172  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
173  - add fix for use of %%pI with psprintf
174  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
175  - use RTLD_DEEPBIND in apr_dso_open by default
176
177* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
178- new upstream release
179
180* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
181- new upstream release
182
183* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
184- remove Requires: gcc = %%(gcc -dumpversion)
185
186* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
187- rebuilt with new toolchain
188
189* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
190- new upstream release
191
192* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
193- initial build for Vine Linux based on FC package
194
195* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
196- fix another multilib conflict (#192659)
197
198* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
199- BR e2fsprogs-devel for libuuid
200
201* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
202- use multilib parallel-installation wrapper hack for apr.h
203
204* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
205- fix installbuilddir in apr-1-config
206
207* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
208- update to 1.2.7
209- use pkg-config in apr-1-config to make it libdir-agnostic
210
211* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
212- update to 1.2.6
213
214* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
215- bump again for double-long bug on ppc(64)
216
217* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
218- rebuilt for new gcc4.1 snapshot and glibc changes
219
220* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
221- fix namespace pollution (r354824, r355464)
222
223* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
224- fix build with recent glibc (#176911)
225
226* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
227- rebuilt again
228
229* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
230- rebuilt
231
232* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
233- rebuild for new gcc
234
235* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
236- add apr_file_seek() fixes from upstream (r326593, r326597)
237
238* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
239- apr-1-config: strip more exports (#175124)
240
241* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
242- avoid linking against -lrt
243- don't print -L${libdir} in --libs output
244- don't export -lcrypt/-luuid in .la file
245
246* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
247- update to 1.2.2
248
249* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
250- use RTLD_DEEPBIND in apr_dso_open by default
251
252* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
253- update to 0.9.7
254
255* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
256- rebuild for new gcc
257
258* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
259- don't override CFLAGS at build time
260- allow setting TCP_NODELAY and TCP_CORK concurrently
261- use _exit() not exit() in child if exec*() fails (upstream #30913)
262
263* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
264- add from 0.9.x branch:
265 * fix for apr_{uid,gid}_* error handling (r239592)
266 * fix for apr_file_ write flushing (r267192)
267- add backport for use of readdir64_r (r265032, r265681, r265684)
268
269* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
270- rebuild
271
272* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
273- fix apr_procattr_child_*_set error handling
274
275* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
276- have apr-devel depend on specific version of gcc
277- add NOTICE to docdir
278
279* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
280- update to 0.9.6
281
282* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
283- don't disable sendfile on s390 (IBM LTC, #146891)
284
285* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
286- really fix apr-config --srcdir
287
288* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
289- fix apr-config --srcdir again
290
291* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
292- update to 0.9.5
293
294* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
295- rebuild
296
297* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
298- have -devel require apr of same V-R
299
300* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
301- backport fixes from HEAD:
302 * correct implementation of nested mutexes
303 * support for POSIX semaphores on LP64 platforms
304
305* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
306- rebuild for another attempt at using sem_open
307
308* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
309- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
310
311* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
312- rebuild
313
314* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
315- rebuild now /dev/shm is mounted
316
317* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
318- add fix for cleanup structure reuse (part of upstream #23567)
319
320* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
321- rebuilt
322
323* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
324- add support for setuid/setgid/sticky bits (Andr辿 Malo)
325- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
326
327* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
328- enable posixsem and process-shared pthread mutex support, but
329  ensure that sysvsem remains the default mechanism
330
331* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
332- entirely remove 2Gb file size limit from apr_file_copy();
333  fixes "svnadmin hotcopy" on repos with >2Gb strings table
334- work around getnameinfo bugs with v4-mapped addresses
335- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
336
337* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
338- use APR_LARGEFILE in apr_file_{copy,append}
339
340* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
341- add APR_LARGEFILE flag
342
343* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
344- fix configure check for mmap of /dev/zero
345- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
346
347* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
348- rebuilt
349
350* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
351- undocument apr_dir_read() ordering constraint and fix tests
352
353* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
354- rebuilt without -Wall -Werror
355
356* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
357- rebuilt
358
359* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
360- define apr_off_t as int/long/... to prevent it changing
361  with _FILE_OFFSET_BITS on 32-bit platforms
362
363* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
364- add apr_temp_dir_get fixes from HEAD
365
366* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
367- ensure that libapr is linked against libpthread
368- don't link libapr against -lnsl
369
370* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
371- -devel package no longer requires libtool
372
373* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
374- disable tests on x86_64 (#97611)
375
376* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
377- update to 0.9.4, enable tests
378- ensure that libresolv is not used
379
380* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
381- use /dev/urandom (#103049)
382
383* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
384- add back CC=gcc, CXX=g++
385
386* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
387- rebuild
388
389* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
390- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
391
392* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
393- support --cc and --cpp arguments in apr-config
394
395* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
396- force libtool to use CC=gcc, CXX=g++
397
398* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
399- fix libtool location in apr_rules.mk
400
401* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
402- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
403- include a working libtool script rather than relying on
404 /usr/bin/libtool (#97695)
405
406* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
407- don't use /usr/bin/libtool
408
409* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
410- rebuilt
411
412* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
413- add fix for psprintf memory corruption (CAN-2003-0245)
414- remove executable bit from apr_poll.h
415
416* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
417- link libapr against libpthread
418- make apr-devel conflict with old subversion-devel
419- fix License
420
421* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
422- run ldconfig in post/postun
423
424* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
425- patch test suite to not care if IPv6 is disabled
426
427* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
428- initial build
Note: See TracBrowser for help on using the repository browser.