source: projects/specs/trunk/a/apr/apr-vl.spec @ 521

Revision 521, 12.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Summary: Apache Portable Runtime library
7Summary(ja): Apache ポータブルランタイムライブラリ
8Name: apr
9Version: 1.3.9
10Release: 2%{?_dist_release}
11License: Apache Software License
12Group: System Environment/Libraries
13URL: http://apr.apache.org/
14Source0: %{name}-%{version}.tar.bz2
15Source1: apr-wrapper.h
16Patch2: apr-0.9.7-deepbind.patch
17Patch3: apr-1.2.2-locktimeout.patch
18Patch4: apr-1.2.2-libdir.patch
19Patch5: apr-1.3.3-pkgconf.patch
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf, libtool, doxygen, e2fsprogs-devel
22Conflicts: subversion < 0.20.1-2
23Obsoletes: apache2-apr
24
25%description
26The mission of the Apache Portable Runtime (APR) is to provide a
27free library of C data structures and routines, forming a system
28portability layer to as many operating systems as possible,
29including Unices, MS Win32, BeOS and OS/2.
30
31%package devel
32Group: Development/Libraries
33Summary: APR library development kit
34Summary(ja): APR ライブラリ開発キット
35Conflicts: subversion-devel < 0.20.1-2
36Obsoletes: apache2-apr-devel
37Requires: apr = %{version}-%{release}
38Requires: pkgconfig
39
40%description devel
41This package provides the support files which can be used to
42build applications using the APR library.  The mission of the
43Apache Portable Runtime (APR) is to provide a free library of
44C data structures and routines.
45
46%prep
47%setup -q
48%patch2 -p1 -b .deepbind
49%patch3 -p1 -b .locktimeout
50%patch4 -p1 -b .libdir
51%patch5 -p1 -b .pkgconf
52
53%build
54# regenerate configure script etc.
55./buildconf
56
57# Forcibly prevent detection of shm_open (which then picks up but
58# does not use -lrt).
59export ac_cv_search_shm_open=no
60
61%configure \
62        --includedir=%{_includedir}/apr-%{aprver} \
63        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
64        --with-devrandom=/dev/urandom \
65        CC=gcc CXX=g++
66make %{?_smp_mflags} && make dox
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=$RPM_BUILD_ROOT
71
72# Move docs to more convenient location
73rm -rf html
74mkdir -p html
75cp -pr docs/dox/html/* html/
76# mv docs/dox/html html
77
78# Trim exported dependecies
79sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
80      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
81sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
82      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
83
84%ifarch %{multilib_arches}
85# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
86# packages:
87mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
88   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
89install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
90%endif
91
92# Unpackaged files:
93rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
94rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
95
96%check
97# Fail if LFS support isn't present in a 32-bit build, since this
98# breaks ABI and the soname doesn't change: see #254241
99if grep 'define SIZEOF_VOIDP 4' include/apr.h \
100   && ! grep off64_t include/apr.h; then
101  cat config.log
102  : LFS support not present in 32-bit build
103  exit 1
104fi
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(-,root,root,-)
115%doc CHANGES LICENSE NOTICE
116%{_libdir}/libapr-%{aprver}.so.*
117
118%files devel
119%defattr(-,root,root,-)
120%doc docs/APRDesign.html docs/canonical_filenames.html
121%doc docs/incomplete_types docs/non_apr_programs
122%doc --parents html
123%{_bindir}/apr-%{aprver}-config
124%{_libdir}/libapr-%{aprver}.a
125%{_libdir}/libapr-%{aprver}.so
126%{_libdir}/pkgconfig/*.pc
127%dir %{_libdir}/apr-%{aprver}
128%dir %{_libdir}/apr-%{aprver}/build
129%{_libdir}/apr-%{aprver}/build/*
130%dir %{_includedir}/apr-%{aprver}
131%{_includedir}/apr-%{aprver}/*.h
132
133%changelog
134* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
135- rebuilt with new toolchain
136
137* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
138- new upstream release
139
140* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
141- new upstream release with security fix (CVE-2009-2412)
142
143* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
144- new upstream release
145
146* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
147- new upstream release
148- updated Patch5
149
150* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
151- new upstream release
152- removed Patch1 and 6
153
154* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
155- removed *.la files from devel package
156
157* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
158- new upstream release
159- added Patch2 and 6 from Fedora
160  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
161  - add fix for use of %%pI with psprintf
162  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
163  - use RTLD_DEEPBIND in apr_dso_open by default
164
165* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
166- new upstream release
167
168* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
169- new upstream release
170
171* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
172- remove Requires: gcc = %%(gcc -dumpversion)
173
174* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
175- rebuilt with new toolchain
176
177* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
178- new upstream release
179
180* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
181- initial build for Vine Linux based on FC package
182
183* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
184- fix another multilib conflict (#192659)
185
186* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
187- BR e2fsprogs-devel for libuuid
188
189* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
190- use multilib parallel-installation wrapper hack for apr.h
191
192* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
193- fix installbuilddir in apr-1-config
194
195* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
196- update to 1.2.7
197- use pkg-config in apr-1-config to make it libdir-agnostic
198
199* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
200- update to 1.2.6
201
202* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
203- bump again for double-long bug on ppc(64)
204
205* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
206- rebuilt for new gcc4.1 snapshot and glibc changes
207
208* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
209- fix namespace pollution (r354824, r355464)
210
211* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
212- fix build with recent glibc (#176911)
213
214* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
215- rebuilt again
216
217* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
218- rebuilt
219
220* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
221- rebuild for new gcc
222
223* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
224- add apr_file_seek() fixes from upstream (r326593, r326597)
225
226* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
227- apr-1-config: strip more exports (#175124)
228
229* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
230- avoid linking against -lrt
231- don't print -L${libdir} in --libs output
232- don't export -lcrypt/-luuid in .la file
233
234* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
235- update to 1.2.2
236
237* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
238- use RTLD_DEEPBIND in apr_dso_open by default
239
240* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
241- update to 0.9.7
242
243* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
244- rebuild for new gcc
245
246* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
247- don't override CFLAGS at build time
248- allow setting TCP_NODELAY and TCP_CORK concurrently
249- use _exit() not exit() in child if exec*() fails (upstream #30913)
250
251* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
252- add from 0.9.x branch:
253 * fix for apr_{uid,gid}_* error handling (r239592)
254 * fix for apr_file_ write flushing (r267192)
255- add backport for use of readdir64_r (r265032, r265681, r265684)
256
257* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
258- rebuild
259
260* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
261- fix apr_procattr_child_*_set error handling
262
263* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
264- have apr-devel depend on specific version of gcc
265- add NOTICE to docdir
266
267* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
268- update to 0.9.6
269
270* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
271- don't disable sendfile on s390 (IBM LTC, #146891)
272
273* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
274- really fix apr-config --srcdir
275
276* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
277- fix apr-config --srcdir again
278
279* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
280- update to 0.9.5
281
282* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
283- rebuild
284
285* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
286- have -devel require apr of same V-R
287
288* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
289- backport fixes from HEAD:
290 * correct implementation of nested mutexes
291 * support for POSIX semaphores on LP64 platforms
292
293* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
294- rebuild for another attempt at using sem_open
295
296* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
297- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
298
299* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
300- rebuild
301
302* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
303- rebuild now /dev/shm is mounted
304
305* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
306- add fix for cleanup structure reuse (part of upstream #23567)
307
308* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
309- rebuilt
310
311* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
312- add support for setuid/setgid/sticky bits (Andr辿 Malo)
313- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
314
315* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
316- enable posixsem and process-shared pthread mutex support, but
317  ensure that sysvsem remains the default mechanism
318
319* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
320- entirely remove 2Gb file size limit from apr_file_copy();
321  fixes "svnadmin hotcopy" on repos with >2Gb strings table
322- work around getnameinfo bugs with v4-mapped addresses
323- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
324
325* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
326- use APR_LARGEFILE in apr_file_{copy,append}
327
328* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
329- add APR_LARGEFILE flag
330
331* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
332- fix configure check for mmap of /dev/zero
333- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
334
335* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
336- rebuilt
337
338* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
339- undocument apr_dir_read() ordering constraint and fix tests
340
341* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
342- rebuilt without -Wall -Werror
343
344* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
345- rebuilt
346
347* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
348- define apr_off_t as int/long/... to prevent it changing
349  with _FILE_OFFSET_BITS on 32-bit platforms
350
351* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
352- add apr_temp_dir_get fixes from HEAD
353
354* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
355- ensure that libapr is linked against libpthread
356- don't link libapr against -lnsl
357
358* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
359- -devel package no longer requires libtool
360
361* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
362- disable tests on x86_64 (#97611)
363
364* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
365- update to 0.9.4, enable tests
366- ensure that libresolv is not used
367
368* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
369- use /dev/urandom (#103049)
370
371* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
372- add back CC=gcc, CXX=g++
373
374* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
375- rebuild
376
377* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
378- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
379
380* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
381- support --cc and --cpp arguments in apr-config
382
383* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
384- force libtool to use CC=gcc, CXX=g++
385
386* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
387- fix libtool location in apr_rules.mk
388
389* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
390- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
391- include a working libtool script rather than relying on
392 /usr/bin/libtool (#97695)
393
394* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
395- don't use /usr/bin/libtool
396
397* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
398- rebuilt
399
400* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
401- add fix for psprintf memory corruption (CAN-2003-0245)
402- remove executable bit from apr_poll.h
403
404* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
405- link libapr against libpthread
406- make apr-devel conflict with old subversion-devel
407- fix License
408
409* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
410- run ldconfig in post/postun
411
412* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
413- patch test suite to not care if IPv6 is disabled
414
415* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
416- initial build
Note: See TracBrowser for help on using the repository browser.